如何解决在 Visio 中已损坏的图形

文章翻译 文章翻译
文章编号: 826418 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本文讨论了如何解决在 Microsoft Office Visio 2013、 Visio 2010、 Visio 2007、 Microsoft Office Visio 2003 中,和 Microsoft Visio 2002 中损坏的绘图。本文介绍了一些可能表示您正在使用的 Visio 绘图已损坏的症状。

此外,本文列出了一些损坏的绘图中可用的恢复方法。它们包括一般故障排除方法,尝试如果可以或不能打开绘图和方法,以帮助防止可能出现于绘图损坏的方法。

简介

概述

如果您遇到意外的情况,当您处理的 Visio 绘图时,Visio 绘图可能已损坏。如果您有一个已损坏的绘图时,可能会收到以下错误消息:
  • "无效的页面错误,""一般保护错误"非法指令"错误消息
  • 打开绘图时都类似于下列之一的错误消息:

    在打开的操作过程中出现错误 (100)

    Visio 不能打开该文件,因为它不是 Visio 文件或已损坏。
  • "内存不足"错误消息或错误消息,以表明系统资源不足
注意这些错误消息不总是意味着您的绘图已损坏。但是,如果您反复遇到一个或多个这些错误消息时使用特定的绘图,该绘图可能已经损坏。

本文列出了一些可用于尝试恢复损坏的绘图的方法。本文中介绍的方法不能保证成功恢复损坏的绘图。有时,这取决于损坏的类型,您可能无法恢复任何数据。您可能需要重新创建绘图或从备份文件还原绘图。

一般故障排除方法

不自动事件,也没有 Microsoft Visual Basic for Applications 开始 Visio

开始 Visio,而无需自动化事件和 Visual Basic for Applications。若要执行此操作,请使用下列方法之一:

方法 1: Microsoft Office Visio 2013 和 Visio 2010
  1. 开始 Visio。
  2. 文件 选项卡,单击选项,然后单击信任中心
  3. 单击信任中心设置,然后单击禁用所有宏,并且不通知
  4. 单击加载项
  5. 单击以选中禁用所有应用程序加载 复选框。
  6. 单击确定
  7. 退出 Visio 并重新启动 Visio。

方法 2: Microsoft Office Visio 2007
  1. 正常启动 Visio。
  2. 工具菜单上,单击信任中心
  3. 单击宏设置,然后单击禁用所有宏,并且不通知
  4. 单击加载项
  5. 单击以选中禁用所有应用程序外接程序复选框。
  6. 单击确定
  7. 退出 Visio 并重新启动 Visio。
方法 3: Microsoft Office Visio 2003 和早期版本的 Visio
  1. 正常启动 Visio。
  2. 使用下列过程中,具体取决于您所运行的 Visio 版本之一:
    • 如果运行 Visio 2003 时,在工具菜单上,单击选项,然后单击安全选项卡。
    • 如果您正在运行 Visio 2002,在工具菜单上,单击选项,然后单击高级选项卡。
  3. 请执行以下操作:
    • 单击以清除启用 Microsoft Visual Basic for Applications复选框。

      注意单击以清除启用 Microsoft Visual Basic for Applications复选框后,启用 Microsoft Visual Basic for Applications 的项目创建复选框和加载 Microsoft Visual Basic for Applications 文本中的项目复选框将不可用。
    • 单击以清除启用 COM 外接程序复选框。
    • 单击以清除启用自动事件复选框。
  4. 单击确定,然后再退出 Visio。
  5. 重新启动 Visio。
方法 4: 使用复制绘图命令来将每一页复制到一个新的绘图中的页面。
对于 Visio 2013 和 Visio 2010:
  1. 请确保未在绘图中选择。
  2. 主页 选项卡上,在剪贴板 组中,单击复制
  3. 打开要在其中嵌入绘图,并在家庭中的选项卡,剪贴板组中,然后单击粘贴的文档。
对于 Visio 2007 和 Visio 2003:
  1. 在 Microsoft Office Visio 绘图中,请确保未选定。
  2. 编辑菜单上,单击复制绘图注意此命令复制整个绘图,其中包括在其他绘图页和背景上的形状。当嵌入多页 Visio 绘图时,显示的页面将处于活动状态,单击复制绘图时的一个。
  3. 在您要嵌入绘图,然后在打开的文档编辑 菜单上,单击粘贴 (或等效的命令)。
    来源: Visio 2007 帮助和操作方法http://office.microsoft.com/en-us/visio/HP012314701033.aspx

在安全模式下启动 Windows

在安全模式下启动 Windows。为此:

注意因为有多个版本的 Microsoft Windows,下面的步骤可能不同于您的计算机。如果是这样,请参阅产品文档来完成这些步骤。
  1. 关闭,然后重新启动计算机。
  2. 当看到"请选择要启动的操作系统"消息时,按 f8 键。
  3. Windows 高级选项 菜单上,使用箭头键选择安全模式,然后按 ENTER。
  4. 如果有双重引导或多重引导计算机,请从显示列表中,然后按 enter 键选择相应的操作系统。
  5. 开始 Visio,然后再尝试打开您的绘图。
有关安全模式的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
315222 在 Windows XP 中的安全模式引导选项的说明
202485 在 Windows 2000 中的安全启动模式的说明
180902 如何在安全模式下启动基于 Windows 98 的计算机

如果您无法打开绘图,请尝试的方法

方法 1: 将绘图文件拖动到 Visio.exe 文件图标

将绘图文件拖动到代表 Visio.exe 文件的图标。若要执行此操作: 如果您正在运行 Visio 2010,Visio.exe 文件位于以下文件夹中: 驱动器: \Program Files\Microsoft Office\Office14 * 如果您在 Windows 64 位安装 Visio 的 32 位程序文件文件夹将具有 (x86) 文件夹名称后面。Visio 2010 现在具有本机 64 位版本。
  1. 退出 Visio。
  2. 开始 Microsoft Windows 资源管理器,然后找到 Visio.exe 文件在您的硬盘上。如果您将 Visio 安装到默认位置中,Visio.exe 文件位于下面的文件夹中,具体取决于您所运行的 Visio 版本之一:
    • 如果您正在运行 Visio 2013,Visio.exe 文件位于以下文件夹中:
      驱动器: \Program Files\Microsoft Office\Office15
      注意如果您在 64 位版本的 Windows 上安装 32 位版本的 Visio,程序文件文件夹将具有 (x86) 文件夹名称后面。Visio 2013 现在具有本机 64 位版本。
    • 如果您正在运行 Visio 2010,Visio.exe 文件位于以下文件夹中:驱动器: \Program Files\Microsoft Office\Office14注释如果您在 64 位版本的 Windows 中,程序文件文件夹中安装 32 位版本的 Visio 将具有 (x86) 文件夹名称后面。Visio 2010 现在具有本机 64 位版本。


      如果您正在运行 Visio 2007,Visio.exe 文件位于以下文件夹中:
      驱动器: \Program Files\Microsoft Office\Office12
      如果您正在运行 Visio 2003,Visio.exe 文件位于以下文件夹中:
      驱动器: \Program Files\Microsoft Office\Visio11
    • 如果您正在运行 Visio 2002,Visio.exe 文件位于以下文件夹中:
      驱动器: \Program Files\Microsoft Office\Visio10
      注意如果您将 Visio 安装到默认安装位置不同的文件夹中,则 Visio.exe 文件的路径是在您的计算机上的不同。
  3. 在 Windows 资源管理器中,找到要打开的绘图文件。
  4. 将绘图文件拖动到代表 Visio.exe 文件的图标。

方法 2: 双击 Windows 资源管理器中的图形文件

尝试使用 Windows 资源管理器中打开绘图文件。为此:
  1. 退出 Visio。
  2. 开始 Windows 资源管理器,然后找到要打开的绘图文件。
  3. 双击绘图文件。

方法 3: 打开绘图文件的临时副本

修改 Visio 绘图时,将创建绘图文件的临时副本。绘图文件的临时副本命名为 ~ $$文件名。 ~ vsd。绘图文件的临时副本通常创建并存储在您的绘图所在的位置相同的文件夹中。

若要打开绘图文件的临时副本,请执行以下操作:
  1. 开始 Visio,然后再打开绘图。
  2. 开始 Windows 资源管理器,然后找到绘图所在的文件夹。查看此文件夹的绘图文件的临时副本。绘图文件的临时副本命名为 ~ $$文件名。 ~ vsd。

    注意如果绘图文件的临时副本不在文件夹中存储您的绘图,请搜索硬盘的绘图文件的临时副本。

    若要搜索硬盘的绘图文件的临时副本,请执行以下操作:

    注意因为有多个版本的 Microsoft Windows,下面的步骤可能不同于您的计算机。如果是这样,请参阅产品文档来完成这些步骤。
    1. 单击开始,然后单击搜索
    2. 单击所有文件和文件夹
    3. 全部或部分文件名框中,键入 ~$$文件名。 ~ vsd然后单击搜索
  3. 将绘图文件的临时副本的扩展名更改为.vsd。为此:
    1. 用鼠标右键单击绘图文件的临时副本,然后单击重命名
    2. 从 ~.vsd 的绘图文件的临时副本的扩展名更改为.vsd。
  4. 尝试打开您重命名该绘图文件的临时副本。

方法 4: 使用 Microsoft Office Visio Viewer 打开绘图

设置 Microsoft Office Visio 查看器 2010年,然后使用 Visio Viewer 打开并查看您的绘图。在安装 Visio 查看器 2010年时,可以使用 Microsoft Internet Explorer 5.0 或更高版本的 Internet Explorer 查看 Visio 绘图和图表以 Visio 2010、 Visio 2007、 Visio 2003,Visio 2002,Microsoft Visio 2000,或者 Microsoft Visio 5 创建的。有关 Visio 查看器 2010年的详细信息,请访问下面的 Microsoft 网站:

http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=21701

如果您可以在 Visio Viewer 中打开绘图,可能会损坏您的计算机上安装 Visio,或者您的绘图可能包含一个或多个对象可能损坏。

方法 5: 将绘图文件复制到另一台计算机

将绘图文件复制到另一台计算机上安装了 Visio 中。如果可以打开您在该计算机上的绘图,到不同的文件夹中保存绘图文件的计算机、 该计算机的硬盘上,然后将绘图文件复制回原来的计算机。

方法 6: 将绘图文件复制到您的计算机上的另一张磁盘

Windows 可能不能从绘图文件的当前保存位置读取该绘图文件。将绘图文件复制到您的计算机上的另一个磁盘。例如,将文件从软盘复制到硬盘上。在您的计算机上的绘图文件复制到另一个磁盘后,尝试打开绘图文件。

注意如果您不能从保存绘图文件的磁盘复制绘图文件,可能与其他文件或文件夹交叉链接绘图文件或绘图文件可以位于磁盘的坏扇区。若要解决此问题,请按照方法 7。

方法 7: 检测并修复硬盘上的错误

如果您运行的 Microsoft Windows Server 2003,Microsoft Windows XP、 Microsoft Windows 2000,或者 Microsoft Windows NT 4.0 中,使用检查磁盘工具来检测文件系统错误或坏扇区,在您的硬盘上。

详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
315265 如何在 Windows XP 中执行磁盘错误检查
156571 如何在 Windows 中执行磁盘扫描程序

如果您运行的 Microsoft Windows 操作系统版本 (Me) 或 Microsoft Windows 98,请使用磁盘扫描工具来检测文件系统错误或坏扇区,在您的硬盘上。

有关详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
186365 描述磁盘扫描程序的 Windows (Scandskw.exe) 在 Windows 98 / Me

注意虽然检查磁盘工具或磁盘扫描程序工具可以检测并修复文件系统错误或硬盘上的坏扇区,Visio 可能仍不能打开或读取该文件。

如果您运行的 Windows Vista,请访问下面的 Microsoft Web 站点的详细信息:
http://windowshelp.microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx
方法 8: 打开以前"卷影副本"使用早期版本选项卡


1.右键单击 Visio 文件
2.选择属性
3.选择早期版本选项卡,为一些时间来填充列表
4.选择文件的较早版本
5.单击打开
6.如果成功打开文件,从文件菜单上单击另存为并保存该文件的副本



如果可以打开相应的绘图,请尝试的方法

方法 1: 将该文件另存为 XML 绘图

将绘图另存为 XML 绘图 (.vdx 文件),然后保存绘图的绘图 (.vsd 文件) 作为 XML。为此:
  1. 开始 Visio,然后再打开绘图。
  2. 文件菜单上,单击另存为
  3. 另存为对话框中,单击XML 绘图 (*.vdx)<b00> </b00> 将另存为类型框中,然后键入一个文件名,在文件名框中。指定所需保存的绘图文件的位置,然后单击保存
  4. 关闭当前打开的所有绘图。
  5. 文件菜单上,单击打开
  6. 找到在第 3 步中保存的 XML 绘图 (.vdx),然后单击打开
  7. 文件菜单上,单击另存为
  8. 另存为对话框中,单击绘图 (*.vsd)<b00> </b00> 将另存为类型框中,然后键入一个文件名,在文件名框中。指定所需保存的绘图文件的位置,然后单击保存
  9. 关闭绘图。
  10. 文件菜单上,单击打开
  11. 找到您先前在步骤 8 中保存的绘图 (.vsd 文件),然后单击打开

方法 2: 插入到新的空白绘图的绘图

将插入到新的空白绘图的绘图。为此:

对于 Visio 2013 和 Visio 2010:
  1. 开始 Visio
  2. 文件 选项卡上,在新建、 选择空白绘图和然后单击下的创建 按钮。
  3. 插入 选项卡上,单击对象
  4. 单击由文件创建,然后单击浏览
  5. 选择绘图,请单击打开,然后单击确定
  6. 根据您的具体情况,确定绘图文件是否已损坏或是否有其他的问题。
    • 如果您收到"Error 3400"错误信息,该图形文件可能已损坏。使用此文章来尝试恢复绘图所述的方法。
    • 如果您不会收到"Error 3400"错误信息,可能有可能阻止 Visio 打开绘图的另一个问题。例如,在计算机上导致 Visio 无法打开绘图的某些组件之间可能存在冲突。
对于 Visio 2007 和 Visio 2003:
  1. 开始 Visio。
  2. 文件菜单上,指向新建,然后单击新建绘图
  3. 插入菜单上,单击对象
  4. 单击由文件创建,然后单击浏览
  5. 单击绘图,单击打开,然后单击确定
  6. 根据您的具体情况,确定绘图文件是否已损坏或是否有其他的问题。
    • 如果您收到"Error 3400"错误信息,该图形文件可能已损坏。使用此文章来尝试恢复绘图所述的方法。
    • 如果您不会收到"Error 3400"错误信息,可能有可能阻止 Visio 打开绘图的另一个问题。例如,在计算机上导致 Visio 无法打开绘图的某些组件之间可能存在冲突。
    S

尝试有助于预防绘图损坏的方法

您无法阻止所有的文件,可能会出现的损坏。硬盘磨损、 电源故障,和其他不可预知的事件可能会导致文件损坏。下面的提示和建议可能有助于减少出现在 Visio 中和在其他程序中的已损坏的文件的数目。

在 Visio 中的自动恢复设置的优化

自动恢复设置配置为一个适合您的值。如果您的计算机停止响应,或者如果您意外断电时,Visio 将打开自动恢复文件在下次启动该程序。自动恢复文件可能包含未保存的信息将会丢失原始绘图文件中的数据。如果原始绘图文件已损坏,您可以从自动恢复文件恢复信息。

若要在 Visio 中配置自动恢复设置:
  1. 开始 Visio。
  2. 工具菜单上,单击选项
  3. 单击保存选项卡或保存/打开选项卡。
  4. 选择保存自动恢复信息每个复选框,然后再指定所需的分钟时间。默认情况下,自动恢复设置为 10 分钟。
  5. 单击确定

请确保电源已一致

不一致的电源会导致文件损坏,即使您不会丢失电源。电源供应激增或不充分会影响读取的进程和写在您的计算机上的进程,并可能导致损坏。如果您所在地区的电源不稳定,请使用浪涌保护器。电涌保护器可以帮助防止损坏您的计算机上,如果出现电源峰值。您可以考虑使用不间断电源 (UPS)。即使停电 UPS 设备可以为您的计算机提供电源。有关如何获取这些设备的详细信息,请与您的硬件供应商联系。

备份数据

请确保定期备份您的数据。例如,在不同的硬盘上的卷上存储备份副本的绘图。或者,根据您的需求和您的环境,实现其他备份或其他容错解决方案在您的计算机上。一些容错的解决方案,如冗余独立磁盘阵列 (RAID),通常只是适用于较大的网络。其他备份选项,包括:
  • 磁带备份
  • 光盘的备份
  • 镜像的卷
  • Raid-5 卷
  • 外部硬盘驱动器上
  • (Flash) USB 驱动器

使用本地数据

如果您在网络环境中工作,并且经常遇到损坏问题,可能要考虑到本地计算机中复制文件,或在打开文件之前修改该文件。通过使用我的电脑或 Windows 资源管理器,请将文件复制到您的桌面。时使用的文件存储在您的本地计算机上,在防止读取的问题,或写入问题可能由网络连接问题,如下所示:
  • 慢速网络连接
  • 网络连接断开
  • 网络流量高峰
您可能还需要考虑从硬盘中工作,并且从可移动媒体 (如软盘或 ZIP 驱动器无法正常工作。更多的媒体和存储中涉及的多个设备驱动程序操作、 更多的可能性发生文件损坏。

参考

有关 Visio 的详细信息,请访问下面的 Microsoft 网站:

属性

文章编号: 826418 - 最后修改: 2013年11月1日 - 修订: 5.0
这篇文章中的信息适用于:
  • Microsoft Visio Professional 2013
  • Microsoft Visio Standard 2013
  • Microsoft Visio Premium 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
关键字:?
kbpubtypekc kbopenfile kberrmsg kbdisplay kbhowtomaster kbtshoot kbprb kbmt KB826418 KbMtzh
机器翻译
重要说明:本文是由 Microsoft 机器翻译软件进行的翻译并可能由 Microsoft 社区通过社区翻译机构(CTF)技术进行后期编辑,或可能是由人工进行的翻译。Microsoft 同时向您提供机器翻译、人工翻译及社区后期编辑的文章,以便对我们知识库中的所有文章以多种语言提供访问。翻译的文章可能存在词汇、句法和/或语法方面的错误。Microsoft 对由于内容的误译或客户对内容的使用所导致的任何不准确、错误或损失不承担责任。
点击这里察看该文章的英文版: 826418
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com