如何疑難排解在 Visio 中的復原損壞的繪圖

文章翻譯 文章翻譯
文章編號: 826418 - 檢視此文章適用的產品。
全部展開 | 全部摺疊

在此頁中

結論

本文將告訴您如何疑難排解復原損壞的繪圖在 Microsoft Office Visio 2013、 Visio 2010,Visio 2007,Microsoft Office Visio 2003 中,Microsoft Visio 2002。本文將告訴您可能已損毀的繪圖,您在 Visio 中使用的某些徵狀。

此外,本文會列出一些您可以使用損壞的繪圖的復原方法。其中包括一般疑難排解方法,如果您可以或無法開啟繪圖,以及可協助防止繪圖損壞的方法,可嘗試的方法。

簡介

概觀

如果您遇到未預期的行為,當您使用 Visio 繪圖時,Visio 繪圖可能已經損毀。如果您有損壞的繪圖,您可能會收到下列錯誤訊息:
  • 「 無效分頁錯誤 」、 「 一般性保護錯誤 」 或 「 指令無效 」 錯誤訊息
  • 當您開啟的繪圖是類似於下列其中之一的錯誤訊息:

    動作開啟時發生錯誤 (100)

    Visio 無法開啟檔案,因為它不是一個 Visio 檔案,或已損毀。
  • 記憶體不足 」 錯誤訊息或錯誤訊息,指出系統資源不足
附註這些錯誤訊息並不一定代表您的繪圖已損毀。不過,如果您重複遇到一個或多個這些錯誤訊息當您使用特定的繪圖時,該繪圖可能會損毀。

本文將列出一些您可以使用來嘗試復原損壞的繪圖的方法。本文中所述的方法並不保證能夠成功復原損壞的繪圖。有時候,修復效果將視損壞而定,您可能無法復原任何資料。您可能必須重新建立繪圖,或從備份檔案還原繪圖。

一般疑難排解方法

啟動 Visio,沒有自動化事件,而不需 Microsoft Visual Basic for Applications

自動化事件不及的 Visual Basic for Applications,請啟動 Visio。若要這樣做,請使用下列方法之一:

方法 1: Microsoft Office Visio 2013 和 Visio 2010
  1. 開始使用 Visio。
  2. 檔案 索引標籤上,按一下 [選項],然後按一下 [信任中心
  3. 按一下 [信任中心設定],然後按一下 [停用所有巨集不事先通知
  4. 按一下 [增益集]。
  5. 按一下以選取停用所有的應用程式增益集 ] 核取方塊。
  6. 按一下[確定]
  7. 結束 Visio,然後再重新啟動 Visio。

方法 2: Microsoft Office Visio 2007
  1. 正常地啟動 Visio。
  2. 在 [工具] 功能表上按一下 [信任中心]。
  3. 按一下 [巨集設定],然後按一下 [停用所有巨集不事先通知
  4. 按一下 [增益集]。
  5. 按一下以選取 [停用所有的應用程式增益集] 核取方塊。
  6. 按一下[確定]
  7. 結束 Visio,然後再重新啟動 Visio。
方法 3: Microsoft Office Visio 2003 和舊版的 Visio
  1. 正常地啟動 Visio。
  2. 請使用下列程序,視您正在執行的 Visio 版本而定:
    • 如果您正在執行 Visio 2003,按一下 [工具] 功能表上的選項,然後按一下 [安全性] 索引標籤。
    • 如果您正在執行 Visio 2002,按一下 [工具] 功能表上的選項,然後按一下 [進階] 索引標籤。
  3. 請執行下列動作:
    • 按一下以清除啟用 Microsoft Visual Basic for Applications核取方塊。

      附註按一下以清除 [啟用 Microsoft Visual Basic for Applications ] 核取方塊之後,讓 Microsoft Visual Basic for Applications 專案建立] 核取方塊,並載入 Microsoft Visual Basic for Applications 專案,從 [文字] 核取方塊會變成無法使用。
    • 按一下以清除 [啟用的 COM 增益集] 核取方塊。
    • 按一下以清除 [啟用自動化事件] 核取方塊。
  4. 按一下 [確定],然後結束 [Visio。
  5. 重新啟動 Visio。
方法 4: 使用 [複製繪圖] 命令,將每一頁複製到新繪圖中的頁面。
Visio 2013 和 Visio 2010:
  1. 請確定已選取的繪圖中的任何項目。
  2. 家用 索引標籤,在剪貼簿 群組,請按一下 [複製]。
  3. 開啟您要內嵌的繪圖,然後在 [首頁] 索引標籤剪貼簿] 群組中,按一下 [貼上的文件。
Visio 2007 和 Visio 2003:
  1. 在 Microsoft Office Visio 繪圖中,請確定未選取任何內容。
  2. 按一下 [編輯] 功能表的 [複製繪圖]。附註此指令會複製整個繪圖,包括在其他繪圖頁與背景上的圖形。當您內嵌多頁面的 Visio 繪圖時,可見的頁面將是當您按一下 [複製繪圖為作用中的一個。
  3. 在您要內嵌繪圖,然後在開啟的文件編輯 ] 功能表中,按一下 [貼上 (或同等的指令)。
    來源: Visio 2007 說明和使用說明http://office.microsoft.com/en-us/visio/HP012314701033.aspx

以安全模式啟動 Windows

以安全模式啟動 Windows。若要執行這項操作:

附註因為有數個版本的 Microsoft Windows,下列步驟可能會在您的電腦上不同。如有需要,請參閱您的產品說明文件,以完成這些步驟。
  1. 關機並重新啟動您的電腦。
  2. 當您看到 「 請選擇要啟動的作業系統 」 訊息時,請按 F8。
  3. Windows 進階選項 ] 功能表中,使用方向鍵來選取「 安全模式中,並按 ENTER。
  4. 如果您有雙開機方式或多重開機電腦,請從清單中,會出現,然後再按 ENTER 鍵選取適當的作業系統。
  5. 啟動 Visio,然後再開啟您的繪圖。
如需有關安全模式的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:
315222 在 Windows XP 的 「 安全模式開機選項的說明
202485 在 Windows 2000 中的 「 安全開機模式的描述
180902 如何以安全模式啟動 Windows 98 的電腦

無法開啟繪圖時可嘗試的方法

方法 1: 將繪圖的檔案拖曳到 Visio.exe 檔案圖示

將繪圖檔案拖曳至代表 Visio.exe 檔案的圖示。若要執行這項操作: 如果您正在執行 Visio 2010,Visio.exe 檔案位於下列資料夾中: 磁碟機: \Program Files\Microsoft Office\Office14 * 如果您在 Windows 64 位元上安裝 Visio 32 位元會有的程式檔案資料夾 (x86) 後面的資料夾名稱。Visio 2010 現在有一個原生的 64 位元版本。
  1. 請結束 Visio。
  2. 啟動 Microsoft Windows 檔案總管],然後找出您硬碟上的 Visio.exe 檔案。如果您到預設位置安裝 Visio,Visio.exe 檔案位於下列資料夾中,根據您正在執行的 Visio 版本中的一個:
    • 如果您正在執行 Visio 2013,Visio.exe 檔案位於下列資料夾:
      磁碟機: \Program Files\Microsoft Office\Office15
      附註:如果您在 64 位元版本的 Windows 上安裝 32 位元版本的 Visio,Program Files 資料夾會有 (x86) 後面的資料夾名稱。Visio 2013 現在有一個原生的 64 位元版本。
    • 如果您正在執行 Visio 2010,Visio.exe 檔案位於下列資料夾中:磁碟機: \Program Files\Microsoft Office\Office14附註如果您在 64 位元版本的 Windows 程式檔案資料夾上安裝 32 位元版本的 Visio 將會有 (x86) 後面的資料夾名稱。Visio 2010 現在有一個原生的 64 位元版本。


      如果您正在執行 Visio 2007,Visio.exe 檔案位於下列資料夾:
      磁碟機: \Program Files\Microsoft Office\Office12
      如果您正在執行 Visio 2003,Visio.exe 檔案位於下列資料夾:
      磁碟機: \Program Files\Microsoft Office\Visio11
    • 如果您正在執行 Visio 2002,Visio.exe 檔案位於下列資料夾:
      磁碟機: \Program Files\Microsoft Office\Visio10
      附註如果您安裝 Visio 的資料夾,預設安裝位置不同,Visio.exe 檔案的路徑是在您的電腦上不同。
  3. 在 Windows 檔案總管] 中,找出您想要開啟的繪圖檔案。
  4. 將繪圖檔案拖曳至代表 Visio.exe 檔案的圖示。

方法 2: 按兩下 Windows 檔案總管] 中的繪圖檔案

請試著使用 Windows 檔案總管] 開啟繪圖檔案。若要執行這項操作:
  1. 請結束 Visio。
  2. 啟動 Windows 檔案總管,然後找出您想要開啟的繪圖檔案。
  3. 按兩下繪圖檔案。

方法 3: 開啟繪圖檔案暫時備份

當您修改的 Visio 繪圖時,會建立的繪圖檔案暫時備份。在名為繪圖檔案的暫存副本 ~ $$檔名。 ~ vsd。繪圖檔案的暫時備份通常建立並儲存在您的繪圖所在的同一個資料夾中。

若要開啟的繪圖檔案暫時備份,請執行下列各項:
  1. 啟動 Visio,然後再開啟您的繪圖。
  2. 啟動 Windows 檔案總管],然後找出存放您的繪圖的資料夾。尋找繪圖檔案的暫時備份此資料夾中。在名為繪圖檔案的暫存副本 ~ $$檔名。 ~ vsd。

    附註如果繪圖檔案的暫時備份不在儲存您的繪圖的資料夾中,搜尋繪圖檔案的暫時備份硬碟。

    若要搜尋繪圖檔案的暫時備份硬碟,請執行下列作業:

    附註因為有數個版本的 Microsoft Windows,下列步驟可能會在您的電腦上不同。如有需要,請參閱您的產品說明文件,以完成這些步驟。
    1. 按一下 [開始],然後按一下 [搜尋
    2. 按一下 [所有檔案和資料夾]。
    3. 在 [部份或完整的檔案名稱] 方塊中,輸入 ~$$檔名。 ~ vsd然後按一下 [搜尋
  3. 將繪圖檔案的暫時備份的副檔名變更為.vsd。若要執行這項操作:
    1. 以滑鼠右鍵按一下繪圖檔案的暫時備份,然後按一下 [重新命名
    2. 從 ~.vsd 繪圖檔案的暫時備份副檔名變更為.vsd。
  4. 嘗試開啟您重新命名的繪圖檔案的暫時備份。

方法 4: 使用 Microsoft Office Visio Viewer,若要開啟的繪圖

安裝 Microsoft Office Visio 檢視器 2010年,然後使用 Visio Viewer 開啟並檢視您的繪圖。當您安裝 Visio 檢視器 2010年時,您可以使用 Microsoft Internet Explorer 5.0 或較新版的 Internet Explorer 來檢視 Visio 繪圖和使用 Visio 2010,Visio 2007,Visio 2003,Visio 2002、 Microsoft Visio 2000 或 Microsoft Visio 5 建立的圖表。如需有關 Visio 檢視器 2010年的詳細資訊,請造訪下列 Microsoft 網站:

http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=21701

如果您可以在 Visio Viewer 中開啟您的繪圖,在電腦上的 Visio 安裝可能已損毀,或您的繪圖可能會包含一或多個可能已經損毀的物件。

方法 5: 將繪圖檔案複製到另一台電腦

將繪圖檔案複製到另一台電腦已在其上安裝 Visio。如果您可以開啟您的電腦上的繪圖,請將繪圖檔案儲存到不同的資料夾中,在該電腦的硬碟上,然後將繪圖檔案複製回原來的電腦。

方法 6: 將繪圖檔案複製到您的電腦上的另一個磁碟

Windows 可能無法從目前儲存繪圖檔案中讀取繪圖檔案。將繪圖檔案複製到您的電腦上的另一個磁碟。例如,將檔案從磁片複製到硬碟。將繪圖檔案複製到不同的磁碟的電腦上之後,請試著開啟繪圖檔案。

附註如果您無法從儲存繪圖檔案的磁碟複製繪圖檔案,可能會與其他檔案或資料夾交叉連結的繪圖檔案,或可能損毀的磁扇區的磁碟位於繪圖檔案。如果要疑難排解這個問題,請依照方法 7。

方法 7: 偵測並修復硬碟上的錯誤

如果您正在執行 Microsoft Windows Server 2003、 Microsoft Windows XP,Microsoft Windows 2000 或 Microsoft Windows NT 4.0,使用 [檢查磁碟] 工具來偵測檔案系統錯誤或損壞的磁區,在您的硬碟上。

如需詳細資訊,按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文件:
315265 如何執行 Windows XP 中檢查的磁碟錯誤
156571 如何在 Windows 中執行磁碟掃瞄工具

如果您正在執行 Microsoft Windows 情況或 Microsoft Windows 98,使用 「 磁碟掃瞄工具 」 工具來偵測檔案系統錯誤或損壞的磁區,在您的硬碟上。

如需詳細資訊,按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
186365 說明磁碟掃瞄工具視窗 (Scandskw.exe) 在 Windows 98 / Me

附註雖然 [檢查磁碟] 工具或 「 磁碟掃瞄工具 」 工具可以偵測並修復檔案系統錯誤或硬碟上的損壞磁扇區,Visio 可能仍然無法開啟或讀取檔案。

如果您執行 Windows Vista,請造訪下列 Microsoft 網站,如需詳細資訊:
http://windowshelp.microsoft.com/Windows/en-US/Help/bc1393cf-9f9c-79c7-0f91-9337c2c41f811033.mspx
方法 8: 開啟先前 「 陰影複製 」 使用 [舊版] 索引標籤


1.Visio 檔案按一下滑鼠右鍵
2.選擇 [屬性]
3.選取 [舊版] 索引標籤,提供一些時間來填入清單
4.選取較舊版本的檔案
5.按一下 [開啟]
6.如果成功開啟檔案,從 [檔案] 功能表按一下 [另存新檔,然後儲存檔案的複本



您可以開啟繪圖時可嘗試的方法

方法 1: 將檔案儲存為 XML 繪圖

將繪圖儲存為 XML 繪圖 (.vdx 檔案),並儲存繪圖為繪圖 (.vsd 檔案) 的 XML。若要執行這項操作:
  1. 啟動 Visio,然後再開啟您的繪圖。
  2. 在 [檔案] 功能表上按一下 [另新檔]。
  3. 在 [另新檔] 對話方塊中,按一下 [ XML 繪圖 (*.vdx)<b00> </b00> 存檔類型] 方塊中,然後再輸入檔案名稱] 方塊中的檔案名稱。指定您要儲存的繪圖檔的位置,然後按一下 [儲存
  4. 關閉目前開啟的所有繪圖。
  5. 在 [檔案] 功能表上按一下 [開啟]。
  6. 尋找您稍早在步驟 3 中儲存的 XML 繪圖 (.vdx),然後按一下 [開啟
  7. 在 [檔案] 功能表上按一下 [另新檔]。
  8. 在 [另新檔] 對話方塊中,按一下 [繪圖 (*.vsd)<b00> </b00> 存檔類型] 方塊中,然後再輸入檔案名稱] 方塊中的檔案名稱。指定您要儲存的繪圖檔的位置,然後按一下 [儲存
  9. 關閉繪圖。
  10. 在 [檔案] 功能表上按一下 [開啟
  11. 尋找您稍早在步驟 8 中儲存的繪圖 (.vsd 檔案),然後按一下 [開啟

方法 2: 插入新的空白繪圖的繪圖

插入新的空白繪圖的繪圖。若要執行這項操作:

Visio 2013 和 Visio 2010:
  1. 開始使用 Visio
  2. 檔案 ] 索引標籤下 [新增]、 選取空白的繪圖,然後再按一下建立 ] 按鈕。
  3. 插入 索引標籤上,按一下 [物件]。
  4. 按一下 [從檔案建立],然後按一下 [瀏覽]
  5. Selectthe 繪圖,請按一下 [開啟],然後按一下[確定]
  6. 根據您的情況判斷繪圖檔案已經損毀或是否有另一個問題。
    • 如果您收到 「 錯誤 3400 」 錯誤訊息,繪圖的檔案可能損毀。使用這份文件來嘗試復原繪圖中所述的方法。
    • 如果您不會收到 「 錯誤 3400 」 錯誤訊息,可能會使 Visio 無法開啟繪圖的另一個問題。例如,在電腦上造成 Visio 無法開啟繪圖的特定元件之間可能存在衝突。
Visio 2007 和 Visio 2003:
  1. 開始使用 Visio。
  2. 在 [檔案] 功能表上指向 [新增],然後按一下 [新增繪圖物件
  3. 按一下 [插入] 功能表的 [物件]。
  4. 按一下 [從檔案建立],然後按一下 [瀏覽]
  5. 按一下繪圖,按一下 [開啟],然後按一下[確定]
  6. 根據您的情況判斷繪圖檔案已經損毀或是否有另一個問題。
    • 如果您收到 「 錯誤 3400 」 錯誤訊息,繪圖的檔案可能損毀。使用這份文件來嘗試復原繪圖中所述的方法。
    • 如果您不會收到 「 錯誤 3400 」 錯誤訊息,可能會使 Visio 無法開啟繪圖的另一個問題。例如,在電腦上造成 Visio 無法開啟繪圖的特定元件之間可能存在衝突。
    S

嘗試以協助防止繪圖損壞的方法

您無法防止檔案可能發生的所有損毀。硬碟可能會穿上、 電源供應器可能會失敗,以及其他預見的事件可能會發生,造成檔案損毀。下列秘訣和建議將有助於降低損毀發生在 Visio 中,並在其他程式中的檔案數目。

最佳化在 Visio 中的 「 自動回復 」 設定

設定「 自動回復 」設定為適用於您的值。如果您的電腦停止回應,或如果您意外斷電,Visio 會開啟自動回復 」 檔案下一次您啟動程式。自動回復 」 檔案可能包含未儲存的資訊,否則會遺失原始繪圖檔案。如果原始繪圖檔案已經損毀,您可以從 「 自動回復 」 檔案復原資訊。

若要在 Visio 中設定「 自動回復 」設定:
  1. 開始使用 Visio。
  2. 在 [工具] 功能表上按一下 [選項]。
  3. 按一下 [儲存] 索引標籤或 [儲存或開啟] 索引標籤。
  4. 選取 [儲存自動復原資訊每個核取方塊,然後指定您想要的分鐘時間。根據預設, 「 自動回復 」設定是設定為 10 分鐘。
  5. 按一下[確定]

請確定電源供應是穩定

不一致的電源供給可能會造成檔案損毀,即使您不會遺失電源。電源供給驟增或不足無法讀取的處理和寫入處理程序,在您電腦上,可能會影響,而且可能造成傷害。如果您所在地區的電源供應不一致,請使用突波保護裝置。突波保護器可以協助防止您的電腦上的損害,如果發生電源特殊圖文集。您也可以考慮使用不斷電供電系統 (UPS)。即使沒有電源中斷,UPS 裝置會提供電腦的電源。如需有關如何取得這些裝置,請連絡您的硬體廠商。

備份資料

請確定您定期備份您的資料。例如,在硬碟上的不同磁碟區上儲存一份備份您的繪圖。或者,您也可以根據您的需求以及您的環境中,執行其他備份或其他容錯解決方案在您的電腦上。一些容錯解決方案,例如重複陣列的獨立磁碟 (RAID),通常是僅適合較大型的網路。其他備份選項包括:
  • 磁帶備份
  • CD 備份
  • 鏡像磁碟區
  • Raid-5 磁碟區
  • 外部硬碟磁碟機
  • USB (閃電) 磁碟機

處理本機資料

如果您在網路環境中工作且經常遇到損毀,您可能要考慮在開啟檔案或修改檔案之前,將檔案複製到本機電腦。使用我的電腦,或使用 Windows 檔案總管,請將檔案複製到您的桌面。當您使用儲存在本機電腦的檔案時,您防止讀取的問題或寫入可能如下所示的網路連線問題所造成的問題:
  • 低速網路連線
  • 網路連線中斷
  • 網路流量驟增
您也可以考慮使用硬碟中,而不要使用卸除式媒體,例如磁碟片或 ZIP 磁碟機。媒體及儲存涉及多個裝置驅動程式作業、 更多增加的檔案損壞的可能性。

?考

如需有關 Visio 的詳細資訊,請造訪下列 Microsoft 網站:

屬性

文章編號: 826418 - 上次校閱: 2013年10月29日 - 版次: 3.0
這篇文章中的資訊適用於:
  • Microsoft Visio Professional 2013
  • Microsoft Visio Standard 2013
  • Microsoft Visio Premium 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
關鍵字:?
kbpubtypekc kbopenfile kberrmsg kbdisplay kbhowtomaster kbtshoot kbprb kbmt KB826418 KbMtzh
機器翻譯
請注意--重要:本文是以 Microsoft 機器翻譯軟體翻譯而成,且可能由 Microsoft Community 利用 Community Translation Framework技術或人工進行事後編修。翻譯過程並無專業譯者參與。Microsoft 同時提供使用者人為翻譯、機器翻譯及社群編修後的機器翻譯三種版本的文章,讓使用者可以依其使用語言使用知識庫中的所有文章。但是,所有翻譯文章都可能不盡完美,內容都可能出現詞彙、語意或文法上的錯誤。就翻譯內容之不正確或錯誤,或客戶因使用翻譯內容所產生的任何損害,微軟不負擔任何責任。Microsoft將依合理的商業努力不斷地更新機器翻譯軟體和工具,以期能為使用者提供更好的服務。
按一下這裡查看此文章的英文版本:826418
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com