Datos no se completamente escriben en archivos que se encuentran en un recurso compartido de red después de establecer los atributos de los archivos en Windows 2000 Service Pack 4

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Síntomas

En Microsoft Windows 2000 Service Pack 4 (SP4) - basado en equipo, si utiliza la función WriteFile para escribir datos en un archivo que se encuentra en un recurso compartido de red y, a continuación, establecer los atributos del archivo mediante la función SetFileAttributes , experimenta todos los síntomas siguientes:
  • No todos los datos se escriben en el archivo. El tamaño del archivo que se encuentra en el recurso compartido de red es menor de lo esperado.
  • No se recibe un mensaje de error y no mensajes de error se registran en el registro de sucesos.
  • Si realiza una traza de Monitor de red de la operación, el tamaño del archivo se trunca al mismo tamaño que se devuelve a la solicitud CreateAndX en el paquete de bloque de mensajes de servidor (SMB) de Windows 2000.
  • Es posible que no pueda abrir, girar o ver el archivo en el recurso compartido de red mediante el programa de Microsoft Office Document Imaging.

Causa

Este problema se produce en situaciones donde SMB procesa incorrectamente varias operaciones de apertura del archivo.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión requiere Windows 2000 SP4.

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   13-Nov-2003  02:04  5.0.2195.6874     408,080  Mrxsmb.sys
   13-Nov-2003  02:03  5.0.2195.6874     169,776  Rdbss.sys
   13-Nov-2003  02:20                      7,502  Kb371795.cat

Solución

Para evitar el problema de Microsoft Office Document Imaging que se describe en la sección "Síntomas", deshabilite el bloqueo oportunista. Microsoft recomienda que deshabilite el bloqueo oportunista en el equipo cliente que está experimentando este problema en lugar de en el servidor. Al hacerlo, no está afectado el rendimiento del servidor. Para obtener información adicional acerca de cómo configurar el bloqueo oportunista en Windows, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296264Configuración del bloqueo de archivo en Windows
Para evitar el problema de truncamiento de tamaño de archivo que también se describe en la sección "Síntomas", utilice la función FlushFileBuffers antes de utilizar la función SetFileAttributes . Al hacerlo, se forzar los datos se escriban en el archivo.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Más información

Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 826482 - Última revisión: jueves, 13 de febrero de 2014 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwin2000presp5fix KB826482 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 826482

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