Data is not completely written to files that are located on a network share after you set the attributes of the files in Windows 2000 Service Pack 4

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Article ID: 826482 - View products that this article applies to.
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SYMPTOMS

On your Microsoft Windows 2000 Service Pack 4 (SP4)-based computer, if you use the WriteFile function to write data to a file that is located on a network share, and then you set the attributes of the file by using the SetFileAttributes function, you experience all the following symptoms:
  • Not all the data is written to the file. The size of the file that is located on the network share is smaller than expected.
  • You do not receive an error message, and no error messages are logged to the event log.
  • If you perform a Network Monitor trace of the operation, the size of the file is truncated to the same size that is returned to the CreateAndX request in the Windows 2000 Server Message Block (SMB) packet.
  • You may not be able to open, to rotate, or to view the file on the network share by using the Microsoft Office Document Imaging program.

CAUSE

This problem occurs in situations where SMB incorrectly processes multiple open operations of the file.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows 2000 SP4.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   13-Nov-2003  02:04  5.0.2195.6874     408,080  Mrxsmb.sys
   13-Nov-2003  02:03  5.0.2195.6874     169,776  Rdbss.sys
   13-Nov-2003  02:20                      7,502  Kb371795.cat

WORKAROUND

To work around the Microsoft Office Document Imaging issue that is described in the "Symptoms" section, disable opportunistic locking. Microsoft recommends that you disable opportunistic locking on the client computer that is experiencing this issue instead of on the server. By doing so, server performance is not affected. For additional information about how to configure opportunistic locking in Windows, click the following article number to view the article in the Microsoft Knowledge Base:
296264 Configuring opportunistic locking in Windows
To work around the file-size-truncation issue that is also described in the "Symptoms" section, use the FlushFileBuffers function before you use the SetFileAttributes function. When you do so, you force data to be written to the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 826482 - Last Review: October 26, 2013 - Revision: 3.2
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbwin2000presp5fix KB826482

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