Aparece un mensaje de error de inicialización "Error de User32.dll" o la interfaz de usuario no se actualiza correctamente

Seleccione idioma Seleccione idioma
Id. de artículo: 826518 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Si un programa (por ejemplo, Microsoft Word) utiliza una función de interfaz de dispositivo gráfico (GDI) API que crea un pincel, como CreateSolidBrush , si el programa quita una ventana antes de que se quita el pincel, pueden quedar bajos recursos GDI y puede experimentar uno o varios de los síntomas siguientes:
  • Recibirá un mensaje de error que es similar al siguiente:
    Service_NameError Error de inicialización - DLL: inicialización de la c:\windows\system32\user32.dll de biblioteca de vínculos dinámicos. El proceso está terminando de forma anormal.
  • La interfaz de usuario no puede actualizar correctamente. Por ejemplo, los menús no se muestran correctamente, se pierde el texto del botón o no volverá a dibujar imágenes de icono.

Causa

Este problema se produce porque el sistema operativo puede perder un identificador para un objeto de pincel GDI si una ventana se quita antes de quita el pincel.

Para obtener más información acerca de cómo solucionar esta pérdida, consulte la sección "More Information" de este artículo.

Solución

Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
No se necesita ningún requisito previo.
Requisito de reinicio
Una vez aplicado este hotfix, debe reiniciar el equipo.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información del archivo
La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
  Date         Time   Version       Size       File name 
  -------------------------------------------------------
  08-Dec-2003  06:11  5.2.3790.110  1,811,456  Win32k.sys

Windows 2000

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Para aplicar este hotfix, debe tener instalado en el equipo Windows 2000 Service Pack 4 (SP4). Para obtener información adicional acerca de cómo obtener el service pack más reciente, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000
Requisito de reinicio
Una vez aplicado este hotfix, debe reiniciar el equipo.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información del archivo
La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Sep-2003  18:52  5.0.2195.6738      42,256  Basesrv.dll      
   17-Jan-2003  16:06  5.0.2195.6656     236,304  Cmd.exe          
   10-Sep-2003  18:52  5.0.2195.6762     222,992  Gdi32.dll        
   10-Sep-2003  18:52  5.0.2195.6816     711,440  Kernel32.dll     
   10-Sep-2003  18:52  5.0.2195.6807     333,584  Msgina.dll       
   10-Sep-2003  18:52  5.0.2195.6701      90,232  Rdpwd.sys
   04-Sep-2003  17:06  5.0.2195.6801   5,232,128  Sp3res.dll       
   10-Sep-2003  18:52  5.0.2195.6799     380,176  User32.dll       
   10-Sep-2003  18:52  5.0.2195.6794     385,808  Userenv.dll      
   08-Sep-2003  17:21  5.0.2195.6817   1,628,464  Win32k.sys
   03-Sep-2003  22:13  5.0.2195.6815     182,032  Winlogon.exe     
   10-Sep-2003  18:52  5.0.2195.6775     243,984  Winsrv.dll       
   10-Sep-2003  18:52  5.0.2195.6816     711,440  Kernel32.dll     
   08-Sep-2003  17:21  5.0.2195.6817   1,628,464  Win32k.sys
   10-Sep-2003  18:52  5.0.2195.6775     243,984  Winsrv.dll 

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Más información

Para solucionar este problema, utilice la herramienta de Gdiobj.exe para supervisar la columna de pincel PID 0 . PID 0 representa objetos GDI que no son privados. Si la columna de pincel continuamente aumenta pero no disminuye, puede experimentar la pérdida que se describe en este artículo. En este caso, puede ver la pérdida al iniciar y detener Microsoft Word; la columna de pincel aumenta en 2, pero cuando salga del programa, no disminuye.

Para descargar la herramienta Gdiobj.exe, visite el siguiente sitio Web de Yuan Feng:
http://www.fengyuan.com/download.html
Para obtener información adicional acerca de los objetos GDI, visite el siguiente sitio Web:
http://msdn2.microsoft.com/en-us/library/ms724291.aspx
Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura para paquetes de revisión de Microsoft Windows

Propiedades

Id. de artículo: 826518 - Última revisión: martes, 24 de julio de 2007 - Versión: 3.7
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix KB826518 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 826518

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com