PowerPoint 2003 および PowerPoint 2002 でプレゼンテーションが破損した場合のトラブルシューティング方法

文書翻訳 文書翻訳
文書番号: 826810 - 対象製品
Microsoft PowerPoint 2000 については、次の資料を参照してください。207377
すべて展開する | すべて折りたたむ

目次

概要

Microsoft Office PowerPoint 2003 プレゼンテーションで作業中に予期しない現象が発生する場合は、プレゼンテーションが破損している可能性があります。プレゼンテーションが破損した場合、次のような現象が発生することがあります。
  • ページ違反、一般保護エラー、または無効な命令エラーが発生する。
  • プレゼンテーションを開くときに、次のいずれかのエラー メッセージが表示される。
    This is not a PowerPoint Presentation
    filename の種類のファイルは、PowerPoint では開けません。
    ファイルの一部が失われているため、filename を開けません。
  • メモリ不足エラー、またはシステム リソース不足エラーが発生する。
この現象が特定のプレゼンテーションのみで発生する場合は、そのプレゼンテーションが破損している可能性があります。この資料では、破損したプレゼンテーションを修復するための一般的な手順について説明します。ただし、この手順を実行しても、破損したプレゼンテーションが必ず修復できるわけではありません。破損の状態によっては、データをまったく復元できず、破損したプレゼンテーション自体を作成し直すことが必要な場合があります。

: これらの現象は、プレゼンテーションの破損以外の原因で発生する場合もあります。

詳細

プレゼンテーションが破損していることが判明した場合は、破損したプレゼンテーションを修復するために、次の手順を実行します。この資料では、以下のように 3 つの場合に分けて修復手順を説明します。

一般的なトラブルシューティング

: Microsoft Windows には複数のバージョンが存在するため、使用中のコンピュータによっては以下の手順が異なる場合があります。この場合、製品のマニュアルを参照のうえ、手順を実行するようにしてください。
Windows をセーフ モードで再起動します。これを行うには、コンピュータの再起動時に、F8 キーを押します。[Windows 拡張オプション] メニューの [セーフ モード] を選択します。

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
180902 Windows 98 を実行しているコンピュータを Safe モードで起動する方法
192926 Windows 98 でクリーン ブート トラブルシューティングを実行する方法
290367 [OFFXP] Microsoft Windows NT 4.0 での Office プログラムのトラブルシューティング
Windows をセーフ モードで起動することによってプレゼンテーションを開くことができる場合、ファイルを開けなかった原因はシステムで競合が発生したことです。



プレゼンテーションを開くことができない場合のトラブルシューティング

プレゼンテーションを開けない場合は、次のいずれかの方法を実行します。

方法 1 : 破損したプレゼンテーションを PowerPoint プログラム ファイルにドラッグする

  1. PowerPoint プログラムがインストールされている場所を確認します。

    デフォルトでは、PowerPoint 2003 は以下の場所にインストールされます。
    C:\Program Files\Microsoft Office\Office11
    デフォルトでは、PowerPoint 2002 は以下の場所にインストールされます。
    C:\Program Files\Microsoft Office\OFFICE11
  2. 破損した PowerPoint プレゼンテーションを PowerPoint プログラムのアイコンにドラッグします。

方法 2 : エクスプローラで、破損したプレゼンテーションをダブルクリックする

エクスプローラで、破損した PowerPoint プレゼンテーションをダブルクリックして、ファイルを開いてみます。

方法 3 : 空白のプレゼンテーションにスライドを挿入する

空白のプレゼンテーションにスライドを挿入するには、次の手順を実行します。
  1. [ファイル] メニューの [新規作成] をクリックし、[新規作成] 作業ウィンドウで [新しいプレゼンテーション] をクリックします。

    これにより、タイトルが空白のスライドが作成されます。このスライドは、プレゼンテーションを作成し直した後、削除することができます。
  2. [挿入] メニューの [ファイルからスライド] をクリックし、[プレゼンテーションの検索] タブをクリックします。
  3. [参照] をクリックします。

    破損したプレゼンテーションを選択して、[開く] をクリックします。
  4. [すべて挿入] をクリックします。

    この操作が成功すると、破損したプレゼンテーションの全スライド (スライド マスタを除く) が新規のプレゼンテーションに挿入されます。
  5. プレゼンテーションを保存します。

    以上の手順を実行しても、元のプレゼンテーションを再作成できない場合は、破損したプレゼンテーションをテンプレートとして適用します。これを行うには、以下の手順を実行します。
    1. プレゼンテーションのバックアップを作成します。
    2. [書式] メニューの [スライドのデザイン] をクリックします。
    3. [スライドのデザイン] 作業ウィンドウで [参照] をクリックします。
    4. 破損したプレゼンテーションを選択し、[適用] をクリックします。
    破損したプレゼンテーションのスライド マスタが新規のスライド マスタと置き換わります。

    : このとき予期しない現象が発生する場合は、適用したテンプレートによりプレゼンテーションが破損している可能性があります。この場合にはバックアップ コピーを使用して再度マスタ スライドを作成します。

方法 4 : 破損したプレゼンテーションの一時ファイルを開く

PowerPoint プレゼンテーションを編集中、PPT####.tmp (#### には任意の番号が入ります) という名前でファイルの一時コピーが作成されます。このファイルは作成中のプレゼンテーションと同じフォルダか、一時ファイル フォルダにあります。一時ファイルのファイル名拡張子を .ppt に変更すると、そのファイルを PowerPoint で開くことができる場合があります。一時ファイルを開くには、以下の手順を実行します。
  1. プレゼンテーションが保存されているフォルダの場所を確認し、PPT####.tmp. という名前のファイルを見つけます。

    フォルダ内にファイルがない場合は、他の場所を検索します。見つかった場合は手順 2. 〜 4. は実行する必要はありません。
  2. [スタート] ボタンをクリックし、[検索] をポイントし、[ファイルやフォルダ] をクリックします。

    : Windows 2000 または Microsoft Windows Millennium Edition (Me) の場合は、[スタート] ボタンをクリックし、[検索] をポイントし、[ファイルやフォルダ] をクリックします。Windows XP の場合は、[スタート] ボタンをクリックし、[検索] をクリックします。
  3. [名前] ボックスまたは [ファイルまたはフォルダの名前] ボックスに、PPT*.tmp と入力します。
  4. [探す場所] ボックスの一覧で [マイ コンピュータ] をクリックし、[検索開始] をクリックします。
  5. ファイルが見つかった場合、次の手順を実行します。
    1. ファイルを右クリックし、[名前の変更] をクリックします。
    2. ファイル名が PPT####.ppt となるように、ファイルの拡張子を .tmp から .ppt に変更します。
    3. このファイルを PowerPoint で開きます。
プレゼンテーションを最後に保存したときの一時ファイルが複数存在する場合は、それぞれのファイルを開いてどのファイルがプレゼンテーションの一時コピーに該当するのかを判別する必要があります。

方法 5 : プレゼンテーションを PowerPoint Viewer で開く

PowerPoint Viewer でプレゼンテーションを開くことができる場合、インストールされている PowerPoint プログラムが破損しているか、プレゼンテーションに破損したオブジェクトが含まれている可能性があります。

方法 6 : プレゼンテーションを別のコンピュータに移動する

PowerPoint プレゼンテーションを別のコンピュータにコピーすると、プレゼンテーションを開くことができる場合があります。プレゼンテーションが開く場合は、各スライドを調べ、空白のオブジェクト プレースホルダがないかどうかを確認します。空白のオブジェクト プレースホルダがあった場合は、そのプレースホルダを削除します。その後、プレゼンテーションを保存し、元のコンピュータにコピーします。

方法 7 : プレゼンテーションを別のディスクへ移動する

Windows で、現在の保存場所からプレゼンテーションを読み込むことができない場合があります。プレゼンテーションを別のディスクにコピーします。たとえば、プレゼンテーションをフロッピー ディスクからハード ディスクにコピーします。

: 保存されているディスクからプレゼンテーションをコピーできない場合は、他のファイルまたはフォルダとクロスリンクされているか、プレゼンテーションが保存されているディスクのセクタが破損している可能性があります。このような場合は、方法 8 を実行します。

方法 8 : スキャンディスクを実行する

スキャンディスクを実行してドライブ上にあるすべてのエラーを修復します。スキャンディスクを実行すると、クロスリンクされているファイルがすべて修復され、消失した断片がファイルに変換されます。

: スキャンディスクによってプレゼンテーションの相互リンクが検出されて修正されても、必ずしもプレゼンテーションが PowerPoint で読み込めるようになるとは限りません。

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
315265 Windows XP でディスクのエラーをチェックする方法
156571 [NT] Windows NT 4.0 におけるスキャンディスクの実行方法について
186365 Windows 98/Me の Windows 版スキャンディスク (Scandskw.exe) について


プレゼンテーションを開くことができる場合のトラブルシューティング

方法 1 : 破損したプレゼンテーションをテンプレートとして適用する

スライドを空白のプレゼンテーションに挿入し、マスタを維持するために、破損したプレゼンテーションをテンプレートとして適用します。これを行うには、以下の手順を実行します。
  1. [ファイル] メニューの [新規作成] をクリックします。

    これにより、タイトルが空白のスライドが作成されます。このスライドは、プレゼンテーションを作成し直した後、削除することができます。
  2. [挿入] メニューの [ファイルからスライド] をクリックし、[プレゼンテーションの検索] タブをクリックします。
  3. [参照] をクリックし、破損したプレゼンテーションを選択し、[開く] をクリックします。
  4. [すべて挿入] をクリックします。

    この操作が成功すると、破損したプレゼンテーションの全スライド (スライド マスタを除く) が新規のプレゼンテーションに挿入されます。
  5. プレゼンテーションを保存します。プレゼンテーションが元のとおりに作成されない場合は、破損したプレゼンテーションをテンプレートとして適用します。これを行うには、次の手順を実行します。
    1. プレゼンテーションのバックアップを作成します。
    2. [書式] メニューの [スライドのデザイン] をクリックします。
    3. [スライドのデザイン] 作業ウィンドウで [参照] をクリックします。
    4. 破損したプレゼンテーションを選択し、[適用] をクリックします。
    破損したプレゼンテーションのスライド マスタが新規のスライド マスタと置き換わります。

    : このとき予期しない現象が発生する場合は、適用したテンプレートによりプレゼンテーションが破損している可能性があります。この場合にはバックアップ コピーを使用して再度マスタ スライドを作成します。

方法 2 : 破損したプレゼンテーションから新規のプレゼンテーションにスライドをコピーする

コピーと貼り付けの操作を行ってスライドを破損したプレゼンテーションから新しいプレゼンテーションにコピーします。これを行うには、次の手順を実行します。
  1. [ファイル] メニューの [開く] をクリックし、破損したプレゼンテーションを指定します。次に [開く] をクリックします。
  2. [ファイル] メニューの [新規作成] をクリックし、[新規作成] 作業ウィンドウで [新しいプレゼンテーション] をクリックします。
  3. [表示] メニューの [スライド一覧] をクリックします。

    表示を切り替えるときにエラー メッセージが表示される場合は、アウトライン表示に切り替えます。
  4. コピーするスライドをクリックします。
  5. [編集] メニューの [コピー] をクリックします。

    複数のスライドをまとめてコピーする場合は、Shift キーを押したままコピーするスライドをすべて選択します。
  6. 新規のプレゼンテーションに切り替えます。

    [ウィンドウ] メニューで、手順 2. で作成した新規のプレゼンテーションをクリックします。
  7. [表示] メニューの [スライド一覧] をクリックします。
  8. [編集] メニューの [貼り付け] をクリックします。
  9. 手順 5. 〜 9. を繰り返してプレゼンテーションのコピーを完了します。
: 場合によっては、1 つのスライドの破損が、プレゼンテーション全体の破損につながることがあります。特定のスライドをコピーした後に、コピー先の新規のプレゼンテーションで異常な現象が発生する場合は、そのスライドが破損していることがほとんどです。このような場合には、破損したスライドを作成し直すか、スライドを部分的に新しいスライドにコピーします。

方法 3 : プレゼンテーションを RTF (リッチ テキスト形式) で保存する

プレゼンテーション全体が破損している場合、RTF 形式で保存することがプレゼンテーションを修復する唯一の方法である場合があります。ただし、RTF 形式で保存した場合、復元されるのは、アウトライン表示で表示されるテキストのみです。RTF 形式で保存するには、以下の手順を実行します。
  1. プレゼンテーションを開きます。
  2. [ファイル] メニューの [名前を付けて保存] をクリックします。
  3. [名前を付けて保存] ボックスの一覧で [アウトライン/リッチ テキスト形式 (*.rtf)] をクリックします。
  4. [ファイル名] ボックスに任意の名前を入力し、プレゼンテーションの保存先を指定してから [保存] をクリックします。
  5. プレゼンテーションを閉じます。
: 保存した RTF 形式のプレゼンテーションを開いて作業を継続するには、[ファイル] メニューの [開く] をクリックし、[ファイルの種類] ボックスの一覧で [すべてのアウトライン] または [すべてのファイル] をクリックします。ここで [プレゼンテーション] などをクリックすると、RTF プレゼンテーションは表示されません。

プロパティ

文書番号: 826810 - 最終更新日: 2006年3月1日 - リビジョン: 4.0
この資料は以下の製品について記述したものです。
  • Microsoft Office PowerPoint 2003
  • Microsoft PowerPoint 2002 Standard Edition
キーワード:?
kberrmsg kbhowto kbtshoot kbcorrupt kbopenfile KB826810
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com