如何疑難排解 PowerPoint 2003 和 PowerPoint 2002 中損壞的簡報

文章翻譯 文章翻譯
文章編號: 826810 - 檢視此文章適用的產品。
如需本文的 Microsoft PowerPoint 2000 版本,請參閱 207377
全部展開 | 全部摺疊

在此頁中

結論

如果您在使用 Microsoft Office PowerPoint 2003 簡報時遇到了非預期的行為,可能是簡報損壞或毀損了。毀損的簡報可能會有下列徵狀:
  • 發生「無效分頁錯誤」、「一般性保護錯誤」或「指令無效」等錯誤。
  • 當您試圖開啟簡報時,收到下列其中一個錯誤訊息:
    This is not a PowerPoint Presentation (這不是 PowerPoint 簡報)
    PowerPoint cannot open the type of file represented by filename.ppt (PowerPoint 無法開啟 filename.ppt 這類型的檔案)
    Part of the file is missing (檔案的一部分遺失)
  • 發生「記憶體不足」錯誤或「系統資源不足」錯誤。
如果這種非預期的行為只發生在某個簡報上,那個簡報可能已經毀損。本文將告訴您,可以用來試著回復損壞之簡報的一些常用步驟。不過,請記住,這些步驟並不保證能夠成功回復損壞的簡報。在某些情況下,依據毀損的類型而定,您將無法回復任何資料,而必須重新建立損壞的簡報。

注意 這些徵狀也可能是由毀損的簡報之外的原因所造成的。

其他相關資訊

如果您判斷簡報已經毀損,請使用下列方法試著回復損壞的簡報。本文所列的方法區分成下列幾節:

一般疑難排解

注意 由於 Microsoft Windows 有多種版本,因此下列步驟可能依您的電腦有所差異。如有需要,請參閱您的產品說明文件,以完成這些步驟。
在「安全模式」中重新啟動 Windows。如果要執行這項操作,請在重新啟動電腦的同時按住 CTRL 鍵。當您看到 Starting Windows (正在啟動 Windows) 訊息時,按下 F8 鍵,然後在 [啟動] 功能表中,選取 [安全模式]

如需詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
180902 如何以安全模式啟動 Windows 98 電腦
192926 如何執行 Windows 98 的初始狀態開機疑難排解
290367 OFFXP: Troubleshooting Office Programs on Microsoft Windows NT 4.0
如果以安全模式啟動 Microsoft Windows 之後就可以開啟簡報,表示存在某種系統衝突而讓您無法開啟簡報。




如果無法開啟簡報

如果還是無法開啟簡報,請使用下列其中一種方法。

方法 1:將簡報拖曳至 PowerPoint 程式檔

  1. 找出 PowerPoint 程式在電腦上的位置。

    PowerPoint 2003 的預設位置是:
    C:\Program Files\Microsoft Office\Office11
    PowerPoint 2002 的預設位置是:
    C:\Program Files\Microsoft Office\Office10
  2. 將損壞的 PowerPoint 簡報拖曳至 PowerPoint 程式圖示。

方法 2:在 Microsoft Windows 檔案總管中按兩下 PowerPoint 簡報

在 Windows 檔案總管中按兩下 PowerPoint 簡報,試著開啟簡報檔。

方法 3:試著在空白簡報中插入投影片

如果要在空白簡報中試圖插入投影片,請依照下列步驟執行:
  1. 按一下 [檔案] 功能表上的 [開新檔案]

    這會建立空白的標題投影片。稍後當您重新建立簡報之後,就可以刪除這個投影片。
  2. [插入] 功能表上,按一下 [從檔案插入投影片],然後按一下 [尋找簡報] 索引標籤。
  3. 按一下 [瀏覽]

    選取損壞的簡報,然後按一下 [開啟]
  4. 按一下 [插入全部]

    如果這項作業成功,損壞之簡報的所有投影片 (除了投影片母片之外) 都會插入至新的簡報。
  5. 儲存簡報。

    如果執行了這些步驟之後,簡報看起來還是不如預期,請試著將損壞的簡報套用為範本。如果要執行這項操作,請依照下列步驟執行:
    1. 建立簡報的備份。
    2. [格式] 功能表上,按一下 [投影片設計]
    3. [投影片設計] 窗格中,按一下 [瀏覽]
    4. 選取損壞的簡報,然後按一下 [套用]
    損壞之簡報的投影片母片會取代新的投影片母片。

    注意 如果您開始遇到非預期的行為,表示範本可能毀損了簡報。在這種情況下,請使用備份再次建立母片投影片。

方法 4:試著開啟簡報的暫存檔版本

當您編輯 PowerPoint 簡報時,它會建立名稱為 PPT####.tmp 的暫存檔,其中 #### 代表隨機產生的四位數字。這個檔案可能會位於和簡報相同的資料夾中,或者是位於暫存檔資料夾中。將該檔案重新命名為 .ppt 副檔名之後,或許就可以在 PowerPoint 中開啟這個檔案。如果要開啟暫存檔,請依照下列步驟執行:
  1. 首先,查看開啟簡報的資料夾,尋找是否有名稱為 PPT####.tmp 的檔案。

    如果在那裡找不到該檔案,您必須進行搜尋。如果找到了,請略過步驟 2 至 4。
  2. 按一下 [開始],指向 [尋找],然後按一下 [檔案或資料夾]

    注意 在 Microsoft Windows 2000 或在 Microsoft Windows Millennium Edition (Me) 中,按一下 [開始],指向 [搜尋],然後按一下 [檔案或資料夾]。在 Microsoft Windows XP 中,按一下 [開始],再按一下 [搜尋]
  3. [名稱] 方塊或 [搜尋名稱如下的檔案或資料夾] 方塊中,輸入 PPT*.tmp
  4. [查詢] 方塊中,按一下 [我的電腦],再按一下 [立即尋找][立即搜尋]
  5. 如果找到檔案了,請依照下列步驟執行:
    1. 用滑鼠右鍵按一下檔案,再按一下 [重新命名]
    2. 將舊的副檔名從 .tmp 改成 .ppt,讓檔案名稱看起來像下面這樣:PPT####.ppt。
    3. 試著在 PowerPoint 中開啟檔案。
如果有多個檔案符合最後一次儲存簡報的時間,您可能需要開啟每一個檔案,查看哪一個才是簡報的暫存複本。

方法 5:試著在 PowerPoint Viewer 中開啟簡報

如果您可以在 PowerPoint Viewer 中開啟簡報,表示 PowerPoint 安裝可能已經毀損,或者是簡報可能包含了毀損的物件。

方法 6:將簡報移到另一部電腦

有時候,將 PowerPoint 簡報複製到另一部電腦就可以開啟簡報。如果您可以開啟簡報,請檢視每一張投影片,判斷是否有任何空白的物件版面配置區。如果有,請刪除它們。重新儲存簡報,然後將簡報複製回原來的電腦。

方法 7:將簡報移到另一個磁碟

Windows 可能無法從目前儲存簡報的地方讀取簡報。請將簡報複製到另一個磁碟,例如,將簡報從磁碟片複製到硬碟。

注意 如果您無法從儲存簡報的磁碟複製簡報,它可能有和其他檔案或資料夾交叉連結,或者可能是位於磁碟損壞的磁區中。請試試方法 8。

方法 8:執行磁碟掃描

執行磁碟掃描以修復磁碟上所有的錯誤,讓它修復所有交叉連結的檔案,並將遺失的片段轉換成檔案。

注意 即使磁碟掃描判斷出簡報處於交叉連結狀態,並修復它,也不保證 PowerPoint 就能夠讀取簡報。

如需詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:
315265 如何在 Windows XP 中執行磁碟錯誤檢查
156571 How to Perform Scandisk in Windows
186365 Description of ScanDisk for Windows (Scandskw.exe) in Windows 98/Me



如果可以開啟損壞的簡報

方法 1:試著將損壞的簡報套用為範本

將投影片插入空白簡報中,然後將損壞的簡報套用為範本以保存母片。如果要執行這項操作,請依照下列步驟執行:
  1. 按一下 [檔案] 功能表上的 [開新檔案]

    這會建立空白的標題投影片。稍後當您重新建立簡報之後,就可以刪除這個投影片。
  2. [插入] 功能表上,按一下 [從檔案插入投影片],然後按一下 [尋找簡報] 索引標籤。
  3. 按一下 [瀏覽],選取損壞的簡報,然後按一下 [開啟]
  4. 按一下 [插入全部]

    如果這項作業成功,就會將損壞之簡報的所有投影片 (除了投影片母片之外) 都插入至新的簡報。
  5. 儲存簡報。如果簡報看起來還是不如預期,請試著將損壞的簡報套用為範本。如果要執行這項操作,請依照下列步驟執行:
    1. 建立簡報的備份。
    2. [格式] 功能表上,按一下 [投影片設計]
    3. [投影片設計] 窗格中,按一下 [瀏覽]
    4. 選取損壞的簡報,然後按一下 [套用]
    損壞之簡報的投影片母片會取代新的投影片母片。

    注意 如果您開始遇到非預期的行為,表示範本可能毀損了簡報。在這種情況下,請使用備份重新建立母片投影片。

方法 2:將損壞之簡報的投影片貼入至新的簡報。

使用複製與貼上作業,將損壞之簡報的投影片移到空白簡報中。如果要執行這項操作,請依照下列步驟執行:
  1. [檔案] 功能表上,按一下 [開啟舊檔],找出損壞的簡報,然後按一下 [開啟]
  2. 按一下 [檔案] 功能表上的 [開新檔案]
  3. 按一下 [檢視] 功能表上的 [投影片瀏覽]

    如果您在切換檢視時收到錯誤訊息,請試著改用 [大綱模式] 檢視。
  4. 按一下要複製的投影片。
  5. [編輯] 功能表上,按一下 [複製]

    如果想要一次複製多張投影片,請按住 SHIFT 鍵,然後按一下您要複製的每一張投影片。
  6. 切換至新的簡報。

    [視窗] 功能表上,按一下您在步驟 2 中所建立的新簡報。
  7. 按一下 [檢視] 功能表上的 [投影片瀏覽]
  8. [編輯] 功能表上,按一下 [貼上]
  9. 重複執行步驟 5 至 9,直到整個簡報都移轉過去為止。
注意 在某些情況下,一張損壞的投影片就可能造成整個簡報發生問題。如果您將某張投影片複製到新簡報後,發現新簡報產生了奇怪的行為,那張投影片很可能是毀損了。請重新建立該投影片,或是將該投影片的一部分複製到新的投影片。

方法 3:將簡報儲存為 RTF 格式

如果整個簡報都毀損了,回復簡報的唯一方法可能是將簡報儲存為 RTF。如果這個方法成功了,也只是回復出現在 [大綱模式] 檢視中的文字。如果要執行這項操作,請依照下列步驟執行:
  1. 開啟簡報。
  2. [檔案] 功能表上,按一下 [另存新檔]
  3. [存檔類型] 清單中,按一下 [大綱/RTF 檔 (*.rtf)]
  4. [檔案名稱] 方塊中,輸入您要的名稱,挑選一個存放簡報的位置,然後按一下 [儲存]
  5. 關閉簡報。
注意 如果要在開啟 RTF 簡報之後繼續工作,請按一下 [檔案] 功能表上的 [開啟舊檔],然後在 [檔案類型] 清單中,按一下 [所有大綱][所有檔案]。如果您按一下 [簡報] 選項,RTF 簡報並不會出現。

屬性

文章編號: 826810 - 上次校閱: 2006年8月10日 - 版次: 4.0
這篇文章中的資訊適用於:
  • Microsoft Office PowerPoint 2003
  • Microsoft PowerPoint 2002 Standard Edition
關鍵字:?
kbopenfile kberrmsg kbcorrupt kbtshoot kbhowto KB826810
Microsoft及(或)其供應商不就任何在本伺服器上發表的文字資料及其相關圖表資訊的恰當性作任何承諾。所有文字資料及其相關圖表均以「現狀」供應,不負任何擔保責任。Microsoft及(或)其供應商謹此聲明,不負任何對與此資訊有關之擔保責任,包括關於適售性、適用於某一特定用途、權利或不侵權的明示或默示擔保責任。Microsoft及(或)其供應商無論如何不對因或與使用本伺服器上資訊或與資訊的實行有關而引起的契約、過失或其他侵權行為之訴訟中的特別的、間接的、衍生性的損害或任何因使用而喪失所導致的之損害、資料或利潤負任何責任。

提供意見

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com