Frequently asked questions about the mail merge feature in Word 2003, Word 2007, and Word 2010

文章翻译 文章翻译
文章编号: 826838 - 查看本文应用于的产品
展开全部 | 关闭全部

概要

This article discusses the mail merge feature in Microsoft Office Word 2003, Word 2007, and Word 2010.

更多信息

A mail merge is used to create form letters, mailing labels, envelopes, directories, and mass e-mail message and fax distributions. There are three documents that are involved in the mail merge process: the main document, the data source, and the merged document. To complete the basic mail merge process, you must do the following:
  • Open or create a main document.

    Main document: In a mail-merge operation in Word, this is the document that contains the text and graphics that are the same for each version of the merged document, such as the return address or the salutation in a form letter.
  • Open or create a data source with individual recipient information.

    Data source: This is the file that contains the information to be merged in a document. For example, the list of names and addresses that you want to use in a mail merge. You must connect to the data source before you can use the information in it for the mail merge process.
  • Add or customize merge fields in the main document.

    Merge field: This is a placeholder that you insert in the main document. For example, insert the City merge field to have Word insert a city name, such as "Paris," that is stored in the City data field.
  • Merge data from the data source in the main document to create a new, merged document.

    Merged document: This is the resulting document that you receive when you merge your mail-merge main document with your address list. The resulting document can be the printed result or a new Word document that contains the merge results.
Word makes mail merge easy by using a wizard that guides you through all the steps. If you prefer to work outside the wizard, you can use the Mail Merge toolbar. Either way, the result is that each row (or record) in the data source produces an individual form letter, mailing label, envelope, or directory item.

You can also use mail merge to create any type of document that maps fields to data, not just mailings or directories. For example, if your videotape collection is listed in a spreadsheet, you can use the Labels option to create videotape labels.

Q1: Can a mail merge be performed the same way that it was in earlier versions of Microsoft Word?

A1: Mail merge has the same functionality as earlier versions of Word. Use one of the following methods to use mail merge in Word:??
  • Use the Mail Merge toolbar.

    In Word 2003, point to Toolbars on the View menu, and then click Mail Merge to display the Mail Merge toolbar.

    In Word 2007 or Word 2010, the mail merge toolbar is in the?Mailings tab, and includes the Start Mail Merge group, the Write and Insert Fields group, the Preview Results group and the Finish group.

    Note The options on the Mail Merge toolbar offer similar functions as the earlier versions of Word.
  • Use the Mail Merge Helper.

    To make it easy to use, add the Mail Merge Helper command to the Letters and Mailings submenu of the Tools menu in Word 2003, follow these steps:
    1. On the Tools menu, click Customize.
    2. Click the Commands tab.
    3. In the Categories list, click All Commands.
    4. In the Commands list, click Mail Merge Helper.
    5. Drag the Mail Merge Helper command to the Letters and Mailings submenu on the Tools menu.

      Note When you rest the pointer over the Letters and Mailings submenu, you will see a horizontal black bar. This bar indicates the location where the command will appear on the Tools menu when you release the mouse button.
    6. In the Customize dialog box, click Close.

    To add the Mail Merge Helper command in the Quick Access Toolbar in Word 2007, follow these steps:
    1. Click the Microsoft Office Button, and then click Word Options.
    2. Click Customize.
    3. Click All Commands in the Choose commands from, and then click Mail Merger Helper in the Choose commands from list.
    4. Click Add, and then OK.
Q2: Can you move the insertion point while you are inserting merge fields?

A2: When the Insert Merge Field dialog box is open, you cannot move the insertion point in your mail merge main document. If you press ENTER or the SPACEBAR to try to move the insertion point, the selected merge field is inserted in the document. To move your insertion point, close the Insert Merge Field dialog box, and then move the insertion point. To insert another merge field in a different location in your mail merge main document, click Insert Merge Fields on the Mail Merge toolbar. To work around this behavior and use the functionality that is similar to earlier versions of Word, add the Insert Merge Field button to the Mail Merge toolbar.

For more information about how to move the insertion point, click the following article number to view the article in the Microsoft Knowledge Base:
276005 Cannot move insertion point when you insert merge field
Q3: The Select Data Source Dialog Box always uses the My Data Sources folder when you click Browse to Open a Data Source. Can this be changed?

A3: Unfortunately, the behavior of the Select Data Source dialog box cannot be changed. It will always default to the My Data Sources folder. However, you can create a shortcut or use other methods in the My Data Sources dialog box to obtain quick access to your mail merge address lists.

For more information on how to obtain quick access to your mail merge address lists, click the following article number to view the article in the Microsoft Knowledge Base:
276004 "My Data Sources" is always displayed in the Select Data Source Look In list in Word


Q4: How do you create and print form letters?

A4: Use the mail merge feature if you want to send the same letter to multiple recipients.

For more information on how to mail merge to form letters, click the following article number to view the article in the Microsoft Knowledge Base:
294683 How to use mail merge to create form letters in Word


Q5: How do you perform a mail merge to an e-mail message?

A5: You would want to use the mail merge feature if you are sending the same e-mail message to multiple recipients by using a mail program.

For more information on how to mail merge to multiple e-mail recipients, click the following article number to view the article in the Microsoft Knowledge Base:
294694 How to use mail merge to create e-mail messages in Word


Q6: Can you use a Merge field in the Subject box of an e-mail message?

A6: No. You can only type text in the Subject box of an e-mail message.

Note Microsoft Publisher 2007 or Publisher 2010 provides support for this.

Q7: How do you perform a mail merge to envelopes?

A7: You would want to use the mail merge feature if you are sending a mass mailing to multiple recipients, and you want a personal look for each envelope.

For more information on how to mail merge addresses to print directly on envelopes, click the following article number to view the article in the Microsoft Knowledge Base:
294685 How to use mail merge to create envelopes in Word


Q8: How do you perform a mail merge to labels?

A8: You would want to use the mail merge feature when you want to print information about labels, for example, mailing addresses for letters or postcards.

For more information on how to mail merge information to labels, click the following article number to view the article in the Microsoft Knowledge Base:
294684 How to use the mail merge to create mailing labels in Word


Q9: How do you add a graphic or logo to my labels?

A9: In your label mail merge main document, to add the graphic or logo that you want to the first label, use the following methods:
  • In Word 2003, point to Picture on the Insert menu, and then click From File.
  • In Word 2007 or Word 2010, click?Picture in the Illustrations group on the Insert tab.
To insert the graphic or logo to the label, use one of the following methods:
  • On the Mail Merge toolbar (on the View menu, point to Toolbars, and then click Mail Merge), click Propagate Labels.
  • In the Mail Merge task pane (on the Tools menu, point to Letters and Mailings, and then click Mail Merge Wizard), click Update all labels.
This copies the information from the first label to each of the other labels on your label mail merge main document.

For more information on how to add a graphic or logo to labels, click the following article number to view the article in the Microsoft Knowledge Base:
285065 How to add a graphic or logo to every label in Word


Q10: Why is there only one page of labels on the screen when you preview a merged document?

A10: To preview your mailing labels by using the Mail Merge task pane, click Next: Preview your labels. The Preview feature in the Mail Merge Wizard is designed to show only one page at a time. To see all your labels, and make any required changes before you print the merged document, click Next: Complete the merge. Click Edit individual labels. This will open a new document that has your merged labels.

Q11: How do you use mail merge to create a directory or catalog?

A11: You would want to use the mail merge feature when you want to print a listing, such as a phone directory or a listing of items on the same page.

For more information on how to mail merge information as a directory or catalog, click the following article numbers to view the articles in the Microsoft Knowledge Base:
294693 How to use mail merge to create a directory in Word
294686 How to use mail merge to create a list sorted by category in Word


Q12: Why is the Merge to Fax option not available for a mail merge?

A12: In earlier versions of Word, the Merge to fax option used Microsoft Fax (also known as At Work Fax). However, Microsoft Office Outlook 2002 and later versions, the messaging program in Microsoft Office XP, does not support Microsoft Fax.

For more information on Merge to fax, click the following article numbers to view the articles in the Microsoft Knowledge Base:
294695 How to use mail merge to create faxes in Word 2002 and in later versions of Word
282550 Merge to Fax command is unavailable on Mail Merge toolbar


Q13: How do you create an Address list for a mail merge?

A13: The easiest data source format to work with is a Word table. However, you can use any database type format, such as a text file with fields that are separated by commas or tabs, and records that are separated by paragraph marks.

For more information about creating an address list for a mail merge in Word, click the following article number to view the article in the Microsoft Knowledge Base:
294688 How to design and set up a mail merge address list in Word


Q14: Can I perform a mail merge with a datasource that is located on an http location?

A14: No, you cannot perform a mail merge with datasource that is located on an http location, including a SharePoint location. When you try to do this, you may receive an error message.

To work around this issue, you need to save the datasource file either locally or onto the network drive (Mapped/UNC path). After you do this, you can perform a mail merge.


Q15: Can I add an attachment when performing a merge to an e-mail message?

A15: No, you cannot add an attachment when performing a merge to an e-mail message. Microsoft Office Word doesn’t support this functionality. However, you can add an attachment when performing a merge to an e-mail message programmatically by using CDOSys. You can contact a solution provider to build solution for you.


Q16: How I can add attachments when doing a merge to e-mail?

A16: Microsoft Word doesn’t support this functionality. However, this can be done programmatically by using CDOSys. You can contact a solution provider to build a solution for you.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
310212 How to use the Cdosys.dll library to send an e-mail message with attachments by using Visual C#

属性

文章编号: 826838 - 最后修改: 2011年9月18日 - 修订: 2.0
这篇文章中的信息适用于:
  • Microsoft Office Word 2007
  • Microsoft Office Outlook 2003
  • Microsoft Office Outlook 2007
  • Microsoft Word 2010
关键字:?
kbexpertisebeginner kbFAQ kbmerge kbhowto KB826838
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com