Řešení potíží s poškozenými dokumenty aplikace Word 2003

Překlady článku Překlady článku
ID článku: 826864 - Produkty, které se vztahují k tomuto článku.
Tento článek je spojením těchto dřívějších článků: 211634 a 290932
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Poškozené soubory dokumentů mohou způsobit neobvyklé chování jakéhokoli programu. Příčinou takového chování je skutečnost, že některé informace v souboru nejsou správné.

Nejlepší způsob, jak zabránit vzniku potíží s poškozenými dokumenty, představuje uchovávání záložních kopií dokumentů. Pokud nemáte záložní kopii dokumentu, můžete pomocí postupů řešení potíží popsaných v tomto článku identifikovat a případně obnovit poškozený dokument aplikace Microsoft Word.

Identifikace poškozeného dokumentu

U poškozených dokumentů se často projevuje chování, které není součástí návrhu programu (například opakované přestránkování, nesprávné rozložení a formátování dokumentu, nečitelné znaky na obrazovce, chybové zprávy v průběhu zpracování, zablokování počítače při načtení nebo zobrazení dokumentu nebo jakékoli jiné neobvyklé chování, které nelze považovat za typické fungování programu). Některé prvky tohoto chování mohou být způsobeny jinými faktory než poškozením dokumentu.

Chcete-li vyloučit jiné faktory, než je poškození dokumentu, postupujte podle následujících kroků:
  1. Vyhledejte podobné chování v jiných dokumentech.
  2. Vyhledejte podobné chování v jiných programech.
  3. Přemístěte sporný dokument do jiného počítače a potom se pokuste chování duplikovat.
  4. Změňte šablonu, která je připojena k poškozenému dokumentu, na globální šablonu (Normal.dot). Pokud je připojena šablona Normal.dot, ukončete aplikaci Word a potom šablonu Normal.dot přejmenujte. Restartujte aplikaci Word a pokuste se chování duplikovat.
    Chcete-li změnit šablonu, která je připojena k poškozenému dokumentu, na globální šablonu, postupujte takto:
    1. Otevřete problémový dokument.
    2. V nabídce Nástroje klepněte na příkaz Šablony a doplňky.
    3. Pokud je v poli Šablona dokumentu uvedena jiná šablona než Normal.dot, klepněte na tlačítko Připojit.
    4. Ve složce Šablony klepněte na položku Normal (Normal.dot) a potom klepněte na tlačítko Otevřít.
  5. Spusťte aplikaci Word s výchozím nastavením. Aplikaci Word je možné spustit pomocí přepínače /a. Pokud použijete přepínač /a, nebudou do aplikace Word zavedeny žádné doplňky ani nebude použita existující šablona Normal.dot. Restartujte aplikaci Word s přepínačem /a a potom se pokuste duplikovat chování. Další informace o práci s přepínači získáte v následujících článcích databáze Microsoft Knowledge Base:
    826857 Popis spouštěcího přepínače /a v aplikaci Word (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
    210565 Způsob použití přepínačů příkazového řádku ke spuštění aplikace Word 2003, Word 2002 a Word 2000 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
  6. Použijte jiný ovladač tiskárny a potom se pokuste chování duplikovat. Přestože dané chování trvá i s jiným ovladačem tiskárny, může být nutné odebrat a znovu instalovat existující ovladač tiskárny. Chcete-li nahradit ovladač tiskárny, proveďte v závislosti na verzi operačního systému následující kroky:

    Systém Microsoft Windows 2000
    1. Klepněte na tlačítko Start, přejděte na příkaz Nastavení a klepněte na příkaz Tiskárny.
    2. Pravým tlačítkem myši klepněte na tiskárnu, kterou chcete nahradit, a klepněte na příkaz Odstranit.
    3. Pokud se zobrazí výzva k odebrání všech souborů, které jsou s tiskárnou spojeny, klepněte na tlačítko Ano.
    4. V části Práce s tiskárnou klepněte na odkaz Přidat tiskárnu a podle pokynů zobrazených v Průvodci přidáním tiskárny přeinstalujte ovladač tiskárny systému Microsoft Windows.
    Systémy Microsoft Windows XP a Windows Server 2003
    1. Klepněte na tlačítko Start a potom na příkaz Tiskárny a faxy.
    2. Pravým tlačítkem myši klepněte na tiskárnu, kterou chcete nahradit, a klepněte na příkaz Odstranit.
    3. Pokud se zobrazí výzva k odebrání všech souborů, které jsou s tiskárnou spojeny, klepněte na tlačítko Ano.
    4. V části Práce s tiskárnou klepněte na odkaz Přidat tiskárnu a podle pokynů zobrazených v Průvodci přidáním tiskárny přeinstalujte ovladač tiskárny systému Microsoft Windows.
    Další informace o řešení potíží s tiskárnou v systému Microsoft Windows získáte v následujících článcích databáze Microsoft Knowledge Base:
    871146 Řešení obecných potíží s tiskem v systému Windows 2000 při použití produktů sady Office (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
    870622 Řešení potíží, které mohou nastat při tisku na místní tiskárně pomocí aplikací sady Office v systému Windows XP
    870968 Řešení obecných potíží s tiskem v systému Windows 2003 Server při použití produktů sady Office (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
  7. Změňte jiné součásti systému (například ovladače videa nebo písma), vypněte jakékoli spuštěné programy jiných výrobců (například rezidentní programy [TSR], správce písem, spořiče obrazovky a systémová prostředí) a potom se pokuste chování duplikovat. Chcete-li pracovat bez těchto programů a součástí systému, spusťte systém Windows v nouzovém režimu. Nouzový režim je metoda spuštění počítače, která umožňuje spustit systém Windows nejjednodušším způsobem. V nouzovém režimu je vynecháno mnoho ovladačů a pomocných souborů, které mohou způsobit potíže, pokud jsou poškozeny. Další informace o spuštění systému Windows v nouzovém režimu získáte v následujících článcích databáze Microsoft Knowledge Base:
    310353 Jak provést čisté spuštění počítače se systémem Windows XP
    202485 Popis režimu bezpečného spuštění v systému Windows 2000
    Chcete-li spustit systém Microsoft Windows Server 2003 v nouzovém režimu, postupujte podle následujících kroků:
    1. Klepněte na tlačítko Start a potom klepněte na příkaz Vypnout.
    2. Klepněte na tlačítko Restartovat a poté klepněte na tlačítko OK.
    3. Po zobrazení následující zprávy stiskněte klávesu F8:
      Vyberte operační systém, který chcete spustit.
    4. V nabídce Upřesnit možnosti spuštění systému Windows vyberte pomocí kláves se šipkami položku Nouzový režim a potom stiskněte klávesu ENTER. Poznámka: Klávesy ŠIPKA na číselné klávesnici budou fungovat, pouze pokud je vypnuta klávesa NUM LOCK.
    5. Jestliže v počítači používáte další operační systémy, vyberte v zobrazeném seznamu položku Microsoft Windows Server 2003 a stiskněte klávesu ENTER.

Vynucení obnovení souboru v aplikaci Word

Při zjištění potíží se souborem se aplikace Microsoft Office Word 2003 a Microsoft Word 2002 automaticky pokusí poškozený dokument obnovit. Obnovení dokumentu při jeho otevření je také možné v aplikaci Word vynutit. Postupujte podle následujících pokynů:
  1. V nabídce Soubor klepněte na příkaz Otevřít.
  2. V dialogovém okně Otevřít vyberte požadovaný dokument aplikace Word.
  3. Klepněte na šipku na tlačítku Otevřít a potom klepněte na příkaz Otevřít a opravit.
Další informace o obnovení dokumentu získáte po klepnutí na příkaz Nápověda pro Microsoft Word v nabídce Nápověda. Do pole Hledat zadejte text obnovení.

Kroky, které je možné provést, jestliže se u dokumentu po otevření projevuje neočekávané chování

Uložení dokumentu do jiného formátu souboru a jeho převod zpět do aplikace Word

Tato metoda představuje nejúplnější metodu obnovení dokumentu. Tuto metodu vždy vyzkoušejte jako první.

Uložte dokument v jiném formátu souboru. Pokuste se uložit dokument ve formátu RTF (s příponou RTF) nebo jako webovou stránku (s příponou HTML). Tyto formáty uchovají formátování dokumentu aplikace Word.

Po uložení dokumentu v jiném formátu souboru dokument zavřete, znovu jej otevřete v aplikaci Word a potom jej uložte jako dokument aplikace Word (s příponou DOC). Pokud je tato metoda úspěšná, bylo poškození souboru při převodu odstraněno.

Jestliže poškození potrvá, pokuste se soubor uložit v jiném formátu. Uložte soubor v následujících formátech souboru v uvedeném pořadí:
  • formát RTF (s příponou RTF),
  • webová stránka (s příponou HTML),
  • jakýkoli jiný formát zpracování textu,
  • pouze text (s příponou TXT).
Poznámka: Je možné, že potíže s poškozením dokumentu budou po uložení souborů ve formátu Pouze text opraveny. Veškeré formátování dokumentu, grafika a kódy maker však budou ztraceny. Pokud soubory uložíte ve formátu Pouze text, bude nutné je formátovat znovu. Tento formát použijte proto jen v případě, že pomocí jiných formátů souborů nebyly potíže odstraněny.

Kopírování veškerého obsahu kromě posledního znaku konce odstavce do nového dokumentu

Aplikace Word spojuje formátování (například oddílu a stylu) s posledním znakem konce odstavce.

Jestliže zkopírujete veškerý obsah kromě posledního znaku konce odstavce do nového dokumentu, může být poškození ponecháno v původním dokumentu.

V novém dokumentu znovu použijte formátování oddílu nebo formátování stylu.

Poznámka: Výběr veškerého obsahu kromě posledního znaku konce odstavce provedete takto:
  1. Stiskněte klávesy CTRL+END a potom klávesy CTRL+SHIFT+HOME.
  2. Pokud dokument obsahuje konce oddílů, kopírujte pouze text umístěný mezi konci oddílů. (Konce oddílů nekopírujte a nevkládejte, protože by poškození mohlo být tímto způsobem přeneseno do nového dokumentu.) Společnost Microsoft doporučuje pracovat s dokumentem aplikace Word při kopírování a vkládání mezi dokumenty v normálním zobrazení, aby nedošlo k přenosu konců oddílů mezi dokumenty. Chcete-li přejít do normálního zobrazení, klepněte v nabídce Zobrazit na příkaz Normálně.

Kopírování nepoškozených částí dokumentu do nového dokumentu

Někdy je možné určit umístění poškození souboru přímo v dokumentu. V takových případech zkopírujte do nového dokumentu vše kromě poškozené části a potom rekonstruujte poškozenou část dokumentu.

Poznámka: Pokud dokument obsahuje konce oddílů, kopírujte pouze text umístěný mezi konci oddílů. (Konce oddílů nekopírujte a nevkládejte, protože by poškození mohlo být tímto způsobem přeneseno do nového dokumentu.)

Kroky, které je možné provést, jestliže se dokument neotevře

Existuje několik metod otevření dokumentu, které lze použít. Použitá metoda závisí na charakteru a závažnosti poškození dokumentu a na chování dokumentu. I když je řada z těchto metod obvykle úspěšná, nelze obnovit každý poškozený dokument.

Otevření poškozeného dokumentu aplikace Word v konceptovém režimu bez aktualizace propojení

Dokument je někdy možné otevřít v konceptovém režimu bez aktualizace propojení. Postupujte podle následujících pokynů:
  1. V nabídce Zobrazit klepněte na příkaz Normálně.
  2. V nabídce Nástroje klepněte na příkaz Možnosti.
  3. Na kartě Zobrazení zaškrtněte políčka Písmo konceptu a Symboly obrázků.
  4. Na kartě Obecné zrušte zaškrtnutí políčka Automaticky aktualizovat propojení při otevření a potom klepněte na tlačítko OK.
  5. Otevřete dokument.
Jestliže se dokument úspěšně otevřel, můžete soubor obnovit nebo opravit pomocí kroků popsaných v tomto článku v části Kroky, které je možné provést, jestliže se u dokumentu po otevření projevuje neočekávané chování.

Vložení dokumentu jako souboru do nového dokumentu

Poslední znak konce odstavce v dokumentu aplikace Word obsahuje informace o dokumentu. Pokud je dokument poškozen, je možné text dokumentu načíst v případě, že lze tento poslední znak konce odstavce vynechat. Chcete-li získat přístup k dokumentu, ale vynechat jeho poslední znak konce odstavce, postupujte takto:
  1. V nabídce Soubor klepněte na příkaz Nový.
  2. Vyberte možnost Prázdný dokument.
  3. V nabídce Vložit klepněte na příkaz Soubor.
  4. V dialogovém okně Vložit soubor vyhledejte a vyberte poškozený dokument a potom klepněte na tlačítko Vložit.
Poznámka: Je možné, že bude třeba u posledního oddílu nového dokumentu znovu použít formátování.

Otevření souboru vytvořením propojení

Pokud se souborem vytvoříte propojení, bude soubor možné otevřít, i pokud se část hlavičky souboru nebo poslední znak konce odstavce nachází v poškozené oblasti dokumentu. Chcete-li vytvořit propojení s nepoškozeným souborem a potom změnit propojení tak, aby směřovalo k poškozenému souboru, postupujte podle následujících kroků:
  1. V nabídce Soubor klepněte na příkaz Nový.
  2. Vyberte možnost Prázdný dokument.
  3. Do nového dokumentu zadejte text Toto je test a dokument uložte.
  4. Vyberte text a potom klepněte v nabídce Úpravy na příkaz Kopírovat.
  5. V nabídce Soubor klepněte na příkaz Nový.
  6. Vyberte možnost Prázdný dokument.
  7. V tomto novém dokumentu klepněte v nabídce Úpravy na příkaz Vložit jinak.
  8. Klepněte na položku Formátovaný text (RTF), klepněte na přepínač Vložit propojení a potom klepněte na tlačítko OK.
  9. V nabídce Úpravy klepněte na příkaz Propojení.
  10. V dialogovém okně Propojení vyberte název souboru propojeného dokumentu a potom klepněte na tlačítko Změnit zdroj.
  11. V dialogovém okně Změnit zdroj vyberte dokument, který nelze otevřít, a klepněte na tlačítko Otevřít.
  12. Klepnutím na tlačítko OK zavřete dialogové okno Propojení. Poznámka: Měly by se zobrazit informace z poškozeného dokumentu (pokud obsahoval obnovitelná data nebo text).
  13. V nabídce Úpravy klepněte na příkaz Propojení.
  14. V dialogovém okně Propojení klepněte na tlačítko Zrušit propojení.
  15. Po zobrazení následující zprávy klepněte na tlačítko Ano:
    Jste si jisti, že chcete zrušit vybraná propojení?
Obnovený dokument můžete nyní znovu formátovat a potom uložit.

Použití převaděče Obnova textu z libovolného souboru

Pomocí převaděče Obnova textu z libovolného souboru lze extrahovat text z jakéhokoli souboru. Nemusí se jednat o soubor aplikace Word.

Převaděč Obnova textu z libovolného souboru má určitá omezení. Formátování dokumentu bude ztraceno. Dojde ke ztrátě veškerého obsahu kromě textu. Bude ztracena grafika, pole, nakreslené objekty a ostatní položky, které nejsou textové. Záhlaví, zápatí, poznámky pod čarou, vysvětlivky a text polí jsou však uchovány jako prostý text. Po obnovení pomocí převaděče Obnova textu z libovolného souboru dále v dokumentu existují binární data, která nebyla převedena, primárně na začátku a na konci dokumentu. Tato binární data je nutné před novým zformátováním a uložením souboru jako dokumentu aplikace Word odstranit. Další informace o obnovení textu z libovolného souboru získáte v následujícím článku databáze Microsoft Knowledge Base:
290946 Obnovení textu z libovolného souboru pomocí převaděče Obnova textu z libovolného souboru aplikací Word 2002 a Word 2003 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Otevření souboru v programu WordPad

Pokud poškozený dokument nelze otevřít v aplikaci Word (obvykle z důvodu poškození hlavičky souboru), můžete se pokusit poškozené části dokumentu vyfiltrovat otevřením dokumentu v programu WordPad a uložením souboru ve formátu RTF. Po uložení souboru ve formátu RTF v programu WordPad budou odstraněny všechny nepodporované řetězce.

Poznámka: Část formátování může být ztracena.

Chcete-li otevřít soubor v programu WordPad, postupujte podle těchto kroků:
  1. Spusťte program WordPad. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na příkaz Příslušenství a klepněte na příkaz WordPad.
  2. V nabídce Soubor klepněte na příkaz Otevřít.
  3. V poli Soubory typu vyberte možnost Word pro Windows (*.doc).
  4. Klepnutím vyberte dokument, který chcete obnovit, a potom klepněte na tlačítko Otevřít.
  5. Dokument aplikace Word by se měl otevřít.
  6. V nabídce Soubor klepněte na příkaz Uložit jako.
  7. Do pole Název souboru zadejte nový název souboru s příponou názvu souboru RTF.
  8. V poli Uložit jako typ vyberte možnost Formát RTF. Před klepnutím na tlačítko OK si zapamatujte složku, ve které je soubor uložen, abyste jej po restartování aplikace Word snadno nalezli. Klepněte na tlačítko OK.
  9. V nabídce Soubor klepněte na příkaz Konec.
  10. Restartujte aplikaci Word a potom otevřete soubor, který byl uložen v programu WordPad (soubor má název, který jste zadali v kroku 7).
  11. V nabídce Soubor klepněte na příkaz Uložit jako a uložte soubor ve formátu dokumentu aplikace Word (s příponou DOC).
Nový dokument můžete nyní znovu zformátovat a přidat grafiku, pole a další formátování, které bylo obsaženo v poškozeném dokumentu.

Vlastnosti

ID článku: 826864 - Poslední aktualizace: 25. srpna 2006 - Revize: 4.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Klíčová slova: 
kbscreenshot kbbackup kbhowtomaster KB826864

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com