Sådan foretages fejlfinding af beskadigede Word-dokumenter

Oversættelser af artikler Oversættelser af artikler
Artikel-id: 826864 - Få vist de produkter, som denne artikel refererer til.
Denne artikel er en opsummering af følgende tidligere tilgængelige artikler: 211634 og 290932
Udvid alle | Skjul alle

På denne side

Sammenfatning

Beskadigede dokumentfiler kan få alle programmer til at fungere unormalt. Dette problem kan opstå, fordi visse oplysninger i filen er ukorrekte.

Du kan bedst forhindre problemer, der skyldes dokumentskader, ved at tage sikkerhedskopier af dine dokumenter. Hvis du ikke har en sikkerhedskopi af et dokument, kan du identificere og muligvis gendanne et beskadiget dokument i Microsoft Word med de fejlfindingsprocedurer, der er beskrevet i denne artikel.

Identificer et beskadiget dokument

Beskadigede dokumenter fungerer ofte på en måde, der ikke er en del af programmets design (f.eks. gentagen sideinddeling, forkert dokumentlayout og -formatering, ulæselige tegn på skærmen, fejlmeddelelser under behandlingen ? og computeren holder op med at reagere, når du indlæser eller får vist filen, eller fungerer unormalt på anden vis, som ikke kan betragtes som typisk for programmet). Nogle af disse problemer kan skyldes andre faktorer end dokumentskade.

Følg disse trin for at kunne udelukke andre faktorer:
  1. Undersøg, om andre dokumenter fungerer på samme måde.
  2. Undersøg, om andre programmer fungerer på samme måde.
  3. Overfør det omtalte dokument til en anden computer, og forsøg derefter at genskabe problemet.
  4. Udskift den skabelon, der er vedhæftet det beskadigede dokument, med den globale skabelon (Normal.dot). Hvis den vedhæftede skabelon er Normal.dot, skal du afslutte Word og derefter omdøbe Normal.dot. Genstart Word, og forsøg derefter at genskabe problemet.
    Udfør disse trin for at udskifte den skabelon, der er vedhæftet det beskadigede dokument, med den globale skabelon:
    1. Åbn det fejlbehæftede dokument.
    2. Klik på Skabeloner og tilføjelsesprogrammer i menuen Funktioner.
    3. Hvis der i feltet Dokumentskabelon vises en anden skabelon end Normal.dot, skal du klikke på Vedhæft.
    4. Klik på Normal (Normal.dot) i mappen Skabeloner, og klik derefter på Åbn.
  5. Start Word med standardindstillingerne. Du kan bruge parameteren /a til at starte Word med. Når du bruger parameteren /a, indlæser Word ikke nogen tilføjelsesprogrammer og bruger heller ikke din eksisterende Normal.dot-skabelon. Genstart Word med parameteren /a, og prøv derefter at genskabe problemet. Yderligere oplysninger om, hvordan du kan arbejde med parametre, finder du ved at klikke på nedenstående artikelnumre for at få vist artiklerne i Microsoft Knowledge Base:
    826857 Beskrivelse af startparameteren "/a" i Word. Artiklen er evt. på engelsk.
    210565 Sådan benyttes startkommandolinjeparametre til at starte Word 2003, Word 2002 og Word 2000. Artiklen er evt. på engelsk.
  6. Brug en anden printerdriver, og prøv derefter at genskabe problemet. Hvis problemet fortsætter med en anden printerdriver, kan du blive nødt til at fjerne og geninstallere den aktuelle printerdriver. Følg de trin, der passer til dit operativsystem, for at udskifte printerdriveren:

    Microsoft Windows 2000
    1. Klik på Start, peg på Indstillinger, og klik derefter på Printere.
    2. Højreklik på den printer, du vil udskifte, og klik derefter på Slet.
    3. Klik på Ja, hvis du bliver spurgt, om du vil fjerne alle de filer, der er associeret med printeren.
    4. Klik på Tilføj en printer under Printeropgaver, og følg derefter vejledningen i guiden Tilføj printer for at geninstallere Microsoft Windows-printerdriveren.
    Microsoft Windows XP og Windows Server 2003
    1. Klik på Start, og klik derefter på Printere og faxenheder.
    2. Højreklik på den printer, du vil udskifte, og klik derefter på Slet.
    3. Klik på Ja, hvis du bliver spurgt, om du vil fjerne alle de filer, der er associeret med printeren.
    4. Klik på Tilføj en printer under Printeropgaver, og følg derefter vejledningen i guiden Tilføj printer for at geninstallere Microsoft Windows-printerdriveren.
    Yderligere oplysninger om fejlfinding af printerproblemer i Microsoft Windows finder du ved at klikke på nedenstående artikelnumre for at få vist artiklerne i Microsoft Knowledge Base:
    871146 Sådan foretages fejlfinding af generelle printerproblemer i Windows 2000, når du bruger Office-produkter. Artiklen er evt. på engelsk.
    870622 Sådan foretages fejlfinding af problemer, som kan opstå, når du prøver at udskrive til en lokal printer ved hjælp af Office-programmer i Windows XP. Artiklen er evt. på engelsk.
    870968 Sådan foretages fejlfinding af generelle printerproblemer i Windows Server 2003, når du bruger Office-produkter. Artiklen er evt. på engelsk.
  7. Udskift andre systemkomponenter (f.eks. skærmdrivere eller skrifttyper), deaktiver alle igangværende programmer fra tredjepart (f.eks. TSR-programmer (Terminate and Stay Resident), skrifttypehåndtering, pauseskærme og systemshells), og prøv derefter at genskabe problemet. Hvis du vil undgå disse programmer og systemkomponenter, skal du starte Windows i fejlsikret tilstand. Brug af Fejlsikret tilstand gør det muligt at starte computeren, så Windows starter på den mest enkle måde. Fejlsikret tilstand springer over mange af de drivere og supplerende filer, der kan forårsage problemer, hvis de er beskadigede. Yderligere oplysninger om, hvordan du starter Windows i fejlsikret tilstand, finder du ved at klikke på nedenstående artikelnumre for at få vist artiklerne i Microsoft Knowledge Base:
    310353 Sådan udføres en ren start i Windows XP. Artiklen er evt. på engelsk.
    202485 Beskrivelse af fejlsikret start i Windows 2000. Artiklen er evt. på engelsk.
    Hvis du vil starte Microsoft Windows Server 2003 i fejlsikret tilstand, skal du følge disse trin:
    1. Klik på Start, og klik derefter på Luk computeren.
    2. Klik på Genstart, og klik derefter på OK.
    3. Tryk på F8, når du får vist en meddelelse som denne:
      Vælg det operativsystem, der skal startes.
    4. Brug piletasterne til at markere Fejlsikret tilstand i menuen Avancerede indstillinger i Windows, og tryk derefter på ENTER. Bemærk! NUM LOCK skal være slået fra, før piletasterne på det numeriske tastatur virker.
    5. Hvis der kører andre operativsystemer på computeren, skal du vælge Microsoft Windows Server 2003 på den viste liste og derefter trykke på ENTER.

Tving Word til at forsøge at gendanne en fil

Microsoft Office Word 2003 og Microsoft Word 2002 forsøger automatisk at gendanne et beskadiget dokument, når der registreres et problem med filen. Du kan også tvinge Word til at forsøge at gendanne et dokument, når du åbner det. Det gør du ved at følge disse trin:
  1. Klik på Åbn i menuen Filer.
  2. Klik for at markere Word-dokumentet i dialogboksen Åbn.
  3. Klik på pilen på knappen Åbn, og klik derefter på Åbn og reparer.
Hvis du vil have flere oplysninger om dokumentgendannelse, skal du klikke på Microsoft Word Hjælp i menuen Hjælp. I feltet Søg efter skal du skrive gendannelse.

Metoder, du kan prøve, hvis dokumentet bliver åbnet, men opfører sig usædvanligt

Gem dokumentet i et andet filformat, og konverter det derefter tilbage til Word

Denne metode er den mest fuldstændige gendannelsesmetode. Prøv altid denne metode først.

Gem dokumentet i et andet filformat. Prøv at gemme dokumentet enten i RTF-format (Rich Text Format) eller i HTML-format som en webside. Disse formater bevarer Word-dokumentets formatering.

Når du har gemt dokumentet i et andet filformat, skal du lukke dokumentet, genåbne det i Word og derefter gemme det som et Word-dokument (*.doc). Hvis denne metode virker, er skaderne i filen fjernet under konverteringen.

Hvis der stadig er skader, skal du prøve at gemme filen i et andet format. Prøv at gemme filen i et af følgende filformater i nævnte rækkefølge:
  • RTF-format (*.rtf)
  • Som webside (*.html)
  • Et andet tekstbehandlingsformat
  • Kun tekst (*.txt)
Bemærk! Når du gemmer filer i formatet Kun tekst, kan du muligvis afhjælpe problemet med det beskadigede dokument. Men al dokumentets formatering, grafik og makrokoder går tabt. Når du gemmer filer i formatet Kun tekst, skal du udføre formateringen igen. Derfor skal du udelukkende bruge formatet Kun tekst, hvis andre filformater ikke kan løse problemet.

Kopier alt, undtagen det sidste afsnitstegn, til et nyt dokument

I Word er formatering tilknyttet det sidste afsnitstegn, f.eks. formatering i forbindelse med afsnit og typografi.

Hvis du kopierer alt undtagen det sidste afsnitstegn til et nyt dokument, bliver skaderne muligvis ladt tilbage i det oprindelige dokument.

Du skal formatere afsnit eller typografi igen i det nye dokument.

Bemærk! Du kan markere alt undtagen det sidste afsnitstegn ved at følge disse trin:
  1. Tryk på CTRL+END, og tryk derefter på CTRL+SKIFT+HOME.
  2. Hvis dokumentet indeholder sektionsskift, skal du kun kopiere teksten mellem sektionsskiftene. Du skal ikke kopiere og indsætte sektionsskift, da det kan overføre skaden til det nye dokument. Microsoft anbefaler, at du arbejder med Word-dokumentet i Normal visning, når du kopierer og indsætter mellem dokumenter. Herved undgår du at overføre sektionsskift mellem dokumenterne. Hvis du vil skifte til Normal visning, skal du klikke på Normal i menuen Vis.

Kopier de ikke-beskadigede dele af dokumentet til et nyt dokument

Nogle gange kan du afgøre, hvor filskaderne befinder sig i dokumentet. I sådanne tilfælde skal du kopiere alt undtagen den beskadigede del til en ny fil og derefter rekonstruere det beskadigede afsnit af dokumentet.

Bemærk! Hvis dokumentet indeholder sektionsskift, skal du kun kopiere teksten mellem sektionsskiftene. Du skal ikke kopiere og indsætte sektionsskift, da det kan overføre skaden til det nye dokument.

Metoder, du kan prøve, hvis dokumentet ikke åbnes

Der findes mange metoder, du kan bruge til at åbne et dokument. Hvilken metode du skal bruge, afhænger af, hvordan dokumentet er beskadiget, hvor alvorligt det er, og hvilke problemer det medfører. Selvom mange af disse metoder ofte går godt, er det ikke alle beskadigede dokumenter, der kan genoprettes.

Åbn det beskadigede Word-dokument i kladdetilstand uden at opdatere kæder

Nogle gange kan du åbne et dokument i kladdetilstand uden at opdatere kæder. Det gør du ved at følge disse trin:
  1. Klik på Normal i menuen Vis.
  2. Klik på Indstillinger i menuen Funktioner.
  3. Under fanen Vis skal du markere afkrydsningsfeltet Kladdeskrifttype og derefter klikke for at markere afkrydsningsfeltet Pladsholdere til billeder.
  4. Fjern markeringen i afkrydsningsfeltet Opdater kæder ved åbning under fanen Generelt, og klik derefter på OK.
  5. Åbn dokument.
Hvis det lykkes at åbne dokumentet, kan du muligvis gendanne eller reparere filen ved at bruge trinene i afsnittet "Metoder, du kan prøve, hvis dokumentet bliver åbnet, men opfører sig usædvanligt" i denne artikel.

Indsæt dokumentet som fil i et nyt dokument

Det sidste afsnitstegn i et Word-dokument indeholder oplysninger om dokumentet. Hvis dokumentet er beskadiget, kan du muligvis gendanne dokumentets tekst, hvis du kan udelade det sidste afsnitstegn. Hvis du vil have adgang til et dokument, men efterlade det sidste afsnitstegn, skal du følge disse trin:
  1. Klik på Ny i menuen Filer.
  2. Vælg Tomt dokument.
  3. Klik på Fil i menuen Indsæt.
  4. Find og marker det beskadigede dokument i dialogboksen Indsæt fil, og klik på Indsæt.
Bemærk! Du kan blive nødt til at formatere det sidste afsnit af det nye dokument igen.

Opret en kæde til filen for at åbne den

Når du opretter en kæde til en fil, kan du muligvis åbne filen, hvis en del af filhovedet eller det sidste afsnitstegn befinder sig i den beskadigede del af dokumentet. Brug følgende trin for at oprette en kæde til en ubeskadiget fil og derefter ændre kæden, så den peger på den beskadigede fil:
  1. Klik på Ny i menuen Filer.
  2. Vælg Tomt dokument.
  3. Skriv Dette er en prøve i det nye dokument, og gem derefter dokumentet.
  4. Marker teksten, og klik derefter på Kopier i menuen Rediger.
  5. Klik på Ny i menuen Filer.
  6. Vælg Tomt dokument.
  7. Klik på Indsæt speciel i menuen Rediger i det nye dokument.
  8. Klik på Formateret tekst (RTF), klik for at markere Indsæt kæde, og klik derefter på OK.
  9. Klik på Kæder i menuen Rediger.
  10. Marker filnavnet på det sammenkædede dokument i dialogboksen Kæder, og klik på Skift kilde.
  11. Marker det dokument, du ikke længere kan åbne, i dialogboksen Skift kilde, og klik derefter på Åbn.
  12. Klik på OK for at lukke dialogboksen Kæder. Bemærk! Oplysningerne fra det beskadigede dokument skulle nu blive vist, hvis der var data eller tekst, der kunne gendannes.
  13. Klik på Kæder i menuen Rediger.
  14. Klik på Bryd kæde i dialogboksen Kæder.
  15. Klik på Ja, når du ser følgende meddelelse:
    Er du sikker på, at du vil bryde de markerede kæder?
Du kan nu omformatere og derefter gemme det gendannede dokument.

Brug konverteringsfunktionen Gendan tekst fra filer

Med konverteringsfunktionen Gendan tekst fra filer kan du trække tekst ud af alle filer. Filen behøver ikke at være en Word-fil.

Konverteringsfunktionen Gendan tekst fra filer har sine begrænsninger. Dokumentets formatering går tabt. Alt, der ikke er tekst, går tabt. Grafik, felter, tegneobjekter og andre ikke-tekstelementer går tabt. Sidehoveder og -fødder, fodnoter, slutnoter og felttekst bliver dog bevaret som almindelig tekst. Desuden vil der være binære data, der ikke kunne konverteres, når et dokument gendannes med konverteringsfunktionen Gendan tekst fra filer. Disse data findes primært i begyndelsen og slutningen af dokumentet. Du skal slette disse binære data, før du omformaterer og gemmer filen som Word-dokument. Yderligere oplysninger om, hvordan du gendanner tekst fra filer, finder du ved at klikke på nedenstående artikelnummer for at få vist artiklen i Microsoft Knowledge Base:
290946 Sådan gendannes tekst fra filer ved hjælp af konverteringsfunktionen "Gendan tekst fra filer" i Word 2002 og Word 2003

Åbn filen i WordPad

Hvis du ikke kan åbne et beskadiget dokument i Word, skyldes det som regel, at filens sidehoved er beskadiget. Du kan prøve at bortfiltrere de beskadigede dele af dokumentet ved at åbne dokumentet i WordPad og derefter gemme filen i rtf-format (Rich Text Format). Når du gemmer en fil som en .rtf-fil i WordPad, fjernes alle ikke-understøttede strenge.

Bemærk! Noget af formateringen vil gå tabt.

Følg disse trin for at åbne filen i WordPad:
  1. Start WordPad. Klik på Start, peg på Programmer, peg på Tilbehør, og klik derefter på WordPad.
  2. Klik på Åbn i menuen Filer.
  3. Klik på Word til Windows (*.doc) i feltet Filtype.
  4. Klik for at markere det dokument, du vil gendanne, og klik derefter på Åbn.
  5. Word-dokumentet skulle nu åbnes.
  6. Klik på Gem som i menuen Filer.
  7. Indtast et nyt filnavn med filtypenavnet .rtf i feltet Filnavn.
  8. Klik på Rich Text-format (*.rtf) i feltet Filtype. Inden du klikker på OK, skal du notere ned, i hvilken mappe filen bliver gemt, så du let kan finde filen, når du genstarter Word. Klik på OK.
  9. Klik på Afslut i menuen Filer.
  10. Genstart Word, og åbn derefter den fil, du gemte i WordPad. Filen har det navn, du gav den i trin 7.
  11. Klik på Gem som i menuen Filer, og gem filen som et Word-dokument (*.doc).
Du kan nu omformatere det nye dokument og tilføje grafik, felter og anden formatering, som det beskadigede dokument indeholdt.

Egenskaber

Artikel-id: 826864 - Seneste redigering: 30. maj 2006 - Redigering: 4.1
Oplysningerne i denne artikel gælder:
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard
  • Microsoft Word 2000 Standard
Nøgleord: 
kbgraphxlink kbscreenshot kbbackup kbhowtomaster KB826864

Send feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com