Comment faire pour résoudre les problèmes de documents Word endommagés

Traductions disponibles Traductions disponibles
Numéro d'article: 826864 - Voir les produits auxquels s'applique cet article
Cet article vient étoffer les articles suivants qui étaient déjà disponibles : 211634 et 290932
Agrandir tout | Réduire tout

Sommaire

Résumé

Des fichiers documents endommagés peuvent entraîner un comportement inhabituel des programmes. Ce problème se produit car certaines informations contenues dans le fichier sont incorrectes.

La meilleure solution pour éviter les problèmes de documents endommagés est de conserver une copie de sauvegarde de vos documents. Si vous n'avez pas de copie de sauvegarde de votre document, vous pouvez utiliser les procédures de résolution de problèmes de cet article pour identifier et éventuellement récupérer un document Microsoft Word endommagé.

Identification d'un document endommagé

Les documents endommagés présentent souvent un comportement qui n'est pas dicté par la conception du programme (comme une repagination incessante, une mise en page et une mise en forme incorrectes du document, des caractères illisibles à l'écran, des messages d'erreur en cours de traitement, un blocage du système lorsque vous chargez ou affichez le fichier, ou tout autre comportement inhabituel non imputable au fonctionnement normal du programme). Certains de ces comportements ne sont pas nécessairement liés au fait que le document est endommagé.

Pour exclure les cas où le comportement inhabituel n'est pas lié à l'endommagement du fichier, procédez comme suit :
  1. Recherchez des comportements similaires dans d'autres documents.
  2. Recherchez des comportements similaires dans d'autres programmes.
  3. Copiez le document concerné sur un autre ordinateur, puis essayez de reproduire le comportement suspect.
  4. Remplacez le modèle attaché au document endommagé par le modèle global (Normal.dot). Si le modèle attaché est Normal.dot, quittez Word, puis renommez Normal.dot. Redémarrez Word, puis essayez de reproduire le comportement.

    Pour remplacer le modèle attaché au document endommagé par le modèle global, procédez comme suit :

    1. Ouvrez le document qui pose problème.
    2. Dans le menu Outils, cliquez sur Modèles et compléments.

      Réduire cette imageAgrandir cette image
      Microsoft Word


    3. Si la zone Modèle de document comporte un modèle autre que Normal.dot, cliquez sur Attacher.

      Réduire cette imageAgrandir cette image
      Boîte de dialogue « Modèles et compléments »


    4. Dans le dossier Modèles, cliquez sur Normal (Normal.dot), puis sur Ouvrir.

      Réduire cette imageAgrandir cette image
      Boîte de dialogue Attacher un modèle
  5. Démarrez Word en utilisant les paramètres Word par défaut. Vous pouvez utiliser le commutateur /a pour démarrer Word. Lorsque vous utilisez le commutateur /a, Word ne charge pas de compléments et n'utilise pas votre modèle Normal.dot existant. Redémarrez Word avec le commutateur /a, puis essayez de reproduire le comportement. Pour plus d'informations sur l'utilisation des commutateurs, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
    826857 Description du commutateur de démarrage « /a » de Word
    210565 Comment faire pour utiliser les commutateurs de ligne de commande de démarrage pour démarrer Word 2003, Word 2002 et Word 2000
  6. Utilisez un autre pilote d'imprimante, puis essayez de reproduire le comportement. Même si le comportement inhabituel persiste avec un autre pilote d'imprimante, vous devrez peut-être supprimer et réinstaller votre pilote d'imprimante existant. Pour remplacer le pilote d'imprimante, appliquez la procédure correspondant à la version de votre système d'exploitation :

    Microsoft Windows 2000
    1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Imprimantes.

      Réduire cette imageAgrandir cette image
      Menu Démarrer


    2. Cliquez avec le bouton droit sur l'imprimante à remplacer, puis cliquez sur Supprimer.

      Réduire cette imageAgrandir cette image
      Fenêtre Imprimantes


    3. Si un message vous demande de supprimer tous les fichiers associés à l'imprimante, cliquez sur Oui.

      Réduire cette imageAgrandir cette image
      Boîte de dialogue Imprimantes


    4. Sous Imprimantes, cliquez sur Ajout d'imprimante, puis suivez les instructions de l'Assistant Ajout d'imprimante pour réinstaller votre pilote d'imprimante Microsoft Windows.

      Réduire cette imageAgrandir cette image
      Fenêtre Imprimantes
    Microsoft Windows XP et Microsoft Windows Server 2003
    1. Cliquez sur Démarrer, puis sur Imprimantes et télécopieurs.

      Réduire cette imageAgrandir cette image
      Menu Démarrer


    2. Cliquez avec le bouton droit sur l'imprimante à remplacer, puis cliquez sur Supprimer.

      Réduire cette imageAgrandir cette image
      Fenêtre « Imprimantes et télécopieurs »


    3. Si un message vous demande de supprimer tous les fichiers associés à l'imprimante, cliquez sur Oui.

      Réduire cette imageAgrandir cette image
      Boîte de dialogue Imprimantes


    4. Sous Tâches d'impression, cliquez sur Ajouter une imprimante, puis suivez les instructions de l'Assistant Ajout d'imprimante pour réinstaller votre pilote d'imprimante Microsoft Windows.

      Réduire cette imageAgrandir cette image
      Fenêtre « Imprimantes et télécopieurs »
    Pour plus d'informations sur la façon de résoudre les problèmes d'imprimantes dans Microsoft Windows, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
    871146 Comment faire pour résoudre les problèmes généraux d'impression dans Windows 2000 lorsque vous utilisez des produits Office
    870622Comment faire pour résoudre les problèmes que vous pouvez rencontrer lors de l'impression sur une imprimante locale par le biais de programmes Office dans Windows XP
    870968 Comment faire pour résoudre les problèmes généraux d'impression dans Windows Server 2003 lorsque vous utilisez des produits Office
  7. Remplacez d'autres composants système (tels que les pilotes vidéo ou les polices), désactivez tous les programmes tiers en cours d'exécution (tels que les programmes résidents, les gestionnaires de police, les écrans de veille et les interpréteurs de commandes du système), puis essayez de reproduire le comportement. Pour contourner ces programmes et composants système, démarrez Windows en mode sans échec. Le mode sans échec est une méthode de démarrage de votre ordinateur grâce à laquelle Windows démarre de la façon la plus simple possible. Le mode sans échec ignore certains pilotes et fichiers de prise en charge qui, s'ils sont endommagés, peuvent provoquer des problèmes. Pour plus d'informations sur la façon de démarrer Windows en mode sans échec, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
    310353 Comment faire pour effectuer un démarrage en mode minimal dans Windows XP
    202485 Description du mode de démarrage sans échec sous Windows 2000
    Pour démarrer Microsoft Windows Server 2003 en mode sans échec, procédez comme suit :

    1. Cliquez sur Démarrer, puis sur Arrêter.

      Réduire cette imageAgrandir cette image
      Bouton Arrêter


    2. Cliquez sur Redémarrer, puis sur OK.

      Réduire cette imageAgrandir cette image
      Boîte de dialogue Arrêt de Windows


    3. Lorsque le message suivant s'affiche, appuyez sur F8 :
      Choisissez le système d'exploitation à démarrer.
    4. Dans le menu Options avancées de Windows, utilisez les touches de direction pour sélectionner Mode sans échec, puis appuyez sur ENTRÉE. Remarque La touche VERR NUM doit être désactivée pour que les touches de direction du pavé numérique fonctionnent.
    5. Si vous exécutez d'autres systèmes d'exploitation sur l'ordinateur, sélectionnez Microsoft Windows Server 2003 dans la liste qui s'affiche, puis appuyez sur ENTRÉE.

Tentative de récupération forcée d'un fichier par Word

Microsoft Office Word 2003 et Microsoft Word 2002 essaient de récupérer automatiquement un document endommagé lorsqu'un problème est détecté avec le fichier. Vous pouvez également « forcer » Word à essayer de récupérer un document lorsque vous ouvrez celui-ci. Pour cela, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Ouvrir.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  2. Dans la boîte de dialogue Ouvrir, sélectionnez votre document Word en cliquant dessus.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Ouvrir


  3. Cliquez sur la flèche sur le bouton Ouvrir, puis sur Ouvrir et réparer.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Ouvrir
Pour plus d'informations sur la récupération de documents, cliquez sur Aide sur Microsoft Office Word dans le menu ? (Aide).

Réduire cette imageAgrandir cette image
Microsoft Word


Dans la zone Rechercher, tapez récupération.

Réduire cette imageAgrandir cette image
Volet d'aide de Word


Opérations à tenter si le document s'ouvre et qu'un comportement inattendu est remarqué

Enregistrement du document dans un autre format de fichier, puis reconversion au format Word

Cette méthode est la méthode de récupération de document la plus complète. Essayez-la toujours en premier.

Enregistrez le document dans un autre format de fichier. Essayez de l'enregistrer au format RTF (.rtf) ou en tant que page Web (.html). Ces formats conservent la mise en forme de votre document Word.

Après avoir enregistré le document dans un format de fichier différent, fermez le document, rouvrez le document dans Word, puis enregistrez-le en tant que document Word (.doc). Si cette méthode aboutit, ce qui endommageait le fichier a été supprimé pendant la conversion.

Sinon, essayez d'enregistrer le fichier dans un autre format de fichier. Essayez de l'enregistrer aux formats de fichier ci-dessous en respectant l'ordre suivant :
  • Rich Text Format (.rtf)
  • page Web (.html) ;
  • tout autre format de traitement de texte ;
  • texte seulement (.txt).

    Remarque Lorsque vous enregistrez des fichiers au format Texte seulement, vous pouvez résoudre le problème d'endommagement du document. Toutefois, la mise en forme, les graphiques et les codes de macro du document sont tous perdus. Lorsque vous enregistrez des fichiers au format Texte seulement, vous devez refaire la mise en forme. Par conséquent, n'utilisez ce format qu'en dernier lieu, si les autres formats n'ont pas permis de résoudre le problème.

Copie du contenu du document, excepté la dernière marque de paragraphe, dans un nouveau document

Word associe la mise en forme à la dernière marque de paragraphe, telle que la mise en forme de section et le style.

Si vous copiez tout sauf la dernière marque de paragraphe dans un nouveau document, il se peut que ce qui endommageait le fichier reste dans le document d'origine.

Dans le nouveau document, réappliquez la mise en forme de section ou le style.

Remarque Pour sélectionner tout sauf la dernière marque de paragraphe, procédez comme suit :
  1. Appuyez sur CTRL+FIN, puis appuyez sur CTRL+MAJ+ORIGINE.
  2. Si votre document contient des sauts de section, copiez uniquement le texte entre les sauts de section. (N'effectuez pas de copier-coller des sauts de section, sinon vous risquez de copier dans votre nouveau document ce qui endommageait votre fichier d'origine.) Microsoft vous recommande d'afficher votre document Word en utilisant l'affichage normal lorsque vous effectuez le copier-coller entre les documents, afin d'éviter de transférer les sauts de section d'un document à l'autre. Pour passer au mode d'affichage Normal, cliquez sur Normal dans le menu Affichage.

Copie des parties non endommagées du document dans un nouveau document

Vous pouvez arriver parfois à déterminer quelle est la partie endommagée de votre document. Dans ce cas, copiez tout sauf la partie endommagée dans un nouveau fichier, puis recréez dans ce nouveau fichier la section qui était endommagée.

Remarque Si votre document contient des sauts de section, copiez uniquement le texte entre les sauts de section. (N'effectuez pas de copier-coller des sauts de section, sinon vous risquez de copier dans votre nouveau document ce qui endommageait votre fichier d'origine.)

Opérations à tenter si le document ne s'ouvre pas

Il existe plusieurs méthodes pour ouvrir un document. La méthode à utiliser dépend de la nature et de la gravité de l'endommagement du document ainsi que du comportement de ce dernier. Bien que la plupart de ces méthodes réussissent généralement, les documents endommagés ne peuvent pas toujours être récupérés.

Ouverture du document Word endommagé en mode Brouillon sans mise à jour des liaisons

Il arrive parfois de pouvoir ouvrir le document en mode Brouillon sans mettre à jour les liaisons. Pour cela, procédez comme suit :
  1. Dans le menu Affichage, cliquez sur Normal.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  2. Dans le menu Outils, cliquez sur Options.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  3. Sous l'onglet Affichage, activez les cases à cocher Police brouillon et Espaces pour images.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Options


  4. Sous l'onglet Général, désactivez la case à cocher Mise à jour des liaisons à l'ouverture, puis cliquez sur OK.

    Réduire cette imageAgrandir cette image
    Onglet Général


  5. Ouvrez le document.
Si le document s'ouvre, vous arriverez peut-être à récupérer ou à réparer le fichier en suivant les étapes indiquées à la section « Opérations à tenter si le document s'ouvre et qu'un comportement inattendu est remarqué » de cet article.

Insertion du document en tant que fichier dans un nouveau document

La dernière marque de paragraphe d'un document Word contient des informations sur le document. Si le document est endommagé, vous pouvez réussir à récupérer le texte du document si vous arrivez à omettre cette dernière marque de paragraphe. Pour accéder à un document, sans tenir compte de sa dernière marque de paragraphe, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Nouveau.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  2. Sélectionnez Document vierge.

    Réduire cette imageAgrandir cette image
    Volet Nouveau document


  3. Dans le menu Insertion, cliquez sur Fichier.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  4. Dans la boîte de dialogue Insérer un fichier, recherchez et sélectionnez le document endommagé, puis cliquez sur Insérer.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Insérer un fichier
Remarque Vous devrez peut-être réappliquer la mise en forme de la dernière section de votre nouveau document.

Ouverture du fichier par le biais d'une liaison à ce fichier

En créant une liaison au fichier, vous pourrez peut-être ouvrir le fichier si une partie de l'en-tête de fichier ou la dernière marque de paragraphe est dans la zone endommagée du document. Pour créer une liaison à un fichier en bon état, puis modifier cette liaison pour qu'elle pointe sur le fichier endommagé, procédez comme suit :
  1. Dans le menu Fichier, cliquez sur Nouveau.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  2. Sélectionnez Document vierge.

    Réduire cette imageAgrandir cette image
    Volet Nouveau document


  3. Dans le nouveau document, tapez C'est un test, puis enregistrez le document.

    Réduire cette imageAgrandir cette image
     Microsoft Word


  4. Sélectionnez le texte, puis cliquez sur Copier dans le menu Edition.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  5. Dans le menu Fichier, cliquez sur Nouveau.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  6. Sélectionnez Document vierge.

    Réduire cette imageAgrandir cette image
    Volet Nouveau document


  7. Dans ce nouveau document, cliquez sur Collage spécial dans le menu Edition.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  8. Cliquez sur Document au format RTF, sélectionnez Coller avec liaison, puis cliquez sur OK.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Collage spécial


  9. Dans le menu Edition, cliquez sur Liaisons.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  10. Dans la boîte de dialogue Liaisons, sélectionnez le nom de fichier du document lié, puis cliquez sur Modifier la source.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Liaisons


  11. Dans la boîte de dialogue Modifier la source, sélectionnez le document que vous n'arrivez pas à ouvrir, puis cliquez sur Ouvrir.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue « Modifier la source »


  12. Cliquez sur OK pour fermer la boîte de dialogue Liaisons. Remarque Les informations du document endommagé doivent s'afficher (dans la mesure où du texte ou des données sont récupérables).

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Liaisons


  13. Dans le menu Edition, cliquez sur Liaisons.

    Réduire cette imageAgrandir cette image
    Microsoft Word


  14. Dans la boîte de dialogue Liaisons, cliquez sur Rompre la liaison.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Liaisons


  15. Lorsque le message suivant s'affiche, cliquez sur Oui :
    Annuler les liaisons sélectionnées ?


    Réduire cette imageAgrandir cette image
    Boîte de dialogue Microsoft Office Word
Vous pouvez maintenant refaire la mise en forme du document récupéré, puis enregistrer le document récupéré.

Utilisation du convertisseur Récupérer le texte de tout type de fichier

Le convertisseur Récupérer le texte de tout type de fichier vous permet d'extraire le texte de n'importe quel type de fichier. Le fichier ne doit pas nécessairement être un fichier Word.

Le convertisseur Récupérer le texte de tout type de fichier a ses limites. La mise en forme du document est perdue. Tout ce qui n'est pas un élément de texte est perdu, notamment les graphiques, les champs et les dessins. Les en-têtes, les pieds de page, les notes de bas de page, les notes de fin et le corps du texte sont cependant interprétés comme du texte simple. De plus, suite à la récupération du document à l'aide du convertisseur Récupérer le texte de tout type de fichier, certaines données binaires ne sont pas converties. Elles se situent principalement au début et à la fin du document. Vous devez supprimer ces données binaires avant de remettre en forme votre fichier et de l'enregistrer au format Word. Pour plus d'informations sur la façon de récupérer du texte d'un fichier, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
290946 Comment faire pour récupérer du texte d'un fichier à l'aide du convertisseur de récupération de texte de tout type de fichier de Word 2002 et Word 2003

Ouverture du fichier dans WordPad

Lorsque vous ne pouvez pas ouvrir un document endommagé dans Word (c'est généralement l'en-tête de fichier qui est en cause), vous pouvez essayer d'éliminer les parties endommagées du document en ouvrant ce dernier dans WordPad, puis en l'enregistrant au format RTF. Lorsque vous enregistrez un fichier au format RTF dans WordPad, toutes les chaînes non prises en charge sont exclues.

Remarque Certains éléments de mise en forme sont perdus.

Pour ouvrir le fichier dans WordPad, procédez comme suit :
  1. Démarrez WordPad. Cliquez sur Démarrer, puis sur Exécuter.

    Réduire cette imageAgrandir cette image
    Menu Démarrer


  2. Dans la zone Ouvrir, tapez wordpad.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Exécuter


  3. Dans le menu Fichier, cliquez sur Ouvrir.

    Réduire cette imageAgrandir cette image
    Wordpad


  4. Dans la zone Fichiers de type, cliquez sur Word pour Windows (*.doc).

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Ouvrir


  5. Sélectionnez le document que vous voulez récupérer, puis cliquez sur Ouvrir.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Ouvrir


  6. Le document Word doit maintenant s'ouvrir.
  7. Dans le menu Fichier, cliquez sur Enregistrer sous.

    Réduire cette imageAgrandir cette image
     WordPad


  8. Dans la zone Nom du fichier, tapez le nom du nouveau fichier en lui attribuant une extension .rtf.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Enregistrer sous


  9. Dans la zone Type de fichier, cliquez sur Texte mis en forme (RTF). Avant de cliquer sur Enregistrer, notez l'emplacement où vous enregistrez le fichier afin de le retrouver facilement lorsque vous redémarrerez Word. Cliquez sur Enregistrer.

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Enregistrer sous


  10. Dans le menu Fichier, cliquez sur Quitter.

    Réduire cette imageAgrandir cette image
     WordPad


  11. Redémarrez Word, puis ouvrez le fichier que vous avez enregistré dans WordPad. (Le nom du fichier est celui que vous avez indiqué à l'étape 7.)
  12. Dans le menu Fichier, cliquez sur Enregistrer sous.

    Réduire cette imageAgrandir cette image
    Microsoft Word 


  13. Enregistrez le fichier au format de document Word (.doc).

    Réduire cette imageAgrandir cette image
    Boîte de dialogue Enregistrer sous
Vous pouvez maintenant mettre en forme le nouveau document et y ajouter les graphiques, champs et autres mises en forme que contenait le document endommagé.

Propriétés

Numéro d'article: 826864 - Dernière mise à jour: vendredi 20 octobre 2006 - Version: 4.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Mots-clés : 
kbnomt kbgraphxlink kbscreenshot kbbackup kbhowtomaster KB826864
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com