Risoluzione dei problemi relativi a documenti danneggiati di Word 2003

Traduzione articoli Traduzione articoli
Identificativo articolo: 826864 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ una sintesi degli articoli precedentemente disponibili riportati di seguito: 211634 e 290932
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

I file danneggiati determinano comportamenti anomali nei programmi. Questo problema si verifica perchÚ alcune informazioni contenute nel file non sono corrette.

Il modo migliore per evitare i problemi causati da documenti danneggiati consiste nel conservare copie di backup dei documenti stessi. Nel caso non si disponga di una copia di backup del documento, utilizzare le procedure per la risoluzione dei problemi descritte in questo articolo per identificare ed eventualmente ripristinare un documento danneggiato di Microsoft Word.

Identificazione di un documento danneggiato

I documenti danneggiati determinano spesso un comportamento anomalo da parte del programma, ad esempio operazioni di impaginazione senza fine, formattazione e layout di documento non corretti, caratteri illeggibili, messaggi di errore durante l'elaborazione, blocco del sistema durante il caricamento o la visualizzazione del file o qualsiasi altro comportamento inusuale non attribuibile al normale funzionamento del programma. Alcuni di questi comportamenti possono tuttavia essere riconducibili anche ad altri fattori e non solo a documenti danneggiati.

Per facilitare l'identificazione di altri fattori, attenersi alla seguente procedura:
  1. Accertarsi se tali comportamenti si verificano anche con altri documenti.
  2. Accertarsi se tali comportamenti si verificano anche in altri programmi.
  3. Utilizzare il documento in questione in un altro computer e provare a riprodurre il comportamento.
  4. Sostituire il modello allegato al documento danneggiato con il modello generale (Normal.dot). Se il modello allegato Ŕ Normal.dot, uscire da Word e rinominare il file Normal.dot. Riavviare Word e provare a riprodurre il comportamento.

    Per sostituire il modello allegato al documento danneggiato con il modello generale (Normal.dot), attenersi alla seguente procedura:

    1. Aprire il documento che ha causato il problema.
    2. Scegliere Modelli e aggiunte dal menu Strumenti.

      Riduci l'immagineEspandi l'immagine
      Microsoft Word


    3. Se nella casella Modello del documento Ŕ elencato un modello diverso da Normal.dot, fare clic su Applica.

      Riduci l'immagineEspandi l'immagine
      finestra di dialogo "Modelli e
					 aggiunte"


    4. Nella cartella Modelli fare clic su Normal (Normal.dot), quindi scegliere Apri.

      Riduci l'immagineEspandi l'immagine
      Finestra di dialogo Applica
					 modello
  5. Avviare Word con le impostazioni predefinite. ╚ possibile avviare Word con l'opzione /a. Utilizzando l'opzione /a per avviare Word si impedisce il caricamento automatico dei componenti aggiuntivi e dei modelli generali. Riavviare Word con l'opzione /a e provare a riprodurre il comportamento. Per ulteriori informazioni sull'utilizzo delle opzioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
    826857 Descrizione dell'opzione di avvio "/a" in Word
    210565 Utilizzo delle opzioni della riga di comando per l'avvio di Word 2003, Word 2002 e Word 2000
  6. Utilizzare un diverso driver di stampante e tentare di riprodurre il comportamento. Se il comportamento persiste anche con un driver di stampante diverso, potrebbe essere necessario rimuovere e reinstallare il driver di stampante esistente. Per sostituire un driver della stampante, attenersi alla procedura per la versione del sistema operativo in uso:

    Microsoft Windows 2000
    1. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Stampanti.

      Riduci l'immagineEspandi l'immagine
      Menu di avvio


    2. Fare clic con il pulsante destro del mouse sulla stampante da sostituire, quindi scegliere Elimina.

      Riduci l'immagineEspandi l'immagine
       Finestra
					 Stampanti


    3. Se viene chiesto di eliminare tutti i file associati alla stampante, scegliere .

      Riduci l'immagineEspandi l'immagine
      Finestra di dialogo
					 Stampanti


    4. In Operazioni stampante scegliere Aggiungi stampante, quindi seguire le istruzioni dell'Installazione guidata stampante per reinstallare il driver della stampante di Microsoft Windows.

      Riduci l'immagineEspandi l'immagine
      Finestra Stampanti
    Microsoft Windows XP e Windows Server 2003
    1. Fare clic sul pulsante Start, quindi scegliere Stampanti e fax.

      Riduci l'immagineEspandi l'immagine
      Menu di avvio


    2. Fare clic con il pulsante destro del mouse sulla stampante da sostituire, quindi scegliere Elimina.

      Riduci l'immagineEspandi l'immagine
      Finestra "Stampanti e
					 fax"


    3. Se viene chiesto di eliminare tutti i file associati alla stampante, scegliere .

      Riduci l'immagineEspandi l'immagine
      Finestra di dialogo
					 Stampanti


    4. In Operazioni stampante scegliere Aggiungi stampante, quindi seguire le istruzioni dell'Installazione guidata stampante per reinstallare il driver della stampante di Microsoft Windows.

      Riduci l'immagineEspandi l'immagine
      Finestra "Stampanti e
					 fax"
    Per ulteriori informazioni sulla risoluzione dei problemi delle stampanti in Microsoft Windows, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
    871146 Risoluzione di problemi generali di stampa in Windows 2000 quando si utilizzano prodotti di Office
    870622 Risoluzione dei problemi che possono verificarsi quando si tenta di stampare su una stampante locale utilizzando i programmi di Office in Windows XP
    870968 Risoluzione di problemi generali di stampa in Windows Server 2003 quando si utilizzano prodotti di Office
  7. Cambiare altri componenti di sistema, come driver video o tipi di carattere, disattivare qualsiasi programma di terze parti in esecuzione, ad esempio programmi TSR, gestori di caratteri, screen saver e shell di sistema, quindi tentare di riprodurre il comportamento. Per disattivare questi programmi e componenti di sistema, avviare Windows in modalitÓ provvisoria. La modalitÓ provvisoria consente di avviare Windows nel modo pi¨ semplice possibile. Non vengono infatti caricati numerosi driver e file di supporto che potrebbero causare problemi se danneggiati. Per ulteriori informazioni sull'avvio di Windows in modalitÓ provvisoria, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
    310353 Come eseguire un avvio parziale in Windows XP
    202485 Descrizione della modalitÓ di avvio provvisoria in Windows 2000
    Per avviare Windows XP o Microsoft Windows Server 2003 in modalitÓ provvisoria, attenersi alla seguente procedura:

    1. Fare clic sul pulsante Start, quindi scegliere Spegni computer.

      Riduci l'immagineEspandi l'immagine
      Pulsante Chiudi
					 sessione


    2. Selezionare Riavvia, quindi scegliere OK.

      Riduci l'immagineEspandi l'immagine
      Finestra di dialogo Fine della sessione di
					 lavoro


    3. Quando viene visualizzato il messaggio riportato di seguito, premere F8:
      Selezionare il sistema operativo da avviare
    4. Nel menu Opzioni avanzate di Windows utilizzare i tasti di direzione per selezionare ModalitÓ provvisoria, quindi premere INVIO. Nota BLOC NUM deve essere disattivato per poter utilizzare i tasti di direzione del tastierino numerico.
    5. Se nel computer sono installati pi¨ sistemi operativi, fare clic su Windows XP o Microsoft Windows Server 2003 nell'elenco visualizzato, quindi premere INVIO.

Imposizione del tentativo di recupero di un file da parte di Word

Quando viene rilevato un problema in un file, Microsoft Office Word 2003 e Microsoft Word 2002 tentano di ripristinare automaticamente il documento danneggiato. ╚ anche possibile forzare il tentativo di ripristino all'apertura di un documento in Word. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Dal menu File, scegliere Apri.

    Riduci l'immagineEspandi l'immagine
    Microsoft Word


  2. Nella finestra di dialogo Apri selezionare il documento di Word desiderato.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo
				Apri


  3. Fare clic sulla freccia accanto al pulsante Apri, quindi scegliere Apri e ripristina.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo Apri
Per ulteriori informazioni sul ripristino di documenti, scegliere Guida in linea Microsoft Word dal menu ?.

Riduci l'immagineEspandi l'immagine
Microsoft Word


Nella casella Cerca digitare ripristino.

Riduci l'immagineEspandi l'immagine
Riquadro Guida in linea
		  Word


Operazioni da effettuare se il documento viene aperto e presenta un comportamento imprevisto

Salvataggio del documento in un altro formato per poi riconvertirlo nel formato di Word

Si tratta del metodo pi¨ completo per il ripristino di un documento, quindi si consiglia di utilizzarlo sempre per primo.

Salvare il documento in un formato diverso. Provare a salvare il documento in formato Rich Text Format (rtf) o Pagina Web (html). Questi formati conservano infatti la formattazione del documento di Word.

Dopo avere salvato il file in un formato differente, chiudere e riaprire il documento in Word, quindi salvarlo come Documento Word (doc). Se questo metodo fornisce risultati positivi, l'errore viene rimosso dal file durante il processo di conversione.

Se l'errore persiste, provare a salvare il file in un altro formato. Provare a salvare il file nei seguenti formati attenendosi all'ordine indicato:
  • Rich Text Format (rtf)
  • Pagina Web (html)
  • Qualsiasi altro formato di elaborazione testi
  • Solo testo (txt)

    Nota Il salvataggio di un file in formato Solo testo consente spesso di risolvere i problemi relativi a documenti danneggiati, ma determina la perdita di qualsiasi informazione di formattazione del documento, compresi elementi grafici e codice macro. Quando si salvano file in formato Solo testo, Ŕ necessario riformattarli. Si consiglia quindi di utilizzare il formato Solo testo solo dopo avere tentato di risolvere il problema con altri formati.

Copia di tutto il contenuto del documento a eccezione dell'ultimo segno di paragrafo in un nuovo documento

Word associa la formattazione all'ultimo segno di paragrafo del documento, ad esempio la formattazione di sezione e di stile.

Copiando tutto il contenuto del documento a eccezione dell'ultimo segno di paragrafo in un nuovo documento, Ŕ possibile che venga tralasciata la parte danneggiata del documento originale.

In seguito sarÓ necessario riapplicare la formattazione di sezione e di stile al nuovo documento.

Nota Per selezionare tutto il contenuto del documento a eccezione dell'ultimo segno di paragrafo, attenersi alla seguente procedura:
  1. Premere CTRL+FINE, quindi CTRL+MAIUSC+HOME.
  2. Se il documento contiene interruzioni di sezione, copiare solo il testo tra le interruzioni. Evitare di copiare e incollare le interruzioni di sezione perchÚ si potrebbero importare errori nel nuovo documento. Quando si copiano e incollano parti di documenti, lavorare in visualizzazione Normale per evitare di trasferire anche le interruzioni di sezione. Per passare alla visualizzazione Normale, scegliere Normale dal menu Visualizza.

Copia delle parti danneggiate del documento in un nuovo documento

Talvolta Ŕ possibile determinare la parte danneggiata di un documento. In questi casi si consiglia di copiare in un nuovo file tutto il contenuto del documento a eccezione della parte danneggiata e ricostruirla nel nuovo documento.

Nota Se il documento contiene interruzioni di sezione, copiare solo il testo tra le interruzioni. Evitare di copiare e incollare le interruzioni di sezione perchÚ si potrebbero importare errori nel nuovo documento.

Operazioni da effettuare se il documento non viene aperto

Per aprire un documento Ŕ possibile utilizzare vari metodi. Il metodo utilizzato dipende dalla natura e dalla gravitÓ del danno e dal tipo di comportamento anomalo del documento. Sebbene molti di questi metodi vengano utilizzati regolarmente con successo, non tutti i documenti danneggiati possono essere recuperati.

Apertura del documento di Word danneggiato in modalitÓ Bozza senza aggiornare i collegamenti

A volte un documento pu˛ essere aperto in modalitÓ Bozza senza aggiornamento dei collegamenti. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Scegliere Normale dal menu Visualizza.

    Riduci l'immagineEspandi l'immagine
    Microsoft Word


  2. Scegliere Opzioni dal menu Strumenti.

    Riduci l'immagineEspandi l'immagine
    Microsoft Word


  3. Nella scheda Visualizza selezionare le caselle di controllo Caratteri bozza e Segnaposto immagini.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo
				Opzioni


  4. Nella scheda Standard deselezionare la casella di controllo Aggiorna collegamenti automatici all'apertura, quindi scegliere OK.

    Riduci l'immagineEspandi l'immagine
    Scheda
				Generale


  5. Aprire il documento.
Se il documento viene aperto correttamente, Ŕ possibile tentare di ripristinare o riparare il file utilizzando la procedura descritta nella sezione "Operazioni da effettuare se il documento viene aperto ma presenta un comportamento imprevisto" in questo articolo.

Inserimento del documento come file in un nuovo documento

L'ultimo segno di paragrafo in un documento di Word contiene informazioni sul documento stesso. Se il documento Ŕ danneggiato, Ŕ possibile tentare di recuperare il testo omettendo l'ultimo segno di paragrafo. Per accedere a un documento tralasciando l'ultimo segno di paragrafo, attenersi alla seguente procedura:
  1. Scegliere Nuovo dal menu File.

    Riduci l'immagineEspandi l'immagine
    Microsoft Word


  2. Selezionare Documento vuoto.

    Riduci l'immagineEspandi l'immagine
    Riquadro
				Nuovo documento


  3. Scegliere File dal menu Inserisci.

    Riduci l'immagineEspandi l'immagine
    Microsoft Word


  4. Nella finestra di dialogo Inserisci file individuare e selezionare il documento danneggiato, quindi scegliere Inserisci.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo Inserisci
				file
Nota ╚ possibile che sia necessario riapplicare la formattazione all'ultima sezione del nuovo documento.

Apertura del file tramite un collegamento

Questo metodo pu˛ consentire l'apertura del file se una parte dell'intestazione del file o l'ultimo segno di paragrafo si trova nell'area danneggiata del documento. Per creare un collegamento a un file non danneggiato, quindi modificare il collegamento in modo che faccia riferimento al file danneggiato, attenersi alla procedura seguente:
  1. Scegliere Nuovo dal menu File.

    Riduci l'immagineEspandi l'immagine
    Microsoft
				Word


  2. Selezionare Documento vuoto.

    Riduci l'immagineEspandi l'immagine
    Riquadro Nuovo
				documento


  3. Nel nuovo documento digitare Questa Ŕ una prova, quindi salvare il documento.

    Riduci l'immagineEspandi l'immagine
     Microsoft
				Word


  4. Selezionare il testo e scegliere Copia dal menu Modifica.

    Riduci l'immagineEspandi l'immagine
    Microsoft
				Word


  5. Scegliere Nuovo dal menu File.

    Riduci l'immagineEspandi l'immagine
    Microsoft
				Word


  6. Selezionare Documento vuoto.

    Riduci l'immagineEspandi l'immagine
    Riquadro Nuovo
				documento


  7. Nel nuovo documento scegliere Incolla speciale dal menu Modifica.

    Riduci l'immagineEspandi l'immagine
    Microsoft
				Word


  8. Selezionare Testo formattato (RTF), selezionare Incolla collegamento, quindi scegliere OK.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo Incolla
				speciale


  9. Scegliere Collegamenti dal menu Modifica.

    Riduci l'immagineEspandi l'immagine
    Microsoft
				Word


  10. Nella finestra di dialogo Collegamenti selezionare il nome file del documento collegato, quindi scegliere Cambia origine.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo
				Collegamento


  11. Nella finestra di dialogo Cambia origine selezionare il documento impossibile da aprire, quindi scegliere Apri.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo "Cambia
				origine"


  12. Scegliere OK per chiudere la finestra di dialogo Collegamenti. Nota Dovrebbero essere visualizzate le informazioni contenute nel documento danneggiato, a condizione che vi siano dati o testo recuperabili.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo
				Collegamenti


  13. Scegliere Collegamenti dal menu Modifica.

    Riduci l'immagineEspandi l'immagine
    Microsoft
				Word


  14. Nella finestra di dialogo Collegamenti fare clic su Interrompi collegamento.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo
				Collegamenti


  15. Quando viene visualizzato il messaggio riportato di seguito, scegliere :
    Interrompere i collegamenti selezionati?


    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo Microsoft Office Word
				2003
A questo punto sarÓ possibile riformattare e salvare il documento recuperato.

Utilizzo del convertitore Recupera testo da qualsiasi file

Il convertitore Recupera testo da qualsiasi file consente di estrarre il testo da un file di qualunque tipo, non necessariamente un file di Word.

Il convertitore Recupera testo da qualsiasi file presenta tuttavia alcuni limiti. Viene persa la formattazione del documento. Vengono persi tutti gli elementi diversi dal testo. Vengono persi grafica, campi, oggetti di disegno e altri elementi non di testo. Intestazioni, piŔ di pagina, note a piŔ di pagina, note di chiusura e campi di testo vengono tuttavia conservati come testo semplice. Inoltre, dopo il ripristino del documento tramite il convertitore Recupera testo da qualsiasi file alcuni dati binari non potranno essere convertiti, soprattutto all'inizio e alla fine del documento. Questi dati binari dovranno essere eliminati prima di riformattare e salvare il file come documento di Word. Per ulteriori informazioni sul recupero di testo da qualsiasi file, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
290946 Recupero di testo da qualsiasi file utilizzando il convertitore "Recupera testo da qualsiasi file" di Word 2002 e Word 2003

Apertura del file in WordPad

Quando non Ŕ possibile aprire un documento danneggiato in Word, in genere a causa di un danno nell'intestazione del file, Ŕ possibile provare a escludere le parti danneggiate del documento aprendolo in WordPad, quindi salvando il file in formato RTF (Rich Text Format). Quando si salva un file come file rtf in WordPad, le eventuali stringhe non supportate vengono rimosse.

Nota Una parte della formattazione andrÓ persa.

Per aprire il file in WordPad, attenersi alla seguente procedura:
  1. Avviare WordPad. Fare clic sul pulsante Start, quindi scegliere Esegui.

    Riduci l'immagineEspandi l'immagine
    Menu di avvio


  2. Nella casella Apri digitare wordpad.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo
				Esegui


  3. Dal menu File, scegliere Apri.

    Riduci l'immagineEspandi l'immagine
    WordPad


  4. Nella casella Tipo file selezionare Word per Windows (*.doc).

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo
				Apri


  5. Fare clic per selezionare il documento da recuperare e scegliere Apri.

    Riduci l'immagineEspandi l'immagine
     Finestra di dialogo
				Apri


  6. Si aprirÓ il documento di Word.
  7. Scegliere Salva con nome dal menu File.

    Riduci l'immagineEspandi l'immagine
     WordPad


  8. Nella casella Nome file digitare un nuovo nome file con estensione rtf.

    Riduci l'immagineEspandi l'immagine
     Finestra di dialogo Salva con
				nome


  9. Nella casella Salva come selezionare Rich Text Format (*.rtf). Prima di scegliere Salva, prendere nota della cartella in cui viene salvato il file per poterlo trovare facilmente quando si riavvia Word. Scegliere Salva.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo Salva con
				nome


  10. Scegliere Esci dal menu File.

    Riduci l'immagineEspandi l'immagine
     WordPad


  11. Riavviare Word e aprire il file salvato da WordPad con il nome assegnato nel passaggio 7.
  12. Scegliere Salva con nome dal menu File.

    Riduci l'immagineEspandi l'immagine
     Microsoft Word


  13. Salvare il file in formato documento di Word (con estensione doc)

    Riduci l'immagineEspandi l'immagine
     Finestra di dialogo Salva con nome
A questo punto Ŕ possibile riformattare il nuovo documento e aggiungere grafica, campi e altra formattazione che erano eventualmente presenti nel documento danneggiato.

ProprietÓ

Identificativo articolo: 826864 - Ultima modifica: lunedý 20 novembre 2006 - Revisione: 4.3
Le informazioni in questo articolo si applicano a
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Chiavi:á
kbnomt kbgraphxlink kbscreenshot kbbackup kbhowtomaster KB826864
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com