손상된 Word 문서의 문제를 해결하는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 826864 - 이 문서가 적용되는 제품 보기.
이 문서는 기존 문서 211634 및 290932를 병합한 것입니다.
모두 확대 | 모두 축소

이 페이지에서

요약

문서 파일이 손상되면 프로그램이 비정상적으로 동작할 수 있습니다. 파일의 일부 내용이 잘못된 경우에 이러한 문제가 발생합니다.

문서 손상으로 인한 문제를 방지하는 가장 좋은 방법은 문서의 백업 복사본을 보관하는 것입니다. 문서의 백업 복사본이 없는 경우 이 문서의 문제 해결 절차를 사용하여 손상된 Microsoft Word 문서를 파악하고 복구할 수 있습니다.

손상된 문서 파악

손상된 문서는 프로그램의 설계 의도와는 다른 동작을 보여 주는데, 이러한 동작에는 반복되는 페이지 다시 매김, 잘못된 문서 레이아웃 및 서식, 화면의 읽을 수 없는 문자, 처리 중의 오류 메시지, 파일을 로드하거나 볼 때 컴퓨터의 응답 중지, 프로그램의 정상적인 작동으로 볼 수 없는 기타 비정상적인 동작 등이 있습니다. 일부 동작은 문서 손상 이외의 원인으로 발생할 수 있습니다.

문서 손상 이외의 원인을 배제하려면 다음과 같이 하십시오.
  1. 다른 문서에서 유사한 동작이 나타나는지 확인합니다.
  2. 다른 프로그램에서 유사한 동작이 나타나는지 확인합니다.
  3. 문제가 있는 문서를 다른 컴퓨터로 가져와서 해당 문제를 재현해 봅니다.
  4. 손상된 문서에 첨부된 서식 파일을 기본 서식 파일(Normal.dot)로 변경합니다. 첨부된 서식 파일이 Normal.dot인 경우에는 Word를 끝내고 Normal.dot의 이름을 변경합니다. Word를 다시 시작한 다음 문제가 발생하도록 재현해 봅니다.

    손상된 문서에 첨부된 서식 파일을 기본 서식 파일로 변경하려면 다음과 같이 하십시오.

    1. 문제가 있는 문서를 엽니다.
    2. 도구 메뉴에서 서식 파일 및 추가 기능을 누릅니다.

      그림 축소그림 확대
      Microsoft Word


    3. 문서 서식 파일 상자에 Normal.dot가 아닌 서식 파일이 나열되어 있으면 첨부를 누릅니다.

      그림 축소그림 확대
      "서식 파일 및 추가 기능" 대화 상자


    4. Templates 폴더에서 Normal(Normal.dot)을 누른 다음 열기를 누릅니다.

      그림 축소그림 확대
      서식 파일 첨부 대화 상자
  5. 기본 설정으로 Word를 시작합니다. /a 스위치를 사용하여 Word를 시작할 수 있습니다. /a 스위치를 사용하면 Word에서 추가 기능을 전혀 로드하지 않고 기존 Normal.dot 서식 파일도 사용하지 않습니다. /a 스위치를 사용하여 Word를 다시 시작한 후 문제를 재현해 봅니다. 스위치를 사용하여 작업하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
    826857 Word의 "/a" 시작 스위치에 대한 설명
    210565 WD: Word 시작 (명령줄) 스위치 및 그 용도
  6. 다른 프린터 드라이버를 사용하고 문제를 재현해 봅니다. 다른 프린터 드라이버를 사용해도 문제가 계속 발생하면 기존 프린터 드라이버를 제거하고 다시 설치해야 할 수도 있습니다. 프린터 드라이버를 바꾸려면 다음 중 사용 중인 운영 체제의 버전에 해당하는 단계를 수행하십시오.

    Microsoft Windows 2000
    1. 시작을 누르고 설정을 가리킨 다음 프린터를 누릅니다.

      그림 축소그림 확대
      시작 메뉴


    2. 바꿀 프린터를 마우스 오른쪽 단추로 누른 다음 삭제를 누릅니다.

      그림 축소그림 확대
       프린터 창


    3. 프린터와 관련된 모든 파일을 제거할지 묻는 메시지가 나타나면 를 누릅니다.

      그림 축소그림 확대
      프린터 대화 상자


    4. 프린터 작업에서 프린터 추가를 누른 다음 프린터 추가 마법사의 지시에 따라 Microsoft Windows 프린터 드라이버를 다시 설치합니다.

      그림 축소그림 확대
      프린터 창
    Microsoft Windows XP 및 Windows Server 2003
    1. 시작을 누른 다음 프린터 및 팩스를 누릅니다.

      그림 축소그림 확대
      시작 메뉴


    2. 바꿀 프린터를 마우스 오른쪽 단추로 누른 다음 삭제를 누릅니다.

      그림 축소그림 확대
      "프린터 및 팩스" 창


    3. 프린터와 관련된 모든 파일을 제거할지 묻는 메시지가 나타나면 를 누릅니다.

      그림 축소그림 확대
      프린터 대화 상자


    4. 프린터 작업에서 프린터 추가를 누른 다음 프린터 추가 마법사의 지시에 따라 Microsoft Windows 프린터 드라이버를 다시 설치합니다.

      그림 축소그림 확대
      "프린터 및 팩스" 창
    Microsoft Windows에서 프린터 문제를 해결하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
    871146 Windows 2000에서 Office 제품을 사용하는 경우 일반 인쇄 문제를 해결하는 방법
    870622 Windows XP에서 Office 프로그램을 사용하여 로컬 프린터에 인쇄하려고 할 때 발생할 수 있는 문제를 해결하는 방법
    870968 Windows Server 2003에서 Office 제품을 사용하는 경우 일반 인쇄 문제를 해결하는 방법
  7. 비디오 드라이버나 글꼴과 같은 다른 시스템 구성 요소를 변경하고 TSR(Terminate-And-Stay-Resident 프로그램), 글꼴 관리자, 화면 보호기 및 시스템 셸과 같이 실행 중인 타사 프로그램을 해제한 다음 문제를 재현해 봅니다. 이러한 프로그램 및 시스템 구성 요소를 사용하지 않으면서 작업하려면 Windows를 안전 모드로 시작하십시오. 안전 모드는 Windows가 가능한 한 가장 간단하게 시작되도록 컴퓨터를 시작하는 방법입니다. 안전 모드는 손상된 경우 문제를 일으킬 수 있는 많은 드라이버 및 지원 파일을 건너뜁니다. Windows를 안전 모드로 시작하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
    310353 "클린 부팅" 상태로 시작되도록 Windows XP를 구성하는 방법
    202485 Windows 2000의 안전 부팅 모드에 대한 설명
    Windows XP나 Microsoft Windows Server 2003을 안전 모드로 시작하려면 다음과 같이 하십시오.

    1. 시작을 누른 다음 시스템 종료를 누릅니다.

      그림 축소그림 확대
      시스템 종료 단추


    2. 다시 시작을 누른 다음 확인을 누릅니다.

      그림 축소그림 확대
      Windows 종료 대화 상자


    3. 아래와 같은 메시지가 나타나면 F8 키를 누릅니다.
      시작할 운영 체제를 선택하십시오.
    4. Windows 고급 옵션 메뉴에서 화살표 키를 사용하여 안전 모드를 선택한 다음 Enter 키를 누릅니다.

      참고 숫자 키패드의 화살표 키가 작동하려면 Num Lock 기능이 꺼져 있어야 합니다.
    5. 컴퓨터에서 다른 운영 체제를 실행 중인 경우에는 나타나는 목록에서 Windows XP 또는 Microsoft Windows Server 2003을 선택한 다음 Enter 키를 누릅니다.

Word에서 파일 복구 시도

Microsoft Office Word 2003 및 Microsoft Word 2002에서는 파일에서 문제가 발견되면 손상된 문서를 자동으로 복구하려고 합니다. 문서를 열 때 "강제로" Word가 문서를 복구하도록 할 수도 있습니다. "강제로" Word가 문서를 복구하도록 하려면 다음과 같이 하십시오.
  1. 파일 메뉴에서 열기를 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  2. 열기 대화 상자에서 Word 문서를 선택합니다.

    그림 축소그림 확대
    열기 대화 상자


  3. 열기 단추에 있는 화살표를 누른 다음 열기 및 복구를 누릅니다.

    그림 축소그림 확대
    열기 대화 상자
문서 복구에 대한 자세한 내용을 보려면 도움말 메뉴에서 Microsoft Office Word 도움말을 누른 다음

그림 축소그림 확대
Microsoft Word


검색 대상 상자에 복구를 입력하십시오.

그림 축소그림 확대
Word 도움말 창


문서가 열리지만 예기치 않은 동작이 나타날 경우 시도할 작업

문서를 다른 파일 형식으로 저장한 다음 다시 Word로 변환

이 방법은 가장 완전한 문서 복구 방법이므로 항상 가장 먼저 시도하십시오.

문서를 다른 파일 형식으로 저장합니다. 문서를 서식 있는 텍스트 형식(.rtf) 또는 웹 페이지(.html)로 저장하는 것이 좋습니다. 이러한 형식에서는 Word 문서의 서식이 보존됩니다.

문서를 다른 파일 형식으로 저장한 후 문서를 닫고 Word에서 다시 연 다음 Word 문서(.doc)로 저장합니다. 이 방법에 성공하면 변환하는 동안 파일 손상이 제거됩니다.

손상이 제거되지 않을 경우 파일을 다른 파일 형식으로 저장해 봅니다. 문서를 다음에 나열된 파일 형식으로 순서대로 저장해 보십시오.
  • 서식 있는 텍스트(.rtf)
  • 웹 페이지(.html)
  • 다른 워드 프로세싱 형식
  • 텍스트만(.txt)

    참고 파일을 텍스트만 형식으로 저장하면 문서 손상 문제가 해결될 수도 있습니다. 그러나 문서의 서식, 그래픽 및 매크로 코드는 모두 손실됩니다. 파일을 텍스트만 형식으로 저장하는 경우 서식을 다시 지정해야 합니다. 그러므로 다른 파일 형식을 통해 문제를 해결할 수 없는 경우에만 텍스트만 형식을 사용하십시오.

마지막 단락 기호를 제외한 모든 내용을 새 문서에 복사

Word에서는 구역 서식 및 스타일 서식 등의 서식을 마지막 단락 기호에 연결합니다.

마지막 단락 기호를 제외한 모든 내용을 새 문서에 복사하면 손상된 내용이 복사되지 않고 원본 문서에만 남아 있을 수 있습니다.

새 문서에서 구역 서식이나 스타일 서식을 다시 적용합니다.

참고 마지막 단락을 제외한 모든 내용을 선택하려면 다음과 같이 하십시오.
  1. Ctrl+End를 누른 다음 Ctrl+Shift+Home을 누릅니다.
  2. 문서에 구역 나누기가 포함된 경우 구역 나누기 사이에 있는 텍스트만 복사합니다. 손상된 내용이 새 문서로 옮겨질 수 있으므로 구역 나누기는 복사하여 붙여 넣지 마십시오. 문서 사이에 복사하여 붙여 넣을 때는 문서 사이에 구역 나누기가 전송되지 않도록 기본 보기에서 Word 문서 작업을 하는 것이 좋습니다. 기본 보기로 변경하려면 보기 메뉴에서 기본을 누르십시오.

문서의 손상되지 않은 부분을 새 문서에 복사

문서의 파일 손상 위치를 확인할 수 있는 경우가 있습니다. 이러한 경우 손상된 부분을 제외한 모든 내용을 새 파일에 복사한 다음 문서의 손상된 부분을 다시 작성합니다.

참고 문서에 구역 나누기가 포함된 경우 구역 나누기 사이에 있는 텍스트만 복사합니다. 손상된 내용이 새 문서로 옮겨질 수 있으므로 구역 나누기는 복사하여 붙여 넣지 마십시오.

문서가 열리지 않을 경우 시도할 작업

문서를 여는 데 사용할 수 있는 여러 가지 방법이 있습니다. 문서 손상의 특징과 심각도 및 문서의 동작에 따라 다른 방법을 사용합니다. 일반적으로는 이러한 방법으로 성공하는 경우가 많지만 모든 손상된 문서를 복구할 수 있는 것은 아닙니다.

링크를 업데이트하지 않고 간단하게 인쇄 모드에서 손상된 Word 문서 열기

경우에 따라서는 링크를 업데이트하지 않고 간단하게 인쇄 모드에서 문서를 열 수 있습니다. 간단하게 인쇄 모드에서 문서를 열려면 다음과 같이 하십시오.
  1. 보기 메뉴에서 기본을 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  2. 도구 메뉴에서 옵션을 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  3. 화면 표시 탭에서 기본 글꼴로만 표시 확인란을 선택한 다음 그림 나타내지 않음 확인란을 선택합니다.

    그림 축소그림 확대
    옵션 대화 상자


  4. 일반 탭에서 문서를 열 때 자동 연결 업데이트 확인란의 선택을 취소한 다음 확인을 누릅니다.

    그림 축소그림 확대
    일반 탭


  5. 문서를 엽니다.
문서를 여는 데 성공한 경우 이 문서의 "문서가 열리지만 예기치 않은 동작이 나타날 경우 시도할 작업" 절의 단계를 사용하여 파일을 복구할 수 있습니다.

문서를 새 문서에 파일로 삽입

Word 문서의 최종 단락 기호에는 문서에 대한 정보가 포함되어 있습니다. 문서가 손상된 경우 이 마지막 단락 기호를 빼면 문서의 텍스트를 가져올 수 있습니다. 마지막 단락 기호를 제외하고 문서에 액세스하려면 다음과 같이 하십시오.
  1. 파일 메뉴에서 새로 만들기를 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  2. 새 문서를 선택합니다.

    그림 축소그림 확대
    새 문서 창


  3. 삽입 메뉴에서 파일을 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  4. 파일 삽입 대화 상자에서 손상된 문서를 찾아 선택한 다음 삽입을 누릅니다.

    그림 축소그림 확대
    파일 삽입 대화 상자
참고 새 문서의 마지막 구역에 일부 서식을 다시 적용해야 할 수 있습니다.

파일에 연결하여 열기

파일에 연결하면 파일 헤더의 일부나 마지막 단락 기호가 문서의 손상 영역에 있는 경우에도 파일이 열릴 가능성이 있습니다. 손상되지 않은 파일에 연결한 다음 연결에서 손상된 파일을 가리키도록 변경하려면 다음과 같이 하십시오.
  1. 파일 메뉴에서 새로 만들기를 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  2. 새 문서를 선택합니다.

    그림 축소그림 확대
    새 문서 창


  3. 새 문서에 테스트 문서를 입력한 다음 문서를 저장합니다.

    그림 축소그림 확대
     Microsoft Word


  4. 텍스트를 선택한 다음 편집 메뉴에서 복사를 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  5. 파일 메뉴에서 새로 만들기를 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  6. 새 문서를 선택합니다.

    그림 축소그림 확대
    새 문서 창


  7. 새 문서에서 편집 메뉴의 선택하여 붙여넣기를 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  8. 서식 있는 텍스트(RTF)를 누르고 연결하여 붙여넣기를 선택한 다음 확인을 누릅니다.

    그림 축소그림 확대
    선택하여 붙여넣기 대화 상자


  9. 편집 메뉴에서 연결을 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  10. 연결 대화 상자에서 연결된 문서의 파일 이름을 선택한 다음 원본 변경을 누릅니다.

    그림 축소그림 확대
    연결 대화 상자


  11. 원본 변경 대화 상자에서 더 이상 열 수 없는 문서를 선택한 다음 열기를 누릅니다.

    그림 축소그림 확대
    "원본 변경" 대화 상자


  12. 확인을 눌러 연결 대화 상자를 닫습니다.

    참고 손상된 문서에 복구할 수 있는 데이터나 텍스트가 있으면 해당 문서의 정보가 표시됩니다.

    그림 축소그림 확대
    연결 대화 상자


  13. 편집 메뉴에서 연결을 누릅니다.

    그림 축소그림 확대
    Microsoft Word


  14. 연결 대화 상자에서 연결 끊기를 누릅니다.

    그림 축소그림 확대
    연결 대화 상자


  15. 다음과 같은 메시지가 나타나면 를 누릅니다.
    선택한 연결을 해제하시겠습니까?


    그림 축소그림 확대
    Microsoft Office Word 대화 상자
이제 복구된 문서의 서식을 다시 지정하고 저장할 수 있습니다.

텍스트 복구 변환기 사용

텍스트 복구 변환기를 사용하여 모든 파일에서 텍스트를 추출할 수 있습니다. 작업 파일은 Word 문서가 아니어도 됩니다.

텍스트 복구 변환기에는 다음과 같은 제한 사항이 있습니다. 문서의 서식이 손실되고 텍스트 이외의 모든 내용이 손실됩니다. 그래픽, 필드, 그리기 개체 및 기타 텍스트가 아닌 항목이 손실됩니다. 그러나 머리글, 바닥글, 각주, 미주 및 필드 텍스트는 단순 텍스트로 유지됩니다. 뿐만 아니라, 텍스트 복구 변환기를 사용하여 복구한 문서에는 주로 문서의 시작 부분과 끝 부분에 변환되지 않은 이진 데이터가 일부 남아 있습니다. 문서의 서식을 다시 지정하고 Word 문서로 저장하기 전에 이러한 이진 데이터를 삭제해야 합니다. 텍스트 복구 변환기의 사용 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
290946 Word 2002 및 Word 2003의 "텍스트 복구" 변환기를 사용하여 파일에서 텍스트를 복구하는 방법

워드패드에서 파일 열기

대개 파일 헤더의 손상으로 인해 Word에서 손상된 문서를 열 수 없는 경우 워드패드에서 문서를 연 다음 서식있는 텍스트(RTF)로 저장하여 문서의 손상된 부분을 필터링할 수 있습니다. 워드패드에서 .rtf 파일로 저장하면 지원되지 않는 문자열이 모두 제거됩니다.

참고 일부 서식이 손실될 수 있습니다.

파일을 워드패드에서 열려면 다음과 같이 하십시오.
  1. 워드패드를 시작합니다. 시작을 누르고 실행을 누릅니다.

    그림 축소그림 확대
    시작 메뉴


  2. 열기 상자에 wordpad를 입력합니다.

    그림 축소그림 확대
    실행 대화 상자


  3. 파일 메뉴에서 열기를 누릅니다.

    그림 축소그림 확대
    워드패드


  4. 파일 형식 상자에서 Windows용 Word(*.doc)를 누릅니다.

    그림 축소그림 확대
    열기 대화 상자


  5. 복구할 문서를 누른 다음 열기를 누릅니다.

    그림 축소그림 확대
     열기 대화 상자


  6. 이제 Word 문서가 열립니다.
  7. 파일 메뉴에서 다른 이름으로 저장을 누릅니다.

    그림 축소그림 확대
     워드패드


  8. 파일 이름 상자에 .rtf 파일 확장명과 함께 새 파일 이름을 입력합니다.

    그림 축소그림 확대
     다른 이름으로 저장 대화 상자


  9. 파일 형식 상자에서 서식 있는 텍스트 (RTF)를 누릅니다. 저장을 누르기 전에 Word를 다시 시작할 때 파일을 쉽게 찾을 수 있도록 파일이 저장된 폴더를 기록해 둡니다. 저장을 누릅니다.

    그림 축소그림 확대
    다른 이름으로 저장 대화 상자


  10. 파일 메뉴에서 끝내기를 누릅니다.

    그림 축소그림 확대
     워드패드


  11. Word를 다시 시작한 다음 워드패드에서 저장한 파일을 엽니다. 이 파일의 이름은 7단계에서 지정한 이름과 같습니다.
  12. 파일 메뉴에서 다른 이름으로 저장을 누릅니다.

    그림 축소그림 확대
     Microsoft Word


  13. Word 문서(.doc) 형식으로 파일을 저장합니다.

    그림 축소그림 확대
     다른 이름으로 저장 대화 상자
이제 새 문서의 서식을 다시 지정하고 손상된 문서에 포함되었던 그래픽, 필드 및 기타 서식을 추가합니다.



Word, Excel 및 PowerPoint 2007용 Microsoft Office 호환 기능 팩의 이전 버전에서 발생하는 알려진 문제로 인한 파일 확장명 변경

Word 2007 문서(*.docx) 파일이 실수로 Word 문서(*.doc) 파일 확장명을 사용하여 저장되었을 수 있습니다. 이 경우 파일을 열려고 하면 파일 변환 대화 상자가 나타날 수 있습니다. 파일 확장명을 .docx로 변경하는 경우 Word, Excel 및 PowerPoint 2007 파일 형식용 Microsoft Office 호환 기능 팩이 설치된 시스템에서 Word 2003을 사용하여 해당 문서를 열면 일반적으로 문서가 열립니다.

이 호환 기능 팩을 다운로드하려면 다음 Microsoft 웹 사이트를 방문하십시오.
http://www.microsoft.com/downloads/thankyou.aspx?familyId=941B3470-3AE9-4AEE-8F43-C6BB74CD1466&displaylang=ko
자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
947444 2007년 12월 17일자 Word 2003 서비스 팩 3 이후 핫픽스 패키지에 대한 설명


참조

Word 2007에서 손상된 문서를 해결하는 방법에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
918429 Word 2007에서 손상된 문서를 해결하는 방법

속성

기술 자료: 826864 - 마지막 검토: 2008년 4월 23일 수요일 - 수정: 5.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
키워드:?
kbnomt kbgraphxlink kbscreenshot kbbackup kbhowtomaster KB826864

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com