Восстановление поврежденных документов Word

Переводы статьи Переводы статьи
Код статьи: 826864 - Vizualiza?i produsele pentru care se aplic? acest articol.
Данная статья объединяет сведения предыдущих статей: 211634 и 290932
Развернуть все | Свернуть все

В этой статье

Аннотация

Использование поврежденных файлов документов может вызвать необычное поведение различных программ. Возникновение неполадок свидетельствует о том, что в данных файла содержится ошибка.

Лучшим способом защиты от повреждения документов является создание их резервных копий. Если резервная копия документа отсутствует, используйте приведенные в этой статье рекомендации по устранению неполадок для определения и возможного восстановления поврежденного документа Microsoft Word.

Определение поврежденного документа

Поврежденные документы часто вызывают необычное поведение программы, используемой для их открытия, такое как разбиение документа на бесконечное количество страниц, неправильное форматирование, вывод нечитаемых знаков на экран, вывод сообщений об ошибках во время обработки документа, зависание системы при загрузке или просмотре файла документа или любое другое поведение, не соответствующее нормальной работе программы. В некоторых случаях повреждение документа не является причиной подобного поведения.

Для определения действительной причины выполните следующие действия.
  1. Убедитесь, что подобное поведение не наблюдается при использовании других документов.
  2. Убедитесь, что подобное поведение не наблюдается при использовании других программ.
  3. Откройте документ на другом компьютере и попытайтесь воспроизвести проблему.
  4. Замените шаблон, вложенный в поврежденный документ, общим шаблоном (Normal.dot). Если вложенным шаблоном является шаблон Normal.dot, закройте Word, переименуйте файл Normal.dot, перезапустите Word и попробуйте повторить то же необычное поведение.

    Чтобы заменить вложенный шаблон на общий шаблон, выполните следующие действия.

    1. Откройте нужный документ.
    2. В менюСервис выберите команду Шаблоны и надстройки.

      Свернуть это изображениеРазвернуть это изображение
      Microsoft Word


    3. Если в окне Шаблон документа есть шаблон, отличный от шаблона Normal.dot, выберите Присоединить.

      Свернуть это изображениеРазвернуть это изображение
      Откройте диалоговое окно «Шаблоны и надстройки»


    4. В папке «Шаблоны» выберите Normal (Normal.dot) и нажмите кнопку Открыть.

      Свернуть это изображениеРазвернуть это изображение
      Диалоговое окно «Присоединение шаблона»
  5. Запустите Word с параметрами по умолчанию. Используйте параметр /a для запуска программы Word. При использовании параметра /a Word не загружает надстройки и не использует существующий шаблон Normal.dot. Повторно запустив программу Word с ключом /a, попытайтесь воспроизвести проблему. Для получения дополнительных сведений о работе с ключами щелкните приведенный ниже номер статьи базы знаний Майкрософт:
    826857 Описание ключа запуска «/a» в программе Word (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
    210565 Использование параметров командной строки для запуска Word 2003, Word 2002 и Word 2000
  6. Используйте другой драйвер принтера и попытайтесь повторить то же необычное поведение. Если необычное поведение сохраняется с новым драйвером, попробуйте полностью удалить и повторно установить существующий драйвер принтера. Для замены драйвера принтера выполните описанные ниже действия с учетом используемой операционной системы:

    Microsoft Windows 2000
    1. Нажмите кнопку Пуск, выберите пункты Настройка и далее Принтеры.

      Свернуть это изображениеРазвернуть это изображение
      Меню «Пуск»


    2. Щелкните правой кнопкой мыши значок соответствующего принтера и выберите пункт Удалить.

      Свернуть это изображениеРазвернуть это изображение
      Окно «Принтеры»


    3. Чтобы удалить все файлы, имеющие отношение к принтеру, нажмите кнопку Да.

      Свернуть это изображениеРазвернуть это изображение
      Диалоговое окно «Принтеры»


    4. В группе Задачи печати выберите Установка принтера, и следуйте указаниям мастера установки принтера по переустановке драйвера Windows для принтера.

      Свернуть это изображениеРазвернуть это изображение
      Окно «Принтеры»
    Microsoft Windows XP и Windows Server 2003
    1. Нажмите кнопку Пуск и выберите раздел Принтеры и факсы.

      Свернуть это изображениеРазвернуть это изображение
      Меню «Пуск»


    2. Щелкните правой кнопкой мыши значок соответствующего принтера и выберите пункт Удалить.

      Свернуть это изображениеРазвернуть это изображение
      Окно «Принтеры и факсы»


    3. Чтобы удалить все файлы, имеющие отношение к принтеру, нажмите кнопку Да.

      Свернуть это изображениеРазвернуть это изображение
      Диалоговое окно «Принтеры»


    4. В группе Задачи печати выберите Установка принтера и следуйте указаниям мастера установки принтера по переустановке драйвера Windows для принтера.

      Свернуть это изображениеРазвернуть это изображение
      Окно «Принтеры и факсы»
    Для получения дополнительных сведений об устранении неполадок с печатью в Windows 2000 щелкните следующие номера статей базы знаний Майкрософт:
    871146 Устранение общих неполадок с печатью в Windows 2000 при использовании продуктов Office (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
    870622Устранение проблем, возникающих при печати на локальном принтере из приложений Office на компьютере под управлением Windows XP
    870968 Устранение общих проблем с печатью из приложений Office на компьютере под управлением Windows Server 2003 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
  7. Измените другие компоненты системы (например видеодрайверы или шрифты), закройте все запущенные программы сторонних разработчиков (например резидентные программы (TSR), диспетчеры шрифтов, экранные заставки и системные оболочки) и попробуйте повторить то же необычное поведение. Для обхода использования этих программ и системных компонентов загрузите Windows в безопасном режиме. Безопасный режим - это метод, позволяющий запустить Windows простейшим возможным способом. В безопасном режиме обходятся многие драйверы и вспомогательные файлы, которые могут вызвать неполадки, если они повреждены. Для получения дополнительных сведений о загрузке Windows в безопасном режиме щелкните следующие номера статей базы знаний Майкрософт:
    310353 Выполнение «чистой» загрузки в Windows XP
    202485 Описание режима безопасной загрузки в Windows 2000 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
    Для запуска Windows XP или Microsoft Windows Server 2003 в безопасном режиме выполните следующие действия:

    1. Нажмите кнопку Пуск и выберите пункт Завершение работы.

      Свернуть это изображениеРазвернуть это изображение
      Кнопка Завершение работы


    2. Выберите Перезагрузить и нажмите OK.

      Свернуть это изображениеРазвернуть это изображение
      Диалоговое окно Завершение работы Windows


    3. Нажмите клавишу F8 после получения следующего сообщения:
      Выберите операционную систему для запуска
    4. В меню Меню дополнительных вариантов загрузки Windows с помощью клавиш со стрелками выберите Безопасный режим и нажмите клавишу ВВОД. Примечание Для того чтобы использовать клавиши со стрелками на цифровой клавиатуре, режим NUM LOCK должен быть отключен.
    5. Если на кмпьютере имеются другие операционные системы, выберите Windows XP или Microsoft Windows Server 2003 из появившегося списка и нажмите ВВОД.

Попытка восстановить файл принудительно с помощью Word

Если обнаружена проблема, Microsoft Office Word 2003 и Microsoft Word 2002 автоматически пытаются восстановить поврежденный документ. Можно попробовать восстановить документ в принудительном порядке при его открытии. Для этого выполните следующие действия.
  1. В меню Файл выберите пункт Открыть.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  2. В диалоговом окне Открыть выберите ваш документ Word.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Открыть


  3. Нажмите стрелку на кнопке Открыть, затем выберите пункт Открыть и восстановить.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Открыть
Для получения дополнительных сведений о восстановлении документов выберите Справка: Microsoft Office Word в меню Справка.

Свернуть это изображениеРазвернуть это изображение
Microsoft Word


В окне Найти введите восстановление.

Свернуть это изображениеРазвернуть это изображение
Панель Справка Word


Действия, которые можно предпринять, если открытый документ ведет себя неожиданным образом

Сохранение документа в виде файла другого формата, затем преобразование его обратно в формат Word

Это наиболее эффективный способ восстановления документа. Этот метод следует применять в первую очередь.

Сохраните документ в виде файла другого формата. Попробуйте сохранить документ в формате «текст с разметкой» (rtf) или как веб-страницу (html). Эти форматы позволяют сохранить форматирование в документе Word.

После сохранения документа в виде фала другого формата закройте его, снова откройте в программе Word, а затем сохраните как документ Word (doc). В случае успеха поврежденные участки файла будут восстановлены во время преобразований.

Если повреждения продолжают проявляться, сохраните документ в виде файла другого формата. Попробуйте сохранить документ в следующих форматах в порядке перечисления:
  • Формат «текст с разметкой» (.rtf)
  • Веб-страница (html)
  • Любой другой формат хранения текста
  • Только текст (txt)

    Примечание Сохранение документов в виде файлов формата Только текст часто приводит к устранению повреждений. Однако все форматирование документа, все рисунки и макросы при этом теряются. После сохранения документов в виде файлов формата «Только текст» необходимо заново произвести форматирование. Поэтому формат «Только текст» следует использовать только в случае, если проблема не решается с помощью сохранения файла в других форматах.

Копирование всго содержимого, за исключением последнего знака абзаца, в новый документ

Программа Word связывает с последним знаком абзаца многие сведения о форматировании, например, форматирование разделов и стилей.

Если скопировать все содержимое, за исключением последнего знака абзаца, в новый документ, поврежденный участок исходного документа может остаться за концом скопированного фразмента.

В новом документе следует повторно применить форматирование разделов и стилей.

Примечание Чтобы выделить все содержимое документа, кроме последнего знака абзаца, выполните следующие действия:
  1. Нажмите клавиши CTRL+END, а затем — CTRL+SHIFT+HOME.
  2. Если документ содержит разрывы разделов, скопируйте только текст между разрывами. (Разрывы разделов не следует копировать и вставлять, так как они могут повредить новый документ.) Корпорация Microsoft рекомендует обычный режим просмотра при копировании и вставке в документ Word, чтобы избежать переноса разрывов разделов между документами. Чтобы перейти в обычный режим, выберите команду Обычный в меню Вид.

Копирование неповрежденных фрагментов документа в новый документ

Иногда удается определить расположение поврежденного участка в документе. В таком случае скопируйте все, кроме поврежденного участка, в новый файл и воссоздайте поврежденный фрагмент в новом документе.

ПримечаниеЕсли документ содержит разрывы разделов, копируйте только текст между разрывами. (Разрывы разделов не следует копировать и вставлять, так как они могут повредить новый документ).

Действия, которые можно предпринять, если не удается открыть документ

Существует несколько способов открытия неоткрывающихся документов. Выбор способа зависит от природы и объема повреждения документа, а также от наблюдаемого необычного поведения. Хотя многие из этих способов часто позволяют решить проблему, не каждый поврежденный документ можно восстановить.

Открытие поврежденного документа Word в черновом режиме без обновления ссылок

Иногда документ, который не удается открыть в других режимах, можно открыть в черновом режиме без обновления ссылок. Для этого выполните следующие действия.
  1. В меню Вид выберите Обычный.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  2. В меню Инструменты выберите Свойства.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  3. На вкладке Вид установите флажок Черновик, затем флажок Пустые рамки рисунков.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Свойства


  4. На вкладке Общие снимите флажок Автоматически обновлять связи при открытии и нажмите кнопку OK.

    Свернуть это изображениеРазвернуть это изображение
    вкладка Общие


  5. Откройте документ.
Если документ был успешно открыт, к нему можно применить методы восстановления, описанные в разделе «Действия, которые можно предпринять, если открытый документ ведет себя неожиданным образом» этой статьи.

Вставка документа как файла в новый документ

Последний знак абзаца в документе Word содержит сведения о документе. Текст поврежденного документа можно извлечь, если удастся опустить последний знак абзаца. Чтобы получить доступ к документу без последнего знака абзаца, выполните следующие действия.
  1. В меню Файл выберите Создать.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  2. Выберите Новый документ.

    Свернуть это изображениеРазвернуть это изображение
    Панель Новый документ


  3. В меню Вставка выберите Файл.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  4. В диалоговом окне Вставка файла найдите и выберите поврежденный документ и нажмите кнопку Вставить.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Вставить файл
Примечание Может потребоваться повторно применить форматирование к последнему разделу нового документа.

Открытие файла путем создания ссылки на него

Этот метод может позволить открыть файл с поврежденным заголовком или последним знаком абзаца. Выполните приведенную ниже процедуру, чтобы создать ссылку на неповрежденный файл, затем измените ссылку, чтобы она указывала на поврежденный файл.
  1. В меню Файл выберите Создать.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  2. Выберите Новый документ.

    Свернуть это изображениеРазвернуть это изображение
    Панель Новый документ


  3. В новом документе введите Это проба и сохраните его.

    Свернуть это изображениеРазвернуть это изображение
     Microsoft Word


  4. Выделите текст и выберите Копировать в меню Правка.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  5. В меню Файл выберите Создать.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  6. Выберите Новый документ.

    Свернуть это изображениеРазвернуть это изображение
    Панель Новый документ


  7. В новом документе выберите пункт Специальная вставка в меню Правка.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  8. Выберите Текст в формате RTF, выберите переключатель Связать и нажмите кнопку OK.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Специальная вставка


  9. В меню Правка выберите Связи.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  10. В диалоговом окне Связи выберите имя файла связываемого документа и нажмите кнопку Сменить источник.

    Свернуть это изображениеРазвернуть это изображение
    диалоговое окно Связи


  11. В диалоговом окне Сменить источник выберите документ, который не удается открыть, и нажмите Открыть.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно «Сменить источник»


  12. Нажмите кнопку OK для закрытия диалогового окна Связи. ПримечаниеВ новом документе должны появиться сведения из поврежденного документа (если документ содержит восстанавливаемые данные или текст).

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Связи


  13. В меню Правка выберите Связи.

    Свернуть это изображениеРазвернуть это изображение
    Microsoft Word


  14. В диалоговом окне Связи выберите Разорвать связь.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Связи


  15. Нажмите кнопку Да в сообщении со следующим запросом:
    Разорвать указанные связи?


    Свернуть это изображениеРазвернуть это изображение
    диалоговое окно Microsoft Office Word
Затем к восстановленному документу можно повторно применить форматирование и сохранить его.

Воспользуйтесь фильтром «Восстановление текста из любого файла»

C помощью фильтра «Восстановление текста из любого файла» можно извлечь текст из любого файла. Это не обязательно должен быть файл Word.

У фильтра «Восстановление текста из любого файла» есть определенные ограничения. Форматирование документа теряется. Все, что не является текстом, теряется. Рисунки, поля, графики и т. п. теряются. Поэтому все колонтитулы, сноски и текст полей представляются обычным текстом. Вдобавок текст, восстановленный фильтром «Восстановление текста из любого файла», может содержать некоторые непреобразованные двоичные данные. Обычно они расположены в начале и в конце документа. Необходимо удалить эти двоичные данные перед переформатированием файла и сохранением его в качестве документа Word. Для получения дополнительные сведений о восстановлении текста из любого файла щелкните следующий номер статьи базы знаний Майкрософт:
290946 Извлечение текста из любых файлов с помощью фильтра «Восстановление текста из любого файла» для Word 2002 и Word 2003 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)

Открытие файла в программе WordPad

Если поврежденный файл не удается открыть в программе Word для Windows (обычно из-за повреждения заголовка), можно попытаться отфильтровать поврежденные участки документа, открыв его в программе WordPad, а затем сохранить его в формате RTF. При сохранении файла в формате rtf в программе WordPad все неподдерживаемые строки отрезаются.

Примечание Форматирование может быть частично утрачено.

Для открытия файла в программе WordPad выполните следующие действия:
  1. Запустите программу WordPad. Выберите в меню Пуск пункт Выполнить.

    Свернуть это изображениеРазвернуть это изображение
    Меню Пуск


  2. В окне Открыть введите wordpad.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Выполнить


  3. В меню Файл выберите Открыть.

    Свернуть это изображениеРазвернуть это изображение
    WordPad


  4. В окне Тип файла выберите Word для Windows (*.doc).

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Открыть


  5. Выберите документ, который нужно восстановить, и нажмите кнопку Открыть.

    Свернуть это изображениеРазвернуть это изображение
     Диалоговое окно Открыть


  6. Должен открыться Документ Word.
  7. В меню Файл выберите Сохранить как.

    Свернуть это изображениеРазвернуть это изображение
     WordPad


  8. В меню Имя файла введите новое имя файла с расширением rtf.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Сохранить как


  9. В поле Тип файла: выберите Файл RTF. Перед тем как нажимать кнопку Сохранить, запомните, в какой папке был сохранен файл, чтобы его можно было быстро найти после перезапуска программы Word. Нажмите кнопку Сохранить.

    Свернуть это изображениеРазвернуть это изображение
    Диалоговое окно Сохранить как


  10. В меню Файл выберите Выход.

    Свернуть это изображениеРазвернуть это изображение
     WordPad


  11. Перезапустите программу Word и откройте файл, сохраненный с помощью программы WordPad (файл будет иметь имя, введенное на шаге 7).
  12. В менюФайл выберите Сохранить как.

    Свернуть это изображениеРазвернуть это изображение
     Microsoft Word


  13. Сохраните файл в формате Документ Word (doc).

    Свернуть это изображениеРазвернуть это изображение
     Диалоговое окно Сохранить как
Затем можно применить к новому документу форматирование и добавить в него рисунки, поля и другие элементы, которые содержал поврежденный документ.

Свойства

Код статьи: 826864 - Последний отзыв: 12 октября 2006 г. - Revision: 4.2
Информация в данной статье относится к следующим продуктам.
  • Microsoft Office Word 2003
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
Ключевые слова: 
kbnomt kbgraphxlink kbscreenshot kbbackup kbhowtomaster KB826864

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com