"Synchronizace se nezdařila kvůli chybě na serveru ” chybová zpráva při pokusu o synchronizaci mobilního zařízení s serveru Exchange 2000

Překlady článku Překlady článku
ID článku: 826974 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zazálohovat. Seznamte se také s postupem obnovení registru v případě, že nastane problém. Další informace o zálohování, obnovení a úpravě registru naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při pokusu o použití součásti Microsoft Server ActiveSync Microsoft Mobile Information Server 2002 synchronizovat složku Doručená pošta, složky Kalendář a složce Kontakty v mobilním zařízení s serveru se systémem Microsoft Exchange 2000 Server zobrazí následující chybová zpráva v mobilním zařízení:
Synchronization failed due to an error on the server. Try again. Kód chyby: HTTP_500
Poznámka: Můžete také r eceive MIS_5 chybě při synchronizaci mobilního zařízení.

Příčina

K tomuto problému může dojít, pokud platí některá z následujících podmínek:
  • Virtuální adresář serveru Exchange v počítači se serverem Exchange 2000 není nakonfigurován pro integrované ověřování systému Windows.
  • Kerberos je zakázán v počítači se serverem Exchange 2000.
Součást Server ActiveSync, která je součástí Microsoft Mobile Information Server 2002 používá ověřování Kerberos, když komunikuje s počítačem Exchange 2000. Počítače Exchange 2000 není nakonfigurován pro integrované ověřování systému Windows, Exchange 2000 počítače vrátí chybu 401 Mobile Information Server 2002 počítače, který je spuštěn Server ActiveSync a vrátí Server ActiveSync 500 Chyba mobilní zařízení. Součást Server ActiveSync nefunguje správně, pokud je protokol Kerberos zakázán.

Řešení

Při řešení tohoto problému postupujte takto:
  1. Přezkoumat protokolu Internetová informační služba (IIS) soubory na serveru Exchange 2000 počítače kde jsou umístěny poštovní schránky. (Obvykle soubory protokolu IIS jsou umístěna ve složce WinDir \System32\Logfiles\W3svc #.) Vyhledejte chyby 401. Pokud víte, který uživatelský účet dochází k problému, můžete hledat název účtu.
  2. Pomocí nástroje Microsoft Network Monitor zachytit síťový provoz ze Mobile Information Server 2002.

    Poznámka: Digitalizovat Výtěžek analýzy další plynule, pokud mají všechny konfigurační informace, včetně adres IP Mobile Information Server 2002 a Exchange 2000 Server.

    V programu Sledování sítě sběr dat, při zobrazení odpověď z počítače Exchange 2000 Mobile Information Server 2002 hledejte „ 401 Přístup odepřen, „ "WWW-Authenticate: NTLM," a "WWW-Authenticate: základní" zprávy v podokně Šestnáctkový. Pokud je uveden „ 401 Access denied"nebo"WWW-Authenticate: základní"zprávy, je problém ověřování.

    Další informace o použití nástroje Sledování sítě klepněte na následující čísla následujících článcích databáze Microsoft Knowledge Base:
    243270Postup instalace programu Sledování sítě v systému Windows 2000
    148942Jak sbírat data o síťovém provozu pomocí nástroje Sledování sítě
  3. V počítači Exchange 2000, kde jsou umístěny poštovní schránky zkontrolujte, zda virtuální adresář Exchange nastavena na integrované ověřování systému Windows. Použijte uvedený postup:
    1. Spusťte správce systému serveru Exchange.
    2. Rozbalte položku Servers, rozbalte název počítače Exchange 2000, rozbalte položku Protocols, rozbalte položku HTTP a rozbalte Virtuální Server Exchange.
    3. Klepněte pravým tlačítkem myši na složku Exchange a potom klepněte na příkaz Vlastnosti.
    4. Klepněte na kartu přístup, klepněte na tlačítko ověřování a potom klepnutím zaškrtněte políčko Integrované ověřování systému Windows.
    5. Klepněte dvakrát na tlačítko OK.

      Poznámka: Pokud povolíte integrované ověřování systému Windows, změna obvykle trvá z 5 až 15 minut k replikaci služby IIS a mezipaměti služby IIS být aktualizována. Chcete-li vynutit okamžitou replikaci, můžete restartovat všechny služby Exchange 2000 a Správa služby IIS.
  4. Zkontrolujte, pokud je problém vyřešen. Pokud problém přetrvává, přejděte ke kroku 5.
  5. Počítače Exchange 2000, kde jsou umístěny poštovní schránky Ujistěte se, zda virtuální server Exchange 2000 není vynucení komunikace protokol SSL (Secure Sockets Layer) (SSL). Použijte uvedený postup:
    1. Klepněte na tlačítko Start, přejděte na příkaz programy, přejděte na položku Nástroje pro správu a potom klepněte na položku Správce služeb Internetu.
    2. Rozbalte název serveru, rozbalte položku výchozí web (nebo příslušný web obsahuje virtuální server HTTP), klepněte pravým tlačítkem myši na složku Exchange a klepněte na příkaz Vlastnosti.
    3. Klepněte na kartu Zabezpečení adresáře a ve skupinovém rámečku Zabezpečená komunikace, klepněte na tlačítko Upravit.
    4. V dialogovém okně Zabezpečená komunikace zkontrolujte, zda není zaškrtnuto políčko Vyžadovat zabezpečený kanál (SSL).
  6. Ujistěte se, že je v počítači se serverem Exchange 2000 povolen Kerberos. Ověřte, zda je povoleno Kerberos, postupujte takto.

    Poznámka: Pokud jste dříve postupovali podle kroků popsaných v článku 215383 zakázat Negotiate znalostní báze Microsoft Knowledge Base, je protokol Kerberos zakázán. Pokud je zakázána Kerberos se nezdaří ActiveSync Exchange Server.
    1. Z příkazového řádku v počítači Exchange 2000 změnit složka WinDir \Inetpub\AdminScripts.
    2. Zadejte následující příkaz a pak stiskněte klávesu ENTER:
      cscript adsutil.vbs get w3svc/NTAuthenticationProviders
      Pokud je povoleno Kerberos "Negotiate, NTLM" zobrazí se odpověď a pokračujte krokem 7.
    3. Odpověď je pouze "NTLM", je protokol Kerberos zakázán. Povolení protokolu Kerberos, zadejte následující a stiskněte klávesu ENTER:

      cscript adsutil.vbs set w3svc/NTAuthenticationProviders "Negotiate, NTLM"
  7. Pokud příkaz cscript adsutil.vbs get w3svc/NTAuthenticationProviders"Negotiate, NTLM" odpověď vrátí, ale Kerberos v stále nefunguje, ujistěte se, že je v registru počítače Exchange 2000 povolen Kerberos. Použijte uvedený postup.

    Upozornění Při nesprávných úpravách registru pomocí Editoru registru nebo jiným způsobem může dojít k vážným problémům. Tyto problémy mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nezaručuje, že tyto problémy bude možné vyřešit. Úpravy registru provádíte na vlastní nebezpečí.
    1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, do pole Otevřít zadejte příkaz regedt32 a klepněte na tlačítko OK.
    2. Vyhledejte následující podklíč registru a klepněte na něj:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. V pravém podokně klepněte na položku
      Security Packages
      položka registru.
    4. V nabídce Úpravy klepněte na tlačítko Vícenásobný řetězec. V poli Údaj ujistěte, že kerberos je uveden jako jednu z hodnot.

      Kerberos není uvedena, vytvořte nový řádek na začátku hodnoty a potom zadejte kerberos.

      Poznámka: Ve výchozím hodnoty v poli Údaj vypadat takto:
      Kerberos
      Msv1_0
      Schannel
    5. Pokud změníte hodnotu registru, restartujte počítač Exchange 2000.

Další informace

Další informace o ověřování Kerberos klepněte na následující číslo článku databáze Microsoft Knowledge Base:
215383Jak nakonfigurovat službu IIS tak, aby podporovala ověřování v síti pomocí protokolu Kerberos i NTLM (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)


Další informace o službě IIS ověřování, zkontrolujte v kapitole 5 v Designing Secure Web-Based aplikací pro systém Windows 2000. Čtení této ukázkové kapitole naleznete na následujícím webu:
http://www.microsoft.com/mspress/books/sampchap/4293.aspx

Vlastnosti

ID článku: 826974 - Poslední aktualizace: 31. ledna 2007 - Revize: 1.4
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Mobile Information Server 2002 Enterprise Edition
Klíčová slova: 
kbmt kbprb KB826974 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:826974

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com