« La synchronisation a échoué due to une erreur sur le serveur ? message d'erreur lorsque vous essayez de synchroniser un appareil mobile avec un serveur Exchange 2000

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256986 Description du Registre Microsoft Windows
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Symptômes

Lorsque vous essayez d'utiliser le composant Microsoft Server ActiveSync de Microsoft Mobile Information Server 2002 pour synchroniser le dossier Boîte de réception, le dossier calendrier et le dossier de contacts sur votre appareil mobile avec un serveur qui exécute Microsoft Exchange 2000 Server, le message d'erreur suivant s'affiche sur votre appareil mobile :
Synchronisation a échoué en raison d'une erreur sur le serveur. Essayez à nouveau. Code d'erreur : HTTP_500
note Vous pouvez également r eceive MIS_5 une erreur lors de la synchronisation de votre appareil mobile.

Cause

Ce problème peut se produire si une des conditions suivantes est remplie :
  • Le répertoire virtuel Exchange sur l'ordinateur 2000 Exchange n'est pas configuré pour l'authentification Windows intégrée.
  • Kerberos est désactivé sur l'ordinateur 2000 Exchange.
Le composant Server ActiveSync qui est fourni avec Microsoft Mobile Information Server 2002 utilise l'authentification Kerberos lorsqu'il communique avec l'ordinateur Exchange 2000. Si l'ordinateur Exchange 2000 n'est pas configuré pour l'authentification Windows intégrée, l'ordinateur 2000 Exchange renvoie une erreur 401 à l'ordinateur Mobile Information Server 2002 qui exécute Server ActiveSync et puis Server ActiveSync renvoie une erreur 500 sur l'appareil mobile. Le composant Server ActiveSync ne fonctionne pas correctement si Kerberos est désactivée.

Résolution

Pour résoudre ce problème, procédez comme suit :
  1. Révision les Microsoft Internet Information Services (IIS) journal fichiers sur Exchange 2000 dans lequel les boîtes aux lettres sont situés. (En général, les fichiers journaux IIS trouvent dans le WinDir \System32\Logfiles\W3svc # dossier.) Recherchez des erreurs 401. Si vous connaissez le compte d'utilisateur rencontre le problème, vous pouvez rechercher le nom de compte.
  2. Utiliser l'outil Moniteur réseau Microsoft pour capturer le trafic réseau à partir de Mobile Information Server 2002.

    note Capturer les frais d'analyse plus facilement si vous avez toutes les les informations de configuration, notamment les adresses IP de Mobile Information Server 2002 et Exchange 2000 Server.

    Dans le Moniteur réseau capture, lorsque vous affichez la réponse de l'ordinateur Exchange 2000 de Mobile Information Server 2002, recherchez « 401 Accès refusé," « WWW-Authenticate : NTLM », et les messages « WWW-Authenticate : Basic » dans le volet hexadécimal. Si un « 401 Accès refusé » ou un message « WWW-Authenticate : Basic » est répertorié, il y a un problème d'authentification.

    Pour plus d'informations sur la façon d'utiliser l'outil Moniteur réseau, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
    243270 Comment faire pour installer Moniteur réseau dans Windows 2000
    148942 Comment capturer le trafic réseau Aide du Moniteur réseau
  3. Dans l'ordinateur Exchange 2000 dans lequel les boîtes aux lettres sont situés, vérifiez que le répertoire virtuel Exchange est configuré sur l'authentification intégrée de Windows. Pour ce faire, procédez comme suit :
    1. Démarrez le Gestionnaire système Exchange.
    2. Développez serveurs , développez le nom de l'ordinateur Exchange 2000, développez protocoles , développez HTTP , puis puis développez serveur virtuel Exchange .
    3. Cliquez avec le bouton droit sur le dossier Exchange , puis cliquez sur Propriétés .
    4. Cliquez sur l'onglet Accès , cliquez sur Authentification , puis cliquez sur Activez la case à cocher Authentification Windows intégrée .
    5. Cliquez sur OK deux fois.

      note Si vous activez l'authentification Windows intégrée, la modification généralement prend de 5 à 15 minutes pour répliquer aux services Internet (IIS) et pour être mis à jour le cache de services Internet (IIS). Pour forcer la réplication immédiate, vous pouvez redémarrer le service d'administration IIS et tous les les services Exchange 2000.
  4. Vérifiez si le problème est résolu. Si le problème persiste, passez à étape 5.
  5. Sur l'ordinateur Exchange 2000 dans lequel les boîtes aux lettres sont situés, vérifiez que le serveur virtuel Exchange 2000 n'est pas forcer communication SSL (Secure Sockets LAYER). Pour ce faire, procédez comme suit :
    1. Cliquez sur Démarrer , pointez sur programmes , pointez sur Outils d'administration et puis cliquez sur Gestionnaire des services Internet .
    2. Développez le nom du serveur, développez site Web par défaut (ou le site Web approprié qui contient le serveur virtuel HTTP) cliquez avec le bouton droit sur le dossier Exchange et puis cliquez sur Propriétés .
    3. Cliquez sur l'onglet Sécurité de répertoire , puis, cliquez sur Modifier sous communications sécurisées .
    4. Dans la boîte de dialogue Communications sécurisées , vérifiez que la case à cocher Exiger un canal sécurisé (SSL) n'est pas activée.
  6. Assurez-vous que Kerberos est activé sur l'ordinateur 2000 Exchange. Pour vérifier que Kerberos est activée, procédez comme suit.

    note Si vous avez déjà suivi les étapes décrites dans l'article de base de connaissances Microsoft 215383 pour désactiver la négociation, Kerberos est désactivée. Si Kerberos est désactivée, Exchange Server ActiveSync échoue.
    1. À partir d'une invite sur l'ordinateur Exchange 2000, accédez au dossier \Inetpub\Adminscripts WinDir.
    2. Tapez la commande suivante et appuyez sur ENTRÉE :
      cscript adsutil.vbs get w3svc/NTAuthenticationProviders
      Si Kerberos est activée, le « Negotiate, NTLM » réponse s'affiche et vous pouvez accédez à l'étape 7.
    3. Si la réponse est « NTLM » uniquement, Kerberos est désactivée. Pour activer Kerberos, tapez la commande suivante, puis appuyez sur ENTRÉE :

      cscript adsutil.vbs set w3svc/NTAuthenticationProviders Negotiate, NTLM
  7. Si la commande cscript adsutil.vbs get w3svc/NTAuthenticationProviders retourne la réponse « Negotiate, NTLM » , mais que Kerberos ne fonctionne toujours pas, assurez-vous que Kerberos est activé dans le Registre de l'ordinateur Exchange 2000. Pour ce faire, procédez comme suit.

    Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.
    1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedt32 dans la zone Ouvrir et puis cliquez sur OK .
    2. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. Dans le volet droit, cliquez sur les
      Security Packages
      entrée de Registre.
    4. Dans le menu Edition , cliquez sur chaîne multiple . Dans la boîte de données , assurez-vous que kerberos est répertorié comme une des valeurs.

      Si kerberos n'est pas répertorié, créer une nouvelle ligne au début des valeurs et tapez kerberos .

      note Par défaut, les valeurs dans la boîte de données apparaissent comme suit :
      Kerberos
      MSV1_0
      Schannel
    5. Si vous modifiez la valeur de Registre, redémarrez l'ordinateur Exchange 2000.

Plus d'informations

Pour plus d'informations sur l'authentification Kerberos, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
215383 Comment faire pour configurer IIS pour prendre en charge le protocole Kerberos et le protocole NTLM pour l'authentification du réseau


Pour plus d'informations sur IIS l'authentification, consultez le chapitre 5 dans les applications Designing Secure Web-Based pour Microsoft Windows 2000 . Pour Lisez ce chapitre exemple, reportez-vous au site de Web Microsoft suivant :
http://www.microsoft.com/mspress/books/sampchap/4293.aspx

Propriétés

Numéro d'article: 826974 - Dernière mise à jour: mercredi 31 janvier 2007 - Version: 1.4
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Mobile Information Server 2002 Enterprise Edition
Mots-clés : 
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La version anglaise de cet article est la suivante: 826974
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