"Falha na sincronização devido a um erro no servidor ? mensagem de erro ao tentar sincronizar um dispositivo móvel com um servidor Exchange 2000

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importante Este artigo contém informações sobre como modificar o registro. Certifique-se de fazer backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
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Sintomas

Quando você tenta usar o componente Microsoft Server ActiveSync do Microsoft Mobile Information Server 2002 para sincronizar a pasta caixa de entrada, a pasta Calendário e a pasta de contatos no seu dispositivo móvel com um servidor que está executando o Microsoft Exchange 2000 Server, você receber a seguinte mensagem de erro no dispositivo móvel:
Falha na sincronização devido a um erro no servidor. Tente novamente. Código de erro: HTTP_500
Observação Você também pode r eceive MIS_5 um erro durante a sincronização do seu dispositivo móvel.

Causa

Esse problema pode ocorrer se qualquer uma das seguintes condições for verdadeira:
  • O diretório virtual do Exchange no computador do Exchange 2000 não está configurado para a autenticação integrada do Windows.
  • Kerberos é desativado no computador Exchange 2000.
O componente Server ActiveSync que acompanha o Microsoft Mobile Information Server 2002 usa a autenticação Kerberos quando ele se comunica com o computador Exchange 2000. Se o computador Exchange 2000 não está configurado para a autenticação integrada do Windows, o computador com o Exchange 2000 retorna um erro 401 para o computador Mobile Information Server 2002 que está executando o Server ActiveSync e, em seguida, o Server ActiveSync retorna um erro 500 para o dispositivo móvel. O componente Server ActiveSync não irá funcionar corretamente se Kerberos for desativado.

Resolução

Para resolver esse problema, execute essas etapas:
  1. Revisão fazer os Microsoft Internet Information Services (IIS) arquivos o Exchange 2000 computador onde as caixas de correio estão localizadas. (Normalmente, os arquivos de log do IIS estão localizados na pasta WinDir \System32\Logfiles\W3svc #.) Procure 401 erros. Se você souber qual conta de usuário está enfrentando o problema, você pode procurar o nome da conta.
  2. Use a ferramenta Microsoft Network Monitor para capturar o tráfego de rede do Mobile Information Server 2002.

    Observação Capture continua análise mais suavemente se você tiver todas as informações de configuração, incluindo os endereços IP do Mobile Information Server 2002 e o Exchange 2000 Server.

    No Monitor de rede captura, quando você exibir a resposta do computador Exchange 2000 ao Mobile Information Server 2002, procure "401 acesso negado," "WWW-Authenticate NTLM:", e mensagens "WWW-Authenticate: básico" no painel de hexadecimal. Se uma "401 acesso negado" ou uma mensagem "WWW-Authenticate: Basic" estiver listada, há um problema de autenticação.

    Para obter mais informações sobre como usar a ferramenta Monitor de rede, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
    243270Como instalar o Monitor de rede no Windows 2000
    148942Como capturar o tráfego de rede com o Monitor de rede
  3. No computador Exchange 2000 em que as caixas de correio estão localizadas, verifique se o diretório virtual do Exchange é definido para a autenticação integrada do Windows. Para fazer isso, execute estas etapas:
    1. Inicie o Exchange System Manager.
    2. Expanda Servers , expanda o nome do computador Exchange 2000, expanda Protocols , expanda HTTP e em seguida, expanda Servidor Virtual do Exchange .
    3. Clique com o botão direito na pasta do Exchange e, em seguida, clique em Propriedades .
    4. Clique na guia acesso , clique em autenticação e, em seguida, clique para selecionar a caixa de seleção Autenticação integrada do Windows .
    5. Clique duas vezes em OK .

      Observação Se você habilitar a autenticação integrada do Windows, a alteração normalmente leva de 5 a 15 minutos para replicar para o IIS e para o cache do IIS para ser atualizado. Para forçar a replicação imediata, você pode reiniciar o serviço de administração do IIS e todos os serviços do Exchange 2000.
  4. Verifique se o problema é resolvido. Se o problema persistir, vá para a etapa 5.
  5. No computador do Exchange 2000 em que as caixas de correio estão localizadas, certifique-se que o servidor virtual do Exchange 2000 não está forçando a comunicação SSL (Secure Sockets LAYER). Para fazer isso, execute estas etapas:
    1. Clique em Iniciar , aponte para programas , aponte para Ferramentas administrativas e, em seguida, clique em Gerenciador de serviços de Internet .
    2. Expanda o nome do servidor, expanda Default Web Site (ou o site adequado que contém o servidor virtual HTTP), clique com o botão direito na pasta do Exchange e, em seguida, clique em Propriedades .
    3. Clique na guia Segurança de diretório e, em seguida, clique em Editar em comunicações de segurança .
    4. Na caixa de diálogo Comunicações de segurança , verifique se que a caixa de seleção Exigir canal de segurança (SSL) não está marcada.
  6. Certifique-se que o Kerberos é ativado no computador do Exchange 2000. Para verificar se o Kerberos está ativado, execute essas etapas.

    Observação Se você seguiu as etapas descritas no artigo 215383 para desabilitar Negociar anteriormente, Kerberos é desabilitado. Se Kerberos for desabilitado, Exchange Server ActiveSync irá falhar.
    1. Em um prompt de comando no computador Exchange 2000, altere para a pasta de \Inetpub\AdminScripts WinDir.
    2. Digite o seguinte e pressione ENTER:
      cscript adsutil.vbs get w3svc/NTAuthenticationProviders
      Se Kerberos for habilitado, o "Negotiate, NTLM" resposta será exibida e você pode ir para a etapa 7.
    3. Se a resposta for "NTLM" somente, Kerberos é desabilitado. Para habilitar o Kerberos, digite o seguinte e pressione ENTER:

      cscript adsutil.vbs set w3svc/NTAuthenticationProviders "Negotiate, NTLM"
  7. Se o comando cscript adsutil.vbs get w3svc/NTAuthenticationProviders retorna a resposta "Negotiate, NTLM" , mas Kerberos ainda não funcionar, certifique-se que o Kerberos está ativado no registro do computador Exchange 2000. Para fazer isso, siga estas etapas.

    Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstale seu sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.
    1. Clique em Iniciar , clique em Executar , digite regedt32 na caixa Abrir e, em seguida, clique em OK .
    2. Localize e, em seguida, clique na seguinte subchave do Registro:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. No painel direito, clique em
      Security Packages
      entrada do Registro.
    4. No menu Editar , clique em Seqüências múltiplas . Na caixa dados , certifique-se de que kerberos está listado como um dos valores.

      Se kerberos não estiver listado, criar uma nova linha no início dos valores e, em seguida, digite kerberos .

      Observação Por padrão, os valores na caixa dados aparecem da seguinte maneira:
      Kerberos
      Msv1_0
      Schannel
    5. Se você alterar o valor do Registro, reinicie o computador Exchange 2000.

Mais Informações

Para obter mais informações sobre a autenticação Kerberos, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
215383Como configurar o IIS para oferecer suporte ao protocolo Kerberos e o protocolo NTLM para autenticação de rede


Para obter mais informações sobre o IIS autenticação, examine o capítulo 5 em Designing Secure Web-Based aplicativos para o Microsoft Windows 2000 . Para ler este capítulo de exemplo, visite o seguinte site da Microsoft:
http://www.microsoft.com/mspress/books/sampchap/4293.aspx

Propriedades

ID do artigo: 826974 - Última revisão: quarta-feira, 31 de janeiro de 2007 - Revisão: 1.4
A informação contida neste artigo aplica-se a:
  • Microsoft Mobile Information Server 2002 Enterprise Edition
Palavras-chave: 
kbmt kbprb KB826974 KbMtpt
Tradução automática
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Clique aqui para ver a versão em Inglês deste artigo: 826974

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