How to Cambiare a livello di programmazione la visualizzazione predefinita di un modulo di Microsoft Office InfoPath 2003

Traduzione articoli Traduzione articoli
Identificativo articolo: 826997 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

I moduli di Microsoft Office InfoPath supportano più visualizzazioni. Una di queste è la visualizzazione predefinita. Quando si apre un modulo in InfoPath, tale modulo viene aperto nella visualizzazione predefinita. In questo articolo viene descritto come modificare a livello di programmazione la visualizzazione predefinita di un modulo di InfoPath.

Creazione di un nuovo modulo

  1. Avviare InfoPath 2003.
  2. Scegliere Progetta modulo dal menu File.
  3. Nel riquadro Progetta modulo scegliere Nuovo modulo vuoto.

Creazione della visualizzazione 1

  1. Nel modulo vuoto digitare Questa è la visualizzazione 1 nella prima riga, quindi digitare Selezionare per mostrare la visualizzazione 2 all'apertura del modulo nella seconda riga.
  2. Nel menu a discesa Riquadro attività fare clic su Controlli.
  3. Nel riquadro attività Controlli fare clic su Casella di controllo.
  4. Sostituire il testo Casella di controllo con Visualizzazione 2.

Creazione della visualizzazione 2

  1. Nel menu a discesa Riquadro attività fare clic su Visualizzazioni.

    Visualizzazione 1 è la visualizzazione predefinita del modulo.
  2. Nella sezione Azioni del riquadro attività scegliere Aggiungi nuova visualizzazione.
  3. Digitare il nome Visualizzazione 2, quindi scegliere OK.
  4. Nel modulo vuoto digitare Questa è la visualizzazione 2.

Aggiunta dello script

  1. Scegliere Script dal menu Strumenti, quindi scegliere Microsoft Script Editor.
  2. Aggiungere il seguente codice nella finestra del codice:
    function XDocument::OnLoad(eventObj)
    {
    	//Pick the default view based on the value of element DefaultView
    	var objDefaultView = XDocument.DOM.selectSingleNode("//my:field1");
    
    	if ((objDefaultView != null) && (objDefaultView.text != ""))
       	{
    		switch (objDefaultView.text)
          		{
             		case "false":
    				    XDocument.ViewInfos("View 1").IsDefault = true;
                			break;
             		case "true":
                			XDocument.ViewInfos("View 2").IsDefault = true;
                			break;
          		}
       	}
    }
  3. Salvare lo script, quindi chiudere Microsoft Script Editor.
  4. Salvare il modello di modulo con nome SwitchDefaultView.xsn, quindi chiuderlo.

Esercizio

  1. Scegliere Compila modulo dal menu File.

    Nota Compilare il modulo in questo passaggio invece di visualizzare l'anteprima del modulo. Nell'anteprima non vengono visualizzate le modifiche apportate a livello di programma alla visualizzazione predefinita in corrispondenza dell'evento OnLoad. In modalità anteprima viene sempre mostrata la visualizzazione correntemente selezionata nella finestra di progettazione di InfoPath.
  2. Nel riquadro attività fare clic su SwitchDefaultView.

    Il modulo verrà aperto in visualizzazione 1 (la visualizzazione predefinita iniziale).
  3. Selezionare la casella di controllo Visualizzazione 2.
  4. Salvare il modulo con nome SwitchDefaultViewForm.xml, quindi chiudere il modulo.
  5. Scegliere Apri dal menu File.
  6. Individuare il file SwitchDefaultViewForm.xml e scegliere Apri.

    Il modulo verrà aperto in visualizzazione 2.

Proprietà

Identificativo articolo: 826997 - Ultima modifica: venerdì 20 gennaio 2006 - Revisione: 3.0
Le informazioni in questo articolo si applicano a
  • Microsoft Office InfoPath 2003
Chiavi: 
kbhowto KB826997
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com