[INP2003] [HOWTO] Microsoft Office InfoPath 2003 フォームの既定のビューをスクリプトで変更する方法

文書翻訳 文書翻訳
文書番号: 826997 - 対象製品
すべて展開する | すべて折りたたむ

目次

概要

Microsoft Office InfoPath フォームでは複数のビューがサポートされており、その 1 つが既定のビューに設定されています。InfoPath でフォームを開くと、そのフォームは既定のビューで開きます。この資料では、InfoPath フォームで使用される既定のビューをスクリプトで変更する方法について説明します。

新しいフォームを作成する

  1. InfoPath 2003 を起動します。
  2. [ファイル] メニューの [フォームのデザイン] をクリックします。
  3. [フォームのデザイン] 作業ウィンドウの [新しい空白のフォーム] をクリックします。

ビュー 1 を作成する

  1. 空白のフォームで、最初の行にこれはビュー 1 ですと入力し、2 行目にフォームを開いたときビュー 2 で表示するには、次のチェック ボックスをオンにしますと入力します。
  2. 作業ウィンドウ右上の下向き矢印をクリックし、一覧の [コントロール] をクリックします。
  3. [コントロール] 作業ウィンドウで [チェック ボックス] をクリックします。
  4. [チェック ボックス] の "フィールド 1" をビュー 2 に変更します。

ビュー 2 を作成する

  1. 作業ウィンドウ右上の下向き矢印をクリックし、一覧の [ビュー] をクリックします。

    フォームの既定のビューはビュー 1 です。
  2. [ビュー] 作業ウィンドウの [操作] の下にある [新しいビューの追加] をクリックします。
  3. [新しいビュー名] ボックスにビュー 2 と入力し、[OK] をクリックします。
  4. 空のフォームにこれはビュー 2 ですと入力します。

スクリプトを追加する

  1. [ツール] メニューの [スクリプト] をポイントし、[Microsoft Script Editor] をクリックします。
  2. コード ウィンドウに次のコードを追加します。
    function XDocument::OnLoad(eventObj)
    {
    	//Pick the default view based on the value of element DefaultView
    	var objDefaultView = XDocument.DOM.selectSingleNode("//my:フィールド1");
    	if ((objDefaultView != null) && (objDefaultView.text != ""))
       	{
    		switch (objDefaultView.text)
          		{
             		case "false":
    				    XDocument.ViewInfos("ビュー 1").IsDefault = true;
                			break;
             		case "true":
                			XDocument.ViewInfos("ビュー 2").IsDefault = true;
                			break;
          		}
       	}
    }
  3. スクリプトを保存して Microsoft Script Editor を閉じます。
  4. フォーム テンプレートを SwitchDefaultView.xsn という名前で保存し、フォーム テンプレートを閉じます。

実際に試してみる

  1. [ファイル] メニューの [フォームの入力] をクリックします。

    : ここでは、[フォームのプレビュー] ではなく、[フォームの入力] を使用します。プレビューには、OnLoad イベントに追加された既定のビューのスクリプトによる変更は反映されません。プレビュー モードでは、InfoPath のデザイナで選択されているビューが常に表示されます。
  2. [フォームの入力] 作業ウィンドウの [SwitchDefaultView] をクリックします。

    フォームがビュー 1 (当初の既定のビュー) で開きます。
  3. [ビュー 2] チェック ボックスをオンにします。
  4. フォームを SwitchDefaultViewForm.xml という名前で保存して閉じます。
  5. [ファイル] メニューの [開く] をクリックします。
  6. SwitchDefaultViewForm.xml をクリックし、[開く] をクリックします。

    フォームがビュー 2 で開きます。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 826997 (最終更新日 2003-09-17) を基に作成したものです。

この資料に含まれているサンプル コード/プログラムは英語版を前提に書かれたものをありのままに記述しており、日本語環境での動作は確認されておりません。

プロパティ

文書番号: 826997 - 最終更新日: 2003年10月15日 - リビジョン: 2.0
この資料は以下の製品について記述したものです。
  • Microsoft Office InfoPath 2003
キーワード:?
kbhowto KB826997
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com