Como alterar programaticamente o modo de exibição padrão de um formulário do InfoPath

Traduções deste artigo Traduções deste artigo
ID do artigo: 826997 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sumário

Formulários do Microsoft Office InfoPath suportam vários modos de exibição. Um modo de exibição é o modo de exibição padrão. Quando você abre um formulário no Microsoft InfoPath 2010, o Microsoft Office InfoPath 2007 ou Microsoft Office InfoPath 2003, abra o formulário no modo de exibição padrão. Este artigo contém um exemplo de como alterar programaticamente o modo de exibição padrão de um formulário do InfoPath.

Criar um novo formulário

  1. Inicie o InfoPath.
    • Para o InfoPath Designer 2010:
      1. Clique em novo, clique em Formulário em branco e, em seguida, clique em Criar formulário.
    • Para o InfoPath 2007:
      1. Clique em criar um modelo de formulário no menu arquivo.
      2. Clique em branco no painel de tarefas de design a Form Template e, em seguida, clique em OK.
    • Para o InfoPath 2003:
      1. Clique em criar um formulário no menu arquivo.
      2. Clique em Novo formulário em branco no painel de tarefas criar um formulário.

Criar exibição 1

Para 2010 do InfoPath:
  1. No formulário em branco, digite Este é o modo de exibição 1 para o título e, em seguida, digite Check para exibir 2 exibir quando o formulário é aberto sob a linha pontilhada.
  2. Clique para posicionar o ponteiro no início da segunda linha.
  3. Em controles, clique duas vezes em caixa de seleção.
  4. Clique no ícone Salvar.
Para o InfoPath 2007 e InfoPath 2003:
  1. No formulário em branco, digite Este é o modo de exibição 1 na linha primeira e digite Check para exibir 2 exibir quando o formulário é aberto na segunda linha.
  2. Clique para posicionar o ponteiro no início da segunda linha.
  3. No menu drop-down de Painel de tarefas, clique em <a1>controles</a1>.
  4. No painel de tarefas controles, clique em caixa de seleção.
  5. Clique no ícone Salvar.

Criar exibição 2

Para 2010 do InfoPath:
  1. Clique na guia de Design da página e aviso de que modo de exibição 1 é o modo de exibição padrão para o formulário.
  2. Na seção modos de exibição, clique em Nova exibição.
  3. Digite o nome de exibição 2 e, em seguida, clique em OK.
  4. Para o título, digite que isto é 2 View.
Para o InfoPath 2007 e InfoPath 2003:
  1. No menu drop-down de Painel de tarefas, clique em modos de exibição.

    Modo de exibição 1 é o modo de exibição padrão para o formulário.
  2. Na seção de ações do painel de tarefas, clique em Adicionar novo modo de exibição.
  3. Digite o nome de exibição 2 e, em seguida, clique em OK.
  4. No formulário em branco, digite que este é o modo 2.

Adicionar o script

O InfoPath 2007

Em 2007 e InfoPath 2010, você deve definir a linguagem de programação que você deseja usar. Para o InfoPath 2003, ignorar este procedimento e, em seguida, use o procedimento de Adicionar o script.

Observação: Este exemplo usa translation from VPE for Csharp linguagem de programação. Você pode usar o Visual Basic ou outras opções disponíveis.
Definir a linguagem de programação
Para 2010 do InfoPath:

Antes de executar este script de exemplo em 2010 do InfoPath, você deve alterar a linguagem de programação para translation from VPE for Csharp. Para fazer isso, siga estas etapas.

Aviso O comando Remover código mencionada no seguinte procedimento remove todos os códigos existentes do formulário atual. Portanto, não use esta opção a menos que tenha certeza de que você deseja executar esta ação.
  1. Clique na guia desenvolvedor.
  2. Na seção de código, clique em idioma e, em seguida, clique para selecionar Programming. Se a caixa de idioma de código do modelo de formulário for desativada, clique em Remover código para remover todo o código existente no formulário. Se a caixa de idioma de código do modelo de formulário está disponível, vá para a próxima etapa.
  3. Na caixa idioma de código do modelo de formulário, clique para selecionar translation from VPE for Csharp e, em seguida, clique em OK.
Para o InfoPath 2007:

Antes de executar este script de exemplo no InfoPath 2007, você deve alterar a linguagem de programação para translation from VPE for Csharp. Para fazer isso, execute as seguintes etapas:

Aviso O comando Remover código mencionada no seguinte procedimento remove todos os códigos existentes do formulário atual. Portanto, não use essa opção, a menos que tenha certeza de que você deseja executar esta ação.
  1. No menu Ferramentas, clique em Opções de formulário.
  2. Na lista categoria, clique em programação. Se a caixa de idioma de código do modelo de formulário for desativada, clique em Remover código para remover todo o código existente no formulário. Se a caixa de idioma de código do modelo de formulário está disponível, vá para a próxima etapa.
  3. Na caixa idioma de código do modelo de formulário, clique em translation from VPE for Csharp e, em seguida, clique em OK.
Adicione o script
Para 2010 do InfoPath:

Adicione o script para o Evento de carregamento. Para fazer isso, execute as seguintes etapas:
  1. Na guia Developer, clique em Carregar evento. Inicia o Microsoft Visual Studio Tools for Applications.
  2. Adicione o exemplo de código a seguir os locais que são indicados.
    {
                //Create an XPathNavigator object for the main DOM
                XPathNavigator xnDocument = this.MainDataSource.CreateNavigator();
    
                //Create an XPathNavigator object for field1 - the check box for switching the View
                XPathNavigator xnDefaultView = xnDocument.SelectSingleNode("/my:myFields/my:field1", this.NamespaceManager);
          
                //Make sure that the XPathNavigator object is not null or an empty string
                if ((xnDefaultView != null) && (xnDefaultView.Value != ""))
    
                {
                    //Switch to the appropriate View
                    switch (xnDefaultView.Value)
    
                    {
                        case "false":
                            e.SetDefaultView("View 1");
                            break;
    
                        case "true":
                            e.SetDefaultView("View 2");
                            break;
    
                    }
            }
    }
    
  3. Salvar as alterações e feche o Visual Studio Tools for Applications.
  4. Salve o modelo de formulário como SwitchDefaultView.xsn e, em seguida, feche o modelo de formulário.
Para o InfoPath 2007

Adicione o script para o evento de carregamento. Para fazer isso, execute as seguintes etapas:
  1. No menu Ferramentas, aponte para programação e, em seguida, clique em Carregar evento. Inicia o Microsoft Visual Studio Tools for Applications.
  2. Adicione o seguinte exemplo de código ao evento Age_OnValidate.
    {
                //Create an XPathNavigator object for the main DOM
                XPathNavigator xnDocument = this.MainDataSource.CreateNavigator();
    
                //Create an XPathNavigator object for field1 - the check box for switching the View
                XPathNavigator xnDefaultView = xnDocument.SelectSingleNode("/my:myFields/my:field1", this.NamespaceManager);
          
                //Make sure that the XPathNavigator object is not null or an empty string
                if ((xnDefaultView != null) && (xnDefaultView.Value != ""))
    
                {
                    //Switch to the appropriate View
                    switch (xnDefaultView.Value)
    
                    {
                        case "false":
                            e.SetDefaultView("View 1");
                            break;
    
                        case "true":
                            e.SetDefaultView("View 2");
                            break;
    
                    }
  3. Salvar as alterações e feche o Visual Studio Tools for Applications.
  4. Salve o modelo de formulário como SwitchDefaultView.xsn e, em seguida, feche o modelo de formulário.

InfoPath 2003

Para adicionar o script no InfoPath 2003, execute estas etapas:
  1. No menu Ferramentas, aponte para script e, em seguida, clique em Editor de scripts Microsoft.
  2. Adicione o seguinte código para a janela Code:
    function XDocument::OnLoad(eventObj)
    {
    	//Pick the default view based on the value of element DefaultView
    	var objDefaultView = XDocument.DOM.selectSingleNode("//my:field1");
    
    	if ((objDefaultView != null) && (objDefaultView.text != ""))
       	{
    		switch (objDefaultView.text)
          		{
             		case "false":
    				    XDocument.ViewInfos("View 1").IsDefault = true;
                			break;
             		case "true":
                			XDocument.ViewInfos("View 2").IsDefault = true;
                			break;
          		}
       	}
    }
  3. Salve o script e feche o Editor de scripts Microsoft.
  4. Salve o modelo de formulário como SwitchDefaultView.xsn e, em seguida, feche o modelo de formulário.

Testar o script

Para 2010 do InfoPath
  1. Abra o preenchimento do Microsoft Office InfoPath.
  2. Clique em Localizar um formulário, navegue até SwitchDefaultView.xsn, selecioná-lo e, em seguida, clique em Abrir.

    O formulário é aberto no modo de exibição 1 (o modo de exibição padrão inicial).
  3. Clique para selecionar a caixa de seleção Exibir 2.
  4. Salve o formulário como SwitchDefaultViewForm.xml e feche o formulário.
  5. Na guia File, clique em Fechar e, em seguida, clique em Abrir.
  6. Localize SwitchDefaultViewForm.xml e, em seguida, clique em Abrir.
O formulário é aberto no modo 2.

Para o InfoPath 2007 e InfoPath 2003:
  1. No menu arquivo, clique em <a1>Preencher Formulário</a1>.

    Observação: Certifique-se de que você preencha o formulário nesta etapa, em vez de visualizar o formulário. Visualização não reflete qualquer alteração programática do modo de exibição padrão no evento OnLoad. Modo de visualização sempre mostra o modo de exibição que está selecionado no designer do InfoPath.
  2. No InfoPath 2007, clique em SwitchDefaultView em Abra um formulário.

    No InfoPath 2003, clique em SwitchDefaultView no painel de tarefas.

    O formulário é aberto no modo de exibição 1 (o modo de exibição padrão inicial).
  3. Clique para selecionar a caixa de seleção Exibir 2.
  4. Salve o formulário como SwitchDefaultViewForm.xml e feche o formulário.
  5. No menu arquivo, clique em Abrir.
  6. Localize SwitchDefaultViewForm.xml e, em seguida, clique em Abrir.
O formulário é aberto no modo 2.

Propriedades

ID do artigo: 826997 - Última revisão: sexta-feira, 14 de maio de 2010 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Office InfoPath 2007
  • Microsoft Office InfoPath 2003
  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)
  • Microsoft Infopath 2010
Palavras-chave: 
kbmt kbhowto KB826997 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 826997

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com