Wie Debuggen eines Skripts für ein InfoPath-Formular

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 827002 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Dieser Artikel beschreibt, wie Sie die Ausführung eines Codes in einem InfoPath-Formular stoppen können Sie möchten das tun, damit Sie ein Skript für ein InfoPath-Formular debuggen können.

Weitere Informationen

Wenn Sie das Skript für ein InfoPath-Formular debuggen möchten, müssen Sie zunächst den Microsoft-Skriptdebugger an Ihr InfoPath-Formular anhängen Haltepunkte werden nicht erkannt, wenn Skriptdebugger Skript für ein InfoPath-Formular debuggt. Daher wird die Codeausführung an Haltepunkten nicht gestoppt Statt Haltepunkte müssen Sie das Microsoft JScript DEBUGGER verwenden Anweisung ( oder die Anweisung von Basic Scripting MICROSOFT VISUAL BASIC-STOP [VBScript]) Codeausführung für De-Bugzwecke zu beenden.

Weitere Informationen dazu, wie Sie die Codeausführung für ein Debugging mithilfe von JScript und VBScript stoppen und die Skriptsprache für Ihr InfoPath-Formular in VBScript oder JScript ändern können, finden Sie im folgenden Artikel der Microsoft Knowledge Base
828853 Wie Ändern der Skriptsprache für Ihr InfoPath-Formular

Ausführungsschritt

Office InfoPath 2007

Zuerst müssen Sie die Programmiersprache, die Sie verwenden möchten, in InfoPath 2007 einstellen. Anschließend müssen Sie das Skript hinzufügen.

Hinweis: JScript und VBScript, das Programmierbeispiele in diesem Artikel aufgenommen wird.
Legen Sie die Programmiersprache fest
Bevor Sie dieses Beispielskript in InfoPath 2007 ausführen, müssen Sie die Programmiersprache in VBScript oder Jscript ändern. Gehen Sie hierzu folgendermaßen vor

Warnung: The Remove Code Befehl, der in den folgenden Schritten erwähnt wird, entfernt vorhandenen gesamten Code aus dem aktuellen Formular. Verwenden Sie diese Option daher nicht, wenn Sie sicher dass Sie diese Aktion durchführen möchten sind.
  1. Klicken Sie in dem Menü Extras auf Formularoption.
  2. Klicken Sie in der Liste Kategorie auf Programmierung. Klicken Sie auf Remove Code, um vorhandenen gesamten Code in dem Formular zu entfernen, wenn das Form template code language Feld deaktiviert ist. Gehen Sie zu Schritt 3, wenn das Formularvorlagecodesprachenfeld verfügbar ist.
  3. Klicken Sie in dem Feld Form template code language auf VBScript oder Jscript, und klicken Sie dann auf OK.
Fügen Sie das Skript hinzu
  1. Klicken Sie in dem Menü Extras auf Programmierung, und klicken Sie anschließend auf On Load Event. Microsoft Visual Studio-Tool für Host-Anwendungen wird gestartet.
  2. Ersetzen Sie die Funktion OnLoad indem Sie den folgenden entsprechenden JScript-Code oder den VBScript-Code verwenden:

    JScript
    	function XDocument::OnLoad(eventObj)
    	{
    		debugger;
    		XDocument.UI.Alert("This is a test.");
    	}
    VBScript
    	Sub XDocument_OnLoad(eventObj)
    		Stop
    		XDocument.UI.Alert "This is a test."
    	End Sub
  3. Speichern Sie die Änderungen, und schließen Sie dann Tools in Visual Studio für Host-Anwendungen.
  4. Klicken Sie auf die Symbolleiste Standard auf Vorschau.
  5. Das Dialogfeld Just-In-Time Debugging wird angezeigt. Wählen Sie in der Liste möglicher Debuggers New Instance of Microsoft Script Editor aus, und klicken Sie anschließend auf Ja.

    Das Skript wird in Skripteditor angezeigt und die Skriptausführung wird unterbrochen.

    Hinweis: If Script Editor wird angezeigt, aber scheint, dass Sie das Feature Web Debugging möglicherweise für Skripteditor installieren müssen, Ihr Code. Details finden Sie in dem Abschnitt "Install Web Script Debugging".
  6. Drücken Sie F10, um die verbleibenden Codezeilen in dem Skript durchzulaufen.

InfoPath 2003

  1. Starten Sie Infopath 2003.
  2. Klicken Sie in dem Menü Datei auf Ein Formular entwerfen.
  3. Klicken Sie in dem Entwurf Formularaufgabenbereich auf Neues Formular erstellen.
  4. Gehen Sie folgendermaßen vor, um Ihrem Formular das folgende Skript hinzuzufügen
    1. Klicken Sie in dem Menü Extras auf Skript, und klicken Sie dann auf On Load Event.

      Microsoft Skript-Editor wird angezeigt.
    2. Ersetzen Sie durch den folgenden Code die Funktion OnLoad:

      JScript
      	function XDocument::OnLoad(eventObj)
      	{
      		debugger;
      		XDocument.UI.Alert("This is a test.");
      	}
      VBScript
      	Sub XDocument_OnLoad(eventObj)
      		Stop
      		XDocument.UI.Alert "This is a test."
      	End Sub
    3. Speichern Sie das Skript, und schließen Sie dann den Skript-Editor
  5. Klicken Sie in dem Menü Datei auf Formularvorschau, und klicken Sie dann auf Standard.
  6. Das Dialogfeld Just-In-Time Debugging wird angezeigt. Wählen Sie in der Liste möglicher Debuggers New Instance of Microsoft Script Editor aus, und klicken Sie anschließend auf Ja.

    Das Step Into Remote Procedure Call Dialogfeld wird angezeigt. Klicken Sie auf OK.

    Ihr Skript wird im Skript-Editor angezeigt, und die Skriptausführung wird gestoppt

    Hinweis: If Script Editor wird angezeigt aber Ihr Code wird nicht angezeigt, möglicherweise installieren müssen dann Sie für Skripteditor das Feature Web Debugging. Details zu diesem Vorgang finden Sie im nachstehenden Abschnitt "Web-Skriptdebugging installieren"
  7. Drücken Sie die Taste [F10], um die verbleibenden Codezeilen in Ihrem Skript durchzugehen

Web-Skriptdebugging installiere

Wann versuchen Sie das Debuggen Ihres Skripts, wenn sich die Skript-Editor-öffnen aber Ihr Code nicht in dem Codefenster befinden, wenn die Skript-Editor-öffnen aber Ihr Code nicht auf das Menü Debug klicken und wenn die Skript-Editor-öffnen aber Ihr Code dann nicht auf Webdebuggen installieren klicken. Wenn die Bug Web-de-Genf-Unktion während Office Setup mit Install-on-demand markiert war, wird folgende Fehlermeldung Ihnen angezeigt:
Die Installation der Webdebuggenfunktion erfordert einen Neustart der Anwendung Microsoft Skript-Editor Diese Funktion ist nicht zurzeit installiert. Möchten Sie es jetzt installieren?
Klicken Sie auf Ja, um Web Debugging zu installieren. Nach der Installation müssen Sie den Vorschaumodus schließen und danach erneut starten, um Ihr Skript zu debuggen

Wenn die Bug Web-de-Genf-Unktion während Office Setup mit not installed markiert war, wird folgende Fehlermeldung Ihnen angezeigt:
Die Installation der Webdebuggenfunktion erfordert einen Neustart der Anwendung Microsoft Skript-Editor Dieses Feature ist nicht verfügbar Starten Sie Setup, wählen Sie "Features hinzufügen/entfernen" und ändern Sie die Installationsart in "Vom Arbeitsplatz starten" oder "Von CD/Vom Netzwerk starten"
Klicken Sie auf OK, und beenden Sie dann Skripteditor.

Gehen Sie folgendermaßen vor, um das Feature Web Debugging bei Setup von Office zu installieren:

InfoPath 2007

  1. Öffnen Sie in der Systemsteuerung das "Software" Element.
  2. Wählen Sie in der Liste installierter Programme Microsoft Office aus, und klicken Sie dann auf Ändern.

    Office Setup wird gestartet.
  3. Wählen Sie in der Liste der Wartung-Modus-Optionen Features hinzufügen oder entfernen aus, und klicken Sie dann auf Weiter.
  4. Erweitern Sie den Knoten von Office Tools.
  5. Erweitern Sie den Knoten von HTML Source Editing.
  6. Erweitern Sie den Knoten von Web Scripting.
  7. Klicken Sie auf Web Debugging, und klicken Sie dann auf Von dem Arbeitsplatz starten.
  8. Klicken Sie auf Weiter.
  9. Klicken Sie auf Schließen, nachdem die Konfiguration aktualisiert wird.

InfoPath 2003

  1. Wählen Sie in der Systemsteuerung Option Software aus.
  2. Wählen Sie in der Liste installierter Programme Microsoft Office aus, und klicken Sie dann auf Ändern.

    Das Office-Setupprogramm wird gestartet
  3. Wählen Sie in der Liste der Wartung-Modus-Optionen Features hinzufügen oder entfernen aus, und klicken Sie dann auf Weiter.
  4. Wählen Sie Erweiterte Anpassung von Anwendungen aus, und klicken Sie dann auf Weiter.
  5. Doppelklicken Sie auf den Knoten von Office Tools.
  6. Doppelklicken Sie auf den Knoten von HTML Source Editing.
  7. Doppelklicken Sie auf den Knoten von Web Scripting.
  8. Wählen Sie für Web Debugging das Dropdownmenü, und klicken Sie dann auf Von dem Arbeitsplatz starten.
  9. Klicken Sie auf Aktualisieren.

Eigenschaften

Artikel-ID: 827002 - Geändert am: Dienstag, 1. Mai 2007 - Version: 2.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office InfoPath 2007
  • Microsoft Office InfoPath 2003
  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)
Keywords: 
kbscript kbdebug kbappdev kbhowto kbcode KB827002 KbMtde kbmt
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 827002
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com