Come utilizzare uno script o un campo dell'origine dati secondaria per la formattazione condizionale in InfoPath

Traduzione articoli Traduzione articoli
Identificativo articolo: 827008 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo viene descritto come utilizzare uno script per un'espressione di formattazione condizionale e l'utilizzo di un campo in un'origine dati secondaria per un'espressione di formattazione condizionale. Č possibile utilizzare lo script o il campo nell'origine dati secondaria in un modulo di Microsoft Office InfoPath 2007 o in un modulo di Microsoft Office InfoPath 2003.

Per utilizzare una funzione di script con la formattazione condizionale o un campo dell'origine dati secondaria con la formattazione condizionale, selezionare l'espressione per il tipo di condizione.

Un'espressione che fa riferimento a un campo in un'origine dati secondaria ha sintassi simile al seguente:

xdXDocument:GetDOM('DataSourceName') / docRoot / Node1 o Node2 = my:myField1

Nella finestra di questa sintassi, i segnaposto sono:
  • DataSourceNamesi riferisce il nome per l'origine dati secondaria.
  • docRootč la radice di documento XML.
  • Node1e Node2 sono nodi che sono contenuti in XML. Nodo 2 č un figlio di nodo 1.
  • my:myField1fa riferimento a un campo nell'origine dati principale del modulo.
In questo esempio specifico, l'istruzione di formattazione condizionale verifica il valore del Node2 nell'origine dati secondaria con testo my:myField1 nell'origine dati principale, quindi viene applicato il formato che č stata selezionata se i due valori corrispondono.

Analogamente, per chiamare una funzione di script dall'espressione di formattazione condizionale, č possibile utilizzare il prefisso xdExtension in cui č associato lo spazio dei nomi http://schemas.microsoft.com/office/infopath/2003/xslt/extension.

Progettare un nuovo modulo

In questo esempio viene descritto come creare un formato condizionale che utilizza entrambi i tipi di espressione.

Per InfoPath 2003

  1. Avviare InfoPath 2003. Progettazione di un nuovo modulo vuoto.
  2. Selezionare il riquadro attivitā origine dati. Per aggiungere campi al modulo, attenersi alla seguente procedura:
    1. Nel riquadro attivitā origine dati, fare clic con il pulsante destro del mouse su campiPersonali e scegliere Aggiungi .
    2. Nella finestra di dialogo Aggiungi campo o gruppo digitare myExpenses . Nell'elenco a discesa tipo , selezionare il gruppo . Selezionare l'opzione ripetuto e quindi fare clic su OK .
    3. Nel riquadro attivitā origine dati, fare clic con il pulsante destro del mouse su myExpenses e scegliere Aggiungi .
    4. Nella finestra di dialogo Aggiungi campo o gruppo digitare ExpenseName e quindi fare clic su OK .
    5. Nel riquadro attivitā origine dati, fare clic con il pulsante destro del mouse su myExpenses e scegliere Aggiungi .
    6. Nella finestra di dialogo Aggiungi campo o gruppo digitare ExpenseValue . Nell'elenco dei tipi di dati, selezionare decimale (double) e quindi fare clic su OK .
  3. Spostare il gruppo myExpenses nel riquadro attivitā origine dati del modulo e quindi fare clic su Tabella ripetuta .

Per InfoPath 2007

  1. Avviare InfoPath 2007.
  2. Nel riquadro sinistro della finestra di dialogo Iniziale , fare clic su Progetta modello di modulo .
  3. Nella finestra di progettazione di una finestra di modello di modulo, fare clic su vuoto e scegliere OK .
  4. Nel riquadro attivitā attivitā di progettazione, fare clic su Origine dati e quindi aggiungere campi al modulo. Per aggiungere campi al modulo, attenersi alla seguente procedura:
    1. Nel riquadro attivitā origine dati, fare clic con il pulsante destro del mouse su campiPersonali e scegliere Aggiungi .
    2. Nella finestra di dialogo Aggiungi campo o gruppo digitare myExpenses .
    3. Scegliere il tipo di gruppo .
    4. Fare clic su ripetuto e quindi fare clic su OK .
    5. Nel riquadro attivitā origine dati, fare clic con il pulsante destro del mouse su myExpenses e scegliere Aggiungi .
    6. Nella finestra di dialogo Aggiungi campo o gruppo digitare ExpenseName e quindi fare clic su OK .
    7. Nel riquadro attivitā origine dati, fare clic con il pulsante destro del mouse su myExpenses e scegliere Aggiungi .
    8. Nella finestra di dialogo Aggiungi campo o gruppo digitare ExpenseValue .
    9. Nell'elenco dei tipi di dati, fare clic su decimale (double) e quindi fare clic su OK .

Utilizzare uno script per la formattazione condizionale

Per InfoPath 2003

  1. script dal menu Strumenti , quindi Microsoft Script Editor .
  2. Aggiungere la seguente funzione alla finestra del codice:
    function CheckItem()
    {
        return "Airfare";
    }
  3. Salvare lo script e quindi chiudere Script Editor.
  4. Nel modulo, fare clic sulla casella di testo per il campo ExpenseName con il pulsante destro del mouse e quindi fare clic su Proprietā casella di testo .
  5. Nella finestra di dialogo Proprietā casella di testo fare clic sulla scheda Visualizza e quindi scegliere Formattazione condizionale .

    Verrā visualizzata la finestra di dialogo Formattazione condizionale .
  6. Fare clic su Aggiungi .

    Verrā visualizzata la finestra di dialogo Formattazione condizionale .
  7. Nella finestra di dialogo Formattazione condizionale , selezionare l'espressione dall'elenco a discesa e digitare la seguente condizione nella casella di testo:

    personali: ExpenseName = xdExtension:CheckItem()

    Fare clic su grassetto e quindi fare clic su OK .
  8. Fare clic su OK per chiudere la finestra di dialogo Formattazione condizionale .
  9. Fare clic su OK per chiudere la finestra di dialogo Proprietā casella di testo .
  10. Fare clic su Anteprima modulo . Per verificare il funzionamento del modulo, attenersi alla seguente procedura:
    1. Immettere il nome di spesa alberghi . Immettere la quantitā 250 .
    2. Premere CTRL + INVIO per aggiungere una nuova riga.
    3. Immettere il nome di spesa tariffe aeree . Immettere l' importo 700 .

      Nota Solo il nome di spesa nella seconda riga č in grassetto perché il nome della spesa č uguale a tariffe aeree e tariffe aeree č il valore di testo che viene restituito dalla funzione CheckItem .

Per InfoPath 2007

  1. Scegliere programmazione dal menu Strumenti , quindi Microsoft Script Editor .
  2. Aggiungere la seguente funzione il codice di finestra
    function CheckItem()
    {
        return "Airfare";
    }
  3. Nel menu file , fare clic su Salva .
  4. Nel menu file , fare clic su Esci .
  5. Nel modulo, fare clic sulla casella di testo per il campo ExpenseName con il pulsante destro del mouse e quindi fare clic su Proprietā casella di testo .
  6. Nella finestra di dialogo Proprietā casella di testo fare clic sulla scheda Visualizza e quindi scegliere Formattazione condizionale .

    Verrā visualizzata la finestra di dialogo Formattazione condizionale .
  7. Fare clic su Aggiungi .

    Verrā visualizzata la finestra di dialogo Formattazione condizionale .
  8. Nella finestra di dialogo Formattazione condizionale , fare clic sull'espressione nell'elenco e digitare la seguente condizione nella casella:
    personali: ExpenseName = xdExtension:CheckItem()
  9. Fare clic su grassetto e quindi fare clic su OK .
  10. Per chiudere la finestra di dialogo Formattazione condizionale , fare clic su OK .
  11. Per chiudere la finestra di dialogo Testo della proprietā , fare clic su OK .
  12. Dal menu file , fare clic su Anteprima e quindi fare clic su Form .
  13. Per verificare il funzionamento del modulo, attenersi alla seguente procedura:
    1. Immettere il nome di spesa alberghi .
    2. Immettere la quantitā 250 .
    3. Per aggiungere una nuova riga, premere CTRL+INVIO.
    4. Immettere il nome di spesa tariffe aeree .
    5. Immettere l' importo 700 .

      Nota Solo il nome di spesa nella seconda riga č in grassetto perché il nome della spesa č uguale a tariffe aeree e tariffe aeree č il valore di testo che viene restituito dalla funzione CheckItem .

Utilizzare un campo di un'origine dati secondaria per la formattazione condizionale

  1. Utilizzare un editor XML o un editor di testo come blocco note per creare un file XML con il seguente contenuto:
    <?xml version="1.0"?>
    <ExpenseRequirements>
    	<RequiresReceipt>75.00</RequiresReceipt>
    </ExpenseRequirements>
    nome del file ExpenseRequirements.xml .
  2. Per aggiungere ExpenseRequirements.xml come un'origine dati secondaria per il modulo, attenersi alla seguente procedura:
    1. Scegliere Converti origine dati principale , dal menu Strumenti .

      Verrā visualizzata guidata origine dati.
    2. Fare clic su Sfoglia .

      Verrā visualizzata la finestra di dialogo Apri .
    3. Spostarsi ExpenseRequirements.xml e quindi fare clic su Apri .
    4. Fare clic su Avanti e quindi fare clic su Fine per completare l'installazione guidata origine dati.
  3. Fare clic con il pulsante destro del mouse nella tabella ripetuta nel modulo e quindi fare clic su Proprietā-tabella ripetuta .
  4. Nella finestra di dialogo Proprietā-tabella ripetuta selezionare la scheda Visualizza e quindi scegliere Formattazione condizionale .

    Verrā visualizzata la finestra di dialogo Formattazione condizionale .
  5. Fare clic su Aggiungi .

    Verrā visualizzata la finestra di dialogo Formattazione condizionale .
  6. Nella casella finestra di dialogo Formattazione condizionale , selezionare l'espressione dell'elenco a discesa. Digitare la seguente condizione nella casella di testo:

    personali: ExpenseValue > xdXDocument:GetDOM("ExpenseRequirements")/ExpenseRequirements/RequiresReceipt

    Nell'elenco a discesa Colore sfondo , selezionare il colore rosso e quindi fare clic su OK .
  7. Fare clic su OK per chiudere la finestra di dialogo Formattazione condizionale .
  8. Fare clic su OK per chiudere la finestra di dialogo Proprietā-tabella ripetuta .
  9. Fare clic su Anteprima modulo .
  10. Per verificare il funzionamento del modulo, attenersi alla seguente procedura:
    1. Immettere il nome di spese pranzo . Immettere la quantitā 25 .
    2. Premere CTRL+INVIO per aggiungere una nuova riga.
    3. Immettere il nome di spesa cena . Immettere l' importo 80 .

      Nota La seconda riga viene formattata con uno sfondo rosso perché il valore spese supera il 75.

Proprietā

Identificativo articolo: 827008 - Ultima modifica: martedė 30 gennaio 2007 - Revisione: 2.2
Le informazioni in questo articolo si applicano a:
  • Microsoft Office InfoPath 2007
  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)
  • Microsoft Office InfoPath 2003
Chiavi: 
kbmt kbhowtomaster KB827008 KbMtit
Traduzione automatica articoli
Il presente articolo č stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non č sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pių o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non č la sua. Microsoft non č responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 827008
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com