Artigo: 827180 - Última revisão: terça-feira, 24 de Julho de 2007 - Revisão: 6.10

Mensagem de erro "Ficheiro C:\Boot.ini não pode ser aberto" quando tenta efectuar alterações para o ficheiro Boot.ini utilizando a ferramenta de sistema

Está disponível transferência de hotfixDisponível transferência de hotfix
Ver e solicitar transferências de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando abrir a ferramenta sistema no painel de controlo e, em seguida, clique no separador Avançadas na caixa de diálogo Propriedades do sistema para alterar as opções de Arranque do sistema num computador com o Windows Server 2003, poderá receber a seguinte mensagem de erro:
Não é possível abrir o ficheiro C:\boot.ini. Não é podem alterar definições de sistema operativo e o tempo de espera.
Nota Para abrir a caixa de diálogo Propriedades do sistema , clique em Iniciar , aponte para Painel de controlo , clique em desempenho e manutenção e, em seguida, clique em sistema .

Causa

Este problema pode ocorrer se a partição onde o Windows Server 2003 está instalado é atribuída qualquer letra diferente de "c". Este problema poderá ocorrer num cenário de arranque duplo ou quando as letras de unidade tem sido reatribuídas por um programa de outros fabricantes tal como Citrix DriveRemap.exe.

Windows armazena as opções de Arranque do sistema no ficheiro Boot.ini oculto que está localizado na raiz da partição do sistema. Neste cenário, Windows incorrectamente enumera as letras de unidade no sistema e utiliza o caminho predefinido C:\Boot.ini. Dado que "C" é normalmente utilizado para a partição de sistema, este problema não ocorre em maior parte dos sistemas, em que este é um caminho válido.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre a substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações de ficheiros

A versão inglesa desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.

x 86

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Aug-2003  20:14  5.2.3790.78       274,432  Sysdm.cpl
   12-Aug-2003  16:54                        271  Branches.inf
   20-Aug-2003  21:05                     10,091  Kb827180.cat
   20-Aug-2003  20:17                        354  Updatebr.inf
   20-Aug-2003  20:17                      5,095  Update_rtmqfe.inf

IA64

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Aug-2003  20:14  5.2.3790.78       475,136  Sysdm.cpl
   20-Aug-2003  20:14  5.2.3790.78       274,432  Wsysdm.cpl
   12-Aug-2003  16:54                        271  Branches.inf
   20-Aug-2003  21:04                     10,444  Kb827180.cat
   20-Aug-2003  20:19                        354  Updatebr.inf
   20-Aug-2003  20:19                      5,355  Update_rtmqfe.inf

Como contornar

Para contornar este problema, edite manualmente o ficheiro Boot.ini no bloco de notas. Para o fazer, siga estes passos:
  1. Clique em Iniciar , aponte para Todos os programas , aponte para Acessórios e, em seguida, clique em bloco de notas .
  2. No menu ficheiro , clique em Abrir .
  3. Na caixa de diálogo Abrir , alterar a selecção na caixa ficheiros do tipo para Todos os ficheiros e, em seguida, altere a selecção na caixa Procurar em para a raiz da unidade de arranque (arranque).
  4. Na pasta raiz da unidade de arranque, abra o ficheiro Boot.ini.

    Nota O ficheiro Boot.ini é um ficheiro oculto do sistema operativo. Para localizar o ficheiro Boot.ini, altere as opções de pastas no Windows. Para o fazer, siga estes passos:
    1. Clique com o botão direito do rato em Iniciar e clique em explorar .
    2. No menu Ferramentas no Explorador do Windows, clique em Opções de pastas .
    3. No separador Ver , faça duplo clique em ficheiros e pastas ocultos e, em seguida, clique em Mostrar ficheiros e pastas ocultos .
    4. Clique para desmarcar a caixa de verificação Ocultar ficheiros protegidos do sistema operativo (recomendado) .
    5. Clique em Sim na seguinte mensagem:
      Optou por mostrar protegidos do sistema operativo ficheiros (ficheiros marcados como sistema e oculto) no Explorador do Windows.

      Estes ficheiros são necessários para iniciar e executar o Windows. Eliminar ou editá-los pode tornar o computador deixe de funcionar. Tem a certeza de que pretende visualizar estes ficheiros?
    6. Clique em OK para fechar a caixa de diálogo Opções de pastas .
  5. Efectue as alterações que pretende para o ficheiro Boot.ini e, em seguida, no menu ficheiro , clique em Guardar .
  6. No menu ficheiro , clique em Sair para fechar o ficheiro Boot.ini e saia do bloco de notas.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo.

Mais Informação

Os produtos de outros fabricantes explicado neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente ao desempenho ou fiabilidade destes produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kberrmsg kbbug kbfix kbqfe kbwinserv2003presp1fix KB827180 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 827180  (http://support.microsoft.com/kb/827180/en-us/ )