ID do artigo: 827180 - Última revisão: terça-feira, 24 de julho de 2007 - Revisão: 6.10

Mensagem de erro "Arquivo C:\Boot.ini não pode ser aberto" ao tentar fazer alterações para o arquivo Boot.ini usando a ferramenta de sistema

Download do hotfix está disponívelDownload do Hotfix Disponível
Visualizar e solicitar downloads de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Quando você abrir a ferramenta sistema no painel de controle e, em seguida, clique na guia Avançado na caixa de diálogo Propriedades do sistema para alterar as opções de Inicialização do sistema em um computador com Windows Server 2003, você receberá a seguinte mensagem de erro:
Não é possível abrir o arquivo C:\Boot.ini. As configurações de Brazilian OS e tempo limite não podem ser alteradas.
Observação Para abrir a caixa de diálogo Propriedades do sistema , clique em Iniciar , aponte para Painel de controle , clique em desempenho e manutenção e, em seguida, clique em sistema .

Causa

Esse problema pode ocorrer se a partição onde o Windows Server 2003 está instalado é atribuída a qualquer letra diferente de "C." Esse problema pode ocorrer em um cenário de inicialização dupla ou quando as letras de unidade tem sido reatribuídas por um programa de terceiros como Citrix DriveRemap.exe.

O Windows armazena as opções de Inicialização do sistema no arquivo Boot.ini oculto que é localizado na raiz da partição do sistema. Nesse cenário, o Windows incorretamente enumera as letras de unidade no sistema e usa o caminho padrão do C:\Boot.ini. Como "C" é normalmente usado para a partição do sistema, esse problema não ocorre na maioria dos sistemas, onde isso é um caminho válido.

Resolução

Informações sobre hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês dessa correção apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.

x 86

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Aug-2003  20:14  5.2.3790.78       274,432  Sysdm.cpl
   12-Aug-2003  16:54                        271  Branches.inf
   20-Aug-2003  21:05                     10,091  Kb827180.cat
   20-Aug-2003  20:17                        354  Updatebr.inf
   20-Aug-2003  20:17                      5,095  Update_rtmqfe.inf

IA64

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Aug-2003  20:14  5.2.3790.78       475,136  Sysdm.cpl
   20-Aug-2003  20:14  5.2.3790.78       274,432  Wsysdm.cpl
   12-Aug-2003  16:54                        271  Branches.inf
   20-Aug-2003  21:04                     10,444  Kb827180.cat
   20-Aug-2003  20:19                        354  Updatebr.inf
   20-Aug-2003  20:19                      5,355  Update_rtmqfe.inf

Como Contornar

Para solucionar esse problema, edite manualmente o arquivo Boot.ini no bloco de notas. Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar , aponte para Todos os programas , aponte para Acessórios e clique em Bloco de notas .
  2. No menu arquivo , clique em Abrir .
  3. Na caixa de diálogo Abrir , altere a seleção na caixa arquivos do tipo para Todos os arquivos e, em seguida, altere a seleção na caixa Examinar para a raiz da sua unidade de inicialização (inicialização).
  4. Na pasta raiz da sua unidade de inicialização, abra o arquivo Boot.ini.

    Observação O arquivo Boot.ini é um arquivo de sistema ocultos. Para localizar o arquivo Boot.ini, altere as opções de pasta no Windows. Para fazer isso, execute as seguintes etapas:
    1. Clique com o botão direito do mouse em Iniciar e clique em explorar .
    2. No menu Ferramentas no Windows Explorer, clique em Opções de pasta .
    3. Na guia Exibir , clique duas vezes em pastas e arquivos ocultos e clique em Mostrar pastas e arquivos ocultos .
    4. Clique para desmarcar a caixa de seleção Ocultar arquivos protegidos do sistema operacional (recomendado) .
    5. Clique em Sim para a seguinte mensagem:
      Você optou por exibir protegidos do sistema operacional arquivos (arquivos rotulado como sistema e ocultos) no Windows Explorer.

      Esses arquivos são necessários para iniciar e executar o Windows. Excluir ou editá-los pode tornar o computador inoperante. Tem certeza de que deseja exibir esses arquivos?
    6. Clique em OK para fechar a caixa de diálogo Opções de pasta .
  5. Faça as alterações que você deseja o arquivo Boot.ini e, em seguida, no menu arquivo , clique em Salvar .
  6. No menu arquivo , clique em Sair para fechar o arquivo Boot.ini e feche o Notepad.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.

Mais Informações

Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kberrmsg kbbug kbfix kbqfe kbwinserv2003presp1fix KB827180 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 827180  (http://support.microsoft.com/kb/827180/en-us/ )