Po spuštění nástroje Sysprep s přepínačem příkazového řádku -nosidgen chybí nastavení služby IIS (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 827385 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Po instalaci Internetová informační služba (IIS) a spuštění nástroje Sysprep s -nosidgen výslednou bitovou kopii chybí přepínač příkazového řádku, nastavení služby IIS a součásti IIS. Například při otevření modulu snap-in Internetová informační služba výchozí web a položky Výchozí server FTP, které byly dříve nakonfigurován v počítači chybí.

Příčina

K tomuto problému dochází, protože při spuštění programu Sysprep s nesprávně odstraněn informace je nezbytná pro systému přístup k metabázi služby IIS -nosidgen přepnout. Systém Windows v důsledku toho nemůže získat přístup informace o konfiguraci služby IIS.

Řešení

Informace o aktualizaci Service Pack

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Microsoft Windows XP. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389získání nejnovější aktualizace Service Pack pro systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.

Tato oprava hotfix obsahuje dva balíčky.
  • V následující tabulce jsou uvedeny informace soubor balíčku (PKG50050) nainstaluje opravu hotfix v systému Windows XP Service Pack 1 (SP1) - založené počítače:
    Date         Time   Version            Size    File name    Platform
    --------------------------------------------------------------------
    19-Aug-2003  19:53  6.0.2600.1260     468,480  Iis.dll      x86
    19-Aug-2003  19:53  6.0.2600.1260   1,281,024  Iis.dll      IA-64
  • Následující tabulka uvádí informace soubor balíčku (PKG50263), který extrahuje nástroj Sysprep.exe:
    Date         Time   Version            Size    File name    Platform
    --------------------------------------------------------------------
    15-Aug-2003  01:54  5.1.2600.1260     114,176  Sysprep.exe  x86
    15-Aug-2003  01:54  5.1.2600.1260     277,504  Sysprep.exe  IA-64
Poznámka: Vzhledem k závislostem souborů vyžaduje tato aktualizace Windows XP Service Pack 1 (SP1)..

Jak potíže obejít

Chcete-li tento problém vyřešit, ručně nainstalovat IIS součásti, které chcete po operací Sysprep dokončení spuštění. Postup:
  1. Klepněte na tlačítko Start a potom klepněte na příkaz Ovládací panely.
  2. Klepněte na tlačítko Přidat nebo odebrat programy a potom klepněte na tlačítko Přidat nebo odebrat.
  3. V seznamu součásti klepněte Internetová informační služba (IIS) (ale nezaškrtávejte políčko) a potom klepněte na tlačítko Podrobnosti.
  4. V rozevíracím Okně Internet Information Services (IIS) klepnutím zaškrtněte políčka vedle IIS součásti, které chcete nainstalovat a klepněte na tlačítko OK.
  5. Klepněte na tlačítko Další a potom klepněte na tlačítko Dokončit.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku. Tento problém byl poprvé opraven aktualizací Microsoft Windows XP Service Pack 2.

Další informace

Další informace o nástroji Sysprep naleznete v tématu Microsoft Windows Corporate Deployment Tools User's Guide (soubor Deploy.chm). Soubor Deploy.chm je umístěn v souboru Deploy.cab ve složce Support\Tools na disku CD-ROM systému Windows XP.

Vlastnosti

ID článku: 827385 - Poslední aktualizace: 29. srpna 2007 - Revize: 4.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB827385 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:827385

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com