Le impostazioni di IIS sono mancante dopo l'esecuzione di Sysprep con l'opzione-nosidgen della riga di comando

Traduzione articoli Traduzione articoli
Identificativo articolo: 827385 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Una volta installato Microsoft Internet Information Services (IIS) e quindi eseguire lo strumento Sysprep con il -nosidgen opzione della riga di comando, le impostazioni di IIS e componenti IIS mancano l'immagine di Sysprep risultante. Ad esempio, quando si apre lo snap-in Internet Information Services, il sito Web predefinito e le voci del Sito FTP predefinito in precedenza sono state configurate nel computer risultano mancante.

Cause

Questo problema si verifica poiché le informazioni necessarie per accedere alla metabase IIS di Windows in modo non corretto viene eliminate quando si esegue Sysprep con il -nosidgen passare. Di conseguenza, le informazioni di configurazione di IIS di Impossibile accedere.

Risoluzione

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack più recente per Microsoft Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389Come ottenere il service pack più recente per Windows XP

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si è notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, è necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Informazioni sui file

La versione inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.

Questo aggiornamento rapido contiene due pacchetti.
  • Nella tabella seguente sono elencate l'informazioni file per il pacchetto (PKG50050) che installa l'aggiornamento rapido in Windows XP Service Pack 1 (SP1) - basata su computer:
    Date         Time   Version            Size    File name    Platform
    --------------------------------------------------------------------
    19-Aug-2003  19:53  6.0.2600.1260     468,480  Iis.dll      x86
    19-Aug-2003  19:53  6.0.2600.1260   1,281,024  Iis.dll      IA-64
  • Nella tabella riportata di seguito elenca le informazioni di file per il pacchetto (PKG50263) che consente di estrarre l'utilità Sysprep.exe:
    Date         Time   Version            Size    File name    Platform
    --------------------------------------------------------------------
    15-Aug-2003  01:54  5.1.2600.1260     114,176  Sysprep.exe  x86
    15-Aug-2003  01:54  5.1.2600.1260     277,504  Sysprep.exe  IA-64
Nota A causa delle dipendenze fra i file, questo aggiornamento richiede Windows XP Service Pack 1 (SP1)..

Workaround

Per aggirare il problema, installare manualmente IIS i componenti che si desidera che dopo le operazioni di Sysprep termine dell'esecuzione. Per effettuare questa operazione:
  1. Fare clic su Start e quindi fare clic su Pannello di controllo .
  2. Fare clic su Installazione applicazioni e quindi fare clic su Installazione componenti di Windows .
  3. Nella casella componenti , fare clic su Internet Information Services (IIS) , ma non fare clic per selezionare la casella di controllo, quindi fare clic su Dettagli .
  4. Nella casella Sottocomponenti di Internet Information Services (IIS) fare clic per selezionare le caselle di controllo accanto a IIS i componenti che si desidera installare e quindi fare clic su OK .
  5. Fare clic su Avanti e quindi fare clic su Fine .

Status

Microsoft ha confermato che questo problema riguarda i prodotti Microsoft elencati all'inizio di questo articolo. Questo problema è stato innanzitutto corretto in Microsoft Windows XP Service Pack 2.

Informazioni

Per ulteriori informazioni lo strumento Sysprep, vedere il Manuale dell'utente strumenti per la distribuzione aziendale di Microsoft Windows (file Deploy.chm). Il file di Deploy.chm si trova nel file Deploy.cab nella cartella Support\Tools del CD di Windows XP.

Proprietà

Identificativo articolo: 827385 - Ultima modifica: mercoledì 29 agosto 2007 - Revisione: 4.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Chiavi: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB827385 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 827385
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com