Transaktionsnachrichten können gelöscht werden, nach dem Neustart Wenn LQS-Dateien fehlen

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 827493 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Nach dem Neustart des Computers möglicherweise Transaktionsnachrichten in Microsoft Message Queuing für eine der folgenden Gründe gelöscht werden:
  • LQS (lokale Queue Storage) Dateien fehlen.
  • Die LQS-Dateien sind nicht verfügbar.
  • LQS-Dateien sind beschädigt.

Ursache

Message Queuing verwaltet einen Cache von Parametern für lokale öffentliche Warteschlangen. Der Cache der Parameter für lokale öffentliche Warteschlangen heißt LQS. Wenn Sie Ihren Computer Paket Dateien wiederherstellen neu starten, verwendet Message Queuing dieser Cache um interne Warteschlangenobjekte zu erstellen. Wenn eine LQS-Datei für eine lokale öffentliche Warteschlange nicht gefunden wird, werden Nachrichten "ausgehende" berücksichtigt Wenn Message Queuing eine mit Active Directory-Verzeichnisdienst Verbindung und anschließend feststellt, dass die Warteschlange eine lokale öffentliche Warteschlange, Message Queuing das Warteschlangenobjekt ungültig markiert und anschließend löscht alle Nachrichten aus der Warteschlange.

Lösung

Hotfix-Informationen

Ein Hotfix zur Behebung dieses Problems ist inzwischen bei Microsoft erhältlich; dieser Hotfix wurde jedoch ausschließlich zur Behebung des in diesem Artikel beschriebenen Problems entwickelt. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Sie durch dieses Problem nicht schwerwiegend betroffen sind, empfiehlt Microsoft daher, für die nächste Microsoft Windows 2000 Service Pack warten, das diesen Hotfix enthält wird.

Wenn Sie das Problem sofort beheben möchten, wenden Sie sich an Microsoft Product Support Services, um den Hotfix zu erhalten. Eine vollständige Liste mit Telefonnummern der Microsoft-Produktsupport und Informationen Supportkosten der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: PLEASE DO NOT TRANSLATE and DELETE THIS PASSAGE. IT DOES NOT APPLY TO GERMANY.

Voraussetzungen

Es gelten keine Voraussetzungen.

Neustartanforderung

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten.

Dateiinformationen

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Aug-2003  17:20  5.0.0.778         281,360  Mq1repl.dll      
   17-Jun-2003  14:33  5.0.0.778          14,096  Mq1sync.exe      
   28-Aug-2003  15:00  5.0.0.783          76,144  Mqac.sys
   28-Aug-2003  17:20  5.0.0.783         217,360  Mqads.dll        
   30-Oct-2002  13:43  5.0.0.761          25,360  Mqbkup.exe       
   28-Aug-2003  17:20  5.0.0.778          76,560  Mqdscli.dll      
   28-Aug-2003  17:20  5.0.0.773          42,256  Mqdssrv.dll      
   21-Oct-2002  17:31  5.0.0.759          98,064  Mqmig.exe        
   28-Aug-2003  17:20  5.0.0.759         265,488  Mqmigrat.dll     
   28-Aug-2003  17:20  5.0.0.740         222,480  Mqoa.dll         
   28-Aug-2003  17:20  5.0.0.783           9,488  Mqperf.dll       
   28-Aug-2003  17:20  5.0.0.783         431,888  Mqqm.dll         
   28-Aug-2003  17:20  5.0.0.778         102,672  Mqrt.dll         
   28-Aug-2003  17:20  5.0.0.776          70,928  Mqsec.dll        
   28-Aug-2003  17:20  5.0.0.783         400,656  Mqsnap.dll       
   28-Aug-2003  17:20  5.0.0.762          23,824  Mqupgrd.dll      
   28-Aug-2003  17:20  5.0.0.782         110,864  Mqutil.dll       
   28-Aug-2003  17:20  5.0.0.748          64,784  Msmq.cpl

Weitere Informationen

In diesem Hotfix werden die folgenden Probleme behoben:
  • Ein Problem kann auftreten, wenn im LQS-Cache zu erstellen. Wenn temporäre Probleme, die auftreten, wenn Abfragen an Active Directory, können Message Queuing gültige LQS-Dateien löschen. Message Queuing ist nicht gültigen LQS-Dateien neu erstellen, erst nach des Computers Neustart. Dieser Hotfix stellt sicher, dass alle Fehler ordnungsgemäß behandelt wird. Der Hotfix wird auch sichergestellt, dass die LQS-Dateien nicht gelöscht werden.
  • Wenn Message Queuing gestartet und stellt dann Paket Dateien wieder her, verwendet Message Queuing im LQS-Cache. Message Queuing Active Directory-Dienst nicht Abfragen. Wenn eine LQS-Datei fehlt oder kann nicht zugegriffen werden, werden die Pakete und die Warteschlange "Ausgehend" berücksichtigt Später, wenn Message Queuing eine mit Active Directory-Verzeichnisdienst Verbindung und dann die Warteschlangen überprüft, trifft Message Queuing eine Inkonsistenz. Die Inkonsistenz rührt die Warteschlange ist "ausgehende" gekennzeichnet, aber der Active Directory-Verzeichnisdienst bezeichnet die Warteschlange als "local". Daher wird die Warteschlange geleert wurde. Dies wurde mit Flags für jedes Paket behoben. Die Flags markieren Sie das Paket als "lokal" oder "in der Zielwarteschlange." Wiederherstellung markiert auf Wenn die Pakete "local", aber das Wartenschlangenobjekt, das erstellt wird, "" wegen einer fehlenden Datei LQS ausgehend ist Message Queuing das Warteschlangenobjekt als "nicht konsistent." Message Queuing dann geht einen "nicht mehr reagiert" Modus. Message Queuing-Sitzungen nicht akzeptiert, und die remote Procedure Call (RPC)-Schnittstellen wurden nicht gestartet. Der Message Queuing-Dienst wartet auf online gehen und re-build im LQS-Cache.

    Die folgenden beiden Situationen auftreten:
    • Inkonsistente Warteschlange kann durch eine öffentliche Warteschlange verursacht werden, die gelöscht wurde. Nachrichten können weiterhin in der Warteschlange sein, wenn keine Benachrichtigung empfangen wird. In diesem Fall die Warteschlange geleert, und Message Queuing setzt normalen Betrieb fort.
    • Die Warteschlange ist tatsächlich in einem inkonsistenten Zustand. Message Queuing beendet und Sie müssen Message Queuing neu starten. Nachrichten sind jedoch nicht verloren gehen. Der Message Queuing-Dienst muss wegen der Komplexität und das Risiko, die beteiligt sind, wird eine "ausgehende" Warteschlange in "local" Warteschlange konvertiert beenden.

      Bei ein Inkonsistenter Zustand nach der Installation dieses Hotfixes möglicherweise das folgende Ereignis im Ereignisprotokoll während der Wiederherstellung protokolliert:

      Ereignistyp: Fehler
      Ereignisquelle: MSMQ
      Ereigniskategorie: Kernel
      Ereignis-ID: 2083
      Datum: 5/18/2004
      Zeit: 4: 02: 09 Uhr
      Benutzer: NV
      Computer: Server

      Beschreibung: Kann nicht die Dauerhaftigkeit Paket Datei und die Protokolldatei wiederhergestellt. (Fehler: Inkonsistente Warteschlangenstatus. Finden Sie im Microsoft Knowledge Base-Artikel 827493 unter support.microsoft.com. Weitere Informationen finden Sie im Hilfe- und Supportcenter unter http://support.microsoft.com.
Ein neuen Registrierungsparameter ist vorhanden, die Sie, um das alte Verhalten wiederherzustellen, wenn Sie nicht die Nachrichten in das Ereignisprotokoll interessiert sind verwenden können. Sie können dieses neue Registrierungsparameter verwenden, wenn Sie nicht möchten, Message Queuing um eine "nicht mehr reagiert" Modus, bis der Message Queuing einen Domänencontroller findet. Erstellen Sie
hklm\software\microsoft\msmq\parameters\PurgeInconsistentQueues
als DWORD-Wert und setzen Sie den DWORD-Wert auf 1, um das alte Verhalten wiederherzustellen.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Informationsquellen

Weitere Informationen zu Hotfix-Paketen und deren Bezeichnungen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
816915Neues Schema für die Dateibenennung in Microsoft Windows-Softwareaktualisierungspaketen

Eigenschaften

Artikel-ID: 827493 - Geändert am: Mittwoch, 20. September 2006 - Version: 3.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Message Queuing 2.0
Keywords: 
kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB827493 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 827493
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com