Mensajes transaccionales se pueden purgar después de reiniciar el equipo si faltan los archivos LQS

Seleccione idioma Seleccione idioma
Id. de artículo: 827493 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de reiniciar el equipo, se pueden purgar mensajes transaccionales en Message Queue Server de cualquiera de las razones siguientes:
  • Faltan los archivos de almacenamiento local de colas (LQS).
  • Los archivos LQS son inaccesibles.
  • Los archivos LQS están dañados.

Causa

Message Queue Server mantiene una memoria caché de parámetros para colas públicas locales. La caché de los parámetros para colas públicas locales se denomina LQS. Cuando reinicie el equipo para recuperar archivos de paquete, Message Queue Server utiliza esta memoria caché para crear objetos de cola interna. Si no se encuentra un archivo LQS para una cola pública local, los mensajes se consideran "salida". Cuando Message Queue Server se conecta con el servicio de directorio de Active Directory y, a continuación, encuentra que la cola es una cola pública local, Message Queue Server marca el objeto de cola no es válido y, a continuación, se purga todos los mensajes de la cola.

Solución

Información de revisiones

Ahora hay disponible un hotfix para el que Microsoft proporciona soporte técnico, pero que sólo se diseñó para corregir el problema descrito en este artículo. Aplíquelo sólo a sistemas que experimenten este problema específico. Este hotfix puede ser sometido a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, se recomienda que espere al próximo Service Pack de Microsoft Windows 2000 que contenga este hotfix.

Para resolver este problema inmediatamente, póngase en contacto con soporte técnico de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de los servicios de soporte técnico de Microsoft e información acerca de los costos de soporte, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Aug-2003  17:20  5.0.0.778         281,360  Mq1repl.dll      
   17-Jun-2003  14:33  5.0.0.778          14,096  Mq1sync.exe      
   28-Aug-2003  15:00  5.0.0.783          76,144  Mqac.sys
   28-Aug-2003  17:20  5.0.0.783         217,360  Mqads.dll        
   30-Oct-2002  13:43  5.0.0.761          25,360  Mqbkup.exe       
   28-Aug-2003  17:20  5.0.0.778          76,560  Mqdscli.dll      
   28-Aug-2003  17:20  5.0.0.773          42,256  Mqdssrv.dll      
   21-Oct-2002  17:31  5.0.0.759          98,064  Mqmig.exe        
   28-Aug-2003  17:20  5.0.0.759         265,488  Mqmigrat.dll     
   28-Aug-2003  17:20  5.0.0.740         222,480  Mqoa.dll         
   28-Aug-2003  17:20  5.0.0.783           9,488  Mqperf.dll       
   28-Aug-2003  17:20  5.0.0.783         431,888  Mqqm.dll         
   28-Aug-2003  17:20  5.0.0.778         102,672  Mqrt.dll         
   28-Aug-2003  17:20  5.0.0.776          70,928  Mqsec.dll        
   28-Aug-2003  17:20  5.0.0.783         400,656  Mqsnap.dll       
   28-Aug-2003  17:20  5.0.0.762          23,824  Mqupgrd.dll      
   28-Aug-2003  17:20  5.0.0.782         110,864  Mqutil.dll       
   28-Aug-2003  17:20  5.0.0.748          64,784  Msmq.cpl

Más información

En este hotfix se tratan los problemas siguientes:
  • Puede producirse un problema al generar la caché LQS. Si hay problemas temporales que producirse al consultar Active Directory, Message Queue Server puede eliminar archivos LQS válidos. Message Queue Server no volver a crear los archivos LQS válidos hasta que reinicie el equipo. Esta revisión garantiza que cualquier error se controla correctamente. Además, la revisión garantiza que no se eliminan los archivos LQS.
  • Cuando Message Queue Server se inicia y, a continuación, recupera los archivos de paquete, Message Queue Server utiliza la caché LQS. Message Queue Server no consulta el servicio de directorio de Active Directory. Si un archivo LQS falta o es inaccesible, los paquetes y la cola se consideran "salida". Posteriormente, cuando Message Queue Server se conecta con el servicio de directorio de Active Directory y, a continuación, valida las colas, Message Queue Server encuentra una incoherencia. La incoherencia se produce porque la cola está marcada "salida", pero el servicio de directorio de Active Directory identifica la cola como "local". Por lo tanto, se purga la cola. Se ha corregido utilizando indicadores para cada paquete. Los indicadores de marcan el paquete como "local" o "en la cola de destino." En la recuperación, si los paquetes son "locales", pero el objeto de cola que se crea es "saliente" porque de un archivo que falta de LQS, MSMQ marca el objeto de cola como "no coherente". Message Queue Server, después, entra en modo "no responde". Message Queue Server no aceptará sesiones, y no se han iniciado las interfaces de procedimiento remoto (RPC) de la llamada. El servicio de Message Queue Server espera para conectarse y, después, vuelva a generar la caché LQS.

    Pueden producirse las dos situaciones siguientes:
    • La cola incoherente puede deberse a una cola pública que se ha eliminado. Los mensajes pueden ser en la cola si no se recibe la notificación. En este caso, se purga la cola y Message Queue Server se reanuda el funcionamiento normal.
    • La cola está realmente en un estado incoherente. Message Queue Server se cierra y tiene que reiniciar MSMQ. Sin embargo, los mensajes no se pierden. El servicio de Message Queue Server tiene que salir debido a de la complejidad y el riesgo que participan cuando una cola de "salida" se convierte en una cola "local".

      Cuando se encuentra un estado incoherente después de aplicar este hotfix, el suceso siguiente puede grabarse en el registro de sucesos durante la recuperación:

      Tipo de suceso: error
      Origen del suceso: MSMQ
      Categoría del suceso: núcleo
      ID. de suceso: 2083
      Fecha: 5/18/2004
      Hora: 4: 02: 09 P.M.
      Usuario: N/d
      Equipo: Server

      Descripción: No se puede recuperar el archivo de paquete de persistencia y el archivo de registro. (Error: estado incoherente de la cola. Consulte el artículo 827493 de la Microsoft Knowledge Base en support.microsoft.com. Para obtener más información, consulte Ayuda y soporte técnico en http://support.microsoft.com.
Un nuevo parámetro del registro existe que puede utilizar para volver al comportamiento anterior si no está interesado en los mensajes en el registro de sucesos. Puede utilizar este parámetro de registro nuevo cuando no desea que Message Queue Server para estar en un modo "no responde" hasta que Message Queue Server busca un controlador de dominio. Crear
hklm\software\microsoft\msmq\parameters\PurgeInconsistentQueues
como un valor DWORD y establezca el valor DWORD a 1 para volver al comportamiento anterior.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Referencias

Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows

Propiedades

Id. de artículo: 827493 - Última revisión: miércoles, 20 de septiembre de 2006 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Message Queue Server 2.0
Palabras clave: 
kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB827493 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 827493

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com