Las operaciones de escritura en un dispositivo de almacenamiento externo tardan mucho tiempo en completarse

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Síntomas

Al escribir datos en un dispositivo de almacenamiento externo, como un lector de tarjeta flash USB o una unidad magneto óptico (MO), puede tardar mucho para todos los datos que se escriban en el dispositivo. Si examina una traza de bus del dispositivo, observará que hay muchas operaciones de escritura duplicado (donde se escriben los mismos datos al mismo destino).

Causa

Este problema se produce porque las páginas de datos que están marcados para escribirse en el dispositivo de almacenamiento pueden escribirse por el escritor de página modificada o el escritor de página asignada (estos componentes forman parte del Administrador de memoria) y el componente de escritura diferida (este componente es parte del Administrador de caché). Estas operaciones de escritura de dos no sincronizan correctamente sus listas de páginas que deben están en el dispositivo. Por lo tanto, puede producirse una operación de escritura duplicados. Esta operación de escritura duplicado produce una degradación del rendimiento porque la misma información se escribe dos veces en el mismo dispositivo de almacenamiento.

Solución

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Microsoft Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe tener instalado antes de instalar esta revisión Windows XP Service Pack 1 (SP1).

Para obtener información adicional acerca de cómo obtener el Service Pack 1 para Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo para obtener el más reciente de Windows XP service pack

Requisito de reinicio

Debe reiniciar el equipo para aplicar los cambios después de instalar este hotfix. Sin embargo, no es necesario reiniciar el equipo inmediatamente después de instalar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

Microsoft Windows XP SP1 32 bits

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Apr-2004  22:21  5.1.2600.1518   1,912,320  Ntkrnlmp.exe     
   22-Apr-2004  22:21  5.1.2600.1518   1,968,128  Ntkrnlpa.exe     
   22-Apr-2004  22:21  5.1.2600.1518   1,940,480  Ntkrpamp.exe     
   22-Apr-2004  23:01  5.1.2600.1518   2,063,872  Ntoskrnl.exe     

Microsoft Windows XP 64-Bit Edition versión 2002 SP1

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Apr-2004  22:25  5.1.2600.1518   5,830,144  Ntkrnlmp.exe     IA-64
   22-Apr-2004  22:25  5.1.2600.1518   5,773,568  Ntoskrnl.exe     IA-64
Advertencia Para descargar la revisión correcta, seleccione el paquete tiene un valor CreateDate de 27/4/2004 , no el paquete tiene un valor de CreateDate de 10, 20/2003 . Los archivos de descarga correcta tendrán los atributos de archivo que este artículo se enumeran anteriormente.

Utilice la versión del archivo Ntorkrnl.exe para determinar la versión de revisión que está instalada en su equipo. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Buscar y, a continuación, haga clic en todos los archivos y carpetas .
  2. En el cuadro todo o parte del nombre de archivo , escriba ntoskrnl.exe y, a continuación, haga clic en Buscar .
  3. Después de mostrar los resultados de búsqueda, haga clic con el botón secundario en el archivo Ntoskrnl.exe en la carpeta Windows\System32 y, a continuación, haga clic en Propiedades para ver la modificado fecha.

Solución

Para evitar este problema, desactive la caché de escritura para el dispositivo de almacenamiento. Para un USB o un dispositivo de almacenamiento extraíble, configure la directiva almacenamiento en caché para utilizar la opción Optimizar para extracción rápida en el Administrador de dispositivos. Para ello, siga estos pasos:
  1. Haga clic en Inicio , haga clic con el botón secundario en Mi PC y, a continuación, haga clic en Propiedades .
  2. Haga clic en la ficha hardware y, a continuación, haga clic en Administrador de dispositivos .
  3. Expanda unidades de disco , haga clic con el botón secundario en el dispositivo de almacenamiento y, a continuación, haga clic en Propiedades .
  4. Haga clic en la ficha directivas , haga clic en Optimizar para extracción rápida y a continuación, haga clic en Aceptar .

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en el Service Pack 2 de Microsoft Windows XP.

Más información

Este problema sólo afecta a Windows XP con SP1 instalado o integrado. No afecta a Windows XP sin SP1 instalado, Microsoft Windows 2000 o Microsoft Windows Server 2003.

Propiedades

Id. de artículo: 828012 - Última revisión: miércoles, 26 de febrero de 2014 - Versión: 6.2
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbhardware kbwinxppresp2fix kbfix kbbug KB828012 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 828012

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