外部ストレージ ・ デバイスへの処理を完了するのには時間がかかるを作成します。

文書翻訳 文書翻訳
文書番号: 828012
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

目次

現象

記述するときデータを外部記憶域デバイスに次のようにUSB のフラッシュ カード リーダまたは光磁気 (MO) ドライブは、非常に長いにかかる場合があります。すべてのデータをデバイスに書き込むの時間。バス トレースを調べるとそのデバイスの多くの重複する書き込み操作が発生します。(場所、同じデータが同じ場所に書き込まれます)。

原因

この問題が発生するためにマークされているデータのページ書き込みとストレージ デバイス、modified page writer によって書き込むことができますか(これらのコンポーネントは、メモリ マネージャーの一部です)、マップされたページ ライターされレイジー ライター コンポーネント (このコンポーネントは、キャッシュ マネージャーの一部です)。これらそのリストにあるページの 2 つの書き込み操作が正しく同期しません。デバイスに書き込む。このため、重複する書き込み操作発生します。この重複するので書き込み操作原因はパフォーマンスの低下と同じ情報は、2 回、同じ記憶装置に書き込まれます。

解決方法

サービス パックの情報

この問題を解決するには、Microsoft Windows XP 用の最新の service pack を入手します。詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
322389 Windows XP の最新の service pack を入手する方法

修正プログラムの情報

サポートされている修正プログラムがマイクロソフトから入手可能です。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストを受け取ることがあります。したがって、この問題で深刻な影響をされていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

この修正プログラムがダウンロードできないか場合は、この記事の上部に「修正プログラムのダウンロード」セクションです。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポート修正プログラムを入手するに問い合わせてください。

メモ その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームに修正プログラムが提供されている言語を表示します。お使いの言語が表示されない場合は、修正プログラムがその言語の利用できないためにです。

前提条件

Windows XP Service Pack がインストールする前に 1 (SP1) が必要この修正プログラムをインストールします。

追加Windows XP では、Service Pack 1 の入手方法の詳細についてをクリックして、次の Knowledge Base の資料を参照するには。
322389最新の Windows を入手する方法XP のサービス パック

再起動の必要性

した後、変更を適用するのには、コンピューターを再起動する必要があります。この修正プログラムをインストールします。ただしは、コンピューターを再起動する必要はありません。すぐにこの修正プログラムをインストールした後。

修正プログラムの置き換えに関する情報

この修正プログラムは、他の修正プログラムに置き換えられない。

ファイル情報

この修正プログラムの英語版にファイルがあります。属性 (またはそれ以降) 次の表に記載されています。日付と時刻これらのファイルを世界協定時刻 (UTC) に一覧表示されます。場合、ファイル情報を表示するには、ローカル時刻に変換されます。検索するのにはUTC および現地時間、使用の違いを タイム ゾーン タブ[日付と時刻] ツール コントロール パネルのします。

Microsoft Windows XP SP1 の 32 ビット

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Apr-2004  22:21  5.1.2600.1518   1,912,320  Ntkrnlmp.exe     
   22-Apr-2004  22:21  5.1.2600.1518   1,968,128  Ntkrnlpa.exe     
   22-Apr-2004  22:21  5.1.2600.1518   1,940,480  Ntkrpamp.exe     
   22-Apr-2004  23:01  5.1.2600.1518   2,063,872  Ntoskrnl.exe     

Microsoft Windows XP 64-bit Edition Version 2002 SP1

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Apr-2004  22:25  5.1.2600.1518   5,830,144  Ntkrnlmp.exe     IA-64
   22-Apr-2004  22:25  5.1.2600.1518   5,773,568  Ntoskrnl.exe     IA-64
警告 適切な修正プログラムをダウンロードするには、あるパッケージを選択します。 CreateDate2004 年 4 月 27 日を持つパッケージでない、 CreateDate2003/10/20.ダウンロード ファイルがあります、ファイルの属性この資料で以前のバージョンの一覧です。

Ntorkrnl.exe ファイルを使用します。コンピューターにインストールされている修正プログラムのバージョンを確認するのには.するにはこれを行うは、次の手順を実行します。
  1. クリックしてください。 開始をクリックして 検索,し すべてのファイルとフォルダー.
  2. では、 ファイル名のすべてまたは一部 ボックスの種類ntoskrnl.exe,し 検索.
  3. 検索結果が表示されたら、右クリックし、Ntoskrnl.exe を windows \system32 フォルダー内のファイルし、プロパティ 表示するのには 変更日付。

回避策

この問題を回避するには、書き込みキャッシュを無効にする、ストレージ ・ デバイス。USB またはリムーバブル記憶域デバイスにはのキャッシュを構成します。ポリシーを使用するのには、 クイック削除のための最適化します。 デバイス オプションマネージャーです。これを行うには、次の手順を実行します。
  1. クリックしてください。 開始を右クリックして 私コンピューター、し プロパティ.
  2. クリックして、 ハードウェア タブをクリックしデバイス マネージャー.
  3. 展開 ディスク ・ ドライブを右クリックし、ストレージ ・ デバイス、およびクリック プロパティ.
  4. クリックして、 ポリシー タブで、クリックしてくださいクイック削除のための最適化します。、し[OK].

状況

マイクロソフトでは、この「対象」に記載されているマイクロソフト製品の問題として認識しています。 この問題は Microsoft Windows XP Service Pack 2 で修正されました。

詳細

この問題は Windows XP sp1 がインストールされているに影響を与えますか統合されました。インストールされている場合は、SP1 に Microsoft Windows XP に影響しませんWindows 2000、または Microsoft Windows Server 2003 を使用します。

プロパティ

文書番号: 828012 - 最終更新日: 2014年2月26日 - リビジョン: 2.0
キーワード:?
kbnosurvey kbarchive kbbug kbfix kbqfe kbhardware kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver kbautohotfix kbmt KB828012 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:828012
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com