写入外部存储设备的操作花费很长时间才完成

文章翻译 文章翻译
文章编号: 828012 - 查看本文应用于的产品
本文已归档。它按“原样”提供,并且不再更新。
展开全部 | 关闭全部

本文内容

症状

在将数据写入外部存储设备(如 USB 闪存卡读取器或光盘 (MO) 驱动器)时,可能要花很长时间才能将所有数据写入该设备。如果检查该设备的总线跟踪,就会发现存在很多重复的写入操作(向同一目标写入相同数据)。

原因

发生此问题的原因在于:标记为写入存储设备的数据页可能由修改的页编写器或映射的页编写器(这些组件包含在内存管理器中)编写,且被写入惰性编写器组件(该组件包含在缓存管理器中)中。这两次写入操作未正确同步要写入设备的页列表。因此,可能会出现重复的写入操作。由于相同的信息被两次写入同一存储设备,因此这种重复写入操作会导致性能降低。

解决方案

Service Pack 信息

要解决此问题,请获取最新的 Microsoft Windows XP Service Pack。有关其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
322389 如何获取最新的 Windows XP Service Pack

修补程序信息

Microsoft 目前提供了一个受支持的修补程序。但是,此修补程序仅用于修复本文所述的问题。请仅将此修补程序应用于出现这一特定问题的系统。此修补程序可能还会接受进一步的测试。因此,如果这个问题没有给您造成严重的影响,我们建议您等待包含此修补程序的下一个 Service Pack。

要解决此问题,请向 Microsoft 在线客户服务提交请求以获取该修补程序。要提交联机请求以获取该修补程序,请访问下面的 Microsoft 网站:
http://go.microsoft.com/?linkid=6294451
注意:如果发生其他问题或需要进行任何疑难解答,则您可能需要创建单独的服务请求。对于此特定修补程序无法解决的其他支持问题和事项,将照常收取支持费用。要创建单独的服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support

先决条件

必须先安装 Windows XP Service Pack 1 (SP1),才能安装此修补程序。

有关如何获取 Windows XP Service Pack 1 的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
322389 如何获取最新的 Windows XP Service Pack

重新启动要求

安装此修补程序后,必须重新启动计算机才能应用更改。但在安装此修补程序后,不必立即重新启动计算机。

修补程序替代信息

此修补程序不替代任何其他修补程序。

文件信息

此修补程序的英文版具有下表中列出的文件属性(或更新的属性)。这些文件的日期和时间按协调世界时 (UTC) 列出。当您查看文件信息时,相应的时间将转换为本地时间。要了解 UTC 与本地时间之间的时差,请使用“控制面板”中“日期和时间”工具中的“时区”选项卡。

Microsoft Windows XP SP1 32-Bit

日期         时间   版本            大小       文件名
--------------------------------------------------------------
22-Apr-2004  22:21  5.1.2600.1518   1,912,320  Ntkrnlmp.exe     
22-Apr-2004  22:21  5.1.2600.1518   1,968,128  Ntkrnlpa.exe     
22-Apr-2004  22:21  5.1.2600.1518   1,940,480  Ntkrpamp.exe     
22-Apr-2004  23:01  5.1.2600.1518   2,063,872  Ntoskrnl.exe     

Microsoft Windows XP 64-Bit Edition 2002 版 SP1

日期         时间   版本            大小       文件名
--------------------------------------------------------------
22-Apr-2004  22:25  5.1.2600.1518   5,830,144  Ntkrnlmp.exe     IA-64
22-Apr-2004  22:25  5.1.2600.1518   5,773,568  Ntoskrnl.exe     IA-64
警告:要下载正确的修补程序,请选择“CreateDate”值为 4/27/2004 的程序包,而不是“CreateDate”值为 10/20/2003 的程序包。正确的下载文件将具有本文前面列出的文件属性。

使用 Ntorkrnl.exe 文件版本可确定计算机上所安装的修复程序版本。为此,请按照下列步骤操作:
  1. 单击“开始”,单击“搜索”,然后单击“所有文件和文件夹”。
  2. 在“全部或部分文件名”框中,键入 ntoskrnl.exe,然后单击“搜索”。
  3. 显示搜索结果后,右键单击 Windows\System32 文件夹中的 Ntoskrnl.exe 文件,然后单击“属性”以查看“修改”日期。

替代方法

要解决此问题,请关闭存储设备的写入缓存。对于 USB 或可移动存储设备,请将缓存策略配置为使用“设备管理器”中的“为快速删除而优化”选项。为此,请按照下列步骤操作:
  1. 单击“开始”,右键单击“我的电脑”,然后单击“属性”。
  2. 单击“硬件”选项卡,然后单击“设备管理器”。
  3. 展开“磁盘驱动器”,右键单击存储设备,然后单击“属性”。
  4. 单击“策略”选项卡,单击“为快速删除而优化”,然后单击“确定”。

状态

Microsoft 已经确认这是在“这篇文章的信息适用于:”部分中列出的 Microsoft 产品中存在的问题。 此问题最早在 Microsoft Windows XP Service Pack 2 中得到了解决。

更多信息

此问题只影响安装或集成了 SP1 的 Windows XP。不影响未安装 SP1 的 Windows XP 及 Microsoft Windows 2000 或 Microsoft Windows Server 2003。

属性

文章编号: 828012 - 最后修改: 2014年2月26日 - 修订: 6.1
这篇文章中的信息适用于:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1
关键字:?
kbnosurvey kbarchive kbbug kbfix kbqfe kbhardware kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB828012
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com