Mancata installazione dell'archivio di cassette postali di Exchange Server 2003 quando il database dell'archivio di cassette postali raggiunge il limite di 16 GB

Traduzione articoli Traduzione articoli
Identificativo articolo: 828070 - Visualizza i prodotti a cui si riferisce l?articolo.
Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Assicurarsi di eseguire il backup del Registro di sistema prima di modificarlo e di sapere come ripristinarlo qualora si verifichino dei problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Informazioni sul Registro di sistema di Windows per utenti esperti
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando il database dell'archivio di cassette postali in Microsoft Exchange Server 2003 Standard Edition raggiunge il limite di 16 GB, l'archivio di cassette postali non viene installato. ╚ inoltre possibile che nel registro eventi Applicazione vengano registrati i seguenti ID evento:

Tipo evento: Errore
Origine evento: MSExchangeIS
Categoria evento: Generale
ID evento: 1112
Descrizione: Il database "Archivio cassette postali (NomeServer)" ha raggiunto la dimensione massima consentita. Tentativo di disinstallazione del database in corso.

Tipo evento: Avviso
Origine evento: ESE
Categoria evento: Gestione dello spazio
ID evento: 445
Descrizione: Archivio informazioni (3160) Il modulo del database D:\Programmi\Exchsrvr\MDBDATA\priv1.edb ha raggiunto la dimensione massima consentita di 16383 MB. Se non Ŕ possibile riavviare il database, effettuare una deframmentazione non in linea per ridurre le dimensioni del database.

Nota Sebbene la descrizione dell'ID evento 445 indichi che il file Priv1.edb ha raggiunto la dimensione di 16.383 MB, ci˛ potrebbe non essere vero. L'ID evento 445 viene attivato se la dimensione combinata dei file Priv1.edb e Priv1.stm raggiunge 16.383 MB. Il file Priv1.edb in sÚ stesso pu˛ essere inferiore a 16.383 MB.

Per ulteriori informazioni sugli ID evento 1112 e 445 di MSExchangeIS, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://go.microsoft.com/?linkid=4190138
Per ulteriori informazioni sui miglioramenti apportati alla configurazione e alla gestione dei limiti di dimensione dei database quando si utilizza Microsoft Exchange Server 2003 Service Pack 2 (SP2), vedere l'argomento Database Size Limit Configuration and Management nella Technical Reference Guide for Exchange Server 2003.

Cause

Questo problema si verifica se il database dell'archivio di cassette postali di Exchange Server 2003 Standard Edition ha raggiunto il limite di 16 GB. Il database di messaggistica MDB viene chiuso automaticamente non appena il database di cassette postali raggiunge il limite massimo consentito. Inoltre, il database MDB non viene riavviato se il database di cassette postali ha raggiunto il limite massimo consentito. Questo comportamento Ŕ legato alla progettazione del prodotto ed Ŕ finalizzato a impedire che il sistema tenti di inserire ulteriori dati nel database di cassette postali rispetto alla quantitÓ che in Exchange Server 2003 Standard Edition pu˛ essere gestita da tale database.

Per ulteriori informazioni su come determinare la versione del server di Exchange installata sul server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
820270 Visualizzazione del tipo, dell'edizione e della versione dei server Exchange dell'organizzazione

Risoluzione

Per risolvere il problema, utilizzare uno dei seguenti metodi.

Metodo 1

Per risolvere definitivamente il problema, eseguire l'aggiornamento a Exchange Server 2003 SP2.

Per ulteriori informazioni sul nuovo limite per le dimensioni dei database in Exchange 2003 Service Pack 2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
912375 Aumento del limite massimo di 18 GB del database di Exchange Server 2003 Service Pack 2
Per ulteriori informazioni su come ottenere i service pack pi¨ recenti per Exchange Server 2003, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
836993 Come ottenere i service pack pi¨ recenti per Exchange Server 2003

Metodo 2

Se si Ŕ un amministratore, Ŕ necessario eseguire le operazioni seguenti:
  • Incrementare temporaneamente il limite massimo del database di 1 GB.
  • Rimuovere selettivamente dal database il contenuto non necessario.
  • Deframmentare il database per ridurne la dimensione a un livello inferiore rispetto al limite massimo.
In Exchange Server 2003 Standard Edition la funzionalitÓ che consente di incrementare temporaneamente il limite massimo del database di 1 GB Ŕ integrata direttamente nel prodotto. Tuttavia per attivarla Ŕ necessario che l'amministratore crei la voce
Temporary DB Size Limit Extension
del Registro di sistema.

Dopo avere creato la voce
Temporary DB Size Limit Extension
del Registro di sistema, installare momentaneamente l'archivio di cassette postali che eccede il limite di 16 GB. Questa tuttavia Ŕ solo una soluzione temporanea. Al successivo avvio di Exchange Server 2003, infatti, il limite tornerÓ a essere 16 GB. Occorre pertanto ridurre la dimensione del database prima che il limite massimo di 16 GB venga ripristinato. Per ridurre la dimensione del database, attenersi alla seguente procedura.


Avviso L'errata modifica del Registro di sistema tramite l'editor o un altro metodo pu˛ causare seri problemi, che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non Ŕ in grado di garantire la soluzione di problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. La modifica del Registro di sistema Ŕ a rischio e pericolo dell'utente.
Nota Il valore del Registro di sistema indicato in questa procedura consente un incremento temporaneo del limite massimo per la dimensione dell'archivio di cassette postali e non dovrebbe essere utilizzato per il normale funzionamento.
  1. Aggiungere la voce
    Temporary DB Size Limit Extension
    al Registro di sistema del computer che esegue Exchange 2003 Standard Edition o Exchange 2000 Standard Edition. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
    2. Individuare e selezionare la seguente chiave del Registro di sistema:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<Exchange Server Name>\Private-<long hexadecimal string>
    3. Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.
    4. Digitare Temporary DB Size Limit Extension, quindi premere INVIO.
    5. Fare doppio clic su Temporary DB Size Limit Extension.
    6. Digitare 1 nella casella Dati valore, fare clic su Decimale nella casella Base, quindi scegliere OK.
    7. Chiudere l'editor del Registro di sistema.
  2. Per impedire l'aggiunta di nuovi messaggi di posta elettronica all'archivio di cassette postali oltre il limite temporaneo di 17 GB durante il processo di ripristino, Ŕ vivamente consigliato di arrestare il servizio SMTP e il servizio Microsoft Exchange - Stack Agente di trasferimento messaggi prima di installare l'archivio di cassette postali.
  3. Installare l'archivio di cassette postali.
  4. Rimuovere i dati dall'archivio di cassette postali. A questo scopo, utilizzare uno dei seguenti metodi:
    • Utilizzare Microsoft Outlook per eliminare i messaggi di posta elettronica non necessari dalle singole cartelle Posta in arrivo e dalle altre cartelle.
    • Utilizzare Outlook per eliminare i messaggi di posta elettronica non necessari dalla cartella Posta inviata.
    • Utilizzare Outlook per svuotare la cartella Posta eliminata.
    • Se Ŕ impostato il mantenimento degli elementi eliminati, Ŕ opportuno ridurlo temporaneamente a zero (0) giorni:
      1. Fare clic sul pulsante Start, scegliere Programmi, Microsoft Exchange, quindi Gestore di sistema.
      2. Fare clic con il pulsante destro del mouse su Archivio cassette postali e scegliere ProprietÓ.
      3. Fare clic sulla scheda Limiti e digitare 0 nella casella Mantieni elementi eliminati per (giorni).
    • Eliminare le cassette postali non pi¨ utilizzate.
    • Utilizzare lo strumento Sposta cassetta postale per spostare le cassette postali in un archivio di cassette postali situato su un altro server che esegue Microsoft Exchange Server.
    • Chiedere agli utenti di creare i propri file PST sui rispettivi dischi rigidi locali e di archiviare il rispettivo contenuto del database di cassette postali sui propri dischi rigidi locali.
    • Utilizzare lo strumento ExMerge per archiviare il contenuto del database di cassette postali nei file PST.

      Nota Lo strumento ExMerge Ŕ in grado di archiviare il contenuto per cartella o per intervallo di dati.

      Per ulteriori informazioni sull'utilizzo dello strumento ExMerge, vedere il documento Mailbox Merge Wizard (ExMerge).doc incluso nel download dello strumento stesso. Per scaricare lo strumento ExMerge, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
      http://www.microsoft.com/downloads/details.aspx?FamilyID=429163ec-dcdf-47dc-96da-1c12d67327d5&DisplayLang=en
      Per ulteriori informazioni sulle autorizzazioni necessarie per lo strumento ExMerge, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
      273642 Impossibile utilizzare ExMerge se non si dispone delle autorizzazioni Ricevi come e Invia come per l'archivio
  5. Dopo avere rimosso i dati dall'archivio di cassette postali, Ŕ necessario consentire l'esecuzione della manutenzione in linea in modo che gli elementi vengano contrassegnati per l'eliminazione definitiva prima dell'esecuzione della deframmentazione non in linea.

    Per impostazione predefinita, la manutenzione in linea viene eseguita ogni notte dalle 01.00 alle 05.00. Per imporre l'immediata esecuzione della manutenzione in linea, attenersi alla procedura seguente:
    1. Fare clic sul pulsante Start, scegliere Programmi, Microsoft Exchange, quindi Gestore di sistema di Exchange per aprire Gestore di sistema di Exchange.
    2. Fare doppio clic sul server Microsoft Exchange Server, quindi fare doppio clic su Gruppo di archiviazione.
    3. Fare clic con il pulsante destro del mouse su Archivio cassette postali e scegliere ProprietÓ.
    4. Fare clic sulla scheda Database, quindi fare clic su Personalizza per modificare la pianificazione in modo che venga eseguita immediatamente.

      Nota La manutenzione in linea pu˛ richiedere 30 minuti prima di avviarsi e diverse ore per essere completata. Una volta avviata, nel registro eventi Applicazione viene registrato il seguente messaggio di ID evento:

      Tipo evento: Informazione
      Origine evento: ESE
      Categoria evento: Deframmentazione in linea
      ID evento: 700
      Descrizione: MSExchangeIS (170) Avvio della deframmentazione in linea completa nel database "C:\exchsrvr\mdbdata\priv1.edb".

  6. Visualizzare il registro eventi Applicazione per verificare che la manutenzione in linea dell'archivio di cassette postali sia terminata. L'ID evento1221 indica che la manutenzione in linea Ŕ finita. Questo messaggio di ID evento indica inoltre quanto spazio verrÓ liberato dopo l'esecuzione della deframmentazione non in linea dell'archivio di cassette postali. L'ID evento 1221 Ŕ simile al seguente:

    Tipo evento: Informazione
    Origine evento: MSExchangeIS Archivio cassette postali
    Categoria evento: Generale
    ID evento: 1221
    Descrizione: Il database NomeGruppoArchiviazione\Mailbox Store dispone di 565 MB liberi dopo la deframmentazione in linea.

  7. Eseguire una deframmentazione non in linea dell'archivio di cassette postali utilizzando lo strumento Eseutil (Eseutil.exe).

    Occorre disinstallare l'archivio di cassette postali prima di eseguire una deframmentazione non in linea. Inoltre, Ŕ necessario disporre di spazio libero su disco per almeno il 110 percento delle dimensioni del database per eseguire eseutil /d. Se non si indica un percorso temporaneo per il file di database mediante il comando t, il percorso temporaneo viene automaticamente impostato sulla cartella Exchsrvr/Bin.

    Nell'esempio di questo passaggio, X Ŕ la lettera dell'unitÓ (sul disco rigido o su un'unitÓ di rete), in cui si trova il percorso temporaneo del database deframmentato. Dopo avere eseguito il comando eseutil /d per l'archivio di cassette postali, Ŕ necessario disinstallare tutti gli archivi del gruppo di archiviazione e rimuovere eventuali file di registro dalla cartella Mdbdata prima di installare nuovamente il database. Il tempo necessario per completare una deframmentazione non in linea varia a seconda di fattori quali i componenti hardware in uso e l'esistenza o meno del reindirizzamento del database temporaneo a un'unitÓ di rete. Il comando seguente Ŕ un esempio di riga di comando da utilizzare per l'esecuzione dello strumento Eseutil:
    exchsrvr\bin\eseutil /d "percorso del file EDB" /tX:\tempdfg.edb
    Nota Quando si deframmenta un file di database EDB, anche il file STM associato viene deframmentato.

    Per ulteriori informazioni sull'utilizzo dello strumento Eseutil, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
    328804 Deframmentazione dei database di Exchange
    254132 XADM: Eseutil /d deframmenta il database e il file di flusso
    192185 Esecuzione della deframmentazione con l'utilitÓ Eseutil (Eseutil.exe)
  8. Installare i database ed eseguire i backup.

    Avviso ╚ necessario eseguire un backup completo dei database dopo avere utilizzato Eseutil.exe per deframmentarli. Il backup completo Ŕ necessario perchÚ la deframmentazione possa creare nuovi file di database dotati di nuove firme. La riesecuzione del file di registro dopo il ripristino dipende dalle firme dei database, che devono corrispondere ai valori previsti registrati nei file di registro delle transazioni. I backup di database eseguiti prima della deframmentazione presentano firme diverse da quelle dei nuovi database deframmentati. Se viene ripristinato un database precedente, i nuovi registri delle transazioni legati ai nuovi file di database deframmentati non verranno rieseguiti.
Se non Ŕ possibile eseguire l'aggiornamento del server Exchange Server a Exchange Server 2003 SP2, Ŕ opportuno implementare limiti per le cassette postali cosý da impedire al database di raggiungere il limite massimo. ╚ possibile implementare questi limiti nell'archivio di cassette postali. Se sono presenti cassette postali che richiedono maggiore spazio di archiviazione, Ŕ possibile implementare limiti individuali cassetta postale per cassetta postale.

Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
319583 HOW TO: Configurare limiti di archiviazione per le cassette postali in Exchange 2000

Metodo 3

Utilizzando la nuova funzionalitÓ Gruppo di archiviazione di ripristino in Exchange Server 2003 Ŕ possibile installare il database in un gruppo di archiviazione di ripristino e utilizzare la versione Exchange Server 2003 di Microsoft Exchange Merge Wizard (Exmerge.exe) per estrarre le cassette postali dal database.

La stessa funzionalitÓ Exmerge.exe disponibile per i database inclusi in normali gruppi di archiviazione Ŕ disponibile anche per i database inclusi in un gruppo di archiviazione di ripristino. Notare tuttavia le seguenti differenze che valgono quando si utilizza lo strumento Exmerge.exe con un gruppo di archiviazione di ripristino:
  • Non Ŕ necessario ignorare l'impostazione Nega configurata per l'autorizzazione Ricevi come per i membri del gruppo amministrativo quando si estraggono i dati dal gruppo di archiviazione di ripristino. Tuttavia, quando si riuniscono i dati al normale gruppo di archiviazione, Ŕ necessario aggiungere l'account utente appropriato all'archivio di cassette postali. Occorre inoltre assegnare all'account l'autorizzazione Ricevi come.
  • La cassetta postale originale deve essere ancora presente nel database originale e connessa a un account utente di Active Directory.
Per ulteriori informazioni sull'utilizzo dei gruppi di archiviazione di ripristino in Exchange Server 2003, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824126 Utilizzo dei gruppi di archiviazione di ripristino in Exchange Server 2003

Informazioni

Il limite di 16 GB per il database privato e per il database pubblico dell'archivio di cassette postali di Exchange deriva dalla somma della dimensione dei file Priv.edb e Priv.stm. Quando si visualizza lo spazio utilizzato da una cassetta postale nel Gestore di sistema di Exchange, nella quantitÓ Ŕ incluso solo lo spazio occupato dal file Priv.edb e non quello utilizzato dal file Priv.stm.

Quando si pone un limite a una cassetta postale, si limita soltanto lo spazio di archiviazione nel file Priv.edb. Non viene limitato lo spazio di archiviazione nel file Priv.stm. Ad esempio, nel Gestore di sistema di Exchange pu˛ sembrare che una cassetta postale occupi solo 250 MB di spazio, mentre lo spazio totale effettivo potrebbe essere di 450 MB. Questa differenza Ŕ dovuta al fatto che i 200 MB di spazio occupati dal file Priv.stm non sono indicati nel Gestore di sistema di Exchange.

Per ulteriori informazioni su questo problema in Microsoft Exchange 2000 Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
813051 Aumento temporaneo del limite massimo di 16 GB del database di Exchange 2000

Per ulteriori informazioni su Exchange Server 2003 Service Pack 2, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://technet.microsoft.com/en-us/exchange/bb288486.aspx

Riferimenti

Per ulteriori informazioni, visitare il seguente sito Web Microsoft TechNet (informazioni in lingua inglese):
http://technet.microsoft.com/en-us/library/792dea29-08bd-4b2e-9c2f-cc2056994cdd.aspx

ProprietÓ

Identificativo articolo: 828070 - Ultima modifica: mercoledý 6 febbraio 2008 - Revisione: 11.2
Le informazioni in questo articolo si applicano a
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Service Pack 1
Chiavi:á
kberrmsg kbtshoot kbexchtechbulletin KB828070
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com