Microsoft Visual Studio Tools for the Microsoft Office System readme ファイル

文書翻訳 文書翻訳
文書番号: 828087 - 対象製品
この資料には、Microsoft Visual Studio Tools for the Microsoft Office System に付属しているリリース ノートのテキストが含まれます。
すべて展開する | すべて折りたたむ

Microsoft Visual Studio Tools for the Microsoft Office System readme ファイル

このリリース ノートには、重要なインストール手順および Microsoft Visual Studio Tools for the Microsoft Office System の製品チームからの最後のノートが含まれます。

Microsoft Office を使用したソリューションの開発の最新情報については、Microsoft Office デベロッパー センターは、Web アドレスを参照してください。 http://msdn.microsoft.com/office.

このリリース ノートには、次のセクションが含まれます。

Visual Studio のツールが Microsoft Office システムのインストール

重要: は、前提条件とインストールの順序をよく読んでください。別の順序で必要な製品をインストールすると、正常に Office の Visual Studio ツールを使用することができない可能性があります。

開発用コンピューターの前提条件


Microsoft Visual Studio ツールで Office をインストールするのには、次のソフトウェアが必要です。
  • 次のいずれかです。
    • Microsoft Visual Basic .NET 2003年の標準。
    • Microsoft Visual Studio .NET 2003 Professional。
    • Microsoft Visual Studio .NET 2003年エンタープライズ開発者。
    • Microsoft Visual Studio .NET 2003年エンタープライズ アーキテクト。
  • Visual Basic 言語または Visual Studio .NET をインストールする、Visual C# 言語。
  • MSDN ライブラリの Visual Basic .NET または Visual Studio .NET セットアップ時や追加を使用して更新プログラムをインストールまたは削除 (ヘルプ コンテンツをインストールするために必要)]。
  • Microsoft Office Professional Edition 2003。
省略可能なコンポーネントのサンプル

次のコンポーネントは、いくつかのオンライン ヘルプに含まれているサンプル アプリケーションが必要です。
  • Microsoft インターネット インフォメーション サービス (Microsoft Windows XP または Microsoft Windows 2000 がインストールされている IIS)。
  • Microsoft SQL Server デスクトップ エンジン (Office 2003 のインストール メディアからインストールされている MSDE)。サンプル Office ソリューション データベース セットアップ スクリプトは、MSDE がローカル ホストにインストールされていること前提としています。
Visual Studio .NET 2003年と Microsoft Office 2003年で指定した以外の追加のハードウェアやシステム要件はありません。

開発用コンピューターのインストールの順序

  1. Office 用 Visual Studio ツールを使用するために必要なソフトウェアをこの順序でインストールする必要があります。(省略可能)(IIS のサンプル Office ソリューションの一部で必要)、Microsoft Windows XP または Microsoft Windows 2000 のインストール メディアは、Microsoft インターネット インフォメーション サービス (IIS) をインストールします。 詳細については、「インターネット情報サービス (IIS) をインストールする」を参照してください。
  2. Visual Basic .NET 2003年の標準または Visual Studio .NET 2003年をインストールします。MSDN ライブラリの Visual Basic または Visual C# 言語などがあります。
  3. Microsoft Office Professional Edition 2003 をインストールします。Microsoft Office Word 2003 や Microsoft Office Excel 2003 が含まれます。
  4. (省略可能)Microsoft SQL Server デスクトップ エンジン (MSDE) は、(いくつかのサンプル Office ソリューションでは必須)、Office 2003 のインストール メディアからインストールします。詳細についてを参照してください。 Office 2003 のインストール メディアからの MSDE をインストールします。
  5. Office を Visual Studio のツールをインストールします。

前提条件およびエンドユーザーのコンピューターにインストールの順序Office この順序でこれらのコンポーネントをセットアップする必要があります、Visual Studio のツールを開発するビジネス ソリューションを展開するコンピューター。
  1. 方法は、Microsoft.NET Framework 1.1 をインストールする、.NET Framework 1.1 の Web サイトを取得して Visual Studio .NET 2003年の Cd に。
  2. 次の Microsoft Office 製品のインストールし、インストールしたときに、プライマリ相互運用機能アセンブリ (Pia) を含めます。
    1. Microsoft Office Professional Edition 2003。
    2. Microsoft Office Word 2003 (スタンドアロン エディション)。
    3. Microsoft Office Excel 2003 (スタンドアロン エディション)。
マネージ コード拡張機能をエンドユーザーのコンピューター上で動作するのには、Office 2003 のマネージ コード拡張によって参照される Pia する必要がありますをローカル コンピューターにインストールされているまたは初めて実行するときにインストールとしてマークします。Pia のインストールで [Office のインストール オプションの後ろの状態でを選択します。
  • 完全インストール: Pia がローカル コンピューターにインストールされています。
  • 標準インストール: Piaマークされ、アプリケーションでは、マネージ コード拡張機能を参照するドキュメントが開かれたときにオンデマンドでインストールされます。初めて実行するときに PIA インストール サイレントであることに注意してください。ここでは、ドキュメントを Word または Excel で開くし、PIA インストールが発生した場合は、ダイアログ ボックスが表示されないとインストール中にユーザーのマウス ポインターの変更は行われません。ただし、セットアップ元のインストール メディア (Cd またはネットワーク上の場所) へのアクセスが必要な場合は、エンド ・ ユーザー インストールを完了するためのダイアログ ボックスを表示可能性があります。
  • 最小インストール: Pia は初めて実行するときにインストールされているか、マークされているインストールではないです。
Office 製品の最小セットアップを実行すると、Office メンテナンス モード セットアップで Pia を追加できます。Pia、.NET Framework 1.1 は、エンドユーザーのコンピューターにインストールされている場合は、適切なアプリケーションでの .NET プログラミング サポート機能として Office セットアップでが表示されます。詳細については、「方法に:: をインストール Office プライマリ相互運用アセンブリ」Visual Studio ツールでは Office のヘルプを参照してください。



セットアップのトラブルシューティング

Microsoft Office システムに Visual Studio のツールをインストールすると、これらの可能な考慮事項です。セットアップ中に問題がある場合は、成功したか失敗した手順を参照してくださいするのには、コンピューターの Temp ディレクトリに作成されるログ ファイルを参照してください。
ログ ファイルを確認するのには
  1. [スタート] メニューの [実行] をクリックします。
  2. %Temp%と入力します。
  3. キーを押してENTER します
  4. VSTO のファイルを開きます。ログメモ帳またはその他のいくつかのテキスト リーダーを使用します。

Windows インストーラー パッケージのエラーで問題

Office を Visual Studio のツールをインストールして、コンピューターの管理者でない場合は、次のメッセージが表示されます。
エラー 1721年。この Windows インストーラー パッケージに問題があります。このインストールを完了するために必要なプログラムを実行できませんでした。サポート担当者またはパッケージのベンダーにお問い合わせください。
Office を Visual Studio のツールをインストールするのには、コンピューターの管理者権限が必要です。管理者としてログオンし、セットアップを再度実行します。

いくつかのプロジェクトがインストールされていません

インストールのプロジェクト (Visual Basic .NET または C#) 言語をインストールしています。両方の言語があるない場合は、このインストール プロセスの最後のメッセージが表示されます。
セットアップはコンピューター上の<Language>を検出しませんでしたので、これらのプロジェクトはインストールされません。</Language>
このメッセージが表示する場合でも、セットアップ プロジェクトでは、コンピューターに何の言語をインストールします。プロジェクトを Visual Basic .NET と C# の両方にインストールする場合は、存在しない言語をインストールして、Visual Studio ツールをもう一度 Office セットアップを実行する必要があります。

セットアップ ウィザードのテキストが表示されていません。

ハイ コントラストを使用するのには、モニターが設定されている場合、セットアップ ウィザードのテキストは表示されません。
  1. セットアップ ウィザードでは、テキストを表示するのにはファイルを開く、 [コントロール パネル]、 [ユーザー補助のオプション] をクリックし、[表示] タブをクリックします。
  2. 使用するハイ コントラストのオプションをオフにします。
  3. [OK] をクリックします。
  4. Visual Studio ツール用の Office のセットアップを再度実行します。

Visual Studio ツールの Office のヘルプを表示するヘルプ コレクションのではないです。

Visual Studio .NET のヘルプでは、Office ヘルプの visual Studio ツールが統合されています。Visual Studio ツールを Office のセットアップを実行する前に、Visual Studio .NET 2003 では、コンピューターに付属する MSDN ライブラリがある場合は、Visual Studio のツールで Office セットアップにインストールされます。ヘルプは 2003年およびそれ以降 7 月 MSDN の更新プログラムにも含まれています。2003 年 4 月 MSDN がある場合は、更新プログラムの Office、ヘルプをインストールするため、Visual Studio のツールをインストールするとインストールします。ここでは、2003 年 7 月 MSDN をインストール Office のヘルプを Visual Studio のツールを取得するのには、更新プログラム。

言語バージョンの Office を Visual Studio のツールが Visual Studio .NET の言語バージョンに一致する必要があります。

言語バージョンが一致しない場合は、次のメッセージが表示されます。
セットアップは、このパッケージと Visual Studio の言語の不一致が検出されました。再試行する前に、適切な言語バージョンを入手してください。
言語バージョンの Office のセットアップをインストールされているバージョンの Visual Studio .NET の言語を一致しなければなりません。たとえば、Visual Studio .NET の英語版がある場合、英語版の Office を Visual Studio のツールをインストールしてください。複数の言語バージョンの Visual Studio を同じコンピューターにインストールされている .net の場合は、対応するすべての言語バージョンの Office を Visual Studio のツールをインストールできます。



Microsoft Office システムに Visual Studio のツールをアンインストールします。

Office を Visual Studio のツールをアンインストールするのには、追加と削除] を使用します。

Visual Studio の [ツールの追加と削除] を使用して Office を削除するのには
  1. [スタート] をクリックし、[コントロール パネル] をクリックします。
  2. 選択の追加またはプログラムを削除します
  3. Microsoft Visual Studio Tools for the Microsoft Office Systemは、現在インストールされているプログラム] ボックスの一覧で選択します。
  4. の削除] をクリックします。
メモOffice を Visual Studio のツールをアンインストールした後、完全な信頼が付与されているすべてのアセンブリは完全信頼のセキュリティ ポリシーを保持します。Office を Visual Studio のツールによって行われるすべてのポリシーの変更を削除する場合は、 Office_Projectsのコード グループは、1.1 の Microsoft .NET Framework 構成ツールまたはコード アクセス セキュリティ ポリシー ツール (Caspol.exe) を使用して、ユーザーポリシー レベルから削除します。

詳細については、「方法:: 削除のアクセス許可からフォルダーおよびアセンブリに」Visual Studio ツールでは Office のヘルプを参照してください。また、Visual Studio ツールは Office のヘルプ ファイルをインストールする場合は、それらのファイルが Visual Studio .NET のヘルプ コレクションに残ります。
詳細については、追加と削除] を使用するのには、Windows ヘルプとサポートを参照してください。



開発のトラブルシューティング

これらは、Visual Studio のツールで、Microsoft Office システムの開発時に考慮するいくつかの領域です。

カスタム プロパティが破損しています。

いくつかの原因が、次のエラーのヘルプ トピック「トラブルシューティングで Office で実行時間」で記載されています原因の 1 つのトピックから省略されました。
アセンブリ名プロパティまたはアセンブリ リンク ロケーション プロパティに<filename>が破損しています。管理者、またはこのドキュメントの作成者に問い合わせます。</filename>
このメッセージは、プロジェクトをビルドする前に、ドキュメントまたは Office プロジェクトの一部であるブックを開いている場合にも表示されます。たとえば、新しい Office プロジェクト、または既存のドキュメントまたはブックを作成して、Word または Excel を使用して、プロジェクトをビルドする前に、文書またはブックを開くには場合は、このメッセージが表示されます。この場合、アセンブリがまだ存在しないのでカスタム プロパティ_AssemblyName0まだ文書またはブックに追加されていないことを意味します。この問題を解決するのには、開いているドキュメントを閉じ、プロジェクトをビルド、文書またはブックを開きます。

一部のイベントは、C# を使用すると発生しません

メソッドと同じ名前を持つイベントを持つ Office オブジェクトが分割されて、Office プライマリ相互運用機能アセンブリ内の 2 つのオブジェクト: は、主要なオブジェクトにすべてのプロパティとメソッド、およびイベントで競合するプロパティまたはメソッドの名前を含むイベント オブジェクト。これらのイベント オブジェクトが<objectname>の名前付け規則を使用して _Event。予想されるイベントが表示されない場合は、 <objectname>_Event インターフェイスにキャストします。

たとえば、 Activateイベントとは、 Activateメソッドをブックのです。このイベントを処理するのには、代わりにWorkbookEvents_Event使用ブックします

メンバー変数の宣言セクションを作成します。</objectname></objectname>
private Excel.Workbook wkbk;
private Excel.WorkbookEvents_Event wbEvents;
private Excel.WorkbookEvents_ActivateEventHandler activateEvent;

_Startup でイベントを配線します。
wbEvents = (Excel.WorkbookEvents_Event)wkbk;


activateEvent = new Excel.WorkbookEvents_ActivateEventHandler(ThisWorkbook_Activate);
wbEvents.Activate += activateEvent;

イベント ハンドラーを作成します。
protected void ThisWorkbook_Activate()
{
    // Your code goes here
} 

WorkbookEvents_Eventにキャストする必要があります Excel します。Workbook.Activateは、 Activateメソッドを返しますが、をアクティブにするイベントします

別の方法として、オブジェクト _Startup は、対応するイベント インターフェイスにキャストできます。
((Excel.WorkbookEvents_Event)(thisWorkbook)).Activate += new Excel.WorkbookEvents_ActivateEventHandler(ThisWorkbook_Activate); 

[イベント ハンドラーのコードを記述します。

protected void ThisWorkbook_Activate()
{
    // Your code goes here
} 

モードレス フォームで未処理の例外が発生した場合 Excel と Word を予期せず終了

ユーザーがモードレス フォームでイベントをトリガーした後に Excel または Word でが突然終了する場合は、コードで未処理の例外を発生する可能性がありますすべての場所があるかどうかを確認してください。データの消失を防ぐためのエラー処理を追加します。

詳細については、「スレッド処理のサポートで Office」Visual Studio ツールでは Office のヘルプを参照してください。

Close メソッドは Word と Excel が突然終了する原因します。

Excelのブックオブジェクトまたは WordドキュメントオブジェクトのCloseメソッドをモードレス フォームから呼び出すと、アプリケーションが予期せず終了可能性があります。すべての開いている文書またはブックを閉じるし、データが失われる可能性があります。Microsoft Office Outlook の電子メール エディターとして Word を使用する場合は、すべてのメッセージも終了可能性がありますの電子メールを開きます。AppDomain.DomainUnloadイベントを処理するときに Windows フォームまたはメッセージ ボックスを表示する場合にも発生する可能性があります。

この問題を回避するには、 Closeメソッドをモードレス フォームから、またはイベントでモードレス フォームを呼び出さないでください。その代わりに。
  • モーダル フォームを使用して (たとえばフォームを使用します。ShowDialog()のではなく。Show())場合は、フォームからドキュメントを閉じる必要があります。
  • モードレス フォームを使用する必要がある場合は、モードレス フォームを閉じて、文書またはブックを閉じる前にフォーム参照には、完全に破棄されたことを確認します。例を示します。
Dim myForm as SomeModelessForm
Sub Open()
   myForm = new SomeModelessForm
   ' Show form modelessly.
   myForm.Show()
End Sub

Sub ForceShutdown()
   ' Completely close the form if it is still running.
   ' Note that hiding the form might not work by itself.
   If (Not myForm Is Nothing) Then
      myForm.Close()
      myForm.Dispose()
      myForm = Nothing
   End If
   ThisDocument.Close()
End Sub 
詳細については、「スレッド処理のサポートで Office」Visual Studio ツールでは Office のヘルプを参照してください。

実行時にドキュメントをデザイン モードで開く

Word 文書上の ActiveX コントロールをホストすると、Word 文書のデザイン モードでは、Visual Basic for Applications (VBA) のマクロのセキュリティ高に設定されている場合は、VBA プロジェクトがデジタル署名されていない開きます。秘密を初期化するようにプロジェクトを変更して、この問題を解決するのには、ブール変数、 toggleActiveXControls真に (toggleActiveXControlsは、プロジェクト テンプレートには含まれて)。これは、文書を開いたするときにデザイン モードから切り替えるには、ActiveX コントロールが発生します。

Excel COM 呼び出し一部のクライアントのロケールで失敗可能性があります。

Excel アプリケーションは異なるユーザー ロケールを使用してクライアント コンピューターに配布できます。特定の状況では、これは実行時またはデータ変換のエラーがあります。これらのエラーを防ぐし、ロケール間での一貫性のある機能を確認するのには、特定の開発のガイドラインに従う必要があります。

詳細については、「グローバリゼーションとローカリゼーションの Office ソリューションに Visual Studio のツールは Office のヘルプを参照してください。

ネットワーク上の場所で作成されたプロジェクトに完全な信頼が自動的に付与されません。

プロジェクトを作成し、ドキュメントをネットワーク上の場所を指定する場合は、アセンブリに完全な信頼を付与するかどうかを確認するダイアログ ボックスが表示します。ただし、完全な信頼を付与するのには[はい] をクリックした場合でも、プロジェクトを実行するのには、十分なアクセス許可必要がありますされません。管理者はプロジェクトを実行する前に、アセンブリとドキュメントには信頼するのには、セキュリティ ポリシーを設定する必要があります。詳細については、「ドキュメントをネットワーク上の場所を指定して Microsoft Office プロジェクト ウィザードの [セキュリティの設定] タブで選択したオプションのままで、アセンブリの場所を信頼する」Visual Studio ツールでの Office のヘルプを表示します。

その他のドキュメントや ActiveX コンテナーでホストされるドキュメントでイベントが発生しません。

OLE を使用して他のドキュメントに含まれる Office ドキュメントは開いているまたがアクティブ化されたときにイベントを発生可能性があります。同様は、Office ドキュメントが ActiveX コンテナーでホストされている場合、イベントは発生可能性があります。ドキュメントでマネージ コード拡張機能をホストする Microsoft Internet Explorer 用にサポートされている唯一の ActiveX コンテナー 6.x。

Internet Explorer では、Office ドキュメントを開く場合は、6.x では、マネージ コード拡張機能で発生するイベントの動作は、されると同じであるドキュメントが Internet Explorer でホストされている場合、VBA プロジェクトで発生します。ActiveX ドキュメントをホストしての性質によっては、Excel または Word のアプリケーションのいくつかのコマンドを利用できなくなります。同様に、特定のイベントは、文書またはブックを Internet Explorer など、ActiveX ドキュメントのホストが含まれているときに発生しないことが予想される (たとえば: Word で、差し込み印刷イベントとウィンドウWindowActivateイベントは利用できません。 Excel では、 BeforeCloseイベント ハンドラーが終了をキャンセルすることはできません)。

Normal.dot の破損またはが予期せず大きく

停止するデバッガーコマンドの Visual Studio .NET で、Word プロジェクトのデバッグを終了するのには使用頻度の場合は、Normal.dot テンプレートを使用すると問題が発生可能性があります。この可能性を最小限に抑えるには、すべてデタッチを使用して停止するデバッガーを使用せずにデバッグを終了して、Word のユーザー インターフェイスを介して、通常の手順を使用して Word を終了します。

プライマリ相互運用機能アセンブリをセットアップ プロジェクトには含まれません

配置プロジェクトを作成すると、ソリューションに参照、Office プライマリ相互運用機能アセンブリを手動で除外する必要があります。エンドユーザー ソリューションを使用する前に Office Pia がグローバル アセンブリ キャッシュ (GAC) 内の元の Office インストール メディアからインストールした場合、コンピューターに必要があります。Pia のコピー、ソリューションを配置するがエンドユーザーのコンピューターに問題が発生する可能性があります。詳細については、「方法に:: をインストール Office プライマリ相互運用アセンブリ」Visual Studio ツールでは Office のヘルプを参照してください。



最後の分の変更

Excel ブックのプロジェクトをテンプレートとして保存した後でも

Microsoft Office 2003年プロジェクトの Excel テンプレートのプロジェクトはありません。ただし、マネージ コード拡張機能を Excel ブック プロジェクトを作成し、[テンプレート (*.xlt) としてブックを保存する場合、テンプレートは、同じマネージ アセンブリを参照する新規のブックを作成するを使用できます。

プロジェクトのセキュリティ設定オプションを変更します。

プロジェクトを作成すると、Microsoft Office プロジェクト ウィザードには、Visual Studio の .NET には、アセンブリのビルド時の場所に基づいて完全信頼を付与するかどうかを選択するのには、[セキュリティ設定] タブが含まれています。完全な信頼が付与されるようにするには、既定では、このオプションを選択します。後で選択 (ウィザードが完了した後、プロジェクトを開発するときにいつでも)、プロジェクトの .vbproj ファイルまたは .csproj ファイル内の属性を変更することによって変更できます。

セキュリティの設定オプションを変更するのには
  1. プロジェクトの .vbproj ファイルまたは .csproj ファイルを開きます。
  2. [ユーザー プロパティ] ノードを検索します。
  3. 追加またはTrustedAssemblyと呼ばれる、属性を削除します。
    • ビルド時に完全な信頼を付与するのには、ユーザー プロパティノードにTrustedAssembly属性を追加し、アセンブリへのパスを設定します。例を示します。
      <UserProperties
         OfficeDocumentPath = ".\PROJECT1.XLS"
         OfficeProjectType = "XLS"
         OfficeProject = "true"
         TrustedAssembly = "C:\projects\project1\project1_bin\project1.dll"
      /> 
      
    • ビルド時に完全な信頼を付与するを停止するのには、 TrustedAssembly属性を削除します。



Office 開発のサンプル

Visual Studio .NET で開くことのできるサンプル ソリューションの Office のヘルプを Visual Studio のツールが含まれます。[コンテンツ] ウィンドウで、 Office のプログラミング] ノードの下のサンプルとチュートリアルノードにあります。Visual Studio .NET のサンプル Excel の自動化やサンプル、Word を自動化することで調べることもできます。各ページ サンプルにはをビルドしてサンプルを実行するための詳細な手順が含まれます。

いくつかのサンプルは、Microsoft SQL Server デスクトップ エンジン (MSDE) データベースが必要です。スクリプト ファイルとデータ ファイルはデータベースを自動的に作成するこのサンプルに用意されています。

既定の場所から Excel サンプル データベースはインストールされません。

Excel のサンプルのいくつかは、データベースをインストールするのには、setup スクリプト (setup.bat) を実行する必要があります。データベース セットアップ スクリプトへのパスにスペースが含まれている場合は、データベースは作成されません、し、[コマンド プロンプト] ウィンドウに表示されなくなります。次のエラーが表示されますである database.log で
<root drive>\Documents and Settings\<user name>\Local Settings\Temp:
XML の解析エラー: ドキュメントのトップ レベルが無効です。
この問題を解決するのには。
  1. サンプル トピックにはサンプル ソリューションの読み込みまたはコピーすべてのファイルをクリックします。サンプル ファイルの場所を選択するように求めるダイアログ ボックスが表示されます。
  2. ルート ディレクトリまたはパスにスペースを含まないディレクトリを選択します。サンプル ファイルを選択する場所のサブディレクトリにコピーされます。<selected location="">\Samples\Office Projects\<sample name=""> </sample> </selected>
  3. Projects\<sample name="">の .\Samples\Office から、 ExcelSampleDatabaseフォルダーに移動する 2 つのレベル上のフォルダー、します。 \Samples フォルダーは、Office のプロジェクト ディレクトリの下がなくなったので。</sample>
  4. サンプル データベースを作成するのには、 ExcelSampleDatabaseフォルダー内のsetup.batを実行します。

次のサンプルでは、Excel サンプル データベースを使用します。
  • Excel ワークシートの ADO.NET の例 (ExcelReadWriteADO) を使用します。
  • Excel のワークシートのカスタム テキストのサンプル (ExcelReadCustomUser)
  • Excel のワークシートに Windows フォームのサンプル (ExcelReadWinForm) を使用します。

Windows 2000 を実行するときにエラーが発生 Excel サンプルを返す可能性があります。

Excel サンプル データベースの setup.bat を実行すると、database.log ファイルに次のエラー メッセージが表示されます。
Msxml2.dll の読み込みに失敗しました
Estimates サンプルを実行すると、次のエラー メッセージが表示されます。
オブジェクトのインスタンスへのオブジェクト参照が設定されていません。
MSDE SP3 または SP3a をインストールしたコンピューターに Windows 2000 オペレーティング システムを実行している場合は、コンピューター、MSXML2 のファイルことがあります。DLL は、いくつかのサンプルを正しく実行するが必要です。

この問題を解決するのには、インストールし、MSXML2 を登録します。Dll では、マイクロソフト サポート技術情報 MSXML2.dll の入手方法の詳細については、次の資料を参照してください。
FIX: MSXML 2.6 SQL Server MSDE SP3 または SP3a を再しません。

データベース接続がエラーを返す可能性があります。

データベースを使用して、サンプルを実行すると、このメッセージが表示可能性があります。
SQL Server が存在しないか、アクセスが拒否されました
TCP/IP プロトコルは、SQL Server のインストールに有効になっていない場合を SQL Server 名 localhost にアクセスすることはできませんし、エラー メッセージが表示されます。この問題を解決するのには、ADO.NET への接続は、 (local)のサーバー名またはサーバーの名前を変更します。

たとえば、次の接続文字列:
dbConn = New SqlConnection("Integrated Security=SSPI;" & _ 
    "Initial Catalog=ExcelSample;Data Source=localhost")
変更する必要があります。
dbConn = New SqlConnection("Integrated Security=SSPI;" & _ 
    "Initial Catalog=ExcelSample;Data Source=(local)")
次のサンプルでは、SQL Server、ADO.NET 接続文字列 localhost を参照してください。
  • Excel ワークシートの ADO.NET の例 (ExcelReadWriteADO) を使用します。
  • Excel のワークシートのカスタム テキストのサンプル (ExcelReadCustomUser)
  • Excel のワークシートに Windows フォームのサンプル (ExcelReadWinForm) を使用します。
  • 見積もりのサンプル

Estimates サンプルがエラー メッセージを表示することがあります。

見積もりのサンプルのトピックを開くと、このメッセージが表示可能性があります。
'子' は、null またはオブジェクトされませんです。サンプル ビューアーは、このサンプル情報を見つけることができませんです。ヘルプのインストールを確認してください。
このメッセージが誤って表示されます。問題のサンプルではありません。このメッセージは、数回表示可能性があります。[Ok] をクリックします。メッセージが表示されない場合は、いつものように、Estimates サンプルを操作できます。



詳細情報の入手先

Office のヘルプの visual Studio ツール

2003 年 2 月がある場合は Visual Studio .NET のヘルプを Office ヘルプのセットアップ中が統合された Visual Studio のツールを Office のセットアップ プログラムを実行する前に、コンピューター上のライブラリ。2003 年 2 月 MSDN ライブラリ付属の Visual Studio .NET 2003 を使用します。2003 年 7 月以降の MSDN ライブラリをコンピューターでは、Office ヘルプの [MSDN ライブラリ] ノードに含まれているか。

Office のヘルプを Visual Studio のツール統合された Visual Studio .NET のヘルプ コレクションでを検索するには
  1. Visual Studio .NET の [ヘルプ] メニューを開くしをクリックして内容します
  2. [コンテンツ] ウィンドウで、[ Visual Studio .NET ] ノードを展開します。
  3. Visual Basic および Visual C#のノードを展開します。
  4. Office ヘルプのすべての Visual Studio ツールが含まれていますOffice のプログラミングノードを展開します。
Visual Studio のツールを Office 2003 年 7 月にまたはそれ以降の MSDN ライブラリを検索するのには
  1. Visual Studio .NET の [ヘルプ] メニューを開き、[内容] をクリックします。
  2. コンテンツウィンドウで、展開、ライブラリ -<July 2003="" or="" later=""></July>ノード。
  3. .NET 開発] を展開します。
  4. Visual Studio .NET ] を展開します。
  5. 製品ドキュメントのノードを展開します。
  6. Visual Basic および Visual C#のノードを展開します。
  7. プログラミングは、Office ヘルプのすべての Visual Studio ツールが含まれている Office] ノードを展開します。
ヘルプを検索

Visual Studio .NET の [検索結果] ウィンドウでは、Visual Studio ツールの Office のヘルプを表示するための場所として表示されますOffice プログラミングの概念します

Office 2003 のインストール メディアからの MSDE のインストール

Office を Visual Studio のツールが含まれている Office 開発のサンプルの一部は Microsoft SQL Server デスクトップ エンジン (MSDE) がローカル ホストにインストールされていることを前提としているデータベースの設定スクリプトがあります。

MSDE は Office 2003 のインストール メディアに含まれています。Office 2003 をインストールした後は、追加と削除] を使用してインストールすることはできません。MSDE をインストールするのには、元のインストール メディアが必要です。

インストールする Office 2003 インストール メディアからの MSDE に
  1. 同じ Office インストール フォルダーで setup.exe を [ MSDE2000] サブフォルダーを検索します。このフォルダーには MSDE 用のインストール コンポーネントが含まれます。
  2. セットアップについては、「SQL Server Books Online が表示されます。データベース エンジンのドキュメントで、SQL Server Books Online は、MSDE 2000 に適用されます。SQL Server オンライン ブックのインストール、データベースの作成、管理、トラブルシューティング、およびアプリケーション開発のすべてのバージョンの SQL Server 2000年データベース エンジンについて説明します。
  3. 構成し、SQL Server サービスを起動すると、MSDE のインストール後、コンピューターを再起動します。



インターネット インフォメーション サービス (IIS) をインストールします。

Office を Visual Studio のツールが含まれている Office 開発のサンプルのいくつかには、インターネット インフォメーション サービス (IIS) が必要な Web サービスが含まれます。

Windows 2000 または Windows XP で IIS をインストールするのには
  1. ネットワークから切断またはインストールして実行しているファイアウォールがあることを確認してください。
  2. Windows 2000 には、[スタート] メニューの設定を選択し、[コントロール パネル] の順にクリックします。
    後で、Windows XP の [スタート] メニューのコントロール パネルを選択します。
  3. コントロール パネルで [プログラム追加と削除] をクリックし、[ Windows コンポーネントの追加と削除] をクリックします。
  4. Windows コンポーネント ウィザードで、インターネット インフォメーション サービス (IIS)のコンポーネント] ボックスの一覧から選択します。
  5. インストールを開始する次へ] をクリックします。
  6. インストールが完了すると、IIS サービスを停止します。
  7. Windows Update から更新プログラムをダウンロードします。 (http://www.windowsupdate.com)。
  8. 必要に応じてを再起動し、IIS サービスを開始します。
  9. 追加またはプログラムを削除するに戻る
  10. インストールされている Visual Studio .NET 製品を選択し、[変更] をクリックします。
  11. Visual Studio .NET 製品を再インストールします。



← マイクロソフト株式会社。すべての権利予約します。

プロパティ

文書番号: 828087 - 最終更新日: 2013年5月30日 - リビジョン: 8.0
この資料は以下の製品について記述したものです。
  • Microsoft Visual Studio Tools for the Microsoft Office System version 2003
キーワード:?
kbreadme kbmt KB828087 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:828087
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com