Microsoft Visual Studio Tools for the Microsoft Office System de arquivos Leiame

Traduções deste artigo Traduções deste artigo
ID do artigo: 828087 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo contém o texto do arquivo readme. htm que acompanha o Microsoft Visual Studio Tools for the Microsoft Office System de.
Expandir tudo | Recolher tudo

Microsoft Visual Studio Tools for the Microsoft Office System de arquivos Leiame

Este Leiame contém importantes instruções de instalação e notas de última hora do Microsoft Visual Studio Tools for the Microsoft Office System de equipe do produto.

Para obter as informações mais recentes sobre o desenvolvimento de soluções usando o Microsoft Office, consulte o Microsoft Office Developer Center no endereço da Web http://msdn.microsoft.com/Office.

Este Leiame contém as seções a seguir:

Instalar o Visual Studio Tools para o sistema Microsoft Office

Importante: Leia os pré-requisitos e a ordem de instalação com muito cuidado. Se você instalar os produtos necessários em uma ordem diferente, você não poderá usar o Visual Studio Tools for Office com êxito.

Pré-requisitos para o computador de desenvolvimento


O software a seguir é necessário para instalar o Microsoft Visual Studio Tools for Office:
  • Um dos seguintes:
    • Microsoft Visual Basic .NET 2003 Standard.
    • Microsoft Visual Studio .NET 2003 Professional.
    • Microsoft Visual Studio .NET 2003 Enterprise Developer.
    • Microsoft Visual Studio .NET 2003 Enterprise Architect.
  • A linguagem Visual Basic e/ou a linguagem Visual C#, que pode ser instalada com o .NET do Visual Studio.
  • A Biblioteca MSDN instalado durante o programa de instalação do Visual Studio .NET ou o Visual Basic .NET ou durante uma atualização usando Adicionar ou remover programas (necessário para instalar o conteúdo da Ajuda).
  • Microsoft Office Professional Edição 2003.
Componentes opcionais para amostras

Os seguintes componentes são necessários para alguns aplicativos de exemplo incluídos na Ajuda on-line:
  • Serviços de Informações da Internet da Microsoft (IIS), instalado com o Microsoft Windows XP ou Microsoft Windows 2000.
  • Microsoft SQL Server Desktop Engine (MSDE) instalado a partir da mídia de instalação do Office 2003. Os scripts de instalação de banco de dados do exemplo Office solução presumem que o MSDE é instalado no host local.
Não há nenhum requisito de hardware ou sistema adicional além daqueles especificados pelo Visual Studio .NET 2003 e o Microsoft Office 2003.

Ordem de instalação para o computador de desenvolvimento

  1. O software necessário para usar o Visual Studio Tools for Office deve ser instalado na seguinte ordem: (Opcional) Instale Serviços de Informações da Internet da Microsoft (IIS) da mídia de instalação do Microsoft Windows XP ou Microsoft Windows 2000 (IIS é necessário algumas das soluções Office exemplo). Para obter mais informações, consulte Instalando o Internet Information Services (IIS).
  2. Instale o Visual Basic .NET 2003 Standard ou o Visual Studio .NET 2003. Inclua a Biblioteca MSDN e o idioma e/Visual Basic ou Visual C#.
  3. Instale o Microsoft Office Professional Edição 2003. Incluem o Microsoft Office Word 2003 e/ou do Microsoft Office Excel 2003.
  4. (Opcional) Instale o Microsoft SQL Server Desktop Engine (MSDE) da mídia de instalação do Office 2003 (exigida por algumas das soluções Office exemplo). Para obter mais informações, consulte Instalação MSDE a partir da mídia de instalação do Office 2003.
  5. Instale o Visual Studio Tools for Office.

Pré-requisitos de e ordem de instalação para computadores de usuários finais Cada computador ao qual você implanta soluções de negócios que são desenvolvidas com o Visual Studio Tools for Office deve ser configurado com esses componentes nesta ordem:
  1. Instalar o Microsoft.NET Framework 1.1, que está disponível a partir de como obter o site da Web do.NET Framework 1.1 e no Visual Studio .NET 2003 CDs.
  2. Instalar um dos seguintes produtos do Microsoft Office e incluir os assemblies de interoperabilidade primários (PIAs) na instalação:
    1. Microsoft Office Professional Edição 2003.
    2. Microsoft Office Word 2003 (edição autônoma).
    3. Microsoft Office Excel 2003 (edição autônoma).
Para extensões de código gerenciado para executar corretamente em computadores de usuários finais, os PIAs do Office 2003 referenciada por sua extensão de código gerenciado deve ser instalado no computador local ou marcado como instalado na primeira utilização. O estado de PIAs após a instalação depende da opção de instalação do Office que você escolher:
  • Instalação completa : PIAs estão instalados no computador local.
  • Instalação típica : PIAs são marcados a Instalar na primeira utilização e são instalados sob demanda quando o documento que faz referência a uma extensão de código gerenciado é aberto no aplicativo. Observe que a instalação de PIA no primeiro uso pode ser silenciosa; Nesse caso, quando o documento é aberto no Word ou Excel e a instalação de PIA ocorre, nenhuma caixa de diálogo será exibida e nenhuma alteração ao ponteiro do mouse do usuário final ocorre durante a instalação. No entanto, os usuários finais pode receber uma caixa de diálogo se a instalação precisa de acesso à mídia de instalação original (CDs ou rede local) concluir a instalação.
  • Instalação mínima : PIAs não estão instalada ou marcado como instalação na primeira utilização.
Se você executar uma instalação mínima do produto do Office, você pode adicionar os PIAs por meio da instalação do modo de manutenção do Office. Se o.NET Framework 1.1 foi instalado no computador do usuário final, os PIAs aparecerá na instalação do Office como recursos de suporte à programação .NET em aplicativos apropriados. Para obter mais informações, consulte "Como para: instalar o Office Assemblies de interoperabilidade primários" no Visual Studio Tools para Ajuda do Office.



Solucionando problemas de instalação

Essas são algumas possíveis considerações quando você instala o Visual Studio Tools para o sistema do Microsoft Office. Se você tiver problemas durante a instalação, procure no arquivo de log é criado no diretório de Temp do computador para ver quais etapas tem êxito ou falha.
Para verificar o arquivo de log
  1. No menu Iniciar , clique em Executar.
  2. Digite % temp %.
  3. Pressione ENTER.
  4. Abra o arquivo VSTO.LOG usando o bloco de notas ou algum outro leitor de texto.

Problema com o erro de pacote do Windows Installer

Se você tenta instalar o Visual Studio Tools for Office e não for um administrador no computador, a seguinte mensagem aparece:
Erro 1721. Há um problema com este pacote do Windows Installer. Não foi possível executar um programa necessário concluir a instalação. Contate o fornecedor de pacote ou a equipe de suporte.
Você deve ter privilégios de administrador no computador para instalar o Visual Studio Tools for Office. Faça logon como administrador e execute a instalação novamente.

Alguns projetos não estão instalados

Programa de instalação instalará somente os projetos para os idiomas que você tiver instalado (e/Visual Basic .NET ou C#). Se você não tem as duas linguagens, você verá esta mensagem no final do processo de instalação:
Esses projetos não serão instalados porque a instalação não detectou <Language>em seu computador. </Language>
Mesmo se você vir esta mensagem, o programa de instalação instalará os projetos para o idioma que você tem no seu computador. Se você quiser instalar projetos do Visual Basic .NET e C#, instale o idioma ausente e execute o Visual Studio Tools para o programa de instalação do Office novamente.

O texto fica oculto no Assistente de instalação

Se o seu monitor esteja configurado para usar Alto contraste, o texto no Assistente de instalação não será visível.
  1. Para exibir o texto no Assistente de instalação Abrir o Painel de controle, escolha As opções de acessibilidadee, em seguida, clique na guia Exibir .
  2. Desmarque a opção usar Alto contraste .
  3. Clique em OK.
  4. Execute o Visual Studio Tools para o programa de instalação do Office novamente.

Visual Studio Tools for Office ajuda não aparece na coleção de ajuda

Visual Studio Tools for Office ajuda é integrado com a Ajuda do Visual Studio .NET. Ele é instalado durante o Visual Studio Tools para o programa de instalação do Office se você tiver a Biblioteca MSDN que está incluído no Visual Studio .NET 2003 em seu computador antes de executar o Visual Studio Tools para o programa de instalação do Office. A Ajuda também está incluída nas atualizações do MSDN de julho de 2003 e posterior. Se você tiver o MSDN de abril de 2003 atualização instalada quando você instala o Visual Studio Tools para Office, a Ajuda não será instalado. Nesse caso, instalar o MSDN de julho de 2003 update para obter o Visual Studio Tools para Ajuda do Office.

A versão de idioma do Visual Studio Tools for Office deve coincidir com a versão de idioma do Visual Studio .NET de

Se as versões de idiomas não corresponderem, a seguinte mensagem aparece:
Foi detectada incompatibilidade de idioma entre esse pacote e o Visual Studio. Obtenha a versão de idioma apropriado antes de tentar novamente.
A versão de idioma do Visual Studio Tools para o programa de instalação do Office deve coincidir com o idioma da versão instalada do .NET do Visual Studio. Por exemplo, se você tiver uma versão em inglês do Visual Studio .NET de, você deve instalar a versão em inglês do Visual Studio Tools for Office. Se você tiver várias versões de idioma do Visual Studio .NET estiver instalado no mesmo computador, você pode instalar todas as versões de idioma correspondente do Visual Studio Tools for Office.



Desinstalar o Visual Studio Tools para o sistema Microsoft Office

Use Adicionar ou remover programas para desinstalar o Visual Studio Tools for Office.

Para remover o Visual Studio Tools for Office usando Adicionar ou remover programas
  1. Clique em Iniciar e, em seguida, clique em Painel de controle.
  2. Escolha Adicionar ou remover programas.
  3. Selecione Microsoft Visual Studio Tools for the Microsoft Office System de na lista de programas instalados atualmente .
  4. Clique em Remover .
ObservaçãoTodos os assemblies que foram concedidos a confiança total manterá a confiança total na sua política de segurança após a desinstalação do Visual Studio Tools for Office. Se você deseja remover todas as alterações de diretiva feitas pelo Visual Studio Tools for Office, exclua o grupo de códigos de Office_Projects de nível de diretiva de usuário usando a ferramenta de configuração do Framework Microsoft .NET 1.1 ou a ferramenta Code Access Security Policy (Caspol.exe).

Para obter mais informações, consulte "Como para: remover permissões de pastas e conjuntos" no Visual Studio Tools para Ajuda do Office. Além disso, se você instalou o Visual Studio Tools for Office ajuda arquivos, esses arquivos permanecerão na coleção de Ajuda do Visual Studio .NET.
Para obter mais informações sobre como usar Adicionar ou remover programas, consulte Ajuda e suporte Windows.



Desenvolvimento de solução de problemas

Estas são algumas áreas a considerar ao desenvolver com o Visual Studio Tools para o sistema do Microsoft Office.

Propriedades personalizadas estão corrompidas

Várias causas para o erro a seguir estão documentadas no tópico da Ajuda "Solução de problemas no Office em tempo de execução", mas uma possível causa foi omitida do tópico.
O nome do assembly assembly link local propriedades ou no <filename>está corrompidos. Para obter mais assistência, contate o administrador ou o autor deste documento. </filename>
Essa mensagem também aparece quando um documento ou pasta de trabalho que faz parte de um projeto do Office é aberta antes do projeto foi criado. Por exemplo, se você cria um projeto do Office usando um novo ou existente documento ou pasta de trabalho e, em seguida, usa o Word ou Excel para abrir o documento ou pasta de trabalho antes de criar o projeto, esta mensagem aparece. Nesse caso, isso significa que a propriedade personalizada AssemblyName0 não ainda foi adicionado ao documento ou pasta de trabalho porque o assembly ainda não existe. Para corrigir o problema, feche o documento aberto, crie seu projeto e, em seguida, abra o documento ou pasta de trabalho.

Alguns eventos não são gerados quando usando C#

Objetos do Office que tenham um método e um evento com o mesmo nome foram divididos em dois objetos em assemblies de interoperabilidade primária do Office: um objeto de núcleo com todas as propriedades e métodos e um objeto de evento que contém os eventos com nomes que estão em conflito com uma propriedade ou método. Esses objetos de evento usam a convenção de nomenclatura <objectname>Event. Se você não vir um evento que você esperava, converta para a interface de Event <objectname>.

Por exemplo, há um evento Activate e um método Activate para uma pasta de trabalho. Para manipular esse evento, utilize WorkbookEvents_Event em vez de pasta de trabalho.

Crie variáveis de membro na seção declarações:</objectname></objectname>
private Excel.Workbook wkbk;
private Excel.WorkbookEvents_Event wbEvents;
private Excel.WorkbookEvents_ActivateEventHandler activateEvent;

Conecte o evento Startup:
wbEvents = (Excel.WorkbookEvents_Event)wkbk;


activateEvent = new Excel.WorkbookEvents_ActivateEventHandler(ThisWorkbook_Activate);
wbEvents.Activate += activateEvent;

Escreva um manipulador de eventos:
protected void ThisWorkbook_Activate()
{
    // Your code goes here
} 

Você deve converter WorkbookEvents_Event porque o Excel.Workbook.Activate retorna o método Activate e não o evento Activate.

Como alternativa, você pode converter o objeto à sua interface de evento correspondente no Startup:
((Excel.WorkbookEvents_Event)(thisWorkbook)).Activate += new Excel.WorkbookEvents_ActivateEventHandler(ThisWorkbook_Activate); 

Em seguida, escreva um manipulador de eventos para o seu código:

protected void ThisWorkbook_Activate()
{
    // Your code goes here
} 

Excel e o Word fechar inesperadamente quando uma exceção não tratada ocorre em um formulário sem janela restrita

Se o Excel ou Word fecha inesperadamente após um usuário dispara um evento em um formulário sem janela restrita, verificar se há quaisquer locais onde as exceções não tratadas podem ser geradas no código. Adicione tratamento de erros para evitar possível perda de dados.

Para obter mais informações, consulte "Threading suporte no Office" no Visual Studio Tools para Ajuda do Office.

Método Close faz com que o Word e o Excel fechar inesperadamente

Quando você chamar o método Close do objeto Excel pasta de trabalho ou o objeto de documento do Word a partir de um formulário sem janela restrita, o aplicativo pode fechar inesperadamente. Todos os documentos abertos ou pastas de trabalho serão fechada e os dados podem ser perdidos. Se o Microsoft Office Outlook usa o Word como seu editor de email, todos abrem email mensagens também podem fechar. Isso também pode ocorrer se você exibir Windows Forms ou caixas de mensagens ao manipular o evento AppDomain.DomainUnload .

Para contornar esse problema, não chame o método Close de um formulário sem janela restrita ou em um evento para um formulário sem janela restrita. Em vez disso:
  • Usar formulários de janela restrita (por exemplo, usando o formulário .ShowDialog() em vez de .Show()) se você deve fechar o documento a partir do formulário.
  • Se você deve usar um formulário sem janela restrita, certifique-se de que o formulário sem janela restrita está fechado e que as referências do formulário são destruídas completamente antes de tentar fechar o documento ou pasta de trabalho. Por exemplo:
Dim myForm as SomeModelessForm
Sub Open()
   myForm = new SomeModelessForm
   ' Show form modelessly.
   myForm.Show()
End Sub

Sub ForceShutdown()
   ' Completely close the form if it is still running.
   ' Note that hiding the form might not work by itself.
   If (Not myForm Is Nothing) Then
      myForm.Close()
      myForm.Dispose()
      myForm = Nothing
   End If
   ThisDocument.Close()
End Sub 
Para obter mais informações, consulte "Threading suporte no Office" no Visual Studio Tools para Ajuda do Office.

Documento é aberto no modo de design em tempo de execução

Quando você hospeda um controle ActiveX em um documento do Word, o documento do Word será aberto no modo de design se o Visual Basic for Applications, segurança de macro (VBA) é definido como alto e o projeto do VBA não está assinado digitalmente. Para corrigir esse problema, modifique o projeto para inicializar o private Boolean variável, toggleActiveXControls, como verdadeiro (toggleActiveXControls está incluído nos modelos de projeto). Isso fará com que o controle ActiveX alternar do modo de design quando o documento é aberto.

Chamadas COM Excel podem falhar em algumas localidades do cliente

Os aplicativos do Excel podem ser distribuídos para máquinas clientes com diferentes localidades do usuário. Sob certas condições, isso pode resultar em erros de conversão de dados ou tempo de execução. Para evitar esses erros e garantir uma funcionalidade consistente entre localidades, você deve seguir as diretrizes de desenvolvimento específico.

Para obter mais informações, consulte "Globalização e localização de soluções do Office" no Visual Studio Tools para Ajuda do Office.

Confiança total não é concedida automaticamente a projetos criados em um local de rede

Se você cria um projeto e especifique um local de rede para o documento, você verá uma caixa de diálogo perguntando se você deseja conceder confiança total ao assembly. No entanto, mesmo se você clicar em Sim para conceder confiança total, você não tem permissões suficientes para executar seu projeto. Um administrador deve definir diretiva de segurança para confiar em assembly e o documento no nível do computador antes que o projeto será executado. Para obter mais informações, consulte "Você tiver especificado um local de rede para o documento e escolhido para o local do assembly de confiança, deixando a opção selecionada na guia Configurações de segurança do Microsoft Office Project Wizard" no Visual Studio Tools para Ajuda do Office.

Eventos não são gerados em documentos hospedados em outros documentos ou contêineres de ActiveX

Documentos do Office contidos em outros documentos usando OLE não podem disparar eventos quando eles são ativados ou abertos. Da mesma forma, se um documento do Office estiver hospedado em alguns recipientes ActiveX, ele não pode disparar eventos. O contêiner ActiveX único que tem suporte para hospedar documentos com extensões de código gerenciado é o Microsoft Internet Explorer 6. x.

Se você abrir um documento do Office no Internet Explorer 6. x, o comportamento de eventos gerados na sua extensão de código gerenciado será o mesmo gerado em um projeto do VBA quando o documento está hospedado no Internet Explorer. Devido à natureza da hospedagem de documento ActiveX, alguns comandos nos aplicativos do Excel ou Word estará disponíveis. Da mesma forma, certos eventos não deverão ser gerados quando um documento ou pasta de trabalho está contida em um host de documento ActiveX como o Internet Explorer (por exemplo: no Word, mala direta eventos e eventos de janela como WindowActivate não estão disponíveis; no Excel, você não pode cancelar o fechamento com o manipulador de evento BeforeClose ).

Normal. dot for corrompido ou aumenta o tamanho inesperadamente

Se você utiliza o comando do Depurador parar no Visual Studio .NET de finalizar a depuração de seus projetos do Word, você poderá ter problemas com o modelo normal. dot. Para minimizar essa possibilidade, use Detach All para finalizar a depuração em vez de usar o Depurador parare, em seguida, saia do Word por meio da interface de usuário do Word usando os procedimentos normais.

Assemblies de interoperabilidade primária não devem ser incluídos em projetos de instalação

Exclua manualmente os assemblies de interoperabilidade primários da Office referenciados por sua solução quando você cria um projeto de implantação. Usuários finais devem ter instalado a partir da mídia de instalação original do Office no cache global de assemblies (GAC) PIAs do Office em seus computadores antes de usar a solução. Se sua solução implanta cópias adicionais dos PIAs, ele poderá causar problemas nos computadores dos usuários finais. Para obter mais informações, consulte "Como para: instalar o Office Assemblies de interoperabilidade primários" no Visual Studio Tools para Ajuda do Office.



Alterações de última hora

Projetos de pasta de trabalho do Excel ainda funcionam depois de salvar como modelos

Não há nenhum projeto de modelo do Excel entre os projetos do Microsoft Office 2003. No entanto, se você cria um projeto de pasta de trabalho do Excel com as extensões de código gerenciado e, em seguida, salve a pasta de trabalho como um modelo (*. xlt), o modelo pode ser usado para criar novas pastas de trabalho que aponte para o mesmo assembly gerenciado.

Opção de configurações de segurança para o projeto pode ser alterada

Quando você cria um projeto, o Microsoft Office Project Wizard inclui uma guia de Configurações de segurança que permite que você selecione se deseja que o Visual Studio .NET para conceder confiança total com base no local para o seu assembly em tempo de compilação. Por padrão, essa opção é selecionada para que seja concedida confiança total. Você pode alterar a seleção posterior (após ter concluído o assistente e a qualquer momento enquanto você desenvolve seu projeto), alterando um atributo no arquivo. vbproj ou. csproj para o projeto.

Para alterar sua opção de configurações de segurança
  1. Abra o arquivo. vbproj ou. csproj para o projeto.
  2. Encontre o nó UserProperties .
  3. Adicionar ou remover o atributo chamado TrustedAssembly.
    • Para conceder confiança total em tempo de compilação, adicione o atributo TrustedAssembly ao nó UserProperties e defini-la como o caminho para o assembly. Por exemplo:
      <UserProperties
         OfficeDocumentPath = ".\PROJECT1.XLS"
         OfficeProjectType = "XLS"
         OfficeProject = "true"
         TrustedAssembly = "C:\projects\project1\project1_bin\project1.dll"
      /> 
      
    • Para interromper a conceder confiança total em tempo de compilação, remova o atributo TrustedAssembly .



Amostras de desenvolvimento do Office

Soluções de exemplo que você pode abrir no Visual Studio .NET de estão incluídas no Visual Studio Tools para Ajuda do Office. Na janela conteúdo , eles estão localizados no nó exemplos e explicações passo a passo no nó de programação com o Office . Você também pode procurar no índice .NET do Visual Studio em exemplos, automatizar o Excel e exemplos, automatizar o Word. Cada página de exemplo inclui instruções passo a passo para criar e executar a amostra.

Alguns dos exemplos requerem um banco de dados do Microsoft SQL Server Desktop Engine (MSDE). Um script e arquivos de dados são fornecidos com o exemplo para criar o banco de dados automaticamente.

Dados de exemplo do Excel não instala no local padrão

Para instalar o banco de dados para alguns dos exemplos do Excel, você deve executar um script de instalação (bat). Se o caminho para o script de instalação do banco de dados contiver um espaço, o banco de dados não é criado e desaparece da janela do prompt de comando. Aparece o seguinte erro no database.log, que está localizado em
<root drive>\Documents and Settings\<user name>\Local Settings\Temp:
Erro de análise XML: inválido no nível superior do documento.
Para corrigir esse problema:
  1. Clique em Carregar exemplo de solução ou Copiar todos os arquivos no tópico de exemplo. Uma caixa de diálogo é exibida solicitando que você selecione um local para os arquivos de exemplo.
  2. Selecione o diretório raiz ou um diretório sem espaços no caminho. Os arquivos de exemplo são copiados para uma subpasta do local em que você selecionar: <selected location="">\Samples\Office Projects\<sample name=""> </sample> </selected>
  3. Move a pasta ExcelSampleDatabase do .\Samples\Office Projects\<sample name=""> pasta até dois níveis para a. pasta \Samples, para que ele não está mais sob o diretório de projetos do Office. </sample>
  4. Execute o bat na pasta ExcelSampleDatabase para criar o banco de dados de exemplo.

Os exemplos seguintes usam o banco de dados de exemplo do Excel:
  • Usando o ADO.NET exemplo (ExcelReadWriteADO) de planilha do Excel
  • Planilha do Excel com exemplo de texto personalizado (ExcelReadCustomUser)
  • Planilha do Excel usando um exemplo de formulário do Windows (ExcelReadWinForm)

Exemplos do Excel podem retornar um erro quando executado no Windows 2000

A seguinte mensagem de erro pode aparecer no arquivo database.log ao executar o bat para o banco de dados de exemplo do Excel:
Falha ao carregar Msxml2
Essa mensagem de erro pode aparecer quando você executar o exemplo de estimativas:
Referência de objeto não definida para uma instância de um objeto.
Se seu computador estiver executando um sistema operacional Windows 2000 e tiver instalado o MSDE SP3 ou SP3a, seu computador talvez não tenha o arquivo MSXML2.DLL, que é necessário para alguns dos exemplos para executar com êxito.

Para corrigir esse problema, instale e registre MSXML2.DLL. Consulte o seguinte artigo na Base de dados de Conhecimento da Microsoft para obter detalhes sobre como você pode obter MSXML2:
CORREÇÃO: O MSXML 2.6 não é redistribuído com o SQL Server MSDE SP3 ou SP3a

Conexões de banco de dados podem retornar um erro

Quando você executa os exemplos que usam um banco de dados, você pode ver esta mensagem:
SQL Server não existe ou acesso negado
Se o protocolo TCP/IP não está habilitado para a instalação do SQL Server, você será capaz de acessar o SQL Server com o nome localhost e o erro será exibida. Para corrigir esse problema, altere o nome do servidor na conexão do ADO.NET para ambos (local) ou o nome do seu servidor.

Por exemplo, uma seqüência de conexão, como a seguir:
dbConn = New SqlConnection("Integrated Security=SSPI;" & _ 
    "Initial Catalog=ExcelSample;Data Source=localhost")
Deve ser alterada para:
dbConn = New SqlConnection("Integrated Security=SSPI;" & _ 
    "Initial Catalog=ExcelSample;Data Source=(local)")
Os seguintes exemplos de referência do SQL Server como localhost em uma seqüência de caracteres de conexão ADO.NET:
  • Usando o ADO.NET exemplo (ExcelReadWriteADO) de planilha do Excel
  • Planilha do Excel com exemplo de texto personalizado (ExcelReadCustomUser)
  • Planilha do Excel usando um exemplo de formulário do Windows (ExcelReadWinForm)
  • Exemplo de estimativas

Tópico de exemplo de estimativas pode mostrar mensagens de erro

Quando você abre o tópico de exemplo de estimativas, você poderá ver esta mensagem:
'filhos' é nulo ou não um objeto. O Visualizador de exemplo é capaz de localizar essas informações de exemplo. Verifique a instalação da Ajuda.
Esta mensagem é mostrada erroneamente; Não há nenhum problema com o exemplo. Essa mensagem pode aparecer várias vezes. Clique em OK sempre. Quando a mensagem pára que aparecem, você pode trabalhar com o exemplo de estimativas como de costume.



Onde encontrar mais informações

Ajudam do Visual Studio Tools for Office

Durante a instalação, o Visual Studio Tools para Ajuda do Office está integrado com a Ajuda do Visual Studio .NET se você tiver a fevereiro de 2003 da Biblioteca MSDN em seu computador antes de executar o Visual Studio Tools para o programa de instalação do Office. Fevereiro de 2003 da Biblioteca MSDN é fornecido com o Visual Studio .NET 2003. Se você tiver em julho de 2003 ou posterior da Biblioteca MSDN em seu computador, o Visual Studio Tools for Office ajuda é incluído no nó da Biblioteca MSDN.

Para localizar o Visual Studio Tools para Ajuda do Office na coleção de Ajuda do Visual Studio .NET integrada
  1. No Visual Studio .NET, abra o menu Ajuda e, em seguida, clique em conteúdo.
  2. Na janela conteúdo , expanda o nó do Visual Studio .NET de .
  3. Expanda o nó Visual Basic e Visual C# .
  4. Expanda o nó de programação com o Office , que contém todos os Visual Studio Tools para Ajuda do Office.
Para localizar o Visual Studio Tools para Ajuda do Office em julho de 2003 ou posterior da Biblioteca MSDN
  1. No Visual Studio .NET, abra o menu Ajuda e, em seguida, clique em conteúdo.
  2. Na janela conteúdo , expanda o da Biblioteca MSDN - <July 2003="" or="" later=""></July> nó.
  3. Expanda o nó de Desenvolvimento .NET .
  4. Expanda o nó .NET do Visual Studio .
  5. Expanda o nó de Documentação do produto .
  6. Expanda o nó Visual Basic e Visual C# .
  7. Expanda a programação com o nó do Office, que contém todos os Visual Studio Tools para Ajuda do Office.
Procurando por ajuda

Na janela resultados da pesquisa no .NET do Visual Studio, o local para o Visual Studio Tools for Office ajuda aparece como conceitos de programação do Office.

Instalando o MSDE a partir da mídia de instalação do Office 2003

Alguns dos exemplos de desenvolvimento do Office que acompanha o Visual Studio Tools for Office têm scripts de instalação do banco de dados que assumem que o Microsoft SQL Server Desktop Engine (MSDE) está instalado no host local.

MSDE está incluído na mídia de instalação do Office 2003. Ele não pode ser instalado usando Adicionar ou remover programas, depois de ter instalado o Office 2003. Para instalar o MSDE, você deve ter a mídia de instalação original.

Para instalar o MSDE da mídia de instalação do Office 2003
  1. Na mesma pasta de instalação Office como Setup.exe, localize a subpasta MSDE2000. Esta pasta contém os componentes de instalação do MSDE.
  2. Para obter informações de instalação, consulte os Manuais Online do SQL Server. A documentação do mecanismo de banco de dados no SQL Server Books Online também se aplica ao MSDE 2000. Manuais Online do SQL Server aborda a instalação, criação de banco de dados, administração, solução de problemas e desenvolvimento de aplicativos para todas as versões do mecanismo de banco de dados do SQL Server 2000.
  3. Reinicie o computador após a instalação do MSDE para configurar e iniciar os serviços do SQL Server.



Instalando o Internet Information Services (IIS)

Alguns dos exemplos de desenvolvimento do Office que acompanha o Visual Studio Tools for Office incluem os serviços da Web que requerem o Internet Information Services (IIS).

Para instalar o IIS no Windows 2000 ou Windows XP
  1. Desconectar da rede ou certifique-se de que você tenha um firewall instalado e em execução.
  2. Para o Windows 2000, no menu Iniciar , escolha as configuraçõese, em seguida, escolha Painel de controle.
    Para o Windows XP e posterior, no menu Iniciar , escolha Painel de controle.
  3. No painel de controle, escolha Adicionar ou remover programas e, em seguida, escolha Add/Remove Windows Components.
  4. No Assistente de componentes do Windows, selecione Internet Information Services (IIS) na lista de componentes .
  5. Clique em Avançar para iniciar a instalação.
  6. Após a instalação estiver concluída, pare o serviço do IIS.
  7. Baixar atualizações do Windows Update (http://www.windowsupdate.com).
  8. Reinicie, se necessário e iniciar o serviço do IIS.
  9. Retorne para adicionar ou remover programas.
  10. Selecione o produto Visual Studio .NET de que você instalou e, em seguida, escolha Alterar.
  11. Reinstale o produto .NET do Visual Studio.



© Microsoft Corporation. Todos os direitos reservados.

Propriedades

ID do artigo: 828087 - Última revisão: quinta-feira, 30 de maio de 2013 - Revisão: 6.0
A informação contida neste artigo aplica-se a:
  • Microsoft Visual Studio Tools for the Microsoft Office System version 2003
Palavras-chave: 
kbreadme kbmt KB828087 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido pelo software de tradução automática da Microsoft e eventualmente pode ter sido editado pela Microsoft Community através da tecnologia Community Translation Framework (CTF) ou por um tradutor profissional. A Microsoft oferece artigos traduzidos automaticamente por software, por tradutores profissionais e editados pela comunidade para que você tenha acesso a todos os artigos de nossa Base de Conhecimento em diversos idiomas. No entanto, um artigo traduzido pode conter erros de vocabulário, sintaxe e/ou gramática. A Microsoft não é responsável por qualquer inexatidão, erro ou dano causado por qualquer tradução imprecisa do conteúdo ou por seu uso pelos nossos clientes.
Clique aqui para ver a versão em Inglês deste artigo: 828087

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com