Un paquete asignado se reinstala cada vez que los clientes inician sesión en el dominio

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Síntomas

Cuando se crea un objeto de directiva de grupo para asignar un paquete a los usuarios en su dominio y, a continuación, hace clic para activar la casilla de verificación instalar esta aplicación en el inicio de sesión en la ficha instalación de dicho paquete, el paquete se reinstala en equipos cliente de Microsoft Windows XP Professional cada vez que los usuarios inicien sesión en el dominio.

No esperan que el paquete a instalarse cada vez que los usuarios inicien sesión en el dominio.

Causa

Este problema ocurre cuando se cumplen las dos condiciones siguientes:
  • Los usuarios del dominio están configurados con perfiles móviles de usuario.
  • El dominio o unidad organizativa donde se encuentran los usuarios tiene una directiva de grupo está configurado para quitar las copias en caché de perfiles móviles.
Este problema se produce porque cuando configura una directiva para quitar copias en caché de perfiles móviles, la función de DeleteProfile se llama para eliminar todos los valores de relacionados con el usuario y para quitar la información de paquete de Microsoft Windows Installer por usuario de la siguiente ubicación de carpeta cuando el usuario cierra sesión:
System32\AppMgmt\ User-SID
Cuando el usuario siguiente inicia sesión en el dominio, otro relacionado con la información en el subárbol del registro del usuario se descarga desde el servidor que está almacenado el perfil móvil de Windows Installer. El motor de instalación del programa, a continuación, vuelve a instalar el paquete asignado que coincide con la información en el subárbol del registro del usuario.

Solución

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Debe estar ejecutando Windows XP Service Pack 1 (SP1) para instalar este hotfix. Para obtener información adicional sobre cómo obtener el Service Pack 1 de Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el Windows XP Service Pack más reciente

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información del archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

Windows XP

   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   22-Oct-2003  03:47  5.1.2600.1266    313,856  Cscui.dll
   12-Sep-2003  17:34                 1,515,616  System.adm
   22-Oct-2003  03:47  5.1.2600.1267    672,768  Userenv.dll

Windows XP 64-Bit Edition

   Date         Time   Version        Size       File name     Platform
   --------------------------------------------------------------------
   22-Oct-2003  04:04  5.1.2600.1266    688,640  Cscui.dll     IA-64
   12-Sep-2003  18:35                 1,515,616  System.adm
   22-Oct-2003  04:04  5.1.2600.1267  1,708,032  Userenv.dll   IA-64
   22-Oct-2003  04:47  5.1.2600.1266    313,856  Wcscui.dll    x86
   22-Oct-2003  04:47  5.1.2600.1267    672,768  Wuserenv.dll  x86
Después de instalar este hotfix, un nuevo grupo de configuración de directiva está disponible. Con esta configuración, puede evitar que Windows Installer información desde que se va a quitar. Para habilitar esta opción en un equipo cliente, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba gpedit.msc en el cuadro Abrir y, a continuación, haga clic en Aceptar .
  2. Expanda Configuración del equipo , expanda Plantillas administrativas , expanda sistema y, a continuación, haga clic en Perfiles de usuario .
  3. En el panel derecho, haga doble clic en Windows mantener datos de Installer y grupo de directiva software instalación .
  4. Haga clic en habilitada y, a continuación, haga clic en Aceptar .
Nota Después de aplicar esta configuración de directiva de grupo, el paquete asignado está instalado de nuevo cuando el usuario inicie sesión primero en la red. Este comportamiento se produce porque la información de Windows Installer se quitan de la sesión del usuario por última vez. Sin embargo, el paquete asignado no se reinstalará durante los posteriores inicios de sesión.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en el Service Pack 2 de Microsoft Windows XP.

Más información

Después de instalar esta revisión y, a continuación, configurar el nuevo comportamiento mediante Directiva de grupo, el comportamiento de DeleteProfile ha cambiado. DeleteProfile ya no quita la información de instalación de programa. Esto significa que nunca se quita la información de instalación del programa, incluso si un determinado usuario nunca inicia una sesión en el equipo cliente nuevo. Esta revisión proporciona una nueva plantilla System.adm para equipos cliente Windows XP. Se cambia la siguiente parte de la plantilla de .adm:
CATEGORY !!AdministrativeServices

 

POLICY !!LeaveAppMgmtData

#if version >= 4

SUPPORTED !!SUPPORTED_WindowsXPSP2

#endif

 

EXPLAIN !!LeaveAppMgmtData_Help

KEYNAME "Software\Policies\Microsoft\Windows\System"

VALUENAME "LeaveAppMgmtData"

END POLICY

puede agregar esta información para una plantilla .adm existente en el controlador de dominio o puede utilizar este código para crear una plantilla .adm personalizados. Microsoft recomienda que no modifique los archivos de plantilla de .adm existentes, porque estos archivos podrían actualizar un futuro service pack. En este escenario, puede perder los cambios a estos archivos. Agregar esta información a un archivo .adm, también debe incluir la información de texto de Ayuda siguiente en el [strings] sección del archivo:
LeaveAppMgmtData="Leave Windows Installer and Group Policy Software Installation Data"
LeaveAppMgmtData_Help="Determines whether the system retains a roaming user?s Windows Installer and Group Policy based software installation data on their profile deletion.\n\nBy default User profile deletes all information related to a roaming user (which includes the user?s settings, data, Windows Installer related data etc.) when their profile is deleted. As a result, the next time a roaming user whose profile was previously deleted on that client logs on, they will need to reinstall all apps published via policy at logon increasing logon time. You can use this policy to change this behavior.\n\nIf you enable this setting, Windows will not delete Windows Installer or Group Policy software installation data for roaming users when profiles are deleted from the machine. This will improve the performance of Group Policy based Software Installation during user logon when a user profile is deleted and that user subsequently logs on to the machine.\n\nIf you disable or do not configure this policy, Windows will delete the entire profile for roaming users, including the Windows Installer and Group Policy software installation data when those profiles are deleted.\n\nNote: If this policy is enabled for a machine, local administrator action is required to remove the Windows Installer or Group Policy software installation data stored in the registry and file system of roaming users? profiles on the machine."
SUPPORTED_WindowsXPSP2="At least Microsoft Windows XP Pro with SP2"
Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 828452 - Última revisión: sábado, 01 de diciembre de 2007 - Versión: 3.3
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB828452 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 828452

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