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Article ID: 828535 - Last Review: November 24, 2006 - Revision: 3.3

"ErrNo: C7FF1004" Error Message and Event ID 481 Is Logged When You Use the Msdmback.vbs Tool to Back Up SharePoint Portal Server

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SYMPTOMS

When you use the Msdmback.vbs tool to back up Microsoft SharePoint Portal Server 2001, the backup operation does not complete successfully. The following error message is logged to the backup log file:
ErrNo: C7FF1004
Desc: Automation error
Additionally, event ID error messages that are similar to the following messages are logged to the application event log:

Type: Error
Source: ESE
Category: General
Event ID: 481
Description:
Information Store (864) An attempt to read from the file "C:\Program Files\SharePoint Portal Server\Data\Web Storage System\wss.stm" at offset 0 (0x0000000000000000) for 65536 (0x00010000) bytes failed with system error 87 (0x00000057): " The parameter is incorrect.". The read operation will fail with error -1003 (0xfffffc15). If this error persists then the file may be damaged and may need to be restored from a previous backup. For more information, click http://search.support.microsoft.com/search/?adv=1.

Type: Error
Source: ESE
Category: Logging/Recovery
Event ID: 217
Description:
Information Store (864) SharePoint Portal Server Group: Error (-1003) during backup of a database (file C:\Program Files\SharePoint Portal Server\Data\Web Storage System\wss.stm). The database will be unable to restore.

Type: Error
Source: ESE
Category: Logging/Recovery
Event ID: 215
Description:
Information Store (864) SharePoint Portal Server Group: The backup has been stopped because it was halted by the client or the connection with the client failed.

Type: Error
Source: Microsoft Search
Category: Gatherer
Event ID: 3076
Description:
An error occurred during backup of the application. You may be unable to restore from the backup image.

Context: SharePointPortalServer Application

CAUSE

This issue may occur if TCP/IP filtering is enabled on the server. For example, this issue may occur if you enable TCP/IP filtering with the following configuration:
  • You permit the use of only the following TCP ports:
    • 25
    • 80
    • 135
    • 139
    • 443
    • 445
    • 3389
  • You permit the use of all User Datagram Protocol (UDP) ports
  • You permit the use of all Internet Protocol (IP) protocols.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you have installed SharePoint Portal Server 2001 Service Pack 3 or a later service pack, you do not have to apply the hotfix.

Service pack information

This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2001. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
312963  (http://support.microsoft.com/kb/312963/ ) How to obtain the latest SharePoint Portal Server 2001 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size    File name
   --------------------------------------------------
    22-Sep-2003  21:24  6.5.6920.0        301,568  Eseback2.dll     
   22-Sep-2003  21:24  6.5.6920.0        250,880  Esebcli2.dll     
				
Note Because of file dependencies, this update requires SharePoint Portal Server 2001 Service Pack 2a (SP2a).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was first corrected in SharePoint Portal Server 2001 Service Pack 3.

MORE INFORMATION

For additional information about how to use the Msdmback.vbs tool to back up SharePoint Portal Server, click the following article number to view the article in the Microsoft Knowledge Base:
281413  (http://support.microsoft.com/kb/281413/ ) How to Back Up a SharePoint Portal Server

APPLIES TO
  • Microsoft SharePoint Portal Server 2001
Keywords: 
kbautohotfix kbhotfixserver kbshareptportalsvr2001sp3fix kbqfe kbshareptportalsvr2001presp2fix kbfix kbbug KB828535

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