ターミナル サービス情報が破損している場合、アクセス違反エラーが発生します。

文書翻訳 文書翻訳
文書番号: 828664
すべて展開する | すべて折りたたむ

目次

現象

Tsprof.exe、Mmc.exe、Usrmgr.exe をなど、ターミナル サービス管理ユーティリティを実行するとユーティリティがアクセス違反エラーが発生、特定のユーザー アカウントを管理するときに予期せず終了可能性があります。

API 関数を使用する任意のプログラムを実行すると WTSSetUserConfig または WTSQueryUserConfig 設定またはユーザー情報を取得するには、ユーティリティ可能性があります、アクセス違反エラーが発生し、突然終了する場合、特定のユーザー アカウントを管理します。

リモート デスクトップ接続を行い、特定のユーザー アカウントでログオンしようとすると、リモート デスクトップ接続が突然終了可能性があります。リモート デスクトップ ベースのログオンしようとすると、Microsoft Windows XP ベースのコンピューターに Winlogon が予期せずに終了すると、コンソールの Microsoft Windows Server 2003 ベースのコンピューターにリモート デスクトップ コンピューターがバグチェックされますか。構成によっては、リモート デスクトップ コンピューターを再起動可能性があります。

1 つまたは複数、次のイベントがイベント ログに記述があります。

イベント ID: 1004
ソース アプリケーションのエラー
キュー エラーの報告: エラーが発生したアプリケーション mmc.exe、バージョン 5.2.3790.0 の障害モジュール tsuserex.dll、バージョン 5.2.3790.0、エラー アドレス 0x0000c3a9。

イベント ID: 1004
ソース アプリケーションのエラー
キュー エラーの報告: エラーが発生したアプリケーション mmc.exe、バージョン 5.2.3790.0 の障害モジュール tsuserex.dll、バージョン 5.2.3790.0、エラー アドレス 0x0000c3a9。

イベント ID: 1004
ソース アプリケーションのエラー
キュー エラーの報告: エラーが発生したアプリケーション mmc.exe、バージョン 5.2.3790.0 の障害モジュール tsuserex.dll、バージョン 5.2.3790.0、エラー アドレス 0x0000c3a9。

イベント ID: 1004
ソース アプリケーションのエラー
アプリケーションは、エラー発生モジュール regapi.dll、バージョン 5.2.3790.0、エラー アドレス 0x00002c4d を。 バージョン 0.0.0.0、フォールトします。

イベント ID: 1004
ソース アプリケーションのエラー
キュー エラーの報告: エラーが発生したアプリケーションの winlogon.exe のバージョン 0.0.0.0、フォールト モジュール regapi.dll、バージョン 5.2.3790.0、エラー アドレス 0x00002c4d。

イベント ID 1001
ソース アプリケーションのエラー
エラー発生バケット 62739595。

イベント ID 1001
ソース アプリケーションのエラー
45054588.

原因

この問題が破損している場合ユーザー データが発生発生します。

解決方法

Windows Server 2003 の修正プログラム情報

サポートされている修正プログラムがマイクロソフトから入手可能です。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストを受け取ることがあります。したがって、この問題で深刻な影響をされていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

この修正プログラムがダウンロードできないか場合は、この記事の上部に「修正プログラムのダウンロード」セクションです。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポート修正プログラムを入手するに問い合わせてください。

メモ その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームに修正プログラムが提供されている言語を表示します。お使いの言語が表示されない場合は、修正プログラムがその言語の利用できないためにです。

ファイル情報

この修正プログラムの英語版がファイル属性 (またはそれ以降のファイル属性) が、次のとおり。日付および時刻これらのファイルを世界協定時刻 (UTC) が表示されます。ファイル情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 タイム ゾーン タブ コントロール パネルの日付と時刻ツールでします。

Windows Server 2003 は、32 ビット版

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   19-Aug-2004  23:41  5.2.3790.202       50,176  Regapi.dll
   19-Aug-2004  23:41  5.2.3790.202       81,920  Tsuserex.dll

Windows Server 2003 は、64 ビット エディション

   Date         Time   Version            Size    File name     Platform
   ---------------------------------------------------------------------
   19-Aug-2004  21:37  5.2.3790.202      129,536  Regapi.dll     IA-64
   19-Aug-2004  21:37  5.2.3790.202      223,744  Tsuserex.dll   IA-64
   19-Aug-2004  21:41  5.2.3790.202       50,176  Wregapi.dll    x86
   19-Aug-2004  21:41  5.2.3790.202       81,920  Wtsuserex.dll  x86

Windows XP のサービス パックの情報

この問題を解決するには、Windows XP 用の最新の service pack を入手します。詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
322389 Windows XP の最新の service pack を入手する方法

Windows XP 修正プログラムの情報

サポートされている修正プログラムがマイクロソフトから入手可能です。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストを受け取ることがあります。したがって、この問題で深刻な影響をされていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

この修正プログラムがダウンロードできないか場合は、この記事の上部に「修正プログラムのダウンロード」セクションです。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポート修正プログラムを入手するに問い合わせてください。

メモ その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームに修正プログラムが提供されている言語を表示します。お使いの言語が表示されない場合は、修正プログラムがその言語の利用できないためにです。

ファイル情報

この修正プログラムの英語版がファイル属性 (またはそれ以降のファイル属性) が、次のとおり。日付および時刻これらのファイルを世界協定時刻 (UTC) が表示されます。ファイル情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 タイム ゾーン タブ コントロール パネルの日付と時刻ツールでします。

Windows XP は、32 ビット版

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Sep-2003  18:30  5.1.2600.1254      32,768  Cfgbkend.dll
   10-Sep-2003  18:30  5.1.2600.1254      30,720  Pchsvc.dll
   10-Sep-2003  18:30  5.1.2600.1254      33,280  Racpldlg.dll
   10-Sep-2003  18:30  5.1.2600.1267      44,544  Regapi.dll
   10-Sep-2003  18:30  5.1.2600.1254      41,472  Safrslv.dll
   02-Aug-2003  07:45  5.1.2600.1254     129,536  Sessmgr.exe
   10-Sep-2003  18:30  5.1.2600.1254     200,192  Termsrv.dll
   10-Sep-2003  18:30  5.1.2600.1254      88,064  Tscfgwmi.dll

Windows XP 64 ビット エディション

   Date         Time   Version            Size    File name     Platform
   ----------------------------------------------------------------------
   10-Sep-2003  17:38  5.1.2600.1254     104,448  Cfgbkend.dll  IA-64
   10-Sep-2003  17:38  5.1.2600.1254     110,080  Pchsvc.dll    IA-64
   10-Sep-2003  17:38  5.1.2600.1254      90,112  Racpldlg.dll  IA-64
   10-Sep-2003  17:38  5.1.2600.1267     127,488  Regapi.dll    IA-64
   10-Sep-2003  17:38  5.1.2600.1254     111,616  Safrslv.dll   IA-64
   02-Aug-2003  08:44  5.1.2600.1254     419,328  Sessmgr.exe   IA-64
   10-Sep-2003  17:38  5.1.2600.1254     622,592  Termsrv.dll   IA-64
   10-Sep-2003  17:38  5.1.2600.1254     326,144  Tscfgwmi.dll  IA-64
   10-Sep-2003  18:30  5.1.2600.1267      44,544  Wregapi.dll   x86

Windows 2000

サポートされている修正プログラムがマイクロソフトから入手可能です。ただし、この修正プログラムはこの資料に記載されている問題のみを修正するものです。この修正プログラムはこの問題が発生しているシステムにのみ適用されます。この修正プログラムは、今後さらにテストを受け取ることがあります。したがって、この問題で深刻な影響をされていない場合は、この修正プログラムを含む次のソフトウェア更新プログラムのリリースを待つことをお勧めします。

この修正プログラムがダウンロードできないか場合は、この記事の上部に「修正プログラムのダウンロード」セクションです。このセクションが表示されない場合は、マイクロソフト カスタマー サービス & サポート修正プログラムを入手するに問い合わせてください。

メモ その他の問題が発生した場合、またはトラブルシューティングが必要な場合は、別のサービス リクエストを作成する必要があります。追加の質問およびこの特定の修正プログラムの対象とならない問題については、通常のサポート料金が適用されます。一覧マイクロソフト カスタマー サービス & サポートの電話番号のまたは別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームに修正プログラムが提供されている言語を表示します。お使いの言語が表示されない場合は、修正プログラムがその言語の利用できないためにです。

ファイル情報

この修正プログラムの英語版がファイル属性 (またはそれ以降のファイル属性) が、次のとおり。日付および時刻これらのファイルを世界協定時刻 (UTC) が表示されます。ファイル情報を表示すると、ローカル時刻に変換します。UTC とローカル時刻との時差を確認するを使用して、 タイム ゾーン タブ コントロール パネルの日付と時刻ツールでします。
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   07-Jan-2004  20:44  5.0.2195.6889  36,624  Regapi.dll

状況

マイクロソフトでは、この「対象」に記載されているマイクロソフト製品の問題として認識しています。

Windows XP

この問題は Microsoft Windows XP Service Pack 2 で修正されました。

詳細

この資料に記載されている修正プログラムは、破損したデータは修正されません。この修正プログラム プロセスがアクセス違反エラーで予期せず終了する原因とからコードを保護します。

この修正プログラムを適用した後をエラーなしのリモート デスクトップを使用してログオンする、Windows 2000 ベースまたは Windows XP ベースのコンピューターにできないことがあります。ただし、ユーザー アカウントまたはそのアカウントを使用してログオンするときに、プロパティを変更した場合はエラー メッセージを受け取ることがあります。

編集や、ユーザーのプロパティを表示するには、Microsoft 管理コンソール (MMC) を使用すると、次のようなエラー メッセージを受け取ることがあります。
ターミナル サービスのプロパティ
ターミナル サービス ユーザーのプロパティをこのため読み込めませんでした: パラメーターが正しくないです。
または、リモート デスクトップ接続を使用して、Windows Server 2003 ベースのコンピューターにログオンしようとすると、次のようなエラー メッセージを受け取ることがあります。
ログオン メッセージ
システムは、次のエラーのためログオンできませんでした。パラメーターが間違っています。
再試行するか、システム管理者に問い合わせてください。
ターミナル サービスのユーザー データの破損を修正するには、次の手順を実行します。
  1. テキストの次の行でテキスト ファイルを作成場所 ユーザー名 破損している情報で、ユーザー アカウントの名前と場所 ドメイン 自分のドメイン名です。
    dn: CN =ユーザー名を CN = ユーザー、DC =ドメインDC = com
    値: 修正
    削除: userParameters
  2. "Users.txt"ファイルを名前します。
  3. コマンド プロンプトで、ファイルを実行するのには、次のコマンドを入力します。
    Ldifde ? I ? f users.txt
    このコマンドを実行してもプロパティをオフにされ、Active Directory ドメインでの問題を解決します。

    メモ ユーザー アカウントの userParameters 属性をクリアする他のプログラムがあります。プログラム固有の情報が格納されている場合は、再作成する必要があります。たとえば、受ける可能性のあるプログラムは FPNW、RAS、およびすべてのターミナル サービスに固有のユーザー情報です。

関連情報

この資料で使用されている用語の詳細については、Knowledge Base の資料を参照するのには、次の資料番号をクリックしてください。
824684 マイクロソフトのソフトウェア更新プログラムの説明に使用される一般的な用語の説明

プロパティ

文書番号: 828664 - 最終更新日: 2011年7月30日 - リビジョン: 2.0
キーワード:?
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver kbautohotfix kbmt KB828664 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:828664
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com