Er treedt een toegangsfout op als uw Terminal Services-informatie beschadigd is

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 828664 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u een beheerprogramma van Terminal Services, bijvoorbeeld Tsprof.exe, Mmc.exe of Usrmgr.exe uitvoert, genereert het hulpprogramma een toegangsfout en wordt het programma onverwacht afgesloten tijdens het beheren van bepaalde gebruikersaccounts.

Wanneer u een programma uitvoert dat gebruikmaakt van de API-functies van WTSSetUserConfig of WTSQueryUserConfig voor het instellen of ophalen van gebruikersgegevens, kan het hulpprogramma een toegangsfout genereren en onverwacht worden afgesloten bij het beheren van bepaalde gebruikersaccounts.

Wanneer u een verbinding met een extern bureaublad maakt en u zich probeert aan te melden met een bepaalde gebruikersaccount, wordt de verbinding met het externe bureaublad plotseling verbroken. Als u zich vanaf een extern bureaublad hebt proberen aan te melden bij een computer met Microsoft Windows XP of een consolecomputer met Microsoft Windows Server 2003, wordt op de externe-bureaubladcomputer een foutcontrole uitgevoerd nadat Winlogon onverwacht is afgesloten. Afhankelijk van de configuratie wordt de externe-bureaubladcomputer opnieuw opgestart.

Een of meer van de volgende gebeurtenissen kunnen worden vastgelegd in het gebeurtenislogboek:

Gebeurtenis-ID 1004
Fout in de brontoepassing
Rapport over fout in wachtrij: vastgelopen toepassing: mmc.exe, versie: 5.2.3790.0, vastgelopen module: tsuserex.dll, versie: 5.2.3790.0, vastgelopen op: 0x0000c3a9.

Gebeurtenis-id 1004
Fout in de brontoepassing
Rapport over fout in wachtrij: vastgelopen toepassing: mmc.exe, versie: 5.2.3790.0, vastgelopen module: tsuserex.dll, versie: 5.2.3790.0, vastgelopen op: 0x0000c3a9.

Gebeurtenis-id 1004
Fout in de brontoepassing
Rapport over fout in wachtrij: vastgelopen toepassing: mmc.exe, versie: 5.2.3790.0, vastgelopen module: tsuserex.dll, versie: 5.2.3790.0, vastgelopen op: 0x0000c3a9.

Gebeurtenis-ID 1004
Fout in de brontoepassing
vastgelopen toepassing: , versie: 0.0.0.0, vastgelopen module: regapi.dll, versie: 5.2.3790.0 vastgelopen op: 0x00002c4d.

Gebeurtenis-ID 1004
Fout in de brontoepassing
Rapport over fout in wachtrij: vastgelopen toepassing: winlogon.exe, versie: 0.0.0.0, vastgelopen module: regapi.dll, versie: 5.2.3790.0 vastgelopen op: 0x00002c4d.

Gebeurtenis-ID 1001
Fout in de brontoepassing
Foutbucket 62739595

Gebeurtenis-ID 1001
Fout in de brontoepassing
Foutbucket 45054588

Oorzaak

Dit probleem treedt op wanneer er beschadigde gebruikersgegevens worden gevonden.

Oplossing

Informatie over Windows Server 2003-hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet voor die taal beschikbaar.

Bestandsgegevens

De Engelse versie van deze hotfix heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere bestandskenmerken). De datums en tijden voor deze bestanden worden weergegeven in UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar de lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van het onderdeel Datum en tijd in het Configuratiescherm.

Windows Server 2003 32-bits edities

   Datum       Tijd   Versie         Grootte    Bestandsnaam
   -----------------------------------------------------------
   19-aug-2004  23:41  5.2.3790.202       50.176  Regapi.dll
   19-aug-2004  23:41  5.2.3790.202       81.920  Tsuserex.dll

Windows Server 2003 64-bits edities

   Datum         Tijd   Versie      Grootte     Bestandsnaam    Platform
   ---------------------------------------------------------------------
   19-aug-2004  21:37  5.2.3790.202      129.536  Regapi.dll     IA-64
   19-aug-2004  21:37  5.2.3790.202      223.744  Tsuserex.dll     IA-64
   19-aug-2004  21:41  5.2.3790.202       50.176  Wregapi.dll    x86
   19-aug-2004  21:41  5.2.3790.202       81.920  Wtsuserex.dll    x86

Informatie over servicepacks voor Windows XP

U kunt dit probleem oplossen met het meest recente servicepack voor Windows XP. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
322389 Het meest recente service pack voor Windows XP ophalen

Informatie over Windows XP-hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet voor die taal beschikbaar.

Bestandsgegevens

De Engelse versie van deze hotfix heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere bestandskenmerken). De datums en tijden voor deze bestanden worden weergegeven in UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar de lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van het onderdeel Datum en tijd in het Configuratiescherm.

Windows XP, 32-bits edities

   Datum       Tijd   Versie         Grootte    Bestandsnaam
   --------------------------------------------------------------
   10-sep-2003  18:30  5.1.2600.1254      32.768  Cfgbkend.dll
   10-sep-2003  18:30  5.1.2600.1254      30.720  Pchsvc.dll
   10-sep-2003  18:30  5.1.2600.1254      33.280  Racpldlg.dll
   10-sep-2003  18:30  5.1.2600.1267      44.544  Regapi.dll
   10-sep-2003  18:30  5.1.2600.1254      41.472  Safrslv.dll
   02-aug-2003  07:45  5.1.2600.1254     129.536  Sessmgr.exe
   10-sep-2003  18:30  5.1.2600.1254      200.192  Termsrv.dll
   10-sep-2003  18:30  5.1.2600.1254      88.064  Tscfgwmi.dll

Windows XP, 64-bits edities

   Datum         Tijd   Versie      Grootte     Bestandsnaam    Platform
   ----------------------------------------------------------------------
   10-sep-2003  17:38  5.1.2600.1254     104.448  Cfgbkend.dll  IA-64
   10-sep-2003  17:38  5.1.2600.1254     110.080  Pchsvc.dll  IA-64
   10-sep-2003  17:38  5.1.2600.1254     90.112  Racpldlg.dll  IA-64
   10-sep-2003  17:38  5.1.2600.1267     127.488  Regapi.dll  IA-64
   10-sep-2003  17:38  5.1.2600.1254     111.616  Safrslv.dll  IA-64
   02-aug-2003  08:44:00  5.1.2600.1254     419.328  Sessmgr.dll  IA-64
   10-sep-2003  17:38  5.1.2600.1254     622.592  Termsrv.dll  IA-64
   10-sep-2003  17:38  5.1.2600.1254     326.144  Tscfgwmi.dll  IA-64
   10-sep-2003  18:30  5.1.2600.1267      44.544  Wregapi.dll   x86

Windows 2000

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter alleen bedoeld als oplossing van het probleem dat in dit artikel wordt beschreven. Voer deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet. Deze hotfix moet mogelijk extra worden getest. Als u geen ernstige problemen ondervindt, raadt Microsoft u daarom aan te wachten op de volgende update waarin deze hotfix is opgenomen.

Als de hotfix kan worden gedownload, is aan het begin van dit Knowledge Base-artikel een sectie 'Hotfix kan worden gedownload' opgenomen. Als een dergelijke sectie niet aanwezig is, kunt u de hotfix aanvragen bij de klantondersteuning van Microsoft.

Opmerking Als er nog andere problemen optreden of als er oplossingen vereist zijn, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking komen voor deze specifieke hotfix. Bezoek de volgende website van Microsoft voor een volledige lijst met telefoonnummers van de klantondersteuning van Microsoft of om een afzonderlijk serviceverzoek te maken:
http://support.microsoft.com/contactus/?ws=support
Opmerking Op het formulier 'Hotfix kan worden gedownload' zijn de talen vermeld waarvoor de hotfix beschikbaar is. Als uw taal daar niet bij staat, is de hotfix niet voor die taal beschikbaar.

Bestandsgegevens

De Engelse versie van deze hotfix heeft de bestandskenmerken die in de volgende tabel worden weergegeven (of recentere bestandskenmerken). De datums en tijden voor deze bestanden worden weergegeven in UTC-notatie (Coordinated Universal Time). Wanneer u de bestandsinformatie weergeeft, wordt deze naar de lokale tijd geconverteerd. Als u het verschil tussen UTC en lokale tijd wilt bepalen, gebruikt u het tabblad Tijdzone van het onderdeel Datum en tijd in het Configuratiescherm.
   Datum       Tijd   Versie         Grootte    Bestandsnaam
   ------------------------------------------------------
   07-jan-2004  20:44  5.0.2195.6889  36.624  Regapi.dll

Status

Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Windows XP

In Microsoft Windows XP Service Pack 2 is voor het eerst een correctie opgenomen voor dit probleem.

Meer informatie

De hotfix die in dit artikel wordt beschreven, corrigeert de beschadigde gegevens niet. De hotfix beschermt de code tegen onverwacht afsluiten van het proces als gevolg van een toegangsfout.

Na toepassing van deze hotfix kunt u zich probleemloos aanmelden bij een computer met Windows 2000 of Windows XP met Extern bureaublad. Er kan echter wel een foutbericht worden weergegeven wanneer u de eigenschappen van de gebruikersaccount wijzigt of wanneer u zich aanmeldt met behulp van die account.

Als u MMC (Microsoft Management Console) gebruikt om de gebruikerseigenschappen te bewerken of weer te geven, wordt een foutbericht van de volgende strekking weergegeven:
Eigenschappen voor Terminal Services
Kan eigenschappen voor Terminal Services niet laden voor deze gebruiker vanwege: De parameter is onjuist.
Wanneer u zich wilt aanmelden bij een computer met Windows Server 2003 via een verbinding met een extern bureaublad, wordt een foutbericht van de volgende strekking weergegeven:
Aanmeldingsbericht
Het systeem kan u niet aanmelden vanwege de volgende fout: De parameter is onjuist.
Probeer het nogmaals of raadpleeg de systeembeheerder
Ga als volgt te werk om de beschadigde gebruikersgegevens voor Terminal Services te corrigeren:
  1. Maak een tekstbestand met de volgende regels tekst, waarbij gebruikersnaam staat voor de naam van de gebruikersaccount met de beschadigde gegevens en waarbij domein de domeinnaam is.
    dn: CN=gebruikersnaam,CN=Users,DC=domein,DC=com
    changetype: modify
    delete : userParameters
  2. Geef het bestand de naam Gebruikers.txt.
  3. Typ de volgende opdracht bij een opdrachtprompt om het bestand uit te voeren:
    Ldifde ?I ?f users.txt
    Met het uitvoeren van deze opdracht worden ook de eigenschappen gewist en wordt het probleem op een Active Directory-domein verholpen.

    Opmerking Het wissen van het kenmerk userParameters van de gebruikersaccount kan gevolgen hebben voor andere programma's. Als hierin programmaspecifieke gegevens zijn opgeslagen, moeten deze opnieuw worden opgegeven. Dit geldt voor programma's als FPNW, RAS en alle gebruikersgegevens die specifiek zijn voor Terminal Services.

Referenties

Klik voor meer informatie over de terminologie die wordt gebruikt in dit artikel, op het volgende artikelnummer in de Microsoft Knowledge Base:
824684 Beschrijving van de standaardterminologie die wordt gebruikt om software-updates van Microsoft te beschrijven

Eigenschappen

Artikel ID: 828664 - Laatste beoordeling: woensdag 31 december 2008 - Wijziging: 4.9
De informatie in dit artikel is van toepassing op:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows XP Professional
  • Microsoft Windows® 2000 Server
Trefwoorden: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbqfe kbfix kbbug KB828664

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com