You receive an "Access denied" or a “Word cannot open the document: user does not have access privileges” error message when you access a Windows SharePoint Services document library as a member of the Readers site group

Article translations Article translations
Article ID: 828816 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you connect to your Microsoft Windows SharePoint Service Web site by using a network place shortcut that you created by using Web Distributed Authoring and Versioning (WebDAV), log on as a user who is a member of the Reader site group, and then access a document library, you can view the contents of the folder. However, when you try to open any one of the documents in the folder, you may experience one of the following symptoms (as appropriate to your situation):
  • You receive an error message that is similar to the following:
    Access denied
  • When you try to open a Microsoft Office document, you receive an error message that you cannot open the document. For example, when you try to open a Microsoft Word document, you receive an error message that is similar to the following:
    Word cannot open the document: user does not have access privileges
    (http://Server/.../DocumentName.doc)

CAUSE

This behavior occurs because, when you open a file by using WebDAV, a request is made to retrieve the source of the file (the version of the file that you edit), and not the display version of the file. These two operations require different levels of permissions in Windows SharePoint Services. To retrieve the source of the file, you must have the same level of permissions that are required to save the file. To retrieve the display version of the file, you only require read-only access to the file.

Members of the Reader site group have only read-only access to files the Windows SharePoint Services Web site. As a result, if you are a member of the Reader site group and you try to open a file by using WebDAV, you experience the symptoms that are described in the "Symptoms" section of this article.

RESOLUTION

To work around this behavior, add the user to the Contributor site group. To assign a user to the Contributor site group, follow these steps:
  1. On the Site Settings page of the Windows SharePoint Services Web site, under Administration, click Manage users.
  2. On the Manage Users page, click to select the check box that is next to the name of the user whose site group you want to change, and then click Edit Site Groups of Selected Users.
  3. On the Edit Site Group Membership page, under Site Group Membership, click to select the Contributor - Can add content to existing document libraries and lists. check box, and then click OK.

MORE INFORMATION

For additional information about how to manage users and site groups in Windows SharePoint Services, see the "Managing Users and Cross-Site Groups" and "Managing Site Groups and Permissions" topics in the "Security" section of the Microsoft Windows SharePoint Services 2.0 Administrator's Guide. To obtain the Microsoft Windows SharePoint Services 2.0 Administrator's Guide, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=a637eff6-8224-4b19-a6a4-3e33fa13d230&displaylang=en
For more information about Windows SharePoint Services, visit the following Microsoft Web site:
http://technet.microsoft.com/windowsserver/sharepoint/default.aspx

Properties

Article ID: 828816 - Last Review: September 26, 2007 - Revision: 1.7
APPLIES TO
  • Microsoft Windows SharePoint Services 2.0
Keywords: 
kberrmsg kbopenfile kbnewfile kbtshoot kbprb KB828816

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com