Gewusst wie: Ändern der Skriptsprache für das InfoPath-Formular

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 828853 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Dieser Artikel beschreibt wie Sie die Skriptsprache für Ihre InfoPath-Formular Vorlage ändern.

Wenn Sie bereits Microsoft Skript-Editor für ein Formular Vorlage gestartet haben, können Sie die Skriptsprache nur ändern, indem das vorhandene Skript ersten Formular Vorlage entfernen. Dieser Artikel beschreibt außerdem, wie Sie das Skript aus Ihrem Vorlage entfernen können, und Sie die Skriptsprache ändern können.

Weitere Informationen

Die Skriptsprache für die Formularvorlage ändern

  1. Öffnen Sie die Vorlage im Entwurfsmodus in InfoPath.
  2. Klicken Sie im Menü Extras Formularoptionen .

    Das Dialogfeld Formularoptionen angezeigt wird.
  3. Klicken Sie auf die Registerkarte Erweitert .
  4. Wählen Sie Ihre bevorzugte Sprache in der Form Skriptsprache Dropdown-Liste, und klicken Sie dann auf OK .
  5. Zeigen Sie im Menü Extras auf Skript , und klicken Sie dann auf Microsoft Skript-Editor .

    Microsoft Skript-Editor wird angezeigt.

Das Skript aus der Formularvorlage entfernen

wichtig Die folgenden Schritte entfernen alle vorhandenen Skripts aus Ihrem Formular Vorlage. Um erfolgreich Skriptsprache nach ändern Sie Skript-Editor für Ihr Formular Vorlage gestartet haben, müssen Sie die folgenden Schritte ausführen.
  1. Erstellen Sie eine Sicherungskopie für Ihre InfoPath-Formular-Vorlage (XSN-Datei).
  2. Öffnen Sie die Vorlage im Entwurfsmodus in InfoPath.
  3. Klicken Sie im Menü Datei auf Formulardateien extrahieren .

    Das Dialogfeld Ordner suchen wird angezeigt.
  4. Wählen Sie den Ordner, dem Sie die Formulardateien extrahieren möchten, und klicken Sie dann auf OK .
  5. Schließen Sie das Formular Vorlage.
  6. Gehen Sie folgendermaßen vor um Manifest.xsf zu ändern:
    1. Starten Sie eine Text-Editor wie z. B. Editor, oder starten Sie einen XML-Editor wie Visual Studio .NET. Öffnen Sie Manifest.xsf, die in den Ordner gespeichert ist, in dem die Formulardateien extrahiert.
    2. Suchen und löschen im folgenden Abschnitt:
      <xsf:file name="script.js">
              <xsf:fileProperties>
                  <xsf:property name="scriptType" type="string" value="userEvents"></xsf:property>
              </xsf:fileProperties>
          </xsf:file>
    3. Suchen Sie den Knoten Xsf:solutionProperties , und löschen Sie das ScriptLanguage -Attribut.

      Lesen z. B. Wenn ein InfoPath-Formular für die Skriptsprache derzeit JScript verwendet, der Xsf:solutionProperties -Knoten wird wie folgt:
      <xsf:solutionProperties scriptLanguage="jscript" fullyEditableNamespace="http://schemas.microsoft.com/office/infopath/2003/myXSD/2003-09-10T17:55:25" lastOpenView="view1.xsl"></xsf:solutionProperties>

      Nach dem Löschen des ScriptLanguage -Attributs wird wie folgt der Xsf:solutionProperties -Knoten gelesen::
      <xsf:solutionProperties fullyEditableNamespace="http://schemas.microsoft.com/office/infopath/2003/myXSD/2003-09-10T17:55:25" lastOpenView="view1.xsl"></xsf:solutionProperties>
    4. Suchen und löschen im folgenden Abschnitt:
      <xsf:scripts language="jscript">
           <xsf:script src="script.js"></xsf:script>
      </xsf:scripts>
      
    5. Speichern Sie Ihre Änderungen in Manifest.xsf, und schließen Sie dann Skript-Editor.
  7. Klicken Sie in Windows Explorer mit der rechten Maustaste auf Manifest.xsf und klicken Sie dann auf Entwurf .

    Die Vorlage wird im Entwurfsmodus in InfoPath geöffnet.
  8. Klicken Sie im Menü Datei auf Speichern .
  9. Um Ihre bevorzugten Skriptsprache festzulegen, gehen Sie in den Abschnitt "Ändern der Script Language für die Formularvorlage".

Informationsquellen

Weitere Informationen über das Debuggen des Skripts in Ihre InfoPath-Formular-Vorlage finden Sie die folgende KB-Artikelnummer:
827002Gewusst wie: Debuggen ein Skripts für ein Microsoft Office InfoPath 2003-Formular

Eigenschaften

Artikel-ID: 828853 - Geändert am: Montag, 23. Oktober 2006 - Version: 1.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office InfoPath 2003
Keywords: 
kbmt kbhowto KB828853 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 828853
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com