Nejsou nainstalovány ovladače poskytnutý dodavatelem, které přidáte do úložiště služby ADS zavedení agenta Tvůrce

Překlady článku Překlady článku
ID článku: 829053 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Pokud přidáte do úložiště služby Microsoft Windows automatické zavedení služby verze 1.0 (ADS) zavedení agenta Tvůrce ovladače OEM nebo ovladače jiných výrobců, tyto ovladače poskytnutý dodavatelem možná nebyl nainstalován při do zavedení agenta je spuštěn v počítači. K tomuto problému dochází i při je zkopírujte poskytnutý dodavatelem ovladače do správného umístění na serveru dané hostitelů služby nasazení Agent Builder a zastavte a restartujte službu Agent Tvůrce nasazení.

Poznámka: Tento článek se týká pouze ovladače hardwarových zařízení, které mají být používány za zavedení agenta. Chcete-li zobrazit informace o tom, jak přidat ovladače do ADS obrázky naleznete v dokumentaci k Nástroj přípravy systému Windows (Sysprep) v odpovídající aplikaci Microsoft Windows Resource Kit. Například pokud zavádíte službu ADS bitové kopie systému Windows 2000, příručce Microsoft Windows 2000 Server Resource Kit.

Příčina

K tomuto problému dochází, protože poskytnutý dodavatelem instalační informace soubor (INF) nejsou analyzovány správně. Obecně tento problém je způsoben s řadiče pevných disků s rozhraní (SCSI) small computer systému a síťové adaptéry jsou vyžadovány pro zařízení na funkci v zavedení agenta řadič pevného disku a síťového adaptéru. Soubor INF se používá k instalaci ovladače pro řadič SCSI pevný disk, síťový adaptér nebo jiné hardwarové zařízení.

Služby nasazení Agent Builder používá funkce, které jsou podobné funkce, které používá soubor Setupapi.dll k instalaci hardwarových zařízení, které jsou označeny při vyrobeno tak obrázek zavedení agenta. Však služby nasazení Agent Builder správně nečte souboru INF poskytnutý dodavatelem Pokud soubor nelze analyzovat správně.

Řešení

Informace o opravě hotfix

Podporovaná oprava hotfix k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze k odstranění problému popsaného v tomto článku. Tuto opravu hotfix použijte pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud je přísně neohrožuje tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, je oddíl "K dispozici oprava Hotfix stahování" v horní části tohoto článku znalostní báze Knowledge Base. Pokud v této části se nezobrazí, obraťte se na služby Microsoft a podporu získat opravu hotfix.

Poznámka: Pokud vyskytnout další problémy nebo řešení potíží je vyžadován, pravděpodobně budete muset vytvořit požadavek na samostatnou službu. Výdaje na podporu se obvykle týkají dalších otázek a problémů, které se netýkají této zvláštní opravy hotfix. Úplný seznam telefonních čísel služby Microsoft a podpora nebo vytvořit zvláštní požadavek na službu na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "K dispozici oprava Hotfix stahování" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Je nutné nainstalovat této opravy hotfix společně s opravu hotfix popsanou v článku znalostní báze Microsoft Knowledge Base 830413, chcete-li tento problém vyřešit.

Požadavek na restartování

Není nutné po instalaci této opravy hotfix restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje žádné další opravy hotfix.

Informace o souboru

Anglická verze této opravy hotfix má atributy souborů (nebo vyšší atributy souborů), jsou uvedeny v následující tabulce. Data a časy těchto souborů jsou uvedeny v čase univerzální koordinovaný (čas UTC). Při zobrazení informací o souboru, bude převedena na na místní čas. Rozdíl mezi místním časem a UTC časem kartě časové pásmo v panelu Datum a čas v Ovládacích panelech.
Date         Time   Version      Size       File name         Platform
----------------------------------------------------------------------
03-Nov-2003  18:45  5.2.3790.99  1,993,216  Setupapi.dll      IA-64
03-Nov-2003  18:44  5.2.3790.99  1,039,872  Wsetupapi.dll     x86
25-Oct-2003  00:13                     271  Branches.inf
03-Nov-2003  18:53                   9,981  Kb829053.cat
03-Nov-2003  18:47                     354  Updatebr.inf
03-Nov-2003  18:48                   5,984  Update_rtmqfe.inf

Jak potíže obejít

Nemáte používat toto zástupné řešení, pokud je oprava hotfix popsaná v "Řešení" oddílu je nainstalován společně s opravu hotfix z 830413 článku Microsoft Knowledge Base. Chcete-li tento problém vyřešit tak, aby služby nasazení Agent Builder mohou správně analyzovat soubor INF poskytnutý dodavatelem, postupujte takto:
  1. Pomocí textového editoru otevřete soubor INF poskytnutým dodavatelem.

    Obvykle je tento soubor nazvaný Oemsetup.inf. Soubor Oemsetup.inf je umístěn v úložišti služby Tvůrce zavedení agenta v počítači, který spustí síťové služby pro spouštění. Umístění je:

    Drive: \Program Files\Microsoft ADS\Nbs\Repository\User\PreSystem (nebo PostSystem)
  2. Vyhledejte a potom změňte následující textu v souboru Oemsetup.inf.

    Poznámka: Tento krok používá pro řadič IBM ServeRAID-5i příklad ze souboru Oemsetup.inf poskytnutým dodavatelem. Soubor INF poskytnutý dodavatelem, který použijete, může mít různé hodnoty, ale je podobná syntaxi.
    1. Vyhledejte následující text:

      [Manufacturer]
      %IBM%=IBM,NTx86.5.2
    2. Odebráním čárka "IBM" a "NT" změnit následující řádek:

      [Manufacturer]
      %IBM%=IBMNTx86.5.2
  3. Změňte hodnotu v oddílu "Model", který je spojen s hodnota v oddílu "" výrobce"souboru tak, aby model hodnota odpovídá hodnotě v části""výrobce". Chcete-li najít sekci přidružené "Model", vyhledejte text podobný text na pravé straně znaménko rovná se v části "" výrobce". V tomto příkladu IBMNTx86.5.2 Hledat.
    1. V části "Model" vyhledejte následující text:

      [IBM.NTx86.5.2]
      
    2. Změnit text na následující odebráním období mezi "IBM" a "NT":

      [IBMNTx86.5.2]
      
  4. Uložte soubor INF do úložiště služby nasazení Agent Tvůrce.
  5. Restartujte službu Agent Tvůrce nasazení, spouštěcí device do zavedení agenta a potom zobrazit protokol služby nasazení Agent Tvůrce zobrazíte, pokud ovladač pro zařízení hardwaru byla nainstalována.

    V tomto kroku device je zařízení, které obsahuje hardwarové zařízení, které souvisí s soubor INF poskytnutý dodavatelem, který jste změnili.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části „ platí.

Další informace

Další informace získáte následujícím článku báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané k popisu aktualizací softwaru společnosti Microsoft
Další informace o ADS na následujícím webu společnosti Microsoft:
http://www.microsoft.com/windowsserver2003/techinfo/overview/ads.mspx
Informace o tom, jak zapnout trasování služby nasazení Agent Tvůrce-li jej není již zapnutý naleznete v tématu Automated Deployment nápovědě ke službě.Produkty třetích stran popisované v tomto článku jsou vyráběny společnostmi nezávislými na společnosti Microsoft. Microsoft neposkytuje žádnou záruku (implicitně předpokládanou ani jinou) týkající se výkonu nebo spolehlivosti těchto produktů.

Vlastnosti

ID článku: 829053 - Poslední aktualizace: 24. července 2007 - Revize: 4.11
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbmgmtservices kbwinservperf kbbug kbfix kbqfe kbwinserv2003presp1fix KB829053 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:829053

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com