Vom Hersteller bereitgestellte Treiber, die Sie das Repository ADS Deployment Agent Builder Service hinzufügen, sind nicht installiert

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Problembeschreibung

Wenn Sie das Microsoft Windows Automated Deployment Services Version 1.0 (ADS) Deployment Agent Builder Service Repository OEM-Treiber oder andere Treiber von Drittanbietern hinzufügen, können diese vom Hersteller bereitgestellte Treiber bei der der Computer in der Bereitstellungs-Agent gestartet wird nicht installiert. Dieses Problem tritt auch wenn Sie kopieren die Hersteller gelieferten Treiber an den richtigen Speicherort auf dem Server die Hosts den Deployment Agent Builder-Dienst und Sie beenden und starten Sie den Bereitstellungs-Agent Builder-Dienst neu.

Hinweis: Dieser Artikel bezieht sich nur auf Hardware-Gerätetreiber, die unter Bereitstellungs-Agent verwendet werden. Informationen zum Hinzufügen Ihrer Bilder ADS-Treiber finden Sie unter der Windows-Systemvorbereitungsprogramm (Sysprep)-Dokumentation in der entsprechenden Microsoft Windows Resource Kit. Finden beispielsweise, wenn Sie ADS-Abbilder von Windows 2000 bereitstellen, Sie die Microsoft Windows 2000 Server Resource Kit.

Ursache

Dieses Problem, da die vom Hersteller bereitgestellte Setup-Informationsdatei (INF-Datei) nicht ordnungsgemäß analysiert wird. Dieses Problem tritt im Allgemeinen mit small Computer System Interface ()-Festplattencontroller und Netzwerkadapter da einen Festplattencontroller und einem Netzwerkadapter für das Gerät Funktion im Bereitstellungs-Agent erforderlich sind. Eine INF-Datei wird zum den Treiber für den SCSI-Festplattencontroller, der Netzwerkadapter oder andere Hardware installieren.

Der Bereitstellungs-Agent-Generator-Dienst verwendet Funktionalität, die die Funktionalität ähnelt ist, die verwendet wird, durch die Datei Setupapi.dll, um die Hardwaregeräte zu installieren, die das Bereitstellungsagent-Bild erstellt identifiziert werden. Allerdings der Deployment Agent Builder-Dienst nicht ordnungsgemäß vom Hersteller bereitgestellte INF-Datei lesen Wenn die Datei nicht ordnungsgemäß analysiert wird.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Sie müssen diesen Hotfix zusammen mit den beschriebenen Hotfix installieren, im Microsoft Knowledge Base-Artikel 830413, um dieses Problem zu beheben.

Neustartanforderung

Sie müssen Ihren Computer nicht neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time () angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
Date         Time   Version      Size       File name         Platform
----------------------------------------------------------------------
03-Nov-2003  18:45  5.2.3790.99  1,993,216  Setupapi.dll      IA-64
03-Nov-2003  18:44  5.2.3790.99  1,039,872  Wsetupapi.dll     x86
25-Oct-2003  00:13                     271  Branches.inf
03-Nov-2003  18:53                   9,981  Kb829053.cat
03-Nov-2003  18:47                     354  Updatebr.inf
03-Nov-2003  18:48                   5,984  Update_rtmqfe.inf

Abhilfe

Sie haben keinen dieser Problemumgehung verwenden, wenn der Hotfix, in "Lösung" beschriebenen Abschnitt zusammen mit dem Hotfix von Microsoft Knowledge Base-Artikel 830413 installiert ist. Gehen Sie folgendermaßen vor, um dieses Problem zu umgehen damit der Deployment Agent Builder-Dienst vom Hersteller bereitgestellte INF-Datei korrekt analysiert werden kann,
  1. Verwenden Sie einen Texteditor, um die vom Hersteller bereitgestellte INF-Datei zu öffnen.

    In der Regel heißt diese Datei Oemsetup.inf. Die Datei Oemsetup.inf befindet sich im Repository Bereitstellungs-Agent-Generator-Dienst auf dem Computer, die Boot-Netzwerkdienst ausgeführt wird. Der Speicherort ist:

    Drive: \Program Files\Microsoft ADS\Nbs\Repository\User\PreSystem (oder PostSystem)
  2. Suchen Sie und ändern Sie den folgenden Text in der Oemsetup.inf-Datei.

    Hinweis: Diese Schritt verwendet ein Beispiel aus der vom Hersteller bereitgestellte Oemsetup.inf-Datei für eine IBM ServeRAID-5i-Controller. Die vom Hersteller bereitgestellte INF-Datei, die Sie verwenden möglicherweise unterschiedliche Werte aufweisen, aber die Syntax ähnlich ist.
    1. Suchen Sie den folgenden Text:

      [Manufacturer]
      %IBM%=IBM,NTx86.5.2
    2. Ändern Sie die Zeile auf den folgenden indem Sie das Komma zwischen "IBM" und "NT":

      [Manufacturer]
      %IBM%=IBMNTx86.5.2
  3. Ändern Sie den Wert im Abschnitt "Model", der den Wert in der die Datei im Abschnitt "Hersteller" zugeordnet ist, sodass der Modell-Wert den Wert im Abschnitt "Hersteller" übereinstimmt. Abschnitt "Model" zugeordneten zu suchen, suchen Sie nach Text, der den Text auf der rechten Seite des Gleichheitszeichens im Abschnitt "Hersteller" ähnelt. Suchen Sie in diesem Beispiel nach IBMNTx86.5.2.
    1. Suchen Sie im Abschnitt "Model" den folgenden Text:

      [IBM.NTx86.5.2]
      
    2. Ändern Sie den Text auf den folgenden indem Sie den Zeitraum zwischen dem "IBM" und "NT":

      [IBMNTx86.5.2]
      
  4. Speichern der INF-Datei im Bereitstellungs-Agent-Generator-Dienst-Repository.
  5. Starten Sie den Deployment Agent Builder-Dienst neu, starten Sie das device im Bereitstellungs-Agent, und anschließend zeigen Sie das Bereitstellungs-Agent-Generator-Dienst an, ob ein Treiber für das Gerät wurde installiert wurde.

    In dieser Schritt ist device Gerät, das Hardwaregerät, das vom Hersteller bereitgestellte INF-Datei zugeordnet ist, die Sie geändert.

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates
Weitere Informationen über die ADS die folgende Microsoft-Website:
http://www.microsoft.com/windowsserver2003/techinfo/overview/ads.mspx
Informationen zum Bereitstellungs-Agent Builder Service Ablaufverfolgung aktivieren, wenn es nicht bereits aktiviert ist finden Sie unter Automated Deployment Services-Hilfe.Die in diesem Artikel erwähnten Fremdanbieterprodukte werden von einem Lieferanten hergestellt, der von Microsoft unabhängig ist. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Eigenschaften

Artikel-ID: 829053 - Geändert am: Dienstag, 24. Juli 2007 - Version: 4.11
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbmt kbautohotfix kbhotfixserver kbqfe kbmgmtservices kbwinservperf kbbug kbfix kbqfe kbwinserv2003presp1fix KB829053 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 829053
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