Pilotes fournisseur que vous ajoutez dans le référentiel de service Générateur d'agent de déploiement ADS ne sont pas installés

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Numéro d'article: 829053 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Lorsque vous ajoutez pilotes OEM ou d'autres pilotes tiers dans le référentiel service Générateur d'agent de déploiement Microsoft Windows les services de déploiement version 1.0 automatisés (ADS), ces pilotes fournisseur ne peuvent pas être installés lorsque l'ordinateur est amorcé en l'agent de déploiement. Ce problème produit même lorsque vous copiez les fournisseur pilotes dans l'emplacement correct sur le serveur qui héberge le service déploiement Agent Builder, puis vous arrêtez et redémarrez le service déploiement Agent Builder.

note Cet article fait uniquement référence aux pilotes de périphériques matériels doivent être utilisés dans l'agent de déploiement. Pour savoir comment ajouter des pilotes à vos images ADS, consultez la documentation d'outil de préparation système Windows (Sysprep) dans le Kit de ressources Microsoft Windows appropriée. Par exemple, si vous déployez ADS images de Windows 2000, consultez le Kit de ressources Microsoft Windows 2000 Server.

Cause

Ce problème se produit car le paramétrage de fournisseur d'informations (fichier .inf) est non analysé correctement. En règle générale, ce problème se produit avec les contrôleurs de disque dur interface SCSI (small computer système et cartes réseau car un contrôleur de disque dur et une carte réseau sont requis pour le périphérique à la fonction de l'agent de déploiement. Un fichier .inf est utilisé pour installer le pilote pour le contrôleur de disque dur SCSI, la carte réseau ou autre périphérique matériel.

Le service déploiement Agent Builder utilise la fonctionnalité semblable à la fonctionnalité qui est utilisée par le fichier Setupapi.dll pour installer les périphériques matériels qui sont identifiés lors de l'image de déploiement Agent est construite. Toutefois, le service déploiement Agent Builder ne correctement lit pas le fichier .inf fournisseur si le fichier est analysé pas correctement.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Vous devez installer ce correctif avec le correctif logiciel qui est décrit dans l'article de base de connaissances Microsoft 830413 pour résoudre ce problème.

Demande de redémarrage

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en coordinated universal temps (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
Date         Time   Version      Size       File name         Platform
----------------------------------------------------------------------
03-Nov-2003  18:45  5.2.3790.99  1,993,216  Setupapi.dll      IA-64
03-Nov-2003  18:44  5.2.3790.99  1,039,872  Wsetupapi.dll     x86
25-Oct-2003  00:13                     271  Branches.inf
03-Nov-2003  18:53                   9,981  Kb829053.cat
03-Nov-2003  18:47                     354  Updatebr.inf
03-Nov-2003  18:48                   5,984  Update_rtmqfe.inf

Contournement

Vous devez utiliser cette solution de contournement si le correctif logiciel qui est décrit dans la « résolution » section est installée avec le correctif de 830413 article de base de connaissances Microsoft. Pour contourner ce problème afin que le service déploiement Agent Builder peut analyser correctement le fichier .inf fournisseur, procédez comme suit :
  1. Utilisez un éditeur de texte pour ouvrir le fichier .inf du fournisseur.

    En règle générale, ce fichier se nomme Oemsetup.inf. Le fichier Oemsetup.inf se trouve dans le référentiel service Générateur d'agent de déploiement sur l'ordinateur qui exécute le service de démarrage réseau. L'emplacement est le suivant :

    Drive: \Program Files\Microsoft ADS\Nbs\Repository\User\PreSystem (ou PostSystem)
  2. Recherchez, puis modifier le texte suivant dans le fichier Oemsetup.inf.

    note Cette étape utilise un exemple du fichier Oemsetup.inf fournisseur pour un contrôleur IBM ServeRAID-5i. Le fichier .inf du fournisseur que vous utilisez peut avoir des valeurs différentes, mais la syntaxe est similaire.
    1. Recherchez le texte suivant :

      [Manufacturer]
      %IBM%=IBM,NTx86.5.2
    2. Modifiez la ligne à la suivante en supprimant la virgule entre « IBM » et « NT » :

      [Manufacturer]
      %IBM%=IBMNTx86.5.2
  3. Modifier la valeur dans la section « modèle » qui est associée à la valeur dans la section « fabricant » du fichier afin que la valeur de modèle correspond à la valeur dans la section « fabricant ». Pour trouver la section « modèle » associée, recherchez texte semblable au texte sur le côté droit du signe égal dans la section « fabricant ». Dans cet exemple, recherchez IBMNTx86.5.2.
    1. Dans la section « modèle », recherchez le texte suivant :

      [IBM.NTx86.5.2]
      
    2. Modifier le texte à la suivante en supprimant la période entre « IBM » et « NT » :

      [IBMNTx86.5.2]
      
  4. Enregistrer le fichier .inf dans le référentiel de service Générateur d'agent de déploiement.
  5. Redémarrez le service déploiement Agent Builder le device de démarrage dans l'agent de déploiement, puis affichez le journal de service déploiement Agent Générateur pour voir si un pilote pour le périphérique matériel a été installé.

    Dans cette étape, device est le périphérique qui contient le périphérique matériel associé avec le fichier .inf fournisseur qui vous avez modifié.

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
Pour plus d'informations sur les services ADS, reportez-vous au site de Web Microsoft suivant :
http://www.microsoft.com/windowsserver2003/techinfo/overview/ads.mspx
Pour savoir comment activer déploiement Agent Builder service suivi si elle n'est pas déjà activée, consultez l'aide de services déploiement automatique. Les produits tiers Cet article décrit sont mentionnés par des sociétés indépendantes de Microsoft. Microsoft garantit pas, ou implicite, concernant les performances ou la fiabilité de ces produits.

Propriétés

Numéro d'article: 829053 - Dernière mise à jour: mardi 24 juillet 2007 - Version: 4.11
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Mots-clés : 
kbmt kbautohotfix kbhotfixserver kbqfe kbmgmtservices kbwinservperf kbbug kbfix kbqfe kbwinserv2003presp1fix KB829053 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 829053
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