Artigo: 829151 - Última revisão: quarta-feira, 14 de Novembro de 2007 - Revisão: 5.5

Mensagens de erro quando tenta ligar a correspondência jogo para vários jogadores

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações que mostra a ajuda de definições de segurança mais baixas ou como desactivar as funcionalidades de segurança num computador. Pode efectuar estas alterações para contornar um problema específico. Antes de efectuar estas alterações, recomendamos que avalie os riscos associados à implementação desta solução alternativa no seu ambiente específico. Se implementar esta solução alternativa, tome medidas adicionais adequadas para proteger o seu sistema.

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Sintomas

Quando clicar em ligar para tentar reproduzir uma sessão para vários jogadores, poderá detectar um ou mais dos seguintes sintomas.

Nota Cada um destes sintomas indica que o jogo não é possível estabelecer ligação com um servidor global para reproduzir uma sessão para vários jogadores.
  • É apresentado o seguinte texto no canto superior esquerdo da caixa de diálogo Freelancer servidores :
    A ligar ao servidor global
  • Quando visualiza o separador rede da ferramenta de diagnóstico DirectX (dxdiag), o termo erros poderá aparecer em Fornecedores de serviços DirectPlay registados painel.
  • Poderá receber uma mensagem de erro semelhante à seguinte no painel de notas :
    As informações de registo para o fornecedor de serviços TCP/IP DirectXPlay8 estão em falta ou danificado.
  • Poderá receber a seguinte mensagem de erro:
    Não é possível estabelecer uma ligação de rede. Verifique a ligação à rede e tente novamente.
  • Quando tenta criar uma conta de utilizador depois de iniciar uma sessão para vários jogadores, poderá receber a seguinte mensagem de erro:
    Erro ao criar conta. Certifique-se que está ligado à internet.
Quando aderir ou hospedar um jogo para múltiplos jogadores Microsoft Dungeon Siege II, poderá receber a seguinte mensagem de erro:
Ocorreu um erro fatal e a aplicação tem de encerrar.

Não foi possível inicializar 8 do DirectPlay (isto é necessário para jogos com vários jogadores).

[Nota: Este erro pode ocorrer se o DirectX 8 (ou mais recente) não estiver instalado neste sistema. Execute novamente o programa de instalação do jogo para configurar este. Em alternativa, pode apontar o browser da web www.microsoft.com/directx ou utilizar o Windows Update para instalar a versão mais recente do DirectX.]

Código de erro = 0 x 80040154

Causa

Este problema poderá ocorrer se as seguintes condições são verdadeiras:
  • O ficheiro do Microsoft DirectPlay Dpnet.dll está incorrectamente instalado ou registado.
  • Um firewall ou programa antivírus que está em execução em segundo plano está a interferir com o jogo.

Resolução

Método 1: Verificar se o DirectX está correctamente instalado

Para verificar o DirectX está correctamente instalado e que todos os ficheiros DirectX têm a versão correcta, siga estes passos:
  1. Clique em Iniciar , clique em Executar , escreva dxdiag na caixa Abrir e, em seguida, clique em OK .
  2. Na ferramenta de diagnóstico do DirectX, no separador sistema , verifique se a versão do DirectX é a versão 9.0a ou posteriores versões.
  3. No separador Ficheiros DirectX , na caixa de notas , verifique se o texto "Não foram encontrados problemas" aparece.

    Nota Se forem detectados problemas, instale a versão mais recente do DirectX. Para obter a versão mais recente do DirectX, visite o seguinte Web site da Microsoft:
    http://www.microsoft.com/windows/directx/default.aspx (http://www.microsoft.com/windows/directx/default.aspx)
  4. No separador ' rede ', verifique se os sintomas de uma instalação do DirectPlay danificada não estão presentes. Estes sintomas incluem o seguinte:
    • A palavra "Erros" aparece na caixa de fornecedores de serviços de DirectPlay registado .
    • O botão Teste do DirectPlay não está disponível.
    • Pode receber a seguinte mensagem de erro na caixa notas :
      As informações de registo para o fornecedor de serviços TCP/IP DirectXPlay8 estão em falta ou danificado.
    Nota Se existirem estes sintomas, saia a ferramenta de diagnóstico do DirectX e, em seguida, siga estes passos:
    1. Clique em Iniciar , clique em Executar , escreva regsvr32 dpnet.dll na caixa Abrir e, em seguida, clique em OK .
    2. Quando receber a seguinte mensagem, clique em OK :
      DllRegisterServer em dpnet.dll teve êxito.
    3. Repita os passos 1 a 5 para determinar se os sintomas de uma instalação do DirectPlay danificada estão ainda presentes. Se existirem os sintomas, saia a ferramenta de diagnóstico do DirectX e instale a versão mais recente do DirectX.
Para obter a versão mais recente do DirectX, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windows/directx/default.aspx (http://www.microsoft.com/windows/directx/default.aspx)
Para resolver este problema, transfira e instale a versão mais recente do Microsoft DirectX. Para o fazer, siga estes passos:
  1. Visite o seguinte Web site da Microsoft:
    http://www.microsoft.com/windows/directx (http://www.microsoft.com/windows/directx)
  2. Clique para transferir a versão mais recente do DirectX.
  3. Na caixa de pendente alterar idioma, clique no idioma adequado para o computador e, em seguida, clique em Transferir .
  4. Na caixa de diálogo Transferência de ficheiros , clique em Abrir .
  5. Siga as instruções apresentadas no ecrã para concluir o processo de instalação.

Método 2: Desactivar programas de firewall ou antivírus

aviso Esta medida pode tornar o computador ou a rede mais vulnerável a ataques de utilizadores mal intencionados ou software malicioso como vírus. A Microsoft não recomenda esta medida, mas fornece estas informações para que o utilizador pode implementá-la à sua própria responsabilidade. Usar esta solução por sua conta e risco.

Este problema poderá ocorrer se tiver um vírus ou firewall programa em execução no computador. Por exemplo, programas de firewall que permitam para acesso ou bloquear o acesso à Internet num regime por programa como zona alarme, MacAfee Personal Firewall, Norton Internet Security ou preto ICE Defender podem causar estes problemas.

Para resolver este problema, desactive o antivírus ou software de firewall. Contacte o fabricante do programa para o ajudar a desactivar o programa. Ícones para estes programas podem aparecer no canto inferior direito do ecrã junto ao relógio. Poderá desactivar o programa utilizando este ícone. Tente clique com o botão direito do rato no ícone do programa e, em seguida, clique em Desactivar ou Sair .

Se o problema persistir, efectue um procedimento de arranque limpo.Para obter mais informações sobre como efectuar um procedimento de arranque limpo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
331796  (http://support.microsoft.com/kb/331796/ ) Jogos: Como efectuar um arranque limpo para impedir que programas em segundo plano interfiram com o jogo

Referências

Para obter mais informações sobre como resolver problemas com vários jogadores, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
819836  (http://support.microsoft.com/kb/819836/ ) Jogos: Como resolver problemas com multijogadores
Para obter mais informações sobre o DirectX compatibilidade, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
822798  (http://support.microsoft.com/kb/822798/ ) Não é possível instalar actualizações ou lhe for pedido para instalar actualizações que já tiver instalado

A informação contida neste artigo aplica-se a:
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Dungeon Siege 2.0
  • Microsoft Freelancer
  • Microsoft Halo PC 1.0
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Thrones and Patriots
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 829151  (http://support.microsoft.com/kb/829151/en-us/ )