Event logs are corrupted

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Article ID: 829246 - View products that this article applies to.
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SYMPTOMS

On a Microsoft Windows 2000-based computer, the event logs may become corrupted.

CAUSE

This behavior may occur if the event logs are full, and the event log wrapped.

RESOLUTION

Update information

To resolve this problem, obtain Update Rollup 1 for Windows 2000 Service Pack 4 (SP4). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891861 Update Rollup 1 for Windows 2000 SP4 and known issues

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows 2000 Service Pack 3 (SP3) or later installed on the computer. Besides applying the hotfix, you may have to clean up the corrupted event log files.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   -------------------------------------------------------
   16-Oct-2003  04:31  5.0.2195.6866  47,376  Eventlog.dll
Note If you cannot view the event log after the hotfix installation, save and clear the event log one time.

WORKAROUND

To work around this problem, clear the event log. This workaround is only temporary. The problem may recur when the event logs fill and wrap again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows 2000 Service Pack 4 Update Rollup 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
900345 Fixes that are included in the Update Rollup 1 for Microsoft Windows 2000 Service Pack 4 that is dated June 28, 2005
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
The hotfix in this article is included in the list of recommended hotfixes to be proactively applied to Windows 2000 server clusters. For more information about this list, click the following article number to view the article in the Microsoft Knowledge Base:
895090 Recommended hotfixes for Windows 2000 Service Pack 4-based server clusters
This hotfix should be evaluated and applied proactively to all server clusters that are prone to be negatively affected by the problem that is described in this article.

Properties

Article ID: 829246 - Last Review: February 21, 2007 - Revision: 7.5
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB829246

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