事件日志已损坏

文章翻译 文章翻译
文章编号: 829246 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

在基于 Microsoft Windows 2000 的计算机上,事件日志有可能被损坏。

原因

如果事件日志已满时进行换行,则会发生此问题。

解决方案

更新信息

要解决此问题,请获取 Windows 2000 Service Pack 4 (SP4) 的更新汇总 1。 有关更多信息,请单击下面的文章编号以查看 Microsoft 知识库中相应的文章:
891861 Windows 2000 SP4 更新汇总 1 和已知问题

修补程序信息

Microsoft 提供了一个受支持的修补程序。但此修补程序只用于解决本文中提到的问题。请仅对出现这一特定问题的系统应用此修补程序。

如果可以下载此修补程序,此知识库文章顶部将存在“提供修补程序下载”部分。如果此部分不存在,请向 Microsoft 客户支持服务部门提交请求以获取修补程序。

注意:如果发生其他问题或需要进行任何疑难解答,您可能需要另行创建服务请求。对于此特定修补程序无法解决的其他支持问题和事项,将照常收取支持费用。若要获取 Microsoft 客户支持服务部门的电话号码的完整列表,或者另行创建服务请求,请访问下面的 Microsoft 网站:
http://support.microsoft.com/contactus/?ws=support
注意:“提供修补程序下载”表格显示了修补程序提供的语言。如果找不到您需要的语言,则是因为修补程序没有那种语言的版本。

先决条件

要安装此修补程序,您的计算机上必须安装有 Windows 2000 Service Pack 3 (SP3) 或更高版本。除应用修补程序外,您可能还需要清理损坏的事件日志文件。

重新启动要求

应用此修复程序后,必须首先重新启动计算机。

修补程序替换信息

此修补程序不替换任何其他修补程序。

文件信息

此修补程序的英文版具有下表中列出的文件属性(或更新的文件属性)。这些文件的日期和时间按协调世界时 (UTC) 列出。当您查看文件信息时,该时间将转换为本地时间。要了解 UTC 与本地时间之间的时差,请使用“控制面板”中的“日期和时间”工具中的“时区”选项卡。
日期         时间   版本        大小    文件名
   -------------------------------------------------------
2003-10-16  04:31  5.0.2195.6866      47,376  Eventlog.dll
注意:如果安装修补程序后无法查看事件日志,请保存并清除事件日志一次。

替代方法

要解决此问题,请清除事件日志。这只是临时的解决方法。当事件日志已满并再次换行时,可能会再次出现此问题。

状态

Microsoft 已经确认这是在“适用于”部分中列出的 Microsoft 产品中存在的问题。 此问题最早在 Windows 2000 Service Pack 4 更新汇总 1 中得到了解决。

更多信息

有关更多信息,请单击下面的文章编号以查看 Microsoft 知识库中相应的文章:
900345 2005 年 6 月 28 日发布的 Microsoft Windows 2000 Service Pack 4 更新汇总 1 中包含的修补程序
有关更多信息,请单击下面的文章编号以查看 Microsoft 知识库中相应的文章:
816915 Microsoft Windows 软件更新包的新文件命名方案
本文中的修补程序包含在推荐的修补程序列表中,以便主动应用于 Windows 2000 服务器群集。 有关此列表的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
895090 为基于 Windows 2000 Service Pack 4 的服务器群集推荐的修补程序 (EN)
应对此修补程序进行评估,并将其主动应用于容易受本文所述问题的负面影响的所有服务器群集。

属性

文章编号: 829246 - 最后修改: 2008年9月11日 - 修订: 7.5
这篇文章中的信息适用于:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
关键字:?
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB829246
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com