Wie Sie mithilfe von Visual C++ .NET oder Visual C++ 2005 eine Dialogfeldressource aus einem Projekt in ein anderes Projekt importieren

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 829437 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Dieser schrittweise aufgebaute Artikel beschreibt eine Dialogfeldressource aus einer Ressourcendatei oder aus einer Ressource Vorlage eines Microsoft Visual C++.NET-Projekts in ein anderes Visual C++.NET-Projekt oder aus einer Ressource Vorlage eines Microsoft Visual C++ 2005-Projekts in ein anderes Visual C++ 2005-Projekt importieren.

Dieser Artikel beschreibt auch So erstellen Sie ein Dialogfeld Ressource basierendes Projekt mithilfe von Windows Forms Application-Vorlage und die MFC Application-Vorlage aus, in denen eine Ressource kopiert werden können. Dieser Artikel beschreibt außerdem zwei verschiedene Verfahren, um eine Ressource aus einem Projekt in ein anderes Projekt kopieren.

Voraussetzungen

In diesem Artikel wird vorausgesetzt, dass Sie über Erfahrungen auf den folgenden Gebieten verfügen:
  • Programmieren mit Visual c++.NET oder Visual C++ 2005
  • Ressourcendateien

Erstellen Sie Dialogfeld-basierte Anwendungen, in Visual C++ .NET oder Visual C++ 2005

In Visual C++ .NET 2003 oder in Visual C++ 2005 können Sie die Dialogfeld-basierte Anwendungen erstellen, entweder mithilfe der MFC Application Projekt Vorlage oder Vorlage die Windows Forms Application-Projekt. In Visual C++ .NET 2002 können Sie mithilfe der Vorlage MFC Application Projekt Dialogfeld-basierte Anwendungen erstellen.

Gehen Sie folgendermaßen vor um eine auf Dialogfeldern basierende Anwendung mithilfe der Vorlage Windows Forms Application Projekt in Visual C++ .NET 2003 oder Visual C++ 2005 zu erstellen,
  1. Starten Sie Microsoft Visual Studio .NET 2003 oder Microsoft Visual Studio 2005.
  2. Zeigen im Menü Datei auf neu , und klicken Sie dann auf Projekt .
  3. Klicken Sie unter Projekttypen auf Visual C++-Projekte , und klicken Sie dann unter Vorlagen auf Windows Forms-Anwendung (.NET) .

    Hinweis: Klicken Sie in Visual Studio 2005 unter Projekttypen auf Visual C++ , und klicken Sie dann unter Vorlagen auf Windows Forms-Anwendung .
  4. Geben Sie in das Textfeld Name DialogApp und klicken Sie dann auf OK . Standardmäßig wird das Formular Form1 erstellt.
  5. Klicken Sie im Projektmappen-Explorer auf die Resource View Registerkarte.
  6. In der Ressourcenansicht, erweitern Sie in der DialogApp -Knoten.
  7. Klicken Sie mit der rechten Maustaste auf den app.rc Ordner; klicken Sie dann auf Ressource hinzufügen .
  8. Erweitern Sie Dialogfeld unter Ressourcentyp klicken Sie im Dialogfeld Ressource hinzufügen .
  9. Klicken Sie auf IDD_FORMVIEW [Englisch (USA)] , und klicken Sie auf neu . Eine neue Dialogfeldressource zum Projekt hinzugefügt und wird in der Entwurfsansicht geöffnet.
    Hinweis: Klicken Sie in Visual Studio 2005 auf IDD_FORMVIEW .
  10. Klicken Sie mit der rechten Maustaste auf das Dialogfeld Vorlage, und klicken Sie dann auf Eigenschaften .
  11. Ändern Sie die ID -Eigenschaft in IDD_MY_FORMVIEW .
  12. Dialogfeld Vorlage ein Button -Steuerelement hinzugefügt.
  13. Drücken Sie die Tastenkombination STRG + UMSCHALT + S, alle Dateien zu speichern.
  14. Klicken Sie im Menü Datei auf Projektmappe schließen , um die Projektmappe schließen.
  15. Beenden Sie Visual Studio .NET 2003 oder Visual Studio 2005.
Gehen Sie so eine auf Dialogfeldern basierende Anwendung erstellen Sie mithilfe der MFC Application Projekt Vorlage in entweder Visual C++ .NET 2003, Visual C++ .NET 2002 oder Visual Studio 2005, folgendermaßen vor:
  1. Starten Sie Microsoft Visual Studio .NET oder Visual Studio 2005.
  2. Zeigen im Menü Datei auf neu , und klicken Sie dann auf Projekt .
  3. Klicken Sie unter Projekttypen auf Visual C++-Projekte , und klicken Sie dann unter Vorlagen auf MFC-Anwendung .

    Hinweis: Klicken Sie in Visual Studio 2005 unter Projekttypen auf Visual C++ , und klicken Sie dann unter Vorlagen auf MFC-Anwendung .
  4. Geben Sie in das Textfeld Name DialogApp und klicken Sie dann auf OK .
  5. Im MFC-Anwendungs-Assistenten - DialogApp -Dialogfeld Feld, Klicken Sie auf Anwendung .
  6. Klicken Sie unter Anwendungstyp auf Dialogfeldern basierend auswählen und klicken Sie dann auf Fertig stellen .
  7. Klicken Sie im Projektmappen-Explorer auf die Resource View Registerkarte.
  8. In der Ressourcenansicht, erweitern Sie in der DialogApp -Knoten.
  9. Klicken Sie mit der rechten Maustaste auf den Ordner DialogApp.rc ; klicken Sie dann auf Ressource hinzufügen .
  10. Erweitern Sie Dialogfeld unter Ressourcentyp klicken Sie im Dialogfeld Ressource hinzufügen .
  11. Klicken Sie auf IDD_FORMVIEW [Englisch (USA)] , und klicken Sie auf neu . Eine neue Dialogfeldressource zum Projekt hinzugefügt und wird in der Entwurfsansicht geöffnet.
    Hinweis: Klicken Sie in Visual Studio 2005 auf IDD_FORMVIEW .
  12. Klicken Sie mit der rechten Maustaste auf das Dialogfeld Vorlage, und klicken Sie dann auf Eigenschaften .
  13. Ändern Sie die ID -Eigenschaft in IDD_MY_FORMVIEW .
  14. Dialogfeld Vorlage ein Button -Steuerelement hinzugefügt.
  15. Drücken Sie die Tastenkombination STRG + UMSCHALT + S, alle Dateien zu speichern.
  16. Klicken Sie im Menü Datei auf Projektmappe schließen , um die Projektmappe schließen.
  17. Beenden Sie Visual Studio .NET oder Visual Studio 2005.

Kopieren einer Dialogfeldressource

Um eine Dialogfeldressource aus einer Ressourcendatei ein Visual C++ .NET oder Visual C++ 2005-Projekt in einer Ressourcendatei ein anderes Visual C++ .NET oder Visual C++ 2005-Projekt zu kopieren, gehen Sie folgendermaßen vor:

Hinweis: Eine Ressourcendatei verfügt über eine RC-Erweiterung.
  1. Starten Sie Visual Studio .NET oder Visual Studio 2005.
  2. Zeigen Sie im Menü Datei auf Öffnen , und klicken Sie dann auf Datei .
  3. Suchen Sie die Quelle Ressource-Datei.
  4. Klicken Sie auf die Ressourcendatei, und klicken Sie auf Öffnen , um die Datei zu öffnen.
  5. Führen Sie Schritte 2 bis 4 für die Ziel-Ressourcendatei.
  6. Um zu der Quelldatei Ressource zu wechseln, klicken Sie auf die Registerkarte mit den Namen der Datei.
  7. Erweitern Sie den Ordner mit den gleichen Namen als Dateiname der Quelldatei Ressource.
  8. Erweitern Sie den Ordner Dialog .
  9. Klicken Sie mit der rechten Maustaste auf die Dialogfeld Ressource, die Sie kopieren möchten, und klicken Sie dann auf Kopieren .
  10. Um zur Ressourcendatei für das Ziel zu wechseln, klicken Sie auf die Registerkarte mit den Namen der Datei.
  11. Klicken Sie mit der rechten Maustaste auf den Ordner mit den gleichen Namen wie den Namen der Ressourcendatei für das Ziel, und klicken Sie dann auf Einfügen . Die Dialogfeldressource wird im Ordner Dialog der Ressourcendatei für das Ziel angezeigt.
  12. Drücken Sie die Tastenkombination STRG + UMSCHALT + S, alle Dateien zu speichern.
  13. Klicken Sie im Menü Datei auf Projektmappe schließen , um die Projektmappe schließen.

Verwenden Sie eine Ressource Vorlage

Um eine Dialogfeldressource aus einer Ressourcendatei Vorlage für ein Visual C++ .NET-Projekt in ein anderes Projekt importieren möchten, gehen Sie folgendermaßen vor:
  1. Starten Sie Visual Studio .NET oder Visual Studio 2005.
  2. Zeigen Sie im Menü Datei auf Öffnen , und klicken Sie dann auf Datei .
  3. Suchen Sie die Quelle Ressource-Datei.
  4. Klicken Sie auf die Ressourcendatei, und klicken Sie auf Öffnen , um die Datei zu öffnen.
  5. Klicken Sie im Menü Datei auf Speichern FileName unter .

    Hinweis: FileName ist ein Platzhalter für den Dateinamen der Ressourcendatei.
  6. Um die Ressourcendatei als Vorlage Ressourcendatei speichern, wählen Sie Die Ressourcenvorlage (*.rct) in der Liste Dateityp und klicken Sie dann auf Speichern .
  7. Klicken Sie im Menü Datei auf Schließen , um die Ressourcendatei zu schließen.
  8. Klicken Sie im Menü Datei auf Projektmappe öffnen .
  9. Klicken Sie im Dialogfeld Projektmappe öffnen finden Sie das Zielprojekt, in dem Sie die Dialogfeld Ressourcendatei kopieren müssen.
  10. Klicken Sie auf die Projektmappendatei, und klicken Sie dann auf Öffnen .
  11. Klicken Sie in Projektmappen-Explorer mit der rechten Maustaste auf ProjectName und klicken Sie dann auf Eigenschaften .

    Hinweis: ProjectName ist ein Platzhalter für den Namen des Projekts, die Sie geöffnet haben.
  12. In der ProjectName Eigenschaften Dialogfeld, das angezeigt wird, erweitern Sie den Ordner Konfigurationseigenschaften und klicken Sie dann auf den Ordner Ressourcen .
  13. Klicken Sie auf die Auslassungszeichen Schaltfläche (... ) neben der Wert für die zusätzliche Include Verzeichnisse -Eigenschaft. Die enthalten zusätzliche Verzeichnisse Dialogfeld wird angezeigt.
  14. Klicken Sie in das Listenfeld, und geben Sie den Verzeichnispfad (ohne Anführungszeichen) der Vorlage-Ressourcendatei, die Sie in Schritt 6 gespeichert.

    Alternativ können Sie klicken in der Ecke des Listenfelds um ein Auslassungszeichen (... ) anzuzeigen, die Sie zum Anzeigen eines Dialogfelds klicken können. In diesem Dialogfeld können Sie auf das Verzeichnis verweisen, die Ressourcendatei für das Vorlage enthält, das Sie in Schritt 6 gespeichert.
  15. Klicken Sie auf OK die enthalten zusätzliche Verzeichnisse im Dialogfeld.

    Hinweis: Stellen Sie sicher, dass der Pfad in string der zusätzliche Include Verzeichnisse -Eigenschaft ist nicht in Anführungszeichen eingeschlossen. Wenn der Pfad der RCT-Datei Leerzeichen enthält, und Sie die Schaltfläche mit den Auslassungspunkten (... ), verwendet um den Ordner standardmäßig auswählen, wird er in Anführungszeichen eingeschlossen. Sie müssen die Anführungszeichen in solchen Fällen entfernen. Auch wenn Sie den Pfad eingeben, müssen Sie sicherstellen, dass Sie den richtigen Pfad mit der genauen Anzahl von Leerzeichen eingeben.
  16. Klicken Sie auf Übernehmen und dann auf OK , um schließen die ProjectName Eigenschaften im Dialogfeld.
  17. Klicken Sie im Projektmappen-Explorer auf die Resource View Registerkarte.
  18. Erweitern Sie den ProjectName-Knoten, zeigen Sie in.
  19. Erweitern Sie den Ordner, der entspricht, auf die Ressourcendatei.
  20. Klicken Sie mit der rechten Maustaste auf den Ordner Dialog , und klicken Sie dann auf Ressource hinzufügen .
  21. Erweitern Sie Dialogfeld unter Ressourcentyp klicken Sie im Dialogfeld Ressource hinzufügen . Sie bemerken die Dialogfeld Ressource, die Sie kopieren möchten.
  22. Klicken Sie auf die Dialogfeld Ressource, die Sie kopieren möchten, und klicken Sie auf neu , um dieses Dialogfeldressource dem Projekt hinzufügen.
  23. Drücken Sie die Tastenkombination STRG + UMSCHALT + S zum Speichern des Projekts.
  24. Klicken Sie im Menü Datei auf Projektmappe schließen , um die Projektmappe schließen.
  25. Beenden Sie Visual Studio .NET oder Visual Studio 2005.

Informationsquellen

Weitere Informationen zum Kopieren von Ressourcen aus einem Projekt zu einem anderen die folgenden Microsoft Developer Network (MSDN)-Website:
http://msdn2.microsoft.com/en-us/library/a5axa064(vs.71).aspx

Eigenschaften

Artikel-ID: 829437 - Geändert am: Donnerstag, 19. April 2007 - Version: 2.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Visual C++ 2005 Express Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C++ .NET 2002 Standard Edition
Keywords: 
kbmt kbimport kbhowtomaster kbresource kbhowto KB829437 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 829437
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com