Comment importer une ressource de boîte de dialogue à partir d'un projet dans un autre projet en l'aide de Visual C++ .NET ou de Visual C++ 2005

Traductions disponibles Traductions disponibles
Numéro d'article: 829437 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Résumé

Cette étape par étape explique comment importer une ressource de boîte de dialogue à partir d'un fichier de ressources ou à partir d'un modèle de ressource d'un projet Microsoft Visual C++.NET à un autre projet Visual C++.NET ou d'un modèle de ressource d'un projet Microsoft Visual C++ 2005 à un autre projet Visual C++ 2005.

Cet article explique également comment créer un projet de basés sur les ressources de boîte de dialogue en utilisant le modèle Windows Forms Application et le modèle MFC Application de dans lequel une ressource peut être copiée. Cet article décrit également deux techniques différentes pour copier une ressource à partir d'un projet à un autre projet.

Configuration requise

Cet article suppose que vous êtes familiarisé avec les sujets suivants :
  • Programmation avec Visual C++ .NET ou Visual C++ 2005
  • Fichiers de ressources

Créer des applications en fonction de dialogue dans Visual C++ .NET ou Visual C++ 2005

Dans Visual C++ .NET 2003 ou dans Visual C++ 2005, vous pouvez créer les applications en fonction de dialogue en utilisant le modèle de projet MFC Application ou le modèle de projet Windows Forms Application. Dans Visual C++ .NET 2002, vous pouvez créer des applications en fonction de dialogue en utilisant le modèle de projet MFC Application.

Pour créer une application en fonction de dialogue en utilisant le modèle de projet Windows Forms Application dans Visual C++ .NET 2003 ou dans Visual C++ 2005, procédez comme suit :
  1. Démarrez Microsoft Visual Studio .NET 2003 ou Microsoft Visual Studio 2005.
  2. Dans le menu Fichier , pointez sur Nouveau , puis cliquez sur projet .
  3. Cliquez sur projets Visual C++ sous types de projet , puis cliquez sur Windows Forms applications (.NET) sous modèles .

    note Dans Visual Studio 2005, cliquez sur Visual C++ sous types de projet , puis cliquez sur Windows Forms application sous modèles .
  4. Dans la zone de texte Nom , tapez DialogApp et puis cliquez sur OK . Par défaut, le formulaire Form1 est créé.
  5. Dans l'Explorateur de solutions, cliquez sur le ressource Affichage onglet.
  6. Dans le \uc1\u-257? Affichage des ressources, développez le DialogApp n?ud.
  7. Cliquez avec le bouton droit sur le dossier app.rc , puis cliquez sur Ajouter une ressource .
  8. Dans la boîte de dialogue Ajouter une ressource , développez la boîte de dialogue sous Type de ressource .
  9. Cliquez sur IDD_FORMVIEW [anglais (États-Unis)] , puis cliquez sur Nouveau . Une nouvelle ressource de boîte de dialogue est ajoutée au projet et est ouvert en mode Création.
    note Dans Visual Studio 2005, cliquez sur IDD_FORMVIEW .
  10. Cliquez avec le bouton droit sur le modèle de la boîte de dialogue, puis cliquez sur Propriétés .
  11. Modifiez la propriété ID IDD_MY_FORMVIEW .
  12. Ajouter un contrôle bouton pour le modèle de la boîte de dialogue.
  13. Appuyez sur la combinaison de touches CTRL + MAJ + S pour enregistrer tous les fichiers.
  14. Dans le menu Fichier , cliquez sur la solution fermeture pour fermer la solution.
  15. Quittez Visual Studio .NET 2003 ou Visual Studio 2005.
Pour créer une application en fonction de dialogue en utilisant le modèle de projet MFC Application dans soit Visual C++ .NET 2003, Visual C++ .NET 2002 ou Visual Studio 2005, procédez comme suit :
  1. Démarrez Microsoft Visual Studio .NET ou Visual Studio 2005.
  2. Dans le menu Fichier , pointez sur Nouveau , puis cliquez sur projet .
  3. Cliquez sur projets Visual C++ sous types de projet , puis cliquez sur application MFC sous modèles .

    note Dans Visual Studio 2005, cliquez sur Visual C++ sous types de projet , puis cliquez sur application MFC sous modèles .
  4. Dans la zone de texte Nom , tapez DialogApp et puis cliquez sur OK .
  5. Dans l' Assistant application MFC - DialogApp boîte de dialogue, cliquez sur Type d'application .
  6. Sous type d'application , cliquez pour sélectionner en fonction de la boîte de dialogue , puis cliquez sur Terminer .
  7. Dans l'Explorateur de solutions, cliquez sur le ressource Affichage onglet.
  8. Dans le \uc1\u-257? Affichage des ressources, développez le DialogApp n?ud.
  9. Cliquez avec le bouton droit sur le dossier DialogApp.rc , puis cliquez sur Ajouter une ressource .
  10. Dans la boîte de dialogue Ajouter une ressource , développez la boîte de dialogue sous Type de ressource .
  11. Cliquez sur IDD_FORMVIEW [anglais (États-Unis)] , puis cliquez sur Nouveau . Une nouvelle ressource de boîte de dialogue est ajoutée au projet et est ouvert en mode Création.
    note Dans Visual Studio 2005, cliquez sur IDD_FORMVIEW .
  12. Cliquez avec le bouton droit sur le modèle de la boîte de dialogue, puis cliquez sur Propriétés .
  13. Modifiez la propriété ID IDD_MY_FORMVIEW .
  14. Ajouter un contrôle bouton pour le modèle de la boîte de dialogue.
  15. Appuyez sur la combinaison de touches CTRL + MAJ + S pour enregistrer tous les fichiers.
  16. Dans le menu Fichier , cliquez sur la solution fermeture pour fermer la solution.
  17. Quittez Visual Studio .NET ou Visual Studio 2005.

Copier une ressource de boîte de dialogue

Pour copier une ressource de boîte de dialogue d'un fichier de ressource d'un projet Visual C++ .NET ou Visual C++ 2005 dans un fichier ressource d'un autre projet Visual C++ .NET ou Visual C++ 2005, procédez comme suit.

note Un fichier de ressource a une extension .rc.
  1. Démarrez Visual Studio .NET ou Visual Studio 2005.
  2. Dans le menu Fichier , pointez sur Ouvrir , puis cliquez sur fichier .
  3. Recherchez le fichier de ressource source.
  4. Cliquez sur le fichier de ressources, puis cliquez sur Ouvrir pour ouvrir le fichier.
  5. Effectuer les étapes 2 à 4 pour le fichier de ressources de destination.
  6. Pour basculer vers le fichier de ressources source, cliquez sur l'onglet qui contient le nom du fichier de ce fichier.
  7. Développez le dossier qui porte le même nom comme nom de fichier du fichier de ressource source.
  8. Développez le dossier boîte de dialogue .
  9. Cliquez avec le bouton droit sur la ressource de boîte de dialogue que vous souhaitez copier, puis cliquez sur Copier .
  10. Pour basculer vers le fichier de ressources de destination, cliquez sur l'onglet qui contient le nom du fichier de ce fichier.
  11. Cliquez avec le bouton droit sur le dossier qui porte le même nom comme nom de fichier du fichier de destination ressource, puis cliquez sur Coller . La ressource de boîte de dialogue apparaît dans le dossier boîte de dialogue du fichier de ressource cible.
  12. Appuyez sur la combinaison de touches CTRL + MAJ + S pour enregistrer tous les fichiers.
  13. Dans le menu Fichier , cliquez sur la solution fermeture pour fermer la solution.

Utiliser un modèle de ressource

Pour importer une ressource de boîte de dialogue à partir d'un fichier de modèle de ressource d'un projet Visual C++ .NET dans un autre projet, procédez comme suit :
  1. Démarrez Visual Studio .NET ou Visual Studio 2005.
  2. Dans le menu Fichier , pointez sur Ouvrir , puis cliquez sur fichier .
  3. Recherchez le fichier de ressource source.
  4. Cliquez sur le fichier de ressources, puis cliquez sur Ouvrir pour ouvrir le fichier.
  5. Dans le menu Fichier , cliquez sur Enregistrer FileName sous .

    note FileName est un espace réservé pour le nom de fichier du fichier de ressources.
  6. Pour enregistrer le fichier de ressource en tant que fichier de modèle de ressources, sélectionnez le modèle de ressource (*.rct) dans la liste type de fichier , puis cliquez sur Enregistrer .
  7. Dans le menu Fichier , cliquez sur Fermer pour fermer le fichier de ressources.
  8. Dans le menu Fichier , cliquez sur Ouvrir solution .
  9. Dans la boîte de dialogue Ouvrir solution , recherchez le projet cible où vous devez copier le fichier de ressource de boîte de dialogue.
  10. Cliquez sur le fichier de solution, puis cliquez sur Ouvrir .
  11. Dans l'Explorateur de solutions, cliquez avec le bouton droit sur ProjectName, puis cliquez sur Propriétés .

    note ProjectName est un espace réservé pour le nom du projet que vous avez ouvert.
  12. Dans la ProjectName pages de propriétés boîte de dialogue qui s'affiche, développez le dossier de propriétés de configuration et cliquez sur le dossier de ressources .
  13. Cliquez sur le bouton de sélection (... ) côté pour la valeur de la inclure autres répertoires propriété. Le inclure autres répertoires boîte de dialogue s'affiche.
  14. Cliquez sur dans la zone de liste, puis tapez le chemin de répertoire (sans guillemets) du fichier de ressources modèle que vous avez enregistré à étape 6.

    Vous pouvez également cliquer sur dans l'angle de la zone de liste pour afficher un bouton de sélection (... ) lequel vous pouvez cliquer pour afficher une boîte de dialogue. Vous pouvez utiliser cette boîte de dialogue pour pointer vers le répertoire qui contient le fichier de modèle de ressource que vous avez enregistré à étape 6.
  15. Cliquez sur OK dans la inclure autres répertoires boîte de dialogue.

    note Assurez-vous que le chemin d'accès de chaîne dans la inclure supplémentaires répertoires propriété pas est placée entre guillemets. Si le chemin d'accès du fichier .RCT contient des espaces et que vous avez utilisé le bouton points de suspension (... ) pour choisir le dossier par défaut, il est entre guillemets. Vous devez supprimer les guillemets dans ce cas. Également si vous tapez le chemin d'accès, vous devez vous assurer que vous tapez le chemin correct contenant le nombre exact d'espaces.
  16. Cliquez sur Appliquer , puis cliquez sur OK pour fermer la ProjectName pages de propriétés boîte de dialogue.
  17. Dans l'Explorateur de solutions, cliquez sur le ressource Affichage onglet.
  18. Dans Affichage des ressources, développez le n?ud ProjectName.
  19. Développez le dossier qui correspond au fichier de ressources.
  20. Cliquez avec le bouton droit sur le dossier boîte de dialogue , puis cliquez sur Ajouter une ressource .
  21. Dans la boîte de dialogue Ajouter une ressource , développez la boîte de dialogue sous Type de ressource . Vous remarquerez la ressource boîte de dialogue que vous souhaitez copier.
  22. Cliquez sur la ressource boîte de dialogue que vous souhaitez copier, puis cliquez sur Nouveau pour ajouter cette ressource de boîte de dialogue à votre projet.
  23. Appuyez sur la combinaison de touches CTRL + MAJ + S pour enregistrer le projet.
  24. Dans le menu Fichier , cliquez sur la solution fermeture pour fermer la solution.
  25. Quittez Visual Studio .NET ou Visual Studio 2005.

Références

Pour plus d'informations sur copie des ressources à partir d'un projet à un autre, reportez-vous au site de Web MSDN (Microsoft Developer Network) suivant :
http://msdn2.microsoft.com/en-us/library/a5axa064(vs.71).aspx

Propriétés

Numéro d'article: 829437 - Dernière mise à jour: jeudi 19 avril 2007 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Visual C++ 2005 Express Edition
  • Microsoft Visual C++ .NET 2003 Initiation
  • Microsoft Visual C++ .NET 2002 Initiation
Mots-clés : 
kbmt kbimport kbhowtomaster kbresource kbhowto KB829437 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 829437
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com