Visual C++ .NET 또는 Visual C++ 2005를 사용하여 대화 상자 리소스를 한 프로젝트에서 다른 프로젝트로 가져오는 방법

기술 자료 번역 기술 자료 번역
기술 자료: 829437 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

요약

이 문서에서는 대화 상자 리소스가 리소스 파일 또는 리소스 템플릿을 Visual C++ .NET 프로젝트의 다른 Visual C++ .NET 프로젝트를 위해 또는 다른 Visual C++ 2005 프로젝트에 Visual C++ 2005 프로젝트 리소스 템플릿을 가져오는 방법에 대해 설명합니다.

이 문서에서는 또한 Windows Forms 응용 프로그램 템플릿 및 리소스를 복사할 수 있는 MFC 응용 프로그램 템플릿을 사용하여 리소스 기반 대화 프로젝트를 만드는 방법을 설명합니다. 또한 자원을 한 프로젝트에서 다른 프로젝트로 복사 두 가지 다른 기술을 설명합니다.

요구 사항

이 문서에서는 사용자가 다음 항목을 잘 알고 있다고 가정합니다.
  • Visual C++ .NET 또는 Visual C++ 2005 프로그래밍
  • 리소스 파일

Visual C++ .NET에서 또는 Visual C++ 2005 에서 대화 상자 기반 응용 프로그램 만들기

Visual C++ .NET 2003 또는 Visual C++ 2005의 MFC 응용 프로그램 프로젝트 템플릿 또는 Windows Forms 응용 프로그램 프로젝트 템플릿을 사용하여 대화 상자 기반 응용 프로그램을 만들 수 있습니다. Visual C++ .NET 2002에서 MFC 응용 프로그램 프로젝트 템플릿을 사용하여 대화 상자 기반 응용 프로그램을 만들 수 있습니다.

Visual C++ .NET 2003 에서 또는 Visual C++ 2005 에서 Windows Forms 응용 프로그램 프로젝트 템플릿을 사용하여 대화 상자 기반 응용 프로그램을 만들려면 다음과 같이 하십시오.
  1. Microsoft Visual Studio .NET 2003 또는 Microsoft Visual Studio 2005 시작하십시오.
  2. 파일 메뉴에서 새로 만들기를 가리킨 다음 프로젝트 를 클릭하십시오.
  3. 프로젝트 형식Visual C++ 프로젝트 클릭한 다음 템플릿 에서 Windows Forms 응용 프로그램 (.NET)을 누릅니다.

    참고 Visual Studio 2005에서 프로젝트 형식Visual C++ 클릭한 다음 템플릿 에서 Windows Forms 응용 프로그램 을 누릅니다.
  4. 이름 텍스트 상자에 DialogApp 를 입력한 다음 확인 을 누릅니다. 기본적으로 Form1 폼이 만들어집니다.
  5. 솔루션 탐색기에서 을 사용하여 리소스 보기 탭.
  6. 리소스 뷰에서 DialogApp 확장하여 노드.
  7. app.rc 폴더를 마우스 오른쪽 단추로 클릭한 다음 리소스 추가 클릭하십시오.
  8. 자원 종류대화 상자리소스 추가 대화 상자를 확장하십시오.
  9. IDD_FORMVIEW [영어 (미국)]을 클릭한 다음 새로 만들기 를 클릭하십시오. 새 대화 상자 리소스를 프로젝트에 추가되고 디자인 뷰에서 열립니다.
    참고 Visual Studio 2005에서 IDD_FORMVIEW 를 클릭하십시오.
  10. 대화 상자 템플릿을 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.
  11. ID 속성은 IDD_MY_FORMVIEW 로 변경하십시오.
  12. 대화 상자 템플릿에 Button 컨트롤을 추가하십시오.
  13. 모든 파일을 저장하려면 Ctrl + Shift + S를 키 조합을 누릅니다.
  14. 파일 메뉴에서 솔루션 닫기 솔루션 닫기 클릭하십시오.
  15. Visual Studio .NET 2003 또는 Visual Studio 2005 종료하십시오.
Visual C++ .NET 2002 또는 Visual Studio 2005 어느 Visual C++ .NET 2003 MFC 응용 프로그램 프로젝트 템플릿을 사용하여 대화 상자 기반 응용 프로그램을 만들려면 다음 이 단계를 수행하십시오.
  1. Microsoft Visual Studio .NET 또는 Visual Studio 2005 시작하십시오.
  2. 파일 메뉴에서 새로 만들기를 가리킨 다음 프로젝트 를 클릭하십시오.
  3. 프로젝트 형식Visual C++ 프로젝트 클릭한 다음 템플릿 에서 MFC 응용 프로그램 을 누릅니다.

    참고 Visual Studio 2005에서 프로젝트 형식Visual C++ 클릭한 다음 템플릿 에서 MFC 응용 프로그램 을 누릅니다.
  4. 이름 텍스트 상자에 DialogApp 를 입력한 다음 확인 을 누릅니다.
  5. MFC 응용 프로그램 마법사 - DialogApp 대화 상자에서 응용 프로그램 종류 를 클릭합니다.
  6. 응용 프로그램 종류, 대화 상자 기반 선택하려면 클릭한 다음 마침 을 클릭하십시오.
  7. 솔루션 탐색기에서 을 사용하여 리소스 보기 탭.
  8. 리소스 뷰에서 DialogApp 확장하여 노드.
  9. DialogApp.rc 폴더를 마우스 오른쪽 단추로 클릭한 다음 리소스 추가 클릭하십시오.
  10. 자원 종류대화 상자리소스 추가 대화 상자를 확장하십시오.
  11. IDD_FORMVIEW [영어 (미국)]을 클릭한 다음 새로 만들기 를 클릭하십시오. 새 대화 상자 리소스를 프로젝트에 추가되고 디자인 뷰에서 열립니다.
    참고 Visual Studio 2005에서 IDD_FORMVIEW 를 클릭하십시오.
  12. 대화 상자 템플릿을 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.
  13. ID 속성은 IDD_MY_FORMVIEW 로 변경하십시오.
  14. 대화 상자 템플릿에 Button 컨트롤을 추가하십시오.
  15. 모든 파일을 저장하려면 Ctrl + Shift + S를 키 조합을 누릅니다.
  16. 파일 메뉴에서 솔루션 닫기 솔루션 닫기 클릭하십시오.
  17. Visual Studio .NET 또는 Visual Studio 2005 종료하십시오.

대화 상자 리소스를 복사합니다

Visual C++ .NET 또는 Visual C++ 2005 프로젝트 리소스 파일에서 다른 Visual C++ .NET 또는 Visual C++ 2005 프로젝트의 리소스 파일 대화 상자 리소스를 복사하려면 다음과 같이 하십시오.

참고 리소스 파일을 .rc 확장명이 있습니다.
  1. Visual Studio .NET 또는 Visual Studio 2005 시작하십시오.
  2. 파일 메뉴에서 열기 를 가리킨 다음 파일 을 클릭하십시오.
  3. 원본 리소스 파일을 찾습니다.
  4. 리소스 파일을 클릭한 다음 해당 파일을 열려면 열기 를 클릭하십시오.
  5. 대상 리소스 파일에 대해 2-4단계 수행하십시오.
  6. 원본 리소스 파일을 전환하려면 이 파일의 파일 이름이 들어 있는 탭을 클릭하십시오.
  7. 원본 리소스 파일의 파일 이름과 같은 이름을 가진 폴더를 확장하십시오.
  8. 대화 상자 폴더를 확장하십시오.
  9. 복사하려면 원하는 대화 상자 리소스를 마우스 오른쪽 단추로 클릭한 다음 복사 를 클릭하십시오.
  10. 대상 리소스 파일에 전환하려면 이 파일의 파일 이름이 들어 있는 탭을 클릭하십시오.
  11. 대상 리소스 파일의 파일 이름과 같은 이름을 가진 폴더를 마우스 오른쪽 단추로 클릭한 다음 붙여넣기 를 클릭하십시오. 대화 상자 리소스를 대상 리소스 파일 대화 폴더에 나타납니다.
  12. 모든 파일을 저장하려면 Ctrl + Shift + S를 키 조합을 누릅니다.
  13. 파일 메뉴에서 솔루션 닫기 솔루션 닫기 클릭하십시오.

리소스 템플릿 사용

Visual C++ .NET 프로젝트의 리소스 서식 파일에서 다른 프로젝트 대화 상자 리소스를 가져오려면 다음과 같이 하십시오.
  1. Visual Studio .NET 또는 Visual Studio 2005 시작하십시오.
  2. 파일 메뉴에서 열기 를 가리킨 다음 파일 을 클릭하십시오.
  3. 원본 리소스 파일을 찾습니다.
  4. 리소스 파일을 클릭한 다음 해당 파일을 열려면 열기 를 클릭하십시오.
  5. [파일] 메뉴에서 [을 FileName 저장 이름으로.

    참고FileName 리소스 파일의 파일 이름에 대한 자리 표시자입니다.
  6. 리소스 파일을 리소스 서식 파일로 저장하려면 리소스 템플릿 (*.rct)파일 형식 목록에서 선택한 다음 저장 을 클릭하십시오.
  7. 파일 메뉴에서 리소스 파일을 닫으려면 닫기 를 클릭하십시오.
  8. 파일 메뉴에서 솔루션 열기 를 클릭하십시오.
  9. 솔루션 열기 대화 상자에서 대화 리소스 파일을 복사해야 합니다 대상 프로젝트를 찾습니다.
  10. 솔루션 파일을 클릭한 다음 열기 를 클릭하십시오.
  11. 솔루션 탐색기에서 ProjectName 을 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.

    참고ProjectName 연 프로젝트 이름에 대한 자리 표시자입니다.
  12. 에 있는 ProjectName 속성 페이지 나타나는 대화 상자에서 구성 속성 폴더를 확장한 다음 리소스 폴더를 클릭합니다.
  13. 값 옆의 줄임표 단추 (...)를 사용하여 추가 포함 디렉터리 속성. 해당 추가 포함 디렉터리 대화 상자가 나타납니다.
  14. 목록 상자를 클릭한 다음 6단계에서 저장한 리소스 템플릿 파일 (인용 부호 제외) 디렉터리 경로를 입력하십시오.

    목록 상자 클릭하여 대화 상자를 표시할 수 있는 줄임표 단추 (...) 표시하려면 모서리에 있는 ' 를 클릭합니다. 6단계에서 저장한 리소스 템플릿 파일을 포함하는 디렉터리를 가리키도록 이 대화 상자를 사용할 수 있습니다.
  15. 확인 을 클릭하여 해당 추가 포함 디렉터리 대화 상자.

    참고 경로에 있는 문자열 확인하십시오 있는 추가 포함 디렉터리 속성을 인용 부호로 묶여 있습니다. .rct 파일 경로에 공백이 기본적으로 폴더를 선택하려면 줄임표 단추 (...) 사용되는 경우, 인용 부호로 묶여 있습니다. 이러한 경우 인용 부호를 제거해야 합니다. 또한 경로를 입력하면 공백 개수 사용하여 올바른 경로를 입력하거나 있어야 합니다.
  16. 적용 을 누른 다음 확인 을 클릭하여 닫습니다 있는 ProjectName 속성 페이지 대화 상자.
  17. 솔루션 탐색기에서 을 사용하여 리소스 보기 탭.
  18. 리소스 뷰에서 ProjectName 노드를 확장하십시오.
  19. 리소스 파일에 해당하는 폴더를 확장하십시오.
  20. 대화 상자 폴더를 마우스 오른쪽 단추로 클릭한 다음 리소스 추가 클릭하십시오.
  21. 자원 종류대화 상자리소스 추가 대화 상자를 확장하십시오. 복사할 대화 상자 리소스를 확인할 수 있습니다.
  22. 복사하려면 원하는 대화 상자 리소스를 클릭한 다음 이 대화 상자 리소스를 프로젝트에 추가하려면 새로 만들기를 클릭하십시오.
  23. 프로젝트를 저장하려면 Ctrl + Shift + S를 키 조합을 누릅니다.
  24. 파일 메뉴에서 솔루션 닫기 솔루션 닫기 클릭하십시오.
  25. Visual Studio .NET 또는 Visual Studio 2005 종료하십시오.

참조

프로젝트 간에 자원을 복사에 대한 자세한 내용은 다음 MSDN) Microsoft 개발자 네트워크 (웹 사이트를 방문하십시오.
http://msdn2.microsoft.com/en-us/library/a5axa064(vs.71).aspx

속성

기술 자료: 829437 - 마지막 검토: 2007년 4월 19일 목요일 - 수정: 2.2
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Visual C++ 2005 Express Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C++ .NET 2002 Standard Edition
키워드:?
kbmt kbimport kbhowtomaster kbresource kbhowto KB829437 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com