如何在对话框资源从一个项目导入到另一个项目使用 Visual c + +.net 或 Visual c + + 2005

文章翻译 文章翻译
文章编号: 829437 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

本分步指南介绍了如何从资源文件或从 Microsoft Visual c + +.net 项目到另一个 Visual c + +.net 项目的资源模板或从 Microsoft Visual c + + 2005年项目到另一个 Visual c + + 2005年项目的资源模板导入对话框资源。

本文还介绍了如何通过使用 Windows 窗体应用程序模板和 $ 从可以复制资源 MFC 应用程序模板创建对话框基于资源的项目。本文还介绍了两个不同的技术,将资源从一个项目复制到另一个项目。

要求

本文假定您熟悉下列主题:
  • 使用 Visual c + +.net 或 Visual c + + 2005年编程
  • 资源文件

在 Visual c + +.net 中或在 Visual c + + 2005年中创建的基于对话框的应用程序

在 Visual c + +.net 2003年中或在 Visual c + + 2005年中,您可以通过使用 MFC 应用程序项目模板或 Windows 窗体应用程序项目模板创建基于对话框的应用程序。在 Visual c + +.net 2002 年,您可以通过使用 MFC 应用程序项目模板来创建基于对话框的应用程序。

若要创建一个基于对话框的应用程序通过使用 Windows 窗体应用程序项目模板,在 Visual c + +.net 2003年中或在 Visual c + + 2005年中,请按照下列步骤操作:
  1. 启动 Microsoft Visual Studio.net 2003年或 Microsoft Visual Studio 2005。
  2. 文件 菜单上指向 新建,然后单击 项目
  3. 项目类型 框中,单击 Visual c + + 项目,然后单击 模板 下的 Windows 窗体应用程序 (.NET)

    注意可视有关 Studio 的 2005 年在 项目类型 框中,单击 Visual c + +,然后单击 模板 下的 Windows 窗体应用程序
  4. 名称 文本框中键入 DialogApp,然后单击 确定。默认状态下,创建 Form1 窗体。
  5. 在解决方案资源管理器中,单击在 资源视图 选项卡。
  6. 在资源视图中展开 DialogApp 节点。
  7. 用鼠标右键单击 app.rc 文件夹,然后单击 添加资源
  8. 添加资源 对话框中展开 对话框,在 资源类型 下。
  9. 单击 IDD_FORMVIEW [英语 (美国)],然后单击 新建。新的对话框资源添加到项目,并在设计视图中打开。
    注意在 Visual 有关 Studio 的 2005 年单击 IDD_FORMVIEW
  10. 用鼠标右键单击该对话框模板,然后单击 属性
  11. ID 属性改为 IDD_MY_FORMVIEW
  12. 将一个 按钮 控件添加到对话框模板。
  13. 请按 CTRL + SHIFT + S 键组合,以保存所有文件。
  14. 文件 菜单上单击 关闭解决方案 以关闭解决方案。
  15. 退出 Visual Studio.net 2003年或 Visual Studio 2005。
若要通过在 Visual c + +.net 2003年中使用 MFC 应用程序项目模板创建一个基于对话框的应用程序,Visual c + +.net 2002 或 Visual Studio 2005,请按照下列步骤操作:
  1. 启动 Microsoft Visual Studio.net 或 Visual Studio 2005。
  2. 文件 菜单上指向 新建,然后单击 项目
  3. 项目类型 框中,单击 Visual c + + 项目,然后单击 模板 下的 MFC 应用程序

    注意可视有关 Studio 的 2005 年在 项目类型 框中,单击 Visual c + +,然后单击 模板 下的 MFC 应用程序
  4. 名称 文本框中键入 DialogApp,然后单击 确定
  5. MFC 应用程序向导-DialogApp 对话框中,单击 应用程序类型
  6. 应用程序类型 下,单击以选中 基于对话框,然后单击 完成
  7. 在解决方案资源管理器中,单击在 资源视图 选项卡。
  8. 在资源视图中展开 DialogApp 节点。
  9. 用鼠标右键单击 DialogApp.rc 文件夹,然后单击 添加资源
  10. 添加资源 对话框中展开 对话框,在 资源类型 下。
  11. 单击 IDD_FORMVIEW [英语 (美国)],然后单击 新建。新的对话框资源添加到项目,并在设计视图中打开。
    注意在 Visual 有关 Studio 的 2005 年单击 IDD_FORMVIEW
  12. 用鼠标右键单击该对话框模板,然后单击 属性
  13. ID 属性改为 IDD_MY_FORMVIEW
  14. 将一个 按钮 控件添加到对话框模板。
  15. 请按 CTRL + SHIFT + S 键组合,以保存所有文件。
  16. 文件 菜单上单击 关闭解决方案 以关闭解决方案。
  17. 退出 Visual Studio.net 或 Visual Studio 2005。

复制对话框资源

若要将对话框资源从 Visual c + +.net 或 Visual c + + 2005年项目的资源文件复制到另一个 Visual c + +.net 或 Visual c + + 2005年项目的资源文件,请按照下列步骤操作。

注意资源文件具有.rc 扩展名。
  1. 启动 Visual Studio.net 或 Visual Studio 2005。
  2. 文件 菜单上指向 打开,然后单击 文件
  3. 找到源资源文件。
  4. 单击资源文件,然后单击打开该文件的 打开
  5. 为目标资源文件,请执行步骤 2 到 4。
  6. 若要切换到源资源文件,单击包含此文件的文件名称选项卡。
  7. 展开文件夹具有与源资源文件的文件名相同的名称。
  8. 展开 对话框 文件夹。
  9. 用鼠标右键单击您要复制,对话框资源,然后单击 复制
  10. 若要切换到目标资源文件,单击包含此文件的文件名称选项卡。
  11. 用鼠标右键单击具有与目标的资源文件的文件名相同的名称的文件夹,然后单击 粘贴。 对话框资源将显示在目标资源文件中的 对话框 文件夹中。
  12. 请按 CTRL + SHIFT + S 键组合,以保存所有文件。
  13. 文件 菜单上单击 关闭解决方案 以关闭解决方案。

使用资源模板

若要将对话框资源从导入资源模板文件的 Visual c + +.net 项目另一个项目,请按照下列步骤操作:
  1. 启动 Visual Studio.net 或 Visual Studio 2005。
  2. 文件 菜单上指向 打开,然后单击 文件
  3. 找到源资源文件。
  4. 单击资源文件,然后单击打开该文件的 打开
  5. 文件 菜单上单击 FileName 保存为

    注意FileName 是一个占位符资源文件的文件名。
  6. 要将资源文件另存为资源模板文件,选择 保存类型 列表中的 资源模板 (*.rct),然后单击 保存
  7. 文件 菜单上单击以关闭资源文件的 关闭
  8. 文件 菜单上单击 打开解决方案
  9. 打开解决方案 对话框中找到目标项目,您必须将复制对话框资源文件。
  10. 单击解决方案文件,然后单击 打开
  11. 在解决方案资源管理器中,右击 ProjectName,然后单击 属性

    注意ProjectName 是项目的打开的名称的占位符。
  12. 在该 ProjectName 属性页 出现,对话框展开 配置属性 文件夹,然后单击 资源 文件夹。
  13. 单击省略号按钮 (...) 的值旁边将 附加包含目录 属性。在 附加包含目录,将出现对话框。
  14. 在列表框中单击,然后键入您在第 6 步中保存资源模板文件的路径 (不带引号)。

    或者,您可以单击以显示一个省略号按钮 (...),可以单击它可以显示一个对话框,该列表框的角。使用此对话框可以指向包含您在第 6 步中保存资源模板文件的目录。
  15. 单击 确定,在该 附加包含目录 对话框。

    注意请确保路径字符串中在 附加包含目录 属性不用引号引起来。如果.rct 文件的路径包含空格,并选择文件夹,默认情况下使用省略号按钮 (...) 则被括在引号中。在这种情况下,您必须删除引号引起来。此外如果键入路径,则必须确保您键入了正确的路径,与精确的空格数。
  16. 单击 应用,然后单击 确定 以关闭该 ProjectName 属性页 对话框。
  17. 在解决方案资源管理器中,单击在 资源视图 选项卡。
  18. 在资源视图中展开 ProjectName 节点。
  19. 展开到资源文件的相对应的文件夹。
  20. 用鼠标右键单击该 对话框 文件夹,然后单击 添加资源
  21. 添加资源 对话框中展开 对话框,在 资源类型 下。您会注意到您要复制的对话框资源。
  22. 单击要复制,对话框资源,然后单击 新建,将此对话框资源添加到您的项目。
  23. 请按 CTRL + SHIFT + S 键组合保存项目。
  24. 文件 菜单上单击 关闭解决方案 以关闭解决方案。
  25. 退出 Visual Studio.net 或 Visual Studio 2005。

参考

有关将资源从一个项目复制到另一个的详细信息请访问下面的 Microsoft 开发人员网络 (MSDN) 的网站:
http://msdn2.microsoft.com/en-us/library/a5axa064(vs.71).aspx

属性

文章编号: 829437 - 最后修改: 2007年4月19日 - 修订: 2.2
这篇文章中的信息适用于:
  • Microsoft Visual C++ 2005 Express Edition
  • Microsoft Visual C++ .NET 2003 Standard Edition
  • Microsoft Visual C++ .NET 2002 标准版
关键字:?
kbmt kbimport kbhowtomaster kbresource kbhowto KB829437 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 829437
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com